vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=326558

Cable_Player 17 Sep 2018 19:50

Hi, I've followed your instructions exactly, but notifications to subscribe are not showing.
I'm just running a test board at the moment to see the capabilities of the software and it is located at
Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

In the settings on OneSignal it does not allow me to enter that location, only
Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

- could this be the reason it isn't showing?
Thanks.


Update:
Sorry I was being impatient. It's showing now, but as my connection is private it's blocking notifications. I'll see how it runs for other people though, thanks for providing this plugin.

iA1 17 Sep 2018 22:35

1 Attachment(s)
Quote:

Originally Posted by carik (Post 2596398)
And can I make it so that a notification without nicknames, topic names and messages is sent? The usual notification is a "new answer", or "a new personal message". And click on the link to send a link to a topic or personal message.
That would be the right decision! Moreover, I have a very small notice on the 27 "screen, and it's easier for me to click and read on the site." It's also more convenient for me to follow the link on a mobile phone.

Replace the file includes/functions_OneSignal.php with the attached file. You can even open that file in a text editor and modify the messages as you like.

carik 18 Sep 2018 19:14

Quote:

Originally Posted by iA1 (Post 2596402)
Replace the file includes/functions_OneSignal.php with the attached file. You can even open that file in a text editor and modify the messages as you like.

:up: Yes! working!!!
PM removed from the code?
I change the text in the script if the English language works, if the Russian text does not send messages. I do not understand the problem.

and the transition from push notification to the wrong place where the new answer, but simply to the home page.

iA1 18 Sep 2018 19:27

Quote:

Originally Posted by carik (Post 2596411)
:up: Yes! working!!!
PM removed from the code?
I change the text in the script if the English language works, if the Russian text does not send messages. I do not understand the problem.

No, PM is not removed. It is there at line # 51.

carik 18 Sep 2018 19:32

https://www.carhelp.info/showthread....aign=onesignal Here such link comes in push, I think the end superfluous?

carik 18 Sep 2018 19:41

Quote:

Originally Posted by iA1 (Post 2596412)
No, PM is not removed. It is there at line # 51.

ok!


and this is a link where you had to switch by click to push.
https://www.carhelp.info/forums/show...87#post1544887

z3r0 18 Sep 2018 21:43

If you are using this you may want to take a look here - https://xenforo.com/community/thread...e-this.153212/

IMO there are GDPR implications.

carik 19 Sep 2018 12:18

Quote:

Originally Posted by iA1 (Post 2596412)
No, PM is not removed. It is there at line # 51.

in the delivery report in onesignal if you look there writes here such
Filters {"key":"uid","field":"tag","value":"10234362","relation":"="}
all links in notifications have the wrong view. How to fix it? Thank you!

carik 19 Sep 2018 12:19

Quote:

Originally Posted by z3r0 (Post 2596415)
If you are using this you may want to take a look here - https://xenforo.com/community/thread...e-this.153212/

IMO there are GDPR implications.

your mobile phone transmits a lot more personal data.

carik 19 Sep 2018 12:24

Quote:

Originally Posted by iA1 (Post 2596412)
No, PM is not removed. It is there at line # 51.

in the settings of the service configured not to open in a new tab, but to switch to the tab if it is open in the browser. still open a new tab. I do not understand why.

iA1 19 Sep 2018 14:47

Quote:

Originally Posted by carik (Post 2596420)
in the delivery report in onesignal if you look there writes here such
Filters {"key":"uid","field":"tag","value":"10234362","relation":"="}
all links in notifications have the wrong view. How to fix it? Thank you!

Check your forum url settings in Admincp -> Settings -> Options -> Site Name / URL / Contact Details
https://www.carhelp.info/forums/admi...ogroup=address

Have you entered the correct url for your forum there?

Quote:

Originally Posted by carik (Post 2596422)
in the settings of the service configured not to open in a new tab, but to switch to the tab if it is open in the browser. still open a new tab. I do not understand why.

This is something which cannot be controlled from this add-on. It can only be configured from OneSignal.

iA1 19 Sep 2018 14:49

Quote:

Originally Posted by carik (Post 2596413)
https://www.carhelp.info/showthread....aign=onesignal Here such link comes in push, I think the end superfluous?

The end part is for Google Analytics. If you use analytics, then you can easily check how many users clicked on the notification and visited your forum.

carik 19 Sep 2018 15:06

Quote:

Originally Posted by iA1 (Post 2596423)
Check your forum url settings in Admincp -> Settings -> Options -> Site Name / URL / Contact Details
https://www.carhelp.info/forums/admi...ogroup=address

Have you entered the correct url for your forum there?

Yes, it's all true. links to e-mail come correct.



Quote:

Originally Posted by iA1 (Post 2596423)
This is something which cannot be controlled from this add-on. It can only be configured from OneSignal.

probably because of the incorrect links, there on the service I set everything correctly.

carik 19 Sep 2018 15:10

Quote:

Originally Posted by iA1 (Post 2596424)
The end part is for Google Analytics. If you use analytics, then you can easily check how many users clicked on the notification and visited your forum.

I do not have such settings anywhere.
but the question is why the link to push notification comes here is this:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

but here is the email:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

a link to the email opens a topic or a PM, and the link from the push notification opens first 404 and then goes to the main page of the forum.

carik 19 Sep 2018 15:36


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

???

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.



All times are GMT. The time now is 04:49.

Powered by vBulletin® Version 3.8.14
Copyright © 2021, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.