vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=208324

itsheinz 23 Mar 2009 12:06

yes it is..

TimberFloorAu 23 Mar 2009 12:07

Have you uploaded into your custom style, images/misc ?

hambil 23 Mar 2009 12:12

The button images go in buttons, not misc, actually.

hambil 23 Mar 2009 12:13

Quote:

Originally Posted by itsheinz (Post 1774918)
yes it is..

And configured so that the usergroups can see and give reputation?

itsheinz 23 Mar 2009 12:23

i uploaded some in buttons and some in misc as well. . .coz in the images,there are 2 folders for buttons and for misc right?
what do you mean by configured?

hambil 23 Mar 2009 12:34

I'm sorry, I got confused as to which mod I was responding to, you don't need to do anything with reputation lol

If you want to PM me some login info I'll see if I can figure it out for you.

itsheinz 23 Mar 2009 12:48

my main problem is the icon in which your going to click to send egg etc,doesnt appear.
and also where can i see this https://www.vbulletin.org/forum/external/2009/03/56.jpg please help me hambil :cry:

hambil 23 Mar 2009 12:51

Quote:

Originally Posted by itsheinz (Post 1774935)
my main problem is the icon in which your going to click to send egg etc,doesnt appear.
and also where can i see this http://www.vbulletin.org/forum/attac...6&d=1237051504 please help me hambil :cry:

That's in the usergroup settings. If those aren't set than ya, you won't see anything.

Vinyljunky 23 Mar 2009 12:59

Quote:

Originally Posted by hambil (Post 1774937)
That's in the usergroup settings. If those aren't set than ya, you won't see anything.

Also check that your postbit is displaying the "online now" icon as this mod uses it to reference ;) (It displays just after it)

itsheinz 23 Mar 2009 13:13

owww its working now man,thanks!
MOTM!

hambil 23 Mar 2009 13:21

You can't egg your own avatar, and there are no eggs on it to clean :)

itsheinz 23 Mar 2009 13:27

ITS WORKING NOW MAN thanks a lot for helping!
MOTM!

down.low 23 Mar 2009 18:32

I have the registered users set up as follows:
https://www.vbulletin.org/forum/
|
__________________|__________________
I have mods/admins group set up as follows:
https://www.vbulletin.org/forum/

The problem I'm having:

Registered users can not see/ or clean an egged avatar.

If a mod eggs a mod, both mods can see it- not registered users.

If a mod eggs a user- a different mod can see the egging- not registered users.

I love the mod but I only want VIP's to use it, and Registered users "only view" the eggings until they become VIP,.....


Was this intentionally made this way, or was it just a mishap? Any way to make it so the reg users "can" view, "can" cleanothers, & "not" egg, ?? Setting it up like this makes registered users not see anything at all.....

hambil 23 Mar 2009 18:47

What you want should work. I'll have to check my permissions processing and get it fixed up in 2.0 for you.

down.low 23 Mar 2009 18:55

Quote:

Originally Posted by hambil (Post 1775199)
What you want should work. I'll have to check my permissions processing and get it fixed up in 2.0 for you.

Thanks for a fast response, it's a little weird- even when I have user groups set to:"View only" and the rest off- they still cant see when someone gets egged.

down.low 23 Mar 2009 18:56

No rush my good man,....any idea when the 2.0 would be out??

hambil 23 Mar 2009 19:17

It under 'heavy construction' right now. I've made good progress, but it's a major update. Hopefully you'll see it within a couple days at the most.

down.low 23 Mar 2009 19:42

So the only way to get the user group to see is to allow them to throw?? No quick fix maybe??

hambil 23 Mar 2009 19:51

I'm too deep into 2.0 for quick fixes right now. Just hang in there a day or two :)

down.low 23 Mar 2009 20:07

I'm willing to wait- I was just wondering if there was possibly a fix I could on my side?

SliceofLife 24 Mar 2009 01:39

Is there a way to remove to disable bullets? I've changed the bullet graphic in Admin Options to the kiss.gif but it's still showing up the bulletholes regardless.

Is there a method of removing bullets from being used at all?

gwerzal 24 Mar 2009 01:58

Sweet

Installed

hambil 24 Mar 2009 03:36

Quote:

Originally Posted by SliceofLife (Post 1775476)
Is there a way to remove to disable bullets? I've changed the bullet graphic in Admin Options to the kiss.gif but it's still showing up the bulletholes regardless.

Is there a method of removing bullets from being used at all?

2.0 fixes all that, and will be released very soon.

Saviour 24 Mar 2009 04:51

I had this installed...ad then uninstalled...wasn't working as it should. Followed the directions to the tee.

When the avatar got egged...it would distort the avatar image...and the image isn't even animated. Didn't matter what you threw...it would distort the avatar image.

Just doesn't look very appealing...so, I just decided to uninstall. To each his own, I guess.

hambil 24 Mar 2009 05:01

Quote:

Originally Posted by Saviour (Post 1775555)
I had this installed...ad then uninstalled...wasn't working as it should. Followed the directions to the tee.

When the avatar got egged...it would distort the avatar image...and the image isn't even animated. Didn't matter what you threw...it would distort the avatar image.

Just doesn't look very appealing...so, I just decided to uninstall. To each his own, I guess.

The current version distorts png files, which has been fixed in 2.0. If all goes well, 2.0 should be released within the next few hours.

Saviour 24 Mar 2009 05:16

I'll keep an eye out for the updated release...thanks.

ArcadeSyndicate 24 Mar 2009 17:01

Quote:

Originally Posted by TandyServices (Post 1769497)
... but mine says 25 credits to egg, 100 credits to clean, 25 to clean all.??

Quote:

Originally Posted by hambil (Post 1769508)
You are correct - thank you. I fixed it. I didn't bother with a point release since I had just released this version and it's a minor fix. If you already have 1.2.2 installed then don't reinstall, just unzip the zip file and upload the files again.

still have this prob in the latest version, downloaded and installed today (1.2.3) :confused:

lostguy 25 Mar 2009 01:08

I wonder when Version 2.0 going out .

hambil 25 Mar 2009 15:59

2.0 has arrived. I couldn't get all the feature in I wanted, but I think I got the most important ones. Besides, now I have something to do for 2.1 :p

woffie 25 Mar 2009 16:26

Is it optional to have them know who egged them?

hambil 25 Mar 2009 16:31

Quote:

Originally Posted by woffie (Post 1776737)
Is it optional to have them know who egged them?

Yes. It can be turned on or off in the admincp [tk] Egg Avatar options.

acegames 25 Mar 2009 16:36

Nice update cheers but im getting an error when adding a new egg

"Invalid filepath Specified"

hambil 25 Mar 2009 16:40

Fixed a minor bug - didn't bother with a version update. If you just grabbed the download you might want to grab it again.

hambil 25 Mar 2009 16:41

Quote:

Originally Posted by acegames (Post 1776743)
Nice update cheers but im getting an error when adding a new egg

"Invalid filepath"

Change the default egg path in the [tk] Egg Avatar options to whatever is valid for your server. It defaults to images/misc. And of course, make sure said path is writable.

beerhead 25 Mar 2009 16:46

Great update! The install was perfect.

I have a couple of questions?

1. I can't find the setting to turn on/off the option to see who egged them. In my admincp, the only option I have is to manage eggs-add/delete/enable, etc. I've checked the usergroup permissions as well, and I don't see it there? Is this done by hovering your mouse oveer the item thrown at the avatar?

2. The dropdown menu for the selection of what you would like to throw is very long, because of the large spaces between each choice. Is there anything I can edit to make that window smaller, or in a different format?

This mod looks like a lot of fun. Thanks for all your hard work on this!

Vinyljunky 25 Mar 2009 16:49

Quote:

Originally Posted by beerhead (Post 1776748)
Great update! The install was perfect.

I have a couple of questions?

1. I can't find the setting to turn on/off the option to see who egged them. In my admincp, the only option I have is to manage eggs-add/delete/enable, etc. I've checked the usergroup permissions as well, and I don't see it there? Is this done by hovering your mouse oveer the item thrown at the avatar?

Its in AdminCP -VB Options - tk Egg Avatar

acegames 25 Mar 2009 16:51

Quote:

Originally Posted by hambil (Post 1776746)
Change the default egg path in the [tk] Egg Avatar options to whatever is valid for your server. It defaults to images/misc. And of course, make sure said path is writable.

Thanks sorted now

beerhead 25 Mar 2009 16:51

Thanks for the help.

I checked my admincp, but I did'nt see it, it was added at the very top of the list-normally any new mods appear near the bottom.

My mistake. Guess I should have looked a little harder.

Thanks again for the help!

hambil 25 Mar 2009 16:55

Quote:

Originally Posted by beerhead (Post 1776748)
Great update! The install was perfect.

I have a couple of questions?

1. I can't find the setting to turn on/off the option to see who egged them. In my admincp, the only option I have is to manage eggs-add/delete/enable, etc. I've checked the usergroup permissions as well, and I don't see it there? Is this done by hovering your mouse oveer the item thrown at the avatar?

It's in the options for the mod under vBulletin Options - check the screenshot: Options

Quote:

2. The dropdown menu for the selection of what you would like to throw is very long, because of the large spaces between each choice. Is there anything I can edit to make that window smaller, or in a different format?
The drop down is a fixed size. How many things display in it depends on how big your egg images are. Screenshot.

You can edit the eggav_bit template to change the height of the dropdown:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Or, you could remove the images (or resizes them dynamically) in the clean and egg bits (eggav_cleanbit, eggav_eggbit) templates.

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


DobieGillis© 25 Mar 2009 16:59

Installed! No issues!

Saviour 25 Mar 2009 18:11

Greta mod!

Only issue is that the link to the thread in "Who Egged ME?" only worked once...and now doesn't work at all.

Is there a fix for this?

Saviour 25 Mar 2009 18:13

Disregard my previous post...it works...my bad!

digicom 25 Mar 2009 18:17

Thanks hambil for update excellent work :up:

Saviour 25 Mar 2009 18:45

Who egged me coming up as Unknown location in WOL.

Saviour 25 Mar 2009 19:13

Would love to add additional items, as well...like darts, a harpoon, and anything else someone would deem funny....even a flame thrower which singes the outside edges of the avatar.

This mod is great...imagine all the possibilities!

Throw in the kitchen sink! Why not even replace their avatar with something like an "Idiot of the moment" avatar...I mean the possibilities are endless.

You should make it possible for an Admin to add items to throw at people.

I'm recommending this for MOTM!

Very nice job...and hilarious!

hambil 25 Mar 2009 20:01

Quote:

Originally Posted by Saviour (Post 1776848)
You should make it possible for an Admin to add items to throw at people.

I did. That's a big part of the 2.0 update.

woffie 25 Mar 2009 20:03

I like the dropdown menu much better on the old version. This one is a mile long. Hate scrolling! Other than that its great.

DobieGillis© 25 Mar 2009 20:04

Quote:

Originally Posted by hambil (Post 1776889)
I did. That's a big part of the 2.0 update.

really? Maybe some peeps will put up their own items for us to share.

hambil 25 Mar 2009 20:15

Quote:

Originally Posted by woffie (Post 1776891)
I like the dropdown menu much better on the old version. This one is a mile long. Hate scrolling! Other than that its great.

Since people can add their own items scrolling in necessary. There is no way for me to handle 20 or 30 or whatever number of items someone might add otherwise.

djilou 25 Mar 2009 20:17

Quote:

Originally Posted by hambil (Post 1776755)
Screenshot.

You can edit the eggav_bit template to change the height of the dropdown:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Or, you could remove the images (or resizes them dynamically) in the clean and egg bits (eggav_cleanbit, eggav_eggbit) templates.

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

It's display fine on Firefox but not on IE

djilou 25 Mar 2009 20:22

Some bugs <D

when I try to edit an egg on admincp


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


And this one : 50 Credit to egg, 50 Credit to clean, 0 to clean all.

hambil 25 Mar 2009 20:30

Quote:

Originally Posted by djilou (Post 1776913)
Some bugs <D

when I try to edit an egg on admincp


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Woohooo! My first official 2.0 fix. 2.0.1 is now available.

Quote:

And this one : 50 Credit to egg, 50 Credit to clean, 0 to clean all.
This (I believe) is a refresh bug. I can't seem to get it to recalculate the # of eggs on a avatar until you refresh the thread. Let me know if that is the same problem you are having, and if so it's already on my list to eventually figure out.

If does charge the right amount, it just doesn't display it properly in the popup without a refresh, do to some YUI caching crap I think.

hambil 25 Mar 2009 20:35

Quote:

Originally Posted by djilou (Post 1776908)
It's display fine on Firefox but not on IE

Woah - I can see that! Okay, working on it now.

TimberFloorAu 25 Mar 2009 21:25

Another simply stunning upgrade, great work mate !

hambil 25 Mar 2009 21:38

Quote:

Originally Posted by djilou (Post 1776908)
It's display fine on Firefox but not on IE

2.0.2 now displays much better (but not perfect) on IE. I'll continue to fix it up in further releases, but wanted to get this out quickly so it was at least usable on IE.

hambil 25 Mar 2009 21:39

Quote:

Originally Posted by Saviour (Post 1776830)
Who egged me coming up as Unknown location in WOL.

Ah yes, now that there are places to go, I need to update WOL :p I'll get that in the next release. Thanks.

djilou 25 Mar 2009 21:41

Thanks for the update.

DobieGillis© 25 Mar 2009 21:47

much better, I had yoke on my face from the IE folks..just kidding. It's eggsactly what I wanted. Still don't get why people use IE.

TimberFloorAu 25 Mar 2009 22:01

Please explain upgrade from 2 to 2.02 is it entire upload, or just product or the lot.

Ste

hambil 25 Mar 2009 22:06

Quote:

Originally Posted by TimberFloorAu (Post 1777007)
Please explain upgrade from 2 to 2.02 is it entire upload, or just product or the lot.

Ste

Upload files and import xml (with overwrite). It shouldn't harm any existing settings.

TimberFloorAu 25 Mar 2009 22:18

Quote:

Originally Posted by hambil (Post 1777014)
Upload files and import xml (with overwrite). It shouldn't harm any existing settings.


Sorted thanks :up:

Alien 25 Mar 2009 22:36

Hey!

VERY NICE UPDATE!

I'm definitely installing this as soon as I can customize a way to select where I can have the scroll-out menu/throw_green.gif

Any pointers on this? I want to use a little egg and put that anywhere I want in the postbit (not just specific hook-locations).

How would I go about that?

Thank you very much!

hambil 25 Mar 2009 22:49

Sure. Paste this code over the existing code in the [tk] Egg Avatar: Add Postbit Control plugin:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Then just place the $eggavatar_button variable wherever you want the button to appear in the postbit. I can't really support this though, so if you mess up your board please don't blame me :p

Alien 25 Mar 2009 23:08

LOL!

Thank you SO much, I'll test this tonight and turn it loose on the masses!

SliceofLife 25 Mar 2009 23:38

Thanks for the update! Is there going to be a release where it can be switched off for individual users?

b6gm6n 25 Mar 2009 23:48

this seems like a very well coded and implemented system for something thats completely pointless... to me anyways :) sorry if i sounded rude there, i speak as i find :)

Alien 25 Mar 2009 23:55

1 Attachment(s)
Small AdminCP Bug found, see attachment...

Notice:

1) The action BUTTON on right has no text

2) Last empty option in select menu also has no text showing up. It should read "Disable", as I tested it. ;)

hambil 25 Mar 2009 23:59

Quote:

Originally Posted by b6gm6n (Post 1777084)
this seems like a very well coded and implemented system for something thats completely pointless... to me anyways :) sorry if i sounded rude there, i speak as i find :)

Why speak at all? Just ignore it if you don't want it.

Bigj85 26 Mar 2009 00:04

working great so far,members are using it a lot already
installed :)

hambil 26 Mar 2009 00:06

Quote:

Originally Posted by Alien (Post 1777089)
Small AdminCP Bug found, see attachment...

Notice:

1) The action BUTTON on right has no text

2) Last empty option in select menu also has no text showing up. It should read "Disable", as I tested it. ;)

The phrases definitely exist in the xml file - try a re-import with overwrite...

The Mack 26 Mar 2009 00:16

So how do you add this to the usercp to display who egged you?

hambil 26 Mar 2009 00:18

Just turn on the 'Enable Who Egged' option.

http://www.vbulletin.org/forum/attac...8&d=1237996329

The Mack 26 Mar 2009 00:45

I turned it on but still don't see it in the usercp

SliceofLife 26 Mar 2009 01:04

My users for the majority absolutely love this! They're changing their avatars to some very interesting ones and then seeing where their splats hit [like targets, etc] however, some users aren't so keen, so will you be bringing out a release that will include switching it off for individual users? Thanks! This one is heaps of fun!

samraz972 26 Mar 2009 01:08

The avatars disappeared

woffie 26 Mar 2009 01:45

Nice update!

hambil 26 Mar 2009 02:30

Quote:

Originally Posted by The Mack (Post 1777120)
I turned it on but still don't see it in the usercp

Well, there should be a choice all the way down at the bottom of the usercp menu.

http://img148.imageshack.us/img148/5826/whoeggedme.jpg

Alien 26 Mar 2009 03:35

Quote:

Originally Posted by hambil (Post 1777098)
The phrases definitely exist in the xml file - try a re-import with overwrite...

Hey,

Nope, I get the same issue. I actually uninstalled the previous version that I was testing when I installed 2.0.2. I just did a re-import with overwrite and that didn't work. It's just like that screenshot I included.

I also noticed an additional bug!

When trying to add a brand new object (another towel I have), I fill in all fields like so:

Example:
Throw Another Towel
Select "clean all"
Click on "Browse" to my pictures directory and select towelnew.gif and when I submit, it always gives me the same error message:

Quote:

There was an error encountered with your upload:

* Invalid File Path Specified

If you are not automatically redirected, please click here.

Processing Complete - Proceed
This happens time and time again and the path is perfectly valid.

Hope this all helps!

Thanks!

hambil 26 Mar 2009 03:57

Quote:

Originally Posted by Alien (Post 1777204)
Hey,

Nope, I get the same issue. I actually uninstalled the previous version that I was testing when I installed 2.0.2. I just did a re-import with overwrite and that didn't work. It's just like that screenshot I included.

I'll double check.

Quote:

I also noticed an additional bug!

When trying to add a brand new object (another towel I have), I fill in all fields like so:

Example:
Throw Another Towel
Select "clean all"
Click on "Browse" to my pictures directory and select towelnew.gif and when I submit, it always gives me the same error message:



This happens time and time again and the path is perfectly valid.

Hope this all helps!

Thanks!
Did you make sure you have write permissions to the path?

hambil 26 Mar 2009 04:12

Minor update for the missing phrases - need to upload eggadmin.php and reimport with overwrite.

If you are having trouble uploading new images make sure your path is in the format 'images/misc/' - the trailing backslash matters.

Alien 26 Mar 2009 04:19

Hey,

Yes, the paths were correct. I use images/misc/eggs/ and it has been manually changed via SSH to 777.

Alien 26 Mar 2009 04:22

BTW the phrases issue is confirmed fixed!

hambil 26 Mar 2009 04:29

Quote:

Originally Posted by Alien (Post 1777234)
Hey,

Yes, the paths were correct. I use images/misc/eggs/ and it has been manually changed via SSH to 777.

I have no idea then. I'm able to upload images to my server without issue. The code is based on the code used in upload rank images.

Saviour 26 Mar 2009 04:41

hambil...

I just have v2.0. If I upgrade to 2.0.3 all I have to do is upload the eggadmin.php file and re-import the product allowing overwrite?

Alien 26 Mar 2009 04:41

1 Attachment(s)
UserCP question:

I know there is only a single hook location in the UserCP menu but you end up with the following problem if you have the official Blog installed.

Would it just be wiser (until there are more hook locations) to just do a search and replace to stick it before the first item in Miscellaneous or after the last item in Miscellaneous so it's nice and neat? If not, can I get a workaround just as you did for the postbit so I can stick it in manually nice and neat?

Thank you again for all the hard work!

Saviour 26 Mar 2009 04:48

2 Attachment(s)
hambil...

Also...you should use the Send Update feature of the mod...so we don't have to scroll through posts to find them...also some release notes included with the new version, along with upgrade instructions would be nice.

Just a thought...

BTW...if anyone is looking for additional items to throw, I've attached a glass of beer and a coffee mug.

Alien 26 Mar 2009 04:52

Thanks for the images, Saviour.

Saviour 26 Mar 2009 04:54

You're welcome, Alien...

Saviour 26 Mar 2009 05:11

8 Attachment(s)
More items to throw...

Saviour 26 Mar 2009 05:50

4 Attachment(s)
Even more items to throw...

...now I'm calling it a night.

hambil 26 Mar 2009 07:42

Quote:

Originally Posted by Saviour (Post 1777242)
hambil...

I just have v2.0. If I upgrade to 2.0.3 all I have to do is upload the eggadmin.php file and re-import the product allowing overwrite?

That's sounds correct. Thanks for the images, I put them in the first post. Nice work.

hambil 26 Mar 2009 07:43

Quote:

Originally Posted by Alien (Post 1777243)
UserCP question:

I know there is only a single hook location in the UserCP menu but you end up with the following problem if you have the official Blog installed.

Would it just be wiser (until there are more hook locations) to just do a search and replace to stick it before the first item in Miscellaneous or after the last item in Miscellaneous so it's nice and neat? If not, can I get a workaround just as you did for the postbit so I can stick it in manually nice and neat?

Thank you again for all the hard work!

I'll work something in for the next update.

hambil 26 Mar 2009 15:31

Video demonstration link has been updated for 2.x

ArcadeSyndicate 26 Mar 2009 16:02

Quote:

Originally Posted by hambil (Post 1776720)
2.0 has arrived. I couldn't get all the feature in I wanted, but I think I got the most important ones. Besides, now I have something to do for 2.1 :p

thx, new version works fine now. great addon, our users love it :up:

Saviour 26 Mar 2009 17:55

Quote:

Originally Posted by hambil (Post 1777304)
That's sounds correct. Thanks for the images, I put them in the first post. Nice work.

They aren't mine...some I found on the web. Make sure you change that reserved post of yours to Submitted by...LOL!

drupy 26 Mar 2009 19:17

1 Attachment(s)
Thank you very much for the update :up:

Since updating to 2.0.3 from 1.2.3, this is how the ajax screen look like after I added more things to throw :confused: I am using the Default Style. Is there anyway I can edit the template? Thank you.

hambil 26 Mar 2009 21:17

Quote:

Originally Posted by drupy (Post 1777679)
Thank you very much for the update :up:

Since updating to 2.0.3 from 1.2.3, this is how the ayax screen look like after I added more things to throw :confused: I am using the Default Style. Is there anyway I can edit the template? Thank you.

That's an IE bug. It gets worse after you add stuff? Grrrrr. I'll have another go at the stupid thing.

drupy 26 Mar 2009 21:50

5 Attachment(s)
Quote:

Originally Posted by hambil (Post 1777766)
That's an IE bug. It gets worse after you add stuff? Grrrrr. I'll have another go at the stupid thing.

No rush, thank you!
Yes, the more stuff I added, the longer the blank space will grow.

Here are some of the stuff to throw which I added:

hambil 26 Mar 2009 22:00

Sweet - adding to first post

hambil 27 Mar 2009 02:49

2.0.4 released - fixes IE display problems and adds some image handling logic to the admincp egg image manager.


All times are GMT. The time now is 02:51.

Powered by vBulletin® Version 3.8.14
Copyright © 2021, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.