vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=299546

djbaxter 27 Dec 2013 15:27

Quote:

Originally Posted by ckgb (Post 2470780)
I'm lost here. Where do I go to purchase the PRO version of the product?

https://sellfy.com/TheInsaneManiac

Quote:

Originally Posted by webmastersitesi (Post 2470786)
does it work 4.2 x

Yes.

TheInsaneManiac 28 Dec 2013 01:17

Quote:

Originally Posted by djbaxter (Post 2470788)


I was going to reply but appears I have some support for my support. :D lol

Thanks

ckgb 28 Dec 2013 02:04

Thank you for the mod. Purchased and installed. Hopefully it does what it says it does ))

ForceHSS 06 Jan 2014 01:10

found a bug in ur pro version when disabled no error so it is ur bug
Fatal error: Call to undefined function indexOf() in /*****/*****/public_html/register.php(1226) : eval()'d code on line 88

TheInsaneManiac 06 Jan 2014 07:17

Quote:

Originally Posted by ForceHSS (Post 2472505)
found a bug in ur pro version when disabled no error so it is ur bug
Fatal error: Call to undefined function indexOf() in /*****/*****/public_html/register.php(1226) : eval()'d code on line 88

Is this in 4.0 or 3.8 version?

ForceHSS 06 Jan 2014 15:17

4.0 version and i am using vb 4.2.2

ForceHSS 09 Jan 2014 03:56

Any fix for this problem yet. Can give you access to my forum if you need to test

ckgb 09 Jan 2014 04:43

Strange. I run 4.2.2 and do not get this error

ForceHSS 09 Jan 2014 05:22

Quote:

Originally Posted by ckgb (Post 2473172)
Strange. I run 4.2.2 and do not get this error

Are u running the pro version or the lite one from here

ckgb 09 Jan 2014 07:53

Pro one

ForceHSS 09 Jan 2014 17:04

Maybe one of my other plugins is not working well with this one. I have done checks and it is this plugin causing the problem. If the coder does not give me a fix soon I will be asking for a refund

TheInsaneManiac 10 Jan 2014 08:13

I can issue refund if needed, sorry I just got back in town, business trip took longer than expected, 3 of the 7 servers of a clients domain got brute forced and they were taken down. Anyway all is back to normal. I can take a look at the issue if you PM me information for access.

TheInsaneManiac 12 Jan 2014 00:53

Quote:

Originally Posted by TheInsaneManiac (Post 2472551)
Is this in 4.0 or 3.8 version?

Figured it out, small issue with a bracket. All is resolved. I emailed out updates to everyone.

ForceHSS 12 Jan 2014 03:03

Thx for fix I knew it was a problem with this mod. Would of fixed it myself and told u the problem but been very busy helping other vb owners

TheInsaneManiac 12 Jan 2014 03:26

It's all good man, sorry about the issue. Sometimes happens when rebuilding mods from scratch.

FreewayOrange 20 Jan 2014 21:31

I also get the message Fatal error: Call to undefined function indexOf() in register.php(902) : eval()'d code on line 40

Where is the issue with the bracket so we can fix this on our own? Because if I redownload it, I don't see any updates on the files (timestamps are from 2013). We use the lite version.

TheInsaneManiac 27 Jan 2014 02:05

Quote:

Originally Posted by FreewayOrange (Post 2475633)
I also get the message Fatal error: Call to undefined function indexOf() in register.php(902) : eval()'d code on line 40

Were is the issue with the bracket so we can fix this on our own? Because if I redownload it, I don't see any updates on the files (timestamps are from 2013). We use the lite version.

Hmm shouldn't be in the free version, but I'll take a look and push an update by tonight.

justicechick 31 Jan 2014 20:12

Quote:

Originally Posted by TheInsaneManiac (Post 2477126)
Hmm shouldn't be in the free version, but I'll take a look and push an update by tonight.

Was this update ever completed?

TheInsaneManiac 03 Feb 2014 02:32

Quote:

Originally Posted by justicechick (Post 2478256)
Was this update ever completed?

Yes sorry, been overwhelmed with another project. Just uploaded the fix. Will begin work on the 3.8 version here soon as it needs to be re-coded as well. Once that is completed I will begin work on Database Integration.

Set3sh 22 Mar 2014 15:29

Do you mind mailing me again a link to get the latest pro version?
Thank you.

dawges 23 Mar 2014 22:32

This is a nice addon and i bought the pro. However it does not work for me. I can go to my site using a web proxy sign right up and view the forum. Yes i studied the setting carefully and had the registrations set. Also, it is calling all cell phone ip's proxies. I enabled it and had 1000 proxy alerts all cell phones. Nice idea just does not work for me.

dawges 23 Mar 2014 23:10

I got it the way i wanted it to work now. However, every 5 seconds i get alerts on people using cell phones? There is now way i can stand this, anyway to fix this? If not i cant use it.

ForceHSS 23 Mar 2014 23:18

Turn alerts off

dawges 24 Mar 2014 00:27

Quote:

Originally Posted by ForceHSS (Post 2489169)
Turn alerts off

Thanks for the tip.

It is blocking Tor just fine but not web based proxies. Any ideas?

ForceHSS 24 Mar 2014 00:32

Op would be best to answer that. Mine seems to work as it should

dawges 24 Mar 2014 00:35

Quote:

Originally Posted by ForceHSS (Post 2489182)
Op would be best to answer that. Mine seems to work as it should

I just wanted it to block them at registration.

ForceHSS 24 Mar 2014 00:42

I know that is a pro thing not sure if its on the lite one

dawges 24 Mar 2014 01:06

Quote:

Originally Posted by ForceHSS (Post 2489184)
I know that is a pro thing not sure if its on the lite one

I bought the pro. Sorry I failed to mention that.

ForceHSS 24 Mar 2014 03:44

Quote:

Originally Posted by dawges (Post 2489188)
I bought the pro. Sorry I failed to mention that.

You would need to get in touch with op about the pro version if any problem either pm or his website

Kat-2 25 Mar 2014 05:00

Got Pro. Installed and everyone (including me) gets nothing but a white screen. No idea why.
Plus it is blocking one of my Super Mods.

ForceHSS 25 Mar 2014 05:03

Quote:

Originally Posted by Kat-2 (Post 2489407)
Got Pro. Installed and everyone (including me) gets nothing but a white screen. No idea why.
Plus it is blocking one of my Super Mods.

Disable it from the config then check permissions
Redirect blank = No
In the Proxy Alert: Permissions add the groups you dont want to see the alerts. I put all member groups in there only left out groups 1, 3, 4 and 8

Kat-2 25 Mar 2014 19:11

Fix (I thought) all of the settings. But, if I have it set to yes on globally, still getting blank page.

ForceHSS 25 Mar 2014 21:38

Post screenshot of all settings

Kat-2 25 Mar 2014 22:16

Removed.

ForceHSS 25 Mar 2014 23:21

Proxy Alert: General
Enabled = Yes
Tor = Yes
Lan Proxy = Yes
Web Proxy = Yes
Members Only = Yes
Template Edits = Yes
Redirection = Yes
Redirect Blank = No
Page Message = <span style="color:red;">You were detected using a proxy! For security reasons, we do not allow this on our community. Please disable the proxy or switch browsers if it is built in. Thank you.</span> or leave it the way you have it
Page Message Color = leave this blank
Persistent = Yes
Cookie Time = 365
Location = No
Message = Proxies are frowned upon in our community, please disable this or change browsers. Thank you.
Message Color = white

Proxy Alert: Registrations
Registration = Yes
Registration Only = Yes
Registration Remember = Yes

Proxy Alert: Email
Email = No

Proxy Alert: Thread
Thread = No
Forum ID = leave blank
User ID = leave blank

Proxy Alert: Permissions
IP Whitelist = I would leave this blank

Kat-2 25 Mar 2014 23:37

That is pretty much how I have it set, except if I set it on, it blocks out one of my Super Mods, and they are not behind any Proxy. So, that is why I have their IP in there. Plus...set like you posted, I get a blank screen, and everyone does.

Oh well, pretty much looks like I can't use it. At least it wasn't expensive.

Thank you so much for your help.

Oh...hmmm would any other Proxy hack be interfering? I do have another one it.....Proxy to Real IP.

ForceHSS 25 Mar 2014 23:44

You could have another plugin causing a problem with it don't just disable the one you think is messing with it remove it fully

Kat-2 27 Mar 2014 03:33

I tried it all, and it doesn't seem to matter. If I set it globally, I get the blank page. Guess this one is not for me.

ForceHSS 27 Mar 2014 03:34

Quote:

Originally Posted by Kat-2 (Post 2489820)
I tried it all, and it doesn't seem to matter. If I set it globally, I get the blank page. Guess this one is not for me.

globally?

Kat-2 27 Mar 2014 04:18

Quote:

Originally Posted by ForceHSS (Post 2489821)
globally?


Yes, the first one in the long list of settings. Under General.

Quote:

Would you like to globally enable Proxy Alert? Yes No

ForceHSS 27 Mar 2014 04:22

I see now if you said Enabled I would of understood

Kat-2 27 Mar 2014 06:09

LOL what's in a word. I knew what I meant anyhow. :p

TheInsaneManiac 20 Apr 2014 05:57

Quote:

Originally Posted by Kat-2 (Post 2489832)
LOL what's in a word. I knew what I meant anyhow. :p

If you still need help I will need some information from you. Please PM me.

Sorry I have not been around the last month or so, recently lost my job and have not had a computer. Been a rough patch and a long story. I'll use my friends computer for now and do as much as I can to help till I get back on my feet. Good ole notepad ftw.

mikez006 19 Jun 2014 16:36

I currently only have Tor detection turned on and it seems most of the IPs I'm getting are mobile/wireless IPs like mycingular.net (AT&T)

Is Tor detection 100% accurate? If he's using Tor why does it show up as At&T when I trace the IP?

leemart44 08 Jul 2014 20:13

I got token error when trying to import latest xml

ForceHSS 08 Jul 2014 21:15

Quote:

Originally Posted by leemart44 (Post 2505952)
I got token error when trying to import latest xml

post full error (check error log)

leemart44 08 Jul 2014 21:46

error is gone away, I have the pro version installed now, so maybe was just
an issue on my end not the xml
Installed adblock mod of yours and now the proxy alert stopped working any advise?
I'm using your Pro version 1.92

Okay got it going but now its blocking Google adsense bots

Marv 26 Jul 2014 16:30

Iīve bought the pro version 1.92 and have a few issues with it.
Actual I have to deal with a bunch of trolls on my forums and thought it would be wise, to have a proxy filter like this. Unfortunal, it doesnīt work reliable.

Auto template has seemed to malfunction, so I edited the navbar myself and added the missing line. Now it detects tor users here and then, but you canīt relay on that. Proxy-Alert is setup to block proxy and tor users and redirect them to the PA error page. As far as I can see, that doesnīt work. Wether the users are blocked, nor they become redirected to the error page.

As I visited the forum using tor, it wasnīt detected. Even using a normal proxy-server list in firefox was ignored by this mod.

Maniac, may be you could have a look into this. In this state the mod is unfortunal not recommended for use - at least, if you have trolls lurking around and youīre in need, to get rid off em.

ForceHSS 26 Jul 2014 16:38

Quote:

Originally Posted by Marv (Post 2508354)
Iīve bought the pro version 1.92 and have a few issues with it.
Actually, I have to deal with a bunch of trolls on my forums and thought it would be wise, to have a proxy filter like this. Unfortunal, it doesnīt work reliably.

Auto template has seemed to malfunction, so I edited the navbar myself and added the missing line. Now it detects tor users here and then, but you canīt rely on that. Proxy-Alert is setup to block proxy and tor users and redirect them to the PA error page. As far as I can see, that doesnīt work. Whether the users are blocked, nor they become redirected to the error page.

As I visited the forum using tor, it wasnīt detected. Even using a normal proxy-server list in Firefox was ignored by this mod.

Maniac, maybe you could have a look into this. In this state the mod is unfortunate not recommended for use - at least, if you have trolls lurking around and youīre in need, to get rid off em.

Post the missing line so others can add it

Marv 26 Jul 2014 17:09

The missing line is the one which should be done by the autotemplate. If it fails, there is the line in the readme.txt file in the package.

ForceHSS 26 Jul 2014 17:16

And how can I test to see if that is not working on my site and with or without the brackets
Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Marv 31 Jul 2014 08:45

InsaneManiac,

ProxyAlert is now running for about a week and we had to found out, that we run into some difficulties that are annoying our members, especially those using mobile carriers via phone, tablets or pods.

1. We have in that particular forum a large number of false positives, we had to check manual. Though, by the design of this mod we werenīt able to grant those false identified access to the forums.

2. Most - if not all - mobile providers are using proxies for their customers. ProxyAlert is blocking nearly 80% of all Tapatalk users. Even myself.

Any ideas?

RichieBoy67 31 Jul 2014 11:00

Quote:

Originally Posted by Marv (Post 2509111)
InsaneManiac,

ProxyAlert is now running for about a week and we had to found out, that we run into some difficulties that are annoying our members, especially those using mobile carriers via phone, tablets or pods.

1. We have in that particular forum a large number of false positives, we had to check manual. Though, by the design of this mod we werenīt able to grant those false identified access to the forums.

2. Most - if not all - mobile providers are using proxies for their customers. ProxyAlert is blocking nearly 80% of all Tapatalk users. Even myself.

Any ideas?

I would just use the Tor blocker.

Marv 31 Jul 2014 11:30

Thanks for the head up, Richie. Thatīs exactly what weīve changed meanwhile, too. But we need the webproxy filter to work, to get rid off our "I am a motherf***in special forces"... trolls.

RichieBoy67 31 Jul 2014 11:58

Quote:

Originally Posted by Marv (Post 2509122)
Thanks for the head up, Richie. Thatīs exactly what weīve changed meanwhile, too. But we need the webproxy filter to work, to get rid off our "I am a motherf***in special forces"... trolls.

I hear you but some countries use proxies almost as a default and some isp's will also be flagged that way as will some phone carriers.

In addition many thousands if not more of new proxies are created every day. It is impossible to keep up with them.

Trolls are a pita though!

Marv 31 Jul 2014 12:17

Anyone an idea hot to make this mod smarter? When Iīm using tor Iīm not detected.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


leemart44 01 Aug 2014 21:26

I'm using the pro version at it blocks all my tor attempts
the free version doesn't block tor browser

Marv 01 Aug 2014 21:32

I have the pro version and even with a "this.is.a.tor.exit.node.org" -IP Iīm not getting caught with my tor. Shall I do a testing with your site ;)?

ReactionShot 06 Oct 2014 14:18

It works great for me. Instantly purchased pro. Thanks Maniac!

TheInsaneManiac 12 Nov 2014 00:45

Quote:

Originally Posted by ReactionShot (Post 2517866)
It works great for me. Instantly purchased pro. Thanks Maniac!

You're welcome, thank you for your feed back. I actually have been using courseware in PHP to freshen my skills more since I been doing freelancing, and I believe I am going to do another overhaul in the next couple of months. Detection for tor has improved, and I feel like reducing conditionals into case arguments to lessen code. I currently work 2 jobs and am freelancing so I work about 70 hours a week now, (trying to save up for a car since I drive a bike to work) so I do plan on working on it in my free time. I currently run a newer version which does integrate into the database, but it's relatively simple with only storing users detected. I will begin to code an AdminCP panel to load those users instead of having to view them in phpmyadmin.

I am looking for a beta tester of the new code, if interested PM me.

sonic83 10 Jan 2015 14:03

hello. Excelent plugin. What's the name of the cookie of "Proxy Alert"?
It's for the cookie's advertisement.
Thank you

Nelson58 10 Jan 2015 14:29

Very nice login!! Thank you for producing it!

I do want to update you, that it is recognizing routers as proxies. Here is a message from one of my members:

"I just got a pop up in the corner of my screen saying this and to disable it or change browsers. As far as I know I'm on my usual server and I haven't done anything to change it. I'm currently using an iPhone 4 with safari any ideas why this is happening? It's using my houses router currently. I just used my kindle and it didn't have the window pop up. Any ideas why this would be happening? How would I fix it?"

Nelson58 10 Jan 2015 16:35

It identified these IPs as Tors, and they aren't:

xxxx was detected using a tor!
Real IP: 66.236.27.197
Real Hostname: 66.236.27.197
Proxy IP: 66.236.27.197
Proxy Hostname: 66.236.27.197

was detected using a tor!
Real IP: 107.77.75.80
Real Hostname: 107.77.75.80
Proxy IP: 107.77.75.80
Proxy Hostname: 107.77.75.80


was detected using a tor!
Real IP: 10.154.0.250, 180.94.79.58
Real Hostname: Unknown
Proxy IP: 180.94.79.58
Proxy Hostname: 180.94.79.58

sonic83 10 Jan 2015 20:19

Hello. I purchased the PRO version now, but has no "product-proxyalert.xml" to run.

Appreciate your help. I am sending you pm

sonic83 10 Jan 2015 22:55

Quote:

Originally Posted by sonic83 (Post 2531737)
Hello. I purchased the PRO version now, but has no "product-proxyalert.xml" to run.

Appreciate your help. I am sending you pm

Thanks, I found the xml :)

But I urgently need this option:
Not Allowing users to post Tor
I thought that was already available.
When you think have it?

Thank You

Nelson58 11 Jan 2015 07:15

Quote:

Originally Posted by Nelson58 (Post 2531689)
It identified these IPs as Tors, and they aren't:

xxxx was detected using a tor!
Real IP: 66.236.27.197
Real Hostname: 66.236.27.197
Proxy IP: 66.236.27.197
Proxy Hostname: 66.236.27.197

was detected using a tor!
Real IP: 107.77.75.80
Real Hostname: 107.77.75.80
Proxy IP: 107.77.75.80
Proxy Hostname: 107.77.75.80


was detected using a tor!
Real IP: 10.154.0.250, 180.94.79.58
Real Hostname: Unknown
Proxy IP: 180.94.79.58
Proxy Hostname: 180.94.79.58

Any fix for this incorrect Tor detection?

ozzy47 11 Jan 2015 12:46

Quote:

Originally Posted by Nelson58 (Post 2531846)
Any fix for this incorrect Tor detection?

The pro version seems to have a IP whitelist option available.

Nelson58 11 Jan 2015 12:50

Quote:

Originally Posted by ozzy47 (Post 2531876)
The pro version seems to have a IP whitelist option available.

I would rather it worked correctly than have to whitelist hundreds of users after looking each one up. That takes a lot of time.

I meant has he fixed it from all the false positives.

ozzy47 11 Jan 2015 13:11

It don't appear that way, if you are getting false positives. The developer has not been on here in two months, so who knows when he can address the situation.

Nelson58 11 Jan 2015 13:28

Quote:

Originally Posted by ozzy47 (Post 2531882)
It don't appear that way, if you are getting false positives. The developer has not been on here in two months, so who knows when he can address the situation.

It's too bad, this is a great idea....

I hope this isn't another coder who just "leaves" and gives up on his mod....

TheInsaneManiac 13 Jan 2015 20:37

Quote:

Originally Posted by Nelson58 (Post 2531689)
It identified these IPs as Tors, and they aren't:

xxxx was detected using a tor!
Real IP: 66.236.27.197
Real Hostname: 66.236.27.197
Proxy IP: 66.236.27.197
Proxy Hostname: 66.236.27.197

was detected using a tor!
Real IP: 107.77.75.80
Real Hostname: 107.77.75.80
Proxy IP: 107.77.75.80
Proxy Hostname: 107.77.75.80


was detected using a tor!
Real IP: 10.154.0.250, 180.94.79.58
Real Hostname: Unknown
Proxy IP: 180.94.79.58
Proxy Hostname: 180.94.79.58

The problem is that Tor detection is built off of Tor's exitlist. Which is their own IP address blocking script. Somehow their script is throwing false positives, and I am not understanding why, so this requires me to build the script to block the ip's individually. The problem with this is that I would have to update the ip definitions weekly or possibly daily. Which I don't mind doing, but I am unsure on vBulletins policy with automatic file updates. This may have to be something I do in the premium version. However I am ok with updating the definitions on my website server, but that means extra work for everyone else on uploading a new file every week to their servers. I even did a check for one of the IPs and found no results:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

So yes it can be done, but I need to check with vBulletin staff to see if I could do automatic file updates from my server.



Quote:

Originally Posted by Nelson58 (Post 2531885)
It's too bad, this is a great idea....

I hope this isn't another coder who just "leaves" and gives up on his mod....

No I am not, I am just balancing two jobs and working for a third party on another project, and have not any time to work on anything the last couple months, and probably will still not have time for another 2-3 months when this project is completed.



Quote:

Originally Posted by sonic83 (Post 2531793)
Thanks, I found the xml :)

But I urgently need this option:
Not Allowing users to post Tor
I thought that was already available.
When you think have it?

Thank You

This is something that will be added to the next version.


EDIT: Approval from staff was given, when I have some spare time, I will upgrade detection.


Update: I have pushed out 1.9.3 to everyone. There was an issue that referred all proxies as tor detections. Now you can appropriately track an incorrect detection. If you are still receiving false positives from Tor side, then please let me know and I will code everything based on IP instead of Tor's API for blocking.

ForceHSS 31 Jan 2015 01:14

Have the pro version still waiting for email for the new version

TheInsaneManiac 02 Feb 2015 00:43

Quote:

Originally Posted by ForceHSS (Post 2535329)
Have the pro version still waiting for email for the new version

I sent the email out, PM me your email affiliated with the Pro purchase.

Marv 02 Feb 2015 09:00

Donīt wanna jump a train but if this eMail has gone out to us Pro-customers, I have no mail, too. Doesnīt matter, cause since the mod isnīt really usable without a false detection quote of 30% I donīt use it anymore.

Whitelisting is nice - but heck, I canīt go through 8.000 dynamic IPīs each day and add them one by one to the list. Esp. nearly every mobile carrier uses proxies, where the half is beeing detected false as TOR-users. As I had the mod activated my mailbox turned into pandoras box with complaints over complaints.

Unless there is no data-service which handles & checks (!) the ipīs and ip-ranges for proxies, I wouldnīt recommend to use this on boards with >500 members.

ForceHSS 02 Feb 2015 11:27

Quote:

Originally Posted by TheInsaneManiac (Post 2535632)
I sent the email out, PM me your email affiliated with the Pro purchase.

Still no email

megabink 02 Feb 2015 12:52

The same here....

ForceHSS 02 Feb 2015 13:20

As a pro member we should of got the updated version first wants me to ask for a refund now

ForceHSS 07 Feb 2015 14:37

Still waiting for the email

TheInsaneManiac 09 Feb 2015 04:30

I resent the email out. Please let me know if no one receives it.

ForceHSS 09 Feb 2015 04:37

Still nothing, please check you are sending it to the correct email address if it is right, maybe there is a problem with your email client

megabink 09 Feb 2015 08:29

No email here!

ForceHSS 09 Feb 2015 16:02

Will be another two days before he replies lol

TheInsaneManiac 11 Feb 2015 03:19

Quote:

Originally Posted by ForceHSS (Post 2536769)
Will be another two days before he replies lol

One day. So :p lol

I'm trying to be more active, again working two jobs and a side project for a client leaves me with little free time, but I'm trying and apologize again in advance.

Just a little update, I am waiting on reply from Sellfy why no one is receiving updates for the product, however if you PM me your email that you purchased the pro version with I can verify everything and PM it to you.

ForceHSS 11 Feb 2015 03:21

Quote:

Originally Posted by TheInsaneManiac (Post 2536929)
One day. So :p lol

I'm trying to be more active, again working two jobs and a side project for a client leaves me with little free time, but I'm trying and apologize again in advance.

Just a little update, I am waiting on reply from Sellfy why no one is receiving updates for the product, however if you PM me your email that you purchased the pro version with I can verify everything and PM it to you.

I will pm you it again and a few others just in case

megabink 11 Feb 2015 21:50

Got my pro update today via pm!

TheInsaneManiac 14 Feb 2015 03:28

Quote:

Originally Posted by megabink (Post 2537060)
Got my pro update today via pm!

Let me know where false detections are coming from if you receive any now.

megabink 14 Feb 2015 18:55

Quote:

Originally Posted by TheInsaneManiac (Post 2537362)
Let me know where false detections are coming from if you receive any now.

Will keep you updated!

Alibass 15 Feb 2015 19:36

Apparently 1.9.3 [free version] doesn't detect TOR :erm:

woodmj 28 Feb 2015 14:03

Hi, Is there anyway in latest pro version to let LAN proxies through but still block all other types?

TheInsaneManiac 11 Mar 2015 00:10

Quote:

Originally Posted by woodmj (Post 2539056)
Hi, Is there anyway in latest pro version to let LAN proxies through but still block all other types?

Yes it's in the options in the AdminCP just disable Tor and Web proxy alert.


Quote:

Originally Posted by Alibass (Post 2537579)
Apparently 1.9.3 [free version] doesn't detect TOR :erm:

What do you mean? Have you used TOR and it's letting you in?

leemart44 20 Mar 2015 03:12

thanks for updates how do I get update for paid one I bought from you?

woodmj 18 Apr 2015 08:43

Ref my purchase of Proxy Alert Pro.

I have had a couple of my forum members complain that they can't connect to the forum as they are being flagged as using a proxy. Checking out their IPs they are using either US cable company or ATT cell/mobile internet connections. I did think about whitelisting the IP ranges associated with those companies but the Whitelist function in the Proxy Alert section of the ACP does not allow ranges to be input using CIDR notation and so it would entail listing approx 75,000 odd IPs for each company to cover all 3 of the ranges.

Please would you be able to suggest a better solution?

I did check to see whether I have the most current version of Proxy Alert Pro through the link in my purchase e-mail and it looks like I already have the most current version of 1.93?

woodmj 21 Apr 2015 13:02

Also Redirect To Message does nothing for me. I have to use Redirect To Blank Page to get the software to take any action.

ForceHSS 21 Apr 2015 20:38

Quote:

Originally Posted by woodmj (Post 2543412)
Ref my purchase of Proxy Alert Pro.

I have had a couple of my forum members complain that they can't connect to the forum as they are being flagged as using a proxy. Checking out their IPs they are using either US cable company or ATT cell/mobile internet connections. I did think about whitelisting the IP ranges associated with those companies but the Whitelist function in the Proxy Alert section of the ACP does not allow ranges to be input using CIDR notation and so it would entail listing approx 75,000 odd IPs for each company to cover all 3 of the ranges.

Please would you be able to suggest a better solution?

I did check to see whether I have the most current version of Proxy Alert Pro through the link in my purchase e-mail and it looks like I already have the most current version of 1.93?

You have the option to not ban groups who use proxies have you set this option yet in admincp/options/Proxy Alert: Permissions = Usergroup

woodmj 22 Apr 2015 08:43

Thanks ForceHSS I will try that.

The thing is though the biggest thing I'm trying to use this mod for is to scan non logged in members/guests to try and stop hacking activity so I have it set to scan members and non-members. What you suggest might be a workaround if the members concerned still have a forum cookie on their PCs with their login credentials in.


Do you know if there's anyway to get in touch with the developer of this mod? Does he provide support to those that have purchased the pro version?

ForceHSS 22 Apr 2015 08:46

Quote:

Originally Posted by woodmj (Post 2543824)
Thanks ForceHSS I will try that.

The thing is though the biggest thing I'm trying to use this mod for is to scan non logged in members/guests to try and stop hacking activity so I have it set to scan members and non-members. What you suggest might be a workaround if the members concerned still have a forum cookie on their PCs with their login credentials in.


Do you know if there's anyway to get in touch with the developer of this mod? Does he provide support to those that have purchased the pro version?

The last time he was on 11 Mar 2015, 00:10 as you see he does not get on much you could try pming him

woodmj 22 Apr 2015 17:34

Good plan. Will do.

liadben 24 Apr 2015 09:10

I've installed the PRO version. its work! like and use it!

woodmj 24 Apr 2015 10:45

I disabled it for now until I can get in touch with the mod author on the 2 issues I found. The main one being the blocking of non-proxy connections as proxy connections. It was generating too many member complaints and cutting my traffic.

the one 18 May 2015 11:01

Hello all i want to thank ForceHSS for letting me know this thread existed

I would love to have the pro version where can i get it please.


All times are GMT. The time now is 13:09.

Powered by vBulletin® Version 3.8.14
Copyright © 2021, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.