vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=299546

ForceHSS 18 May 2015 13:05

Quote:

Originally Posted by michelle81 (Post 2545735)
Hello all i want to thank ForceHSS for letting me know this thread existed

I would love to have the pro version where can i get it please.

PM the coder to buy it

the one 18 May 2015 18:14

Ok so i went and paid for the pro version

I then tested my website via this proxy address here https://hide.me/en/proxy.It then showed this message below

https://www.vbulletin.org/forum/external/2015/05/12.jpg

I thought brilliant it works then i then tried another 10 proxy websites and out of them ten i could view my forum on 6 of the proxy sites.So does this plugin only work on a select few proxy sites

These are my settings in admin cp below are they correct

https://www.vbulletin.org/forum/external/2015/05/13.jpg

https://www.vbulletin.org/forum/external/2015/05/14.jpg

ForceHSS 18 May 2015 19:12

persistent = yes
page message =
Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

change the colour to what you want

the one 18 May 2015 21:30

Thank you so much

the one 19 May 2015 07:05

It looks like i am going to have to disable this unless anyone can help

This is the first message i got fro a member

Hi Guys,
My regular computer and tablet cannot log in. Its says I'm using a
proxy but I don't use one, my only connection is wi-fi


This is another message below

hi this is mojo,
the proxy plugin wont allow me and i dont use a proxy server, just wifi...

woodmj 19 May 2015 11:00

I had similar problems with the pro version too and too had to disable for now on my forum due to member complaints.

I'm not sure what else to try to try and get in contact with the author. I posted here and sent them a PM here but as yet have not received a response.

Do let me know if you have any luck getting in touch with them and I'll of course return that favour.

the one 19 May 2015 13:13

I will let you know and i have also sent a pm and email to the author

I didn't mind paying for this, it was only 10$,But i am a bit upset that i have had to disable it straight away.

It does not do exactly what it says but i guess thats the gamble

ForceHSS 19 May 2015 13:56

Quote:

Originally Posted by michelle81 (Post 2545819)
It looks like i am going to have to disable this unless anyone can help

This is the first message I got from a member

Hi Guys,
My regular computer and tablet cannot log in. It says I'm using a
Proxy but I don't use one, my only connection is WiFi


This is another message below

Hi, this is mojo,
The proxy plugin won't allow me and I don't use a proxy server, just wifi...

If you go over all settings you can stop this picking up member groups so it only works with guests so if he sees it as a guest once he logins he won't get the proxy message

kushal 02 Sep 2015 02:45

Quote:

Originally Posted by michelle81 (Post 2545819)
It looks like i am going to have to disable this unless anyone can help

This is the first message i got fro a member

Hi Guys,
My regular computer and tablet cannot log in. Its says I'm using a
proxy but I don't use one, my only connection is wi-fi


This is another message below

hi this is mojo,
the proxy plugin wont allow me and i dont use a proxy server, just wifi...

Generally many countries allow LAN Proxy through Network service provider. The services are being provided through a proxy. I disabled just the LAN Proxy and things seems to be normal.

TheInsaneManiac 11 Sep 2015 19:36

Quote:

Originally Posted by woodmj (Post 2543824)
Thanks ForceHSS I will try that.

The thing is though the biggest thing I'm trying to use this mod for is to scan non logged in members/guests to try and stop hacking activity so I have it set to scan members and non-members. What you suggest might be a workaround if the members concerned still have a forum cookie on their PCs with their login credentials in.


Do you know if there's anyway to get in touch with the developer of this mod? Does he provide support to those that have purchased the pro version?

Sorry, there hasn't been many suggestions or posts in this topic in awhile so I haven't been actively following it, but that is a wonderful idea to scan non members and post alerts. I do still plan on bringing a logging system to this plugin, but haven't had the time. With this new plugin I had an idea for and have started working on, I could actually port the logging system from it over and have that as well, so that you can just monitor everything, members or non members.


Quote:

Originally Posted by woodmj (Post 2543412)
Ref my purchase of Proxy Alert Pro.

I have had a couple of my forum members complain that they can't connect to the forum as they are being flagged as using a proxy. Checking out their IPs they are using either US cable company or ATT cell/mobile internet connections. I did think about whitelisting the IP ranges associated with those companies but the Whitelist function in the Proxy Alert section of the ACP does not allow ranges to be input using CIDR notation and so it would entail listing approx 75,000 odd IPs for each company to cover all 3 of the ranges.

Please would you be able to suggest a better solution?

I did check to see whether I have the most current version of Proxy Alert Pro through the link in my purchase e-mail and it looks like I already have the most current version of 1.93?

I thought I implemented ip ranges, but I will take a look into this.


Quote:

Originally Posted by woodmj (Post 2544046)
I disabled it for now until I can get in touch with the mod author on the 2 issues I found. The main one being the blocking of non-proxy connections as proxy connections. It was generating too many member complaints and cutting my traffic.

I would recommend only using TOR detection if you want to block any members as proxy and web proxy detection could be falsely triggered from a non dynamic IP.


Quote:

Originally Posted by ForceHSS (Post 2545837)
If you go over all settings you can stop this picking up member groups so it only works with guests so if he sees it as a guest once he logins he won't get the proxy message

Thank you for your assistance in my absence. It appears I am not getting emails from my subscribed threads, I will be reaching out to the vB team in regards to this. In the meantime I will keep an eye on my PMs while I am working to push out my new product, which will aim to prevent spam and possibly multiple account creation.

the one 27 Dec 2015 06:35

Hi all only me again i deleted this by accident

I am running 4.2.1 and have uploaded the files correctly but its not blocking tor network

It was before is there something i am now doing wrong or is there a specific download for 4.2.1 or is this not compatible with any other plugin.

Also i cant find my pro version i paid for would i need to pay for this again TheInsaneManiac


Many thanks for any help

the one 27 Dec 2015 10:33

Hi i was told you could block the tor network in the firewall for csf

Does anyone know where this is i have tried looking but cant find it

Many thanks

the one 28 Dec 2015 08:40

Ok i have downloaded and reinstalled the pro version.

All i want to do is block tor but its not working.This is a screen shot below

https://www.vbulletin.org/forum/external/2015/12/7.png

I have had to use my csf firewall in whm to help with the block for now

Is there something i am doing wrong or does this not work if you have other ip plugins installed i have Duplicate IP Report by BOP5

woodmj 28 Dec 2015 09:33

Try enabling Redirect Blank. I recall when I was using the mod it didn't work for me if I didn't have that enabled.

the one 28 Dec 2015 11:06

Quote:

Originally Posted by woodmj (Post 2561258)
Try enabling Redirect Blank. I recall when I was using the mod it didn't work for me if I didn't have that enabled.

Thats great it now works just gives a blank page it would have been cool to have been able to have a message but that dont work.

The normal Redirection Would you like to block access to the forums and redirect to your own message does not work i think it does for proxy but not for tor.For tor to be blocked like you said i had to enable redirect blank.

thanks

TheInsaneManiac 23 Mar 2016 03:17

Are you using the pro version? Need to figure out which to troubleshoot.

edgeless 23 Mar 2016 03:19

Quote:

Originally Posted by TheInsaneManiac (Post 2567880)
Are you using the pro version? Need to figure out which to troubleshoot.

Never mind... you were too fast for me :o. I cleared the cookies and it's now working :up:

edgeless 25 Mar 2016 16:18

Okay, it does work... but I'm encountering a few problems. And one of them is a fairly serious one.

I'll start with the most serious problem. There is no combination of settings that I have been able to find which will allow registration from what I fear may be many mobile devices. For testing I'm using my own cell phone. The test is to try and use it to register as a new member on my forum site. Prior to each test, I freshly clear its cookies and other private data. The problem is that PApro persistently interprets these efforts as proxy connections and blocks me at the registration page. This happens even with the Tor, LAN, and Web Proxy options set to "no" and the Members option set to "yes". And it doesn't matter if the Registration Only option is set to "yes" or "no". The vB message with the text that I entered for the proxy_alert_registration phrase consistently appears and blocks every registration attempt from this cell phone.

I have a theory about this issue, but at the moment I have no way to test it. My theory is this: The IPs assigned to my phone (its service is through Consumer Cellular) do not have rDNS hosts. That is, none of the dhcp IPs leased to my cell phone can be reverse-resolved to host names (i.e., there are no PTR records for them). If PApro uses rDNS lookup as a criterion to approve each IP as being a non-proxy address, then this may be why these IPs are not passing. But as I've said, I have no immediate way of testing this theory, since I only have the one cell phone. I could have some of my members or staff test this theory with their mobile devices by clearing their cookies and then attempting registration. But that tends to become a bit awkward so I'm holding off for now. And of course users who contact admin due to a registration refusal are usually not the best options as test subjects.

The next matter of concern is that my testing has shown that for some reason when the Registration Only option is set to "yes", my registration attempts through Tor will randomly slip through to my forum's registration form. And this is with confirmation that my Tor exit node IP has NOT changed each time it happens. Again, this issue does seem to only occur when the Registration Only option is set to "yes". I haven't been able to duplicate it with that option set to "no"... at least yet.

My last observation is trivial... but I'll still mention it. It is that even when I have the Location option set to "no" while the Registration Only option is set to "no" as well, the PA popup message seems to only appear on the main forum index page. Isn't the Location option being set to "no" supposed to cause this popup message to appear on all pages? This is obviously not a serious problem. It's only an observation at this point.

Thanks for reading... if anyone has any thoughts I'll sure be interested.


EDIT:
I had one of my staff test the reg process using their mobile device - it acquires IP addresses which will in fact properly resolve to host names. Like my mobile IPs, hers are as well managed by AT&T Mobility; they are just different numerical blocks. She was able to get through the registration process without issue. I think that serves as fairly good evidence that the lack of PTR records for the IP blocks that my phone has access to has been responsible for PApro rejecting the registration efforts from my phone. The 2nd issue, intermittent slip throughs on Tor connections, may require some further testing on my part.

EDIT2:
Okay. I've done some more testing on the second issue. As mentioned, when the Registration Only option is set to "no", all Tor connections are blocked and the "proxy connections are not allowed" message is consistently presented as expected - i.e., registration does not occur and the proxy_alert_registration message is displayed. However, when the Registration Only option is set to "yes", the system will randomly fail to display the proxy_alert_registration phrase and instead moves to the next stage, which is the new member information entry form page. But when this happens, once the member information has been entered and the 'Complete Registration' button has been clicked, no registration occurs -which is good- but the vB message which then appears is not about proxies at all... instead it is: "Your email is marked as spam." Below is a screenshot.

https://www.vbulletin.org/forum/external/2016/03/5.pngDoing a search for phrases, the above message phrase is shown to be the contents of email_mark_as_spam. I'm unsure though why this message phrase is triggered by PApro ? So that's my first question. And my next question is why, when the Registration Only option is set to "yes", do Tor connections randomly alternate between allowing the user to reach the member information entry form stage (followed by display of the email_mark_as_spam message), or terminating immediately after the birth date is entered with a prompt display of the proxy_alert_registration message? The important thing of course is that this mod seems to block Tor users. It just doesn't do the same thing each time if the Registration Only Option is set to "yes". At least that's what I'm finding.

Any ideas as to why I'm noticing this behavior?

Dave 25 Mar 2016 16:27

Regarding the problem with your phone, does this also happen when you switch from data to WiFi? A lot of providers nowadays do a lot of magic by passing it through a proxy on their own server that optimizes images/JavaScript/CSS files and add all kind of headers.

edgeless 25 Mar 2016 22:13

Quote:

Originally Posted by Dave (Post 2568002)
Regarding the problem with your phone, does this also happen when you switch from data to WiFi? A lot of providers nowadays do a lot of magic by passing it through a proxy on their own server that optimizes images/JavaScript/CSS files and add all kind of headers.

I'm not sure. I don't have a wifi-equipped router here and there are no wifi access points near enough to me to try. But I have contacted AT&T IP Support who handle their DNS servers and they have confirmed that the PTR records are missing from the IP ranges that my phone has access to. They emailed me that they have submitted a request to the team who administers the mobile ip DNS servers to add the PTR records for the affected ip blocks. They said the problem should be corrected by sometime next week. Once it is fixed (if in fact that occurs), I will test it with my phone and report back here.

edgeless 30 Mar 2016 04:12

AT&T came through and added the PTR records. The two /24 IP blocks that my phone's IPs come from all resolve to host names now. But unfortunately that wasn't the problem. What was, and is the problem is the fact that the only APN available to my phone through its current provider goes through a proxy. So the public IPs that it's given by the dhcp server are in fact proxy IPs. Which, of course, means that my phone being detected by PA as using proxy connections is accurate. I believe there are some comments about mobile carriers using proxy IPs earlier in this thread.

Question: Does the IP Whitelist provision in PApro allow the use of CIDR or wildcards? I'm hoping I don't have to individually allow each IP.

edgeless 30 Mar 2016 19:48

Quote:

Originally Posted by Marv (Post 2535667)
Whitelisting is nice - but heck, I canīt go through 8.000 dynamic IPīs each day and add them one by one to the list. Esp. nearly every mobile carrier uses proxies, where the half is beeing detected false as TOR-users. As I had the mod activated my mailbox turned into pandoras box with complaints over complaints.

Unless there is no data-service which handles & checks (!) the ipīs and ip-ranges for proxies, I wouldnīt recommend to use this on boards with >500 members.

This is exactly the problem! The system falsely detects certain mobile carrier proxy IPs as Tor exit nodes. Therefore, you can't turn off these false detections without turning off Tor detection altogether. Personally, I could get by if there were a way to whitelist IP ranges. But it appears that there isn't. It's really a shame because this system has tremendous potential. But as it stands, auto blocking the registration efforts of legitimate potential members stands to discourage them from ever trying to register again. This problem really needs to be worked out in order to make this an outstandingly useful and dependable add-on.

It also seems difficult to get the developer to address these concerns for some reason :(

Thr33 27 Jul 2016 00:54

im getting an error:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


rhody401 27 Jul 2016 22:39

From the error you posted, it looks like perhaps the files were not all uploaded to your server. (the includes sub folder, etc)

Double check that, perhaps?

Thr33 27 Jul 2016 22:53

When i first read your comment i thought "how stupid does this guy think i am"...

I re-uploaded all the files and the modification works :| Thanks.

Quote:

Originally Posted by rhody401 (Post 2574042)
From the error you posted, it looks like perhaps the files were not all uploaded to your server. (the includes sub folder, etc)

Double check that, perhaps?


MarkFL 28 Jul 2016 00:44

The developer should click the "Additional Files" option then, to make it more clear that files need to be uploaded to the server. :)

Thr33 28 Jul 2016 01:21

I know I know... egg on my face. (shamed)


All times are GMT. The time now is 14:28.

Powered by vBulletin® Version 3.8.14
Copyright © 2021, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.