vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=304190

Wolver2 08 Nov 2013 13:20

I appreicate this mod very much. I was wondering what if there were malicious things that happened around 6 months ago? should I still use this plugin?

SEOvB 08 Nov 2013 13:44

Quote:

Originally Posted by Wolver2 (Post 2459125)
I appreicate this mod very much. I was wondering what if there were malicious things that happened around 6 months ago? should I still use this plugin?

If you're familiar with php then you can just adjust this line:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Change the last "3" to "6" then it'll cover the last 6 months.

Hope that it helps.

Disasterpiece 18 Nov 2013 14:52

I think this scripts output is generally misleading and causes panic where not necessary.

Either you should seriously refine your script and add A LOT more conditions to reduce false positives (and as it seems right now, 95% seems to be only false positives) or discontinue the mod.

Determining if a forum was hacked should be left to specialists. If you let someone who doesn't have a clue run your script, nothing good will come from it.

SEOvB 20 Nov 2013 02:19

Quote:

Originally Posted by Disasterpiece (Post 2461824)
I think this scripts output is generally misleading and causes panic where not necessary.

Either you should seriously refine your script and add A LOT more conditions to reduce false positives (and as it seems right now, 95% seems to be only false positives) or discontinue the mod.

Determining if a forum was hacked should be left to specialists. If you let someone who doesn't have a clue run your script, nothing good will come from it.

Hi Disasterpiece,

We understand where you are coming from; the script errs on the side of caution, perhaps too much. This was originally an in-house tool that we used to quickly determine which commonly exploited sets of data needed investigating for forums that had been recently hacked. If time allows, we can refine and update the scan criteria of the script to be more precise.

However, we do disagree that the current script output is misleading and we disagree that it causes unnecessary panic. If a forum owner is concerned that his forum was hacked, which is highly likely given the recent mass attacks on vBulletin forums, we believe that this script is a good starting point for investigation and diagnosis, if the script description and instructions are carefully read and followed.

The script does not stop with a simple 'warning', but provides additional, useful information about what was modified and by whom. More information is better than less, and caution is better than carelessness, so the script provides as much information as it can, for those forum owners with some vBulletin knowledge who can understand the script output, and it also provides the most careful recommendation, for those with less vBulletin knowledge.

We do realize that this script alone is not enough for a diagnosis, which is why we recommend professional help. Speaking of which, we are happy to take a look at your script output via PM, if you have concerns, to clarify your results; we've done this a few times already.

Thanks,
Nick - Chief vB Developer @ SEOvB


All times are GMT. The time now is 07:38.

Powered by vBulletin® Version 3.8.14
Copyright © 2021, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.