vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=250322

BB Code - Twitvid - Twitter Videos - Embed (BBCode)
by BirdOPrey5
11 Sep 2010 17:14

2 Attachment(s)
Twitvid.com is quickly becoming a popular site to host online videos and many say it's better than YouTube.

This BB Code will allow you to embed Twitvid's on your forum. It has been confirmed working in all major browsers and all current vBulletin versions.

Live Demo: Here

Add a New BB Code

Title: Twitvid Video
BB Code Tag Name: twitvid
Replacement:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Example:[twitvid]HYXYE[/twitvid]
Description: Embed Twitvid Videos
Use Option: No
Button Image: (optional) https://www.vbulletin.org/forum/external/2010/09/41.jpg
Remove Tag If Empty: Yes
All Disable Options: Yes

------

Simply place the twitvid code between the [twitvid] [/twitvid] tags.

Example twitvid URL: http://www.twitvid.com/HYXYE
The code is: HYXYE

Example: [twitvid]HYXYE[/twitvid]

------

Please mark as installed if you use this. :)

Check My Profile for other BB Code enhancements. They work on all versions.

Screenshot Attached:
http://www.vbulletin.org/forum/attac...1&d=1284225100

OldSchoolDSL 05 Jan 2011 23:23

Installed and working

4.1 PL2

bintoro 16 Jan 2011 03:09

Good. Install too for my first experience in vb.

8thos 21 May 2011 19:30

Doesn't work for me. :(

BirdOPrey5 21 May 2011 20:13

They changed their embed code- just updated to the new version.

8thos 21 May 2011 21:24

Still not working. Is it because you are using AME?

BirdOPrey5 21 May 2011 23:09

While I have AME I use the twitvid bbcode as well, on the demo page what you are seeing is the exact BB Code listed here.

What isn't working? No box at all? Video doesn't play? Link to a post with this issue?

8thos 22 May 2011 00:20

Quote:

Originally Posted by BirdOPrey5 (Post 2198508)
While I have AME I use the twitvid bbcode as well, on the demo page what you are seeing is the exact BB Code listed here.

What isn't working? No box at all? Video doesn't play? Link to a post with this issue?

http://the8thlegion.com/showthread.p...ing-Some-Tests

Random but I was thinking about installing AME. I can't believe to this day, some people still don't know how to embed YouTube videos into posts. smh

BirdOPrey5 22 May 2011 00:45

I don't know, I put [twitvid]50D57[/twitvid] on my forum it works fine... the fact yours doesn't even attempt to convert the only thing I can think of is a typo in the "bb code tag name" box in admin cp. It needs to be: twitvid.

Do you have tge advanced bb code permissions mod? Maybe you need to give permission for people to use it.

Boofo 16 Aug 2011 07:36

1 Attachment(s)
This does not work on my 4.1.5 PL1 forum either.

EDIT: Turns out that it just doesn't work in Opera 11. FF4 and IE show the video just fine.

BirdOPrey5 16 Aug 2011 10:48

It kind of works on Opera 11.5 for me, the video plays but it's smaller than it should be. Obviously an Opera issue.

Boofo 16 Aug 2011 11:03

Quote:

Originally Posted by BirdOPrey5 (Post 2234099)
It kind of works on Opera 11.5 for me, the video plays but it's smaller than it should be. Obviously an Opera issue.

I'm using Opera Version 11.50 Build 1074 and the screen I get with the default style is the pic I posted above.

SuperTaz 13 Apr 2015 03:04

This gives me an error when doing it exactly according to your instructions:

Quote:

The following BB Code replacement may not be properly formed. All HTML attributes should be enclosed within double quotes.

<div align="center"><iframe title="Twitvid video player" class="twitvid-player" type="text/html" width="480" height="360" src="http://www.twitvid.com/embed.php?guid={param}&autoplay=0" frameborder="0"></iframe> <br /> <a href="http://www.twitvid.com/{param}" target="_blank">Link To Comments</a></div>

BirdOPrey5 14 Apr 2015 14:28

That is a warning and it is safe to ignore it in this case. Just hit OK/Next/Continue whatever it is and the BBCode will be added as usual.

zorcocuq 04 Oct 2015 21:16

twitvid.com disconnect :(

friendlymela 05 Oct 2015 05:42

This is good addition for Forums


All times are GMT. The time now is 01:42.

Powered by vBulletin® Version 3.8.12
Copyright © 2019, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.