vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=249277

The Rocketeer 20 May 2012 15:41

@Dartho, Update the style after vB 4.1.2 , that should fix most bugs. also please take the time to view and consider including or improving upon my edited cms templates from here, http://www.vbulletin.org/forum/showp...&postcount=889 :)

it should help a lot of people and a great add on for this style out of the box. (no credits needed)

edytwinky 26 May 2012 22:47

Dartho,
Is there any way to include a box on posting replies or threads for users to insert images from their phone?

Hippy 28 May 2012 01:19

Quote:

Originally Posted by semprot (Post 2333675)
For some reason i reinstalled this style as mobile-no-parent after upgrading to 4.2.0..
  • Quoting message works.
  • Add reputation page doesn't work.
  • Add infraction page doesn't work.

Will they fixed if the stylevar on the template is changed?

it removes templates when you did that
I would add it back to the normal style group
or you have to add those templates it's missing back..

edytwinky 28 May 2012 14:32

Quote:

Originally Posted by dbetanco (Post 2238573)
dartho, release the option for blog and cms!! maybe by donation? :)

Second?

edytwinky 30 May 2012 02:44

I'm working with trying to get the notifications on the Lightweight theme.

I pulled out the following code from the default theme and pasted it on to the lightweight navigation bar. It comes up but it doesn't look the same way. Anybody have any suggestions on what I might be missing?

Quote:

<vb:if condition="$notifications_total">
<li class="popupmenu notifications" id="notifications">
<a class="popupctrl" href="usercp.php{vb:raw session.sessionurl_q}">{vb:rawphrase your_notifications}: <span class="notifications-number"><strong>{vb:raw notifications_total}</strong></span></a>
<ul class="popupbody popuphover">
{vb:raw notifications_menubits}
</ul>
</li>
<vb:else />
<li class="popupmenu nonotifications" id="nonotifications">
<a class="popupctrl" href="usercp.php{vb:raw session.sessionurl_q}">{vb:rawphrase your_notifications}</a>
<ul class="popupbody popuphover">
<li>{vb:rawphrase no_new_messages}</li>
<vb:if condition="$show['pmmainlink']"><li><a href="private.php{vb:raw session.sessionurl_q}">{vb:rawphrase inbox}</a></li></vb:if>
</ul>
</li>
</vb:if>

The Rocketeer 31 May 2012 23:59

Dartho whats the news on releasing the newer version of this style? I think we might have to switch back to this as most members dont like the vB mobile and also since it doesn't work with most phones either(something I didn't notice previously :P

http://www.vbulletin.org/forum/showp...&postcount=912

The Rocketeer 01 Jun 2012 00:00

Quote:

Originally Posted by dbetanco (Post 2238573)
dartho, release the option for blog and cms!! maybe by donation? :)

Quote:

Originally Posted by dartho (Post 2238591)
There is no CMS or Blog option. I have done custom work for someone to make their CMS work within this style, but those changes did not translate over to the default CMS or other layouts, so can not be used in this style.

Quote:

Originally Posted by edytwinky (Post 2333869)
Second?

Look at This: http://www.vbulletin.org/forum/showp...&postcount=889

Just a minor bit edit to the CMS style, looks great with the mobile style. If he doesn't have the time to work on a fully fledged CMS theme then he could include it if he wants.



Quote:

Originally Posted by semprot (Post 2333805)
So the add rep & infraction don't work if i add as mobile style group because the templates of those 2 are removed?
How to add those templates?

I reinstalled as mobile because when i installed as normal, it showed activity stream page as default page.
But on my default-computer style, i deleted activity stream Tab.
It doesn't even exist, so i have no idea why i got activity stream as default home-page on lightweight style.

Update: i completely deleted activity stream, and reuploaded as normal-no-parent.

I think You will have to just create a new default / parent style then delete this and the old style and just reinstall the style, that should fix most issues I think it has some minor issues with 4.2 though.

Favori 02 Jun 2012 09:45

There is a poll problem on my forums. Users can't view polls so can't vote polls. Please help me for that problem.

Bounce 05 Jun 2012 15:01

Quote:

Originally Posted by Favori (Post 2335723)
There is a poll problem on my forums. Users can't view polls so can't vote polls. Please help me for that problem.

Have you installed the style as a parent in the "mobile style" section?

Install it with no parent in the normal styles and your polls etc will all work!

Bounce 05 Jun 2012 15:03

Dartho,

Any more thought on adding a PM button?

I added
Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

to my postbit_legacy, it shows but only as link and not a button:(



atm im trying to add that^ and a thanks button and also make post counts show on a members profile?

Getting a bit stuck with the codes thou :(:D

Bounce 05 Jun 2012 23:02

ok I added for a PM button...

In postbit or postbit_legacy

find

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

add after

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

or move to where ever you like :)

edytwinky 08 Jun 2012 02:15

Any word on notifications for the Lightweight style

JAFRI 08 Jun 2012 09:45

update for 4.2.0 PLS.

edytwinky 10 Jun 2012 20:33

Darthos,
I'm having the same issue with 4.2
When I click on the users online link to see what users are doing.
it just shows Array under the Username- - Last Activity table.

But on the forumhome, it shows what users are online.

Quote:

Originally Posted by Robbed (Post 2164159)
dartho - after upgrading to 4.12

Can you fix the online users. It just shows array, changes were made to forumhome whos online.


edytwinky 12 Jun 2012 20:44

I'm looking to hire a dev to make notifications work with this style. Would anybody be willing to split the cost of hiring a dev to do it? Getting ready to get quotes on it

tareqbd 14 Jun 2012 15:47

dartho bro, is there anyway to make dbtech vbshout box work with your mobile style and also how can I add report button on postbit. please let me know.

snakes1100 15 Jun 2012 14:11

For anyone that is using the latest patch, you will have to fix init.php as vbulletin conveniently forgot to patch their own patch......

http://www.vbulletin.org/forum/showp...&postcount=746

Example Vb Version - 4.1.10 patch level 3, requires this fix again in init.php

charlesr 18 Jun 2012 12:44

Not a major issue, but when you click on "new posts" or "search", the navigation disappears, so you have to then click through to a post to see it again.

dartho 19 Jun 2012 03:27

Short story is, it doesn't work correctly with 4.2 as it wasn't written for 4.2, but you would have seen that it wasn't compatible when you upgraded your test site before upgrading your live site. ;)

I really don't have the time to look at this at the moment, but will happily post fixes if someone has them to put forward.

The Rocketeer 20 Jun 2012 09:26

Such a Shame, This was a really nice style :( I wish someone could come and update it and fix it up for vB 4.2 since Dartho cant do it now, once updated I am sure then it will give many more years of great service. even posting the fixes will be a great step towards helping everyone :)

All the best Dartho, I hope you can update it one day soon. :)

letipro 20 Jun 2012 11:38

update for 4.2.0 PLS

charlesr 21 Jun 2012 08:32

What else is broken apart from what I mentioned above? All the rest seems to be working for me? I'm continuing to leave it for users on 4.2 and I know people are using it.

thenamesgould 23 Jun 2012 06:30

Quote:

Originally Posted by charlesr (Post 2341658)
What else is broken apart from what I mentioned above? All the rest seems to be working for me? I'm continuing to leave it for users on 4.2 and I know people are using it.

I use this daily on my own forum, and hadn't even noticed that ... and I haven't had any complaints. Definitely not getting rid of it just because of that!

I'm just hoping that when vb5 rolls around, there will be a version of this for that!!! :)

The Rocketeer 24 Jun 2012 07:30

Quote:

Originally Posted by djbaxter (Post 2324305)
But I don't want to disallow users from using the vBulletin mobile version. I just want to add the option for mobile users to select this one.

I have the Suite. Now the CMS doesn't get a lot of use and blogs are currently disabled so the forum is the main focus, but this style, unlike the vBulletin mobile style, doesn't provide for anything but the forum.

Suggestions?

in the same boat, need some help with the second question..

The Rocketeer 25 Jun 2012 03:23

This issue is said to be once again present in 4.2 after the patch

http://tracker.vbulletin.com/browse/VBIV-13851

Quote:

Originally Posted by dartho (Post 2289299)
If you wish to make this change manually, edit init.php and
search for:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

and replace with

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

and search for

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

and replace with


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


above fix is not working, code not found inside init.php

charlesr 25 Jun 2012 11:51

Quote:

Originally Posted by The Rocketeer (Post 2342450)
in the same boat, need some help with the second question..

I lock the CMS to the site style (pencil on homepage) - it's useable on modern phones.
The vbulletin mobile one seems tremendously slow on my nokia 5800 (older symbian touchscreen), so I don't force it on users. I have this one set as the default for older mobiles and leave the option for modern phones as "none".

deverill2010 25 Jun 2012 11:57

I have this style on my CMS :) its not perfect but it gets the basics done for simple browsing on phones.

http://www.midwiferyonline.co.uk/forum.php?styleid=8. I don't have a 'home' link as I haven't got around to editing that in. So once clicked on the above link, add index.php after .co.uk/

The Rocketeer 30 Jun 2012 17:09

1 Attachment(s)
also I am unable to select the any other style, it only lets me select the default mobile style or none? look at this pic

http://www.vbulletin.org/forum/attac...1&d=1341072418

Gripi 06 Jul 2012 19:25

hi..

i saw that every member that reply post from this mobile style, the signature option automaticly OFF, how to make the "Show Signature" always ON when reply a thread.

thanks

Danny M 10 Jul 2012 17:55

Hey,

I've installed this style, but how do I make it display for users who visit my forum on their mobile.

I looked in the "Style and Language" settings, but the only style that gets listed in the dropdown box is "Default Mobile Style" and not "Lightweight" :(

Anyone know how I can fix this?

Thanks

deverill2010 10 Jul 2012 18:02

in the instructions in the first post it says this -


**Install and configure "LightWeight Style Options"

I think the above does allow it to be selected as a mobile style.

fly 10 Jul 2012 18:03

Quote:

Originally Posted by Danny M (Post 2346699)
Hey,

I've installed this style, but how do I make it display for users who visit my forum on their mobile.

I looked in the "Style and Language" settings, but the only style that gets listed in the dropdown box is "Default Mobile Style" and not "Lightweight" :(

Anyone know how I can fix this?

Thanks

You don't even have to search the thread for your answer, look at the post RIGHT above yours. wow!

Merriweather 15 Jul 2012 18:38

I am wondering if there is a way to include the forum notifications in this style? I know it notifies on a new pm, but I also have notifications that show for new Group posts and when users are tagged/quoted.

edytwinky 15 Jul 2012 23:45

On my poll results, instead of showing who has voted, it just says "array"

Any idea what might be wrong?

dartho 21 Aug 2012 09:14

I've had a bit of a look at 4.2 and this style today. It will involve quite a bit of time for me to get it working under the Mobile master style. Or I have to remove portions of it. It could be just the one thing I looked at, but I couldn;t find how to add a pagenav to the thread bits in forumdisplay.

It should be take significantly less time to make it work as previously as a non-mobile style.

PLease post your issues when installed as a full style and i"ll look at them

NTT 22 Aug 2012 15:16

style ta dng hiện tại edit từ đy, xoắn nhiều qu

dartho 23 Aug 2012 02:52

Sorry, but my Vietnamese language skills are rather poor ...

rkhyd 07 Sep 2012 18:23

If i want to include a dbtech Shoutbox to the mobile page just after then header, how to do that?
Adding the code {vb:raw show.vbshout_instance1} where instance1 is the varname of the SB doesn't do any modification to the lightweight style. Can anyone guide me on this?

RK

jamoss 15 Sep 2012 17:19

Are polls enabled?

NTT 16 Sep 2012 03:34

Quote:

Originally Posted by jamoss (Post 2365669)
Are polls enabled?

yes, but you must edit templates :D

jamoss 16 Sep 2012 03:43

Quote:

Originally Posted by NTT (Post 2365818)
yes, but you must edit templates :D

Gah, I'd have to do that on the default mobile one, too. I was hoping someone had them done already.:rolleyes:

edytwinky 19 Sep 2012 17:29

On my poll results, instead of showing who has voted, it just says "array"

Any idea what might be wrong?

letipro 24 Sep 2012 18:36

1 Attachment(s)
Quote:

Originally Posted by jamoss (Post 2365821)
Gah, I'd have to do that on the default mobile one, too. I was hoping someone had them done already.:rolleyes:

you mean like this?

http://www.vbulletin.org/forum/attac...1&d=1348508183


http://buidoi.net/threads/10058-test...html?styleid=4

dougdirac 27 Sep 2012 01:42

Is this style compatible with blogs?

Robbed 27 Sep 2012 03:39

Quote:

Originally Posted by dartho (Post 2358661)
I've had a bit of a look at 4.2 and this style today. It will involve quite a bit of time for me to get it working under the Mobile master style. Or I have to remove portions of it. It could be just the one thing I looked at, but I couldn;t find how to add a pagenav to the thread bits in forumdisplay.

It should be take significantly less time to make it work as previously as a non-mobile style.

PLease post your issues when installed as a full style and i"ll look at them

It seems to work for me but new posts. when clicking on the link it redirects to fullsite.

I used to be able to test the mobile site from my pc but now it redirects to the fullsite, same with my blackberry it doesn't redirect to the mobile site but iphone/ipod still does.

dougdirac 27 Sep 2012 18:32

Quote:

Originally Posted by Robbed (Post 2368892)
It seems to work for me but new posts. when clicking on the link it redirects to fullsite.

I used to be able to test the mobile site from my pc but now it redirects to the fullsite, same with my blackberry it doesn't redirect to the mobile site but iphone/ipod still does.

Are you using 4.2? There was a known error that did something like this in some previous version of vB. I had the issue with vB 4.1.10.

Also check your "Style and Language Settings". There is a setting "Default Style for Old Mobile Browsers" and "Default Style of Modern Mobile Browswers".

Robbed 27 Sep 2012 21:54

Yes 4.2.

I have both set to none because i use dartho different domain different style to assign a mobile style.

dougdirac 28 Sep 2012 01:26

ok. just a stab in the dark.

Robbed 28 Sep 2012 22:03

any idea why

http://m.domain.com/forums/search.ph...e=vBForum_Post would redirect to the main site now since 4.2

Robbed 04 Oct 2012 06:13

Quote:

Originally Posted by Robbed (Post 2164661)
dartho

I ended up setting Always use Forum URL as Base Path to no

then opening headerinclude for my main skins and change this code


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

I set it manually to mydomain/forums

This worked, let me know if you have any better way of doing this.

Looks like always use forum url as base path was set to yes after one of the upgrades.

Set it back to no and it's working for me again

craigvm 11 Oct 2012 22:13

i`ve installed this but my index.php sends you to vba portal but on the mobile style its just a blank screen even after installing the plugin to disable vba on this style any idea how i can fix it

Muhammad Rahman 21 Oct 2012 02:05

hay, I can not make a thread with this style, anyone can help?
information: vBulletin 4.2

thank you.

thenamesgould 03 Nov 2012 12:23

Has anybody who has this style installed modified it to have the banner running all the way across the top of the page, and obviously appearing a bit bigger?

That's what I want to do, and I thought before I try to do it myself, if someone else has done it and I could have a sneaky look, I would try that first. :)

thenamesgould 04 Nov 2012 09:59

Don't worry, all done now. Just a matter of increasing the height of the image in the CSS file, and increasing the size of the image itself. Looks great on the touchscreens you get these days!

Gripi 06 Jan 2013 18:29

Hello...

May be this is a bug, i found that when i already subcribed to one thread via Full Style, then i post a new reply inside the thread using this Mobile Style, the thread automaticly got ubsubscribed.

Anyone experienced problem like this? and how to solve it?

Thanks alot for your help.

charlesr 14 Jan 2013 11:47

Sorry if I've missed this already, but is anyone able to view their PMs? i.e. hit "usercp" and then "private messages"

Alan_SP 14 Jan 2013 20:48

PMs work for me. Through UserCP I can access them if there aren't new, or there's special link if there are new (unread) PMs.

@ngel 20 Jan 2013 15:20

Hello, for some reason the desktop link doesn't redirect to the desktop style, what should I do?

@ngel 21 Jan 2013 21:29

Quote:

Originally Posted by dartho (Post 2089236)
I'm going to release an addon product which enables such options. In the mean time have a look in the header template and search for


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

and replace with


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

where xxx is your default styleid. change the href to suit your site also.

There are 2 instances that need to be edited as described above

I've done that but still doesn't work for me!

dartho 24 Jan 2013 05:03

Do you allow users to change styles?

also - what version of VB. things are different in 4.2 I think ...

@ngel 24 Jan 2013 10:45

Thank you for your response!
I have 4.1.5 and I do allow users to change style!

dartho 25 Jan 2013 11:58

Quote:

Originally Posted by @ngel (Post 2399135)
Thank you for your response!
I have 4.1.5 and I do allow users to change style!

try editing the footer template and change teh "-1" in the following:

<a href="?styleid=-1">Default Style</a>

to the styleid number of your default style

@ngel 25 Jan 2013 15:17

Nothing... neither with -1 or 3

tareqbd 28 Jan 2013 01:45

Need help to make dbtech credit deluxe work with this style. Seems onclick the charged contents are not loading. Advise appreciated.

djbaxter 28 Jan 2013 03:26

DBTech add-ons don't play nicely with a lot of other add-ons. You may be further ahead looking for a replacement for whatever add-on is conflicting with this one.

Alan_SP 29 Jan 2013 01:48

This is not true, especially as we a talking about custom (mobile) skin.

Thing is, there are hooks that are missing and certainly not some coding problem with DBTech mod per se. If you want, you could ask what hooks you need to add, but with adding hooks, style becomes less mobile, which beats it purpose.

Courty 08 Feb 2013 00:20

Dartho,
first of all, thanks for creating this mod. The Lightweight style is super-popular on my forum.

Now, I have a (minor) issue with users inadvertently hitting the 'report button instead of 'reply'. So my question is this: how do I reorder the buttons below each post?

Disclaimer: Apologies if the info is already in here somewhere. I did do some searching of this thread but have to date been unable to find the answer I am looking for.

dartho 08 Feb 2013 01:58

edit the postbit and/or postbit_legacy templates and you should find the report post button code in there pretty easily - just move it where you want, or even remove it

Courty 10 Feb 2013 00:13

Quote:

Originally Posted by dartho (Post 2402772)
edit the postbit and/or postbit_legacy templates and you should find the report post button code in there pretty easily - just move it where you want, or even remove it

Thanks! Worked a treat.

Courty 11 Feb 2013 11:21

Hmmm, another quick question for Dartho or anyone else who speaks code, apologies if this should be in another thread.

If possible, I would like to align the 'Report' and 'Infraction' button to the left side, and the 'Reply' and 'Edit' buttons to the right. I worked out how to do it using a new div tag, but that pushed the right side onto a new line (which I don't want).

Here's what I'm working with, is there an easy mod to make this work?


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


dartho 11 Feb 2013 14:25

You'll need to float one of the divs

SolidSnakeLive 14 Feb 2013 19:46

Last Update: 16 Dec 2011

Add new update its the best mobile style

tareqbd 10 Mar 2013 04:33

Quote:

Originally Posted by Alan_SP (Post 2400208)
This is not true, especially as we a talking about custom (mobile) skin.

Thing is, there are hooks that are missing and certainly not some coding problem with DBTech mod per se. If you want, you could ask what hooks you need to add, but with adding hooks, style becomes less mobile, which beats it purpose.

Thank you. I have contacted DBT, they advised as below:
Quote:

showthread_below_posts is needed for the JS code that powers charged content.
Help appreciated.

dartho 12 Mar 2013 23:58

edit the SHOWTHREAD template,
search for (near the bottom of the template)

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

and add the following immediately above it


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Dwarden 17 Mar 2013 23:05

very nice style, do you plan release updated version for 4.2.0 pl3 ?

Marco Aurelio 18 Mar 2013 16:24

Hi dartho, thanks for your lightweight!

Please, help me! :D In vBulletin 4.2, this:

{vb:raw post.post_thanks_bit}

doesn't work! How can I fix?

K4GAP 18 Mar 2013 21:08

I have but one question before I install this. How is it better than the standard vb mobile style?

Thanks for your effort and work.

Alan_SP 18 Mar 2013 23:14

Well, I think that you should install it and see differences for yourself.

In my opinion, dartho's style is much better, I use it when I'm on mobile internet and don't need vB mobile style at all. But, it all comes down to your own tastes.

Filgga 19 Mar 2013 17:45

Quote:

Originally Posted by etca (Post 2320223)
dear dartho,

how to fix this? my vbul. 4.1.12

2. empty page, there are no 1, 2, 3 ... . see the attachment.

How did you solve this?

dartho 20 Mar 2013 00:15

Quote:

Originally Posted by Filgga (Post 2410990)
How did you solve this?

Looks like he did here:
http://www.vbulletin.org/forum/showt...46#post2322346

Hippy 20 Mar 2013 03:23

Quote:

Originally Posted by Marco Aurelio (Post 2410795)
Hi dartho, thanks for your lightweight!

Please, help me! :D In vBulletin 4.2, this:

{vb:raw post.post_thanks_bit}

doesn't work! How can I fix?

search post thanks in this thread youll find the code for the whole mod to work..

K4GAP 20 Mar 2013 05:43

Quote:

Originally Posted by Alan_SP (Post 2410870)
Well, I think that you should install it and see differences for yourself.

In my opinion, dartho's style is much better, I use it when I'm on mobile internet and don't need vB mobile style at all. But, it all comes down to your own tastes.

In most cases that is exactly what I do. But usually an alternative will have listed advantages i.e. does this or that work or look better than the original.

dartho 20 Mar 2013 05:52

Quote:

Originally Posted by GaryT (Post 2411104)
In most cases that is exactly what I do. But usually an alternative will have listed advantages i.e. does this or that work or look better than the original.

There is no comparison as there was no vBulletin mobile style when I made this one. I'm not sure if vBulletin listed advantages / comparisons to this one when they release their alternative though :)

Marco Aurelio 20 Mar 2013 12:22

Quote:

Originally Posted by Hippy (Post 2411093)
search post thanks in this thread youll find the code for the whole mod to work..

Sorry, but this:

Quote:

Originally Posted by dartho (Post 2305643)
Integrating Abe1's post thanks add-on into the lightweight style.

replace the following templates with the code provided (in the lightweight style only!!)
post_thanks_box

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

post_thanks_button

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

post_thanks_postbit

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Edit both the postbit & postbit_legacy templates as follows

Search for:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Add the following immediately above:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Then go to end of template and paste in:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

and your done!

doesn't work after upgrade to vBulletin 4.2, because I don't see {vb:raw post.post_thanks_bit}. I write that code in template, but it doesn't appear on forum, so I don't know who thanked.

dartho 20 Mar 2013 15:29

You haven't really given us enough info to help, but I would guess you need to redo the post bit template edits

Hippy 20 Mar 2013 23:50

Quote:

Originally Posted by Marco Aurelio (Post 2411136)
Sorry, but this:



doesn't work after upgrade to vBulletin 4.2, because I don't see {vb:raw post.post_thanks_bit}. I write that code in template, but it doesn't appear on forum, so I don't know who thanked.

still works for me ..
check your work over

Filgga 25 Mar 2013 08:23

Quote:

Originally Posted by dartho (Post 2411059)

There's no direct fix for this? I've some customizations made and re-installing the same to fix this minor bug seems to be painful

:confused:

BTW, have you managed to get vBSEO Like system compatible with it?

dartho 25 Mar 2013 23:46

Sorry but I I don't have vbseo so can not look at this. But if it is just a matter of some hooks needing to be added to templates it would be trivial to do if you could find out which hooks are used by the vbseo hack.

You could export the style from your site, including your customisations, and re-install that as per the suggested 'fix' ?

Filgga 26 Mar 2013 09:23

Quote:

Originally Posted by dartho (Post 2412290)
Sorry but I I don't have vbseo so can not look at this. But if it is just a matter of some hooks needing to be added to templates it would be trivial to do if you could find out which hooks are used by the vbseo hack.

Yeah, loud n clear ;)

Quote:

You could export the style from your site, including your customisations, and re-install that as per the suggested 'fix' ?
Yep, this fixes the problem but another problem rises:
1. If installed as a Standard skin, then the error is fixed!
2. If installed as a mobile skin, the same error comes

Problem: Using vB's default style assignment the theme doesn't appear to be selective under Settings > Options > Style & Language Settings (for mobile themes)

I bet, this' not your fault. vB team was supposed to allow any skin from standard to mobile can be selected to be assigned for mobile users. I see no point of forcing someone to categorize them (IMHO)

What's your suggestion?

dartho 27 Mar 2013 04:25

vBulletin messed things up for this style when the seperated mobile and standard styles.

If you want to use VB detection and simply apply one style to advanced mobile devices, one style to basic mobile devices and a default style to everyone and allow people to select their own style (assuming they are already allowed to do this on your site) and still allow admin to pick any style they want, the following should do it.

Create a plugin on style_fetch with the following code being sure to enter in teh styleids you want for mobile, advanced mobile and default styles:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


dartho 27 Mar 2013 04:47

If you wanted to make this simpler, and don;t mind going into debug mode on your site, you could edit the Option Code for Mobile Style boxes in AdminCP so that all styles (both mobile and standard) show up and then you could replace the styleid numbers in the plugin above with $vbulletin->options['mobilestyleid_basic'], $vbulletin->options['mobilestyleid_advanced'] and $vbulletin->options['styleid'] then if you changed styles down the track you wouldn;t need to edit the plugin by hand. You would still need the above plugin to make it work.

To do this change the Option Code to:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Filgga 27 Mar 2013 04:59

Quote:

Originally Posted by dartho (Post 2412496)
To do this change the Option Code to:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Superb! I know, many will benefit from this... Do I add the code onto the above code and look like:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

?

Thanks for your prompt response

dartho 27 Mar 2013 05:10

No - you would need to put your site into debug mode, then go into your vbulletin options in AdminCP where you choose the style settings and click on the edit link next to where you select the mobile styles and change the Option Code in there

Filgga 27 Mar 2013 05:25

Quote:

Originally Posted by dartho (Post 2412498)
No - you would need to put your site into debug mode, then go into your vbulletin options in AdminCP where you choose the style settings and click on the edit link next to where you select the mobile styles and change the Option Code in there

Gotcha!

Will revert to you once successful. Obrigado!

----Edit----

I worked. Thanks much!

Shaybloom 29 Mar 2013 11:28

How do i change the blue colour thats all over including the footer to black??
I tried changing footer colour and border almost everything in footer IN Style Variable Editor
to black and saved it it even shows red colour indicating it is edited but strangely enough NOTHING has changed on the theme on the forum,its still BLUE
please help!

tareqbd 29 Mar 2013 13:43

Quote:

Originally Posted by dartho (Post 2409603)
edit the SHOWTHREAD template,
search for (near the bottom of the template)

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

and add the following immediately above it


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

OK, I have tried already but no luck. Still the charged content not loading on click.
Any other suggestion please.

dartho 29 Mar 2013 14:03

Quote:

Originally Posted by Shaybloom (Post 2412903)
How do i change the blue colour thats all over including the footer to black??
I tried changing footer colour and border almost everything in footer IN Style Variable Editor
to black and saved it it even shows red colour indicating it is edited but strangely enough NOTHING has changed on the theme on the forum,its still BLUE
please help!

see the 5th dot point of the install instructions

dartho 29 Mar 2013 14:04

Quote:

Originally Posted by tareqbd (Post 2412913)
OK, I have tried already but no luck. Still the charged content not loading on click.
Any other suggestion please.

I don;t use that add-on. Have you asked them what requirements are?

tareqbd 29 Mar 2013 20:09

Quote:

Originally Posted by dartho (Post 2412917)
I don;t use that add-on. Have you asked them what requirements are?

Yes, I did. Their reply was as below:
Quote:

Quote Originally Posted by Belazor View Post
showthread_below_posts is needed for the JS code that powers charged content.

dartho 30 Mar 2013 04:17

So they told you the same thing again? Did you let them know that adding that hook didn't appear to work for you? If not, you may want to do so.


All times are GMT. The time now is 01:07.

Powered by vBulletin® Version 3.8.14
Copyright © 2022, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.