vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=232684

Yet Another Awards System
by squidsk
10 Jan 2010 10:46

8 Attachment(s)
*** CREATE A BACKUP OF YOUR FORUM AND DATABASE BEFORE INSTALLING ***


DESCRIPTION:
This is a Medals/Awards system. Admin can give members awards, and award icons will be displayed in member's profile, posts, as well as in a award list.

FEATURES:
In AdminCP
- Can Create/Edit/Delete/Reorder categories/sub-categories in ACP (with category name and description)
- Can Create/Edit/Delete awards in ACP (with Award Name, Description, Icon URL, Image URL)
- Can Move one (or all) award(s) from one category to another
- Can set some awards un-classified (not displayed for public)
- Can re-order awards in awards showcase
- Issue awards to members, based on username or userid, with Issue Reason
- Remove awards from members
+ Writes granting/removing awards to the log

In ModCP
- Issue awards to members, based on username or userid, with Issue Reason
- Remove awards from members
+ Writes granting/removing award to the log

Front page
- Display awards list in with: Award Name, Description, Icon, Image, and Members who get each award.
- Display awards showcase in profile, with Award information, Issue time and reason
- Display award icons in postbit (showthread, showpost, announcement, private)

New Features/Additions since 3.8
- Points System
- Separate Award Request/Recommendation Forms
- CSS Customizable

Current Release Version 4.0.9
  • Added - Handling of user merges
  • Added - Handling of user deletes
  • Added - Manage awards on per user basis
  • Added - Extra info to the logs for mass removal and editing of issued awards
  • Added - Ability to collapse categories on awards.php
  • Added - Checksum file for checking for suspect file versions
  • Added - Various missing phrases
  • Fixed - Memberlist not showing awards when option is active
  • Fixed - Navtab not being selected (vb version < 4.2)
  • Fixed - Category title not being displayed on awards.php
  • Fixed - Logging not working in modcp
  • Fixed - A few other minor bugs

CypherSTL 10 Jan 2010 10:47

4.0.2 PATCH 1: (05/16/2010)
* Fixed - Possible XSS Exploit in recommend_award.php and request_award.php
award_request_reason and award_request_recipient_name variables changed to "TYPE_NOHTML"

* Date in change log of 4.0.2 release
* Updated Version in version phrase

4.0.2 RELEASE: (04/10/2010 5:30AM CDT)

* Fixed - Spacing on primary Awards Display page
* Fixed - Display Order in AdminCP Options not saving properly
* Fixed - "Awards" displaying on all profile tabs.
* Fixed - Award Profile Tab Phrased

* Added - Award Recommendations and Requests are viewable in the AdminCP
* Added - Diagnostics Tab (Currently not used, place holder).

* Database - Database Errors on installation are now displayed.
* Database - award_requests table added

* Removed - Automation Phrases (Automation will be a seperate plugin)

4.0.1 RELEASE: * INTERNAL RELEASE *

4.0.0 GOLD: * INTERNAL RELEASE *


Frequently Asked Questions

  • What are you using in your development environment?
    PHP 5.2.11, MySQL 5.0.87, Apache 2.0.63. Latest version of vBulletin 4 and YaAS.
  • What is the minimum version of MySQL Required?
    The core of the awards sytem will function on MySQL 4.1. However, in order to use the Points System, or the Automation System, you must be running atleast MySQL 5.0+
  • I'm seeing output like "-- BEGIN TEMPLATE: awards_awardusers_bit -->" before it displays members. Why?
    In your AdminCP -> vBulletin Options -> General Settings -> Display Template Names as HTML Comments -> OFF

ProFifaLeagues 10 Jan 2010 11:27

This looks great,will watch the progress and install asap!

Kolbi 10 Jan 2010 11:33

Perhaps you can upload some screens?

n_only 10 Jan 2010 11:49

hi..

nice work :)

I do have this hack on vb.8.4
http://www.vbulletin.org/forum/showthread.php?t=196244
when I upgraded my forum to 4.0 , I disabled it . can I upgrade it with this release ?

CypherSTL 10 Jan 2010 12:00

Quote:

Originally Posted by n_only (Post 1951806)
hi..

nice work :)

I do have this hack on vb.8.4
http://www.vbulletin.org/forum/showthread.php?t=196244
when I upgraded my forum to 4.0 , I disabled it . can I upgrade it with this release ?

As far as I know you should be able to. Just remember to do a backup of everything first.

I didn't have a test board setup with 3.8 with YAAS 3.8, and upgraded both. Product IDs are the same as previous versions, so it should work fine.

Sador 10 Jan 2010 12:08

Nice, glad to see this got upgraded. I'll use this when it's more stable.

CypherSTL 10 Jan 2010 12:16

Quote:

Originally Posted by Sador (Post 1951822)
Nice, glad to see this got upgraded. I'll use this when it's more stable.

Shouldn't be much longer than a few days. Just trying to figure out two display bugs, and fine-tune the XML Sheet and write up upgrade instructions.

For the most part upgrading should be pretty self-explanatory.

silverfox_uw 10 Jan 2010 12:45

Brilliant, can not wait for this to be final

Veer 10 Jan 2010 12:54

Thanks for the vb4 release.

I tested this on a vb4 test board (upgraded from 3.8.2 version to 4.0.0 BETA RELEASE) upgrade is ok, everything looks fine except Postbit: Style and Profile Tab Style.
both needs style improvements.

Can you please describe Point system?

bart6767 10 Jan 2010 13:29

Thanks

CypherSTL 10 Jan 2010 14:39

Quote:

Originally Posted by Veer (Post 1951840)
Thanks for the vb4 release.

I tested this on a vb4 test board (upgraded from 3.8.2 version to 4.0.0 BETA RELEASE) upgrade is ok, everything looks fine except Postbit: Style and Profile Tab Style.
both needs style improvements.

Can you please describe Point system?

Could you go into a bit more detail on how you think it should look?

With the Point System, I'm working on a text document that will be packaged with the next release that goes over the Point System.

Bouncer222 10 Jan 2010 15:21

Works great on vbulletin 4.0 latest version live forums! You can see it in action here at www.brotherhoodofgamers.com

Hope that you can sometime implemen to separate different categories in postbit and not show medals together :)

Good job!

Bouncer222 10 Jan 2010 15:23

Except eh yeah.. it shows up wrong in profile, but you already know that.

And what is the points system about exactly??

zonaenlinea 10 Jan 2010 15:30

thank prefect

DigitalDark 10 Jan 2010 15:40

Issue: in Mod Control Pannel
Parse error: syntax error, unexpected ';' in /public_html/foro/modcp/award.php on line 245

Thanks for the mod!

Bouncer222 10 Jan 2010 16:01

I have a problem in my recommend awards page... The text doesn't show up because apperently it's black or something, how do I fix this?

Here are the images, first image is without text highlighted and second one I highlighted the text to reveal it. My site is www.brotherhoodofgamers.com

https://www.vbulletin.org/forum/external/2010/01/20.gif

https://www.vbulletin.org/forum/external/2010/01/21.gif

Let me know how I can fix this text not appearing, thanks.

LuckyNeo 10 Jan 2010 16:14

WOW!!! Now for vB4!!! Cool! Thank You Very much! Just keep doing!! It's VERY usefull hack!!! Check five, and install! :):up:

Inferno Dragon 10 Jan 2010 17:46

Thanks for the vb4 release :) I have upgraded from YAWS v3.8 to v4.0 on my test board and it's working fine, I am only seeing those two issues which have been mentioned already:

1) Members profile page awards list output is messed up.
2) Award Manager in ModCP is notworking.
3) Awards List page needs little formatting (needs space between awards)
4) Postbit "Style 1" is not displaying just like it shows in the admincp preview i-e missing that box border.

I guess these are just minor bugs :) once again thanks a lot for such quick release.

Dr.osamA 10 Jan 2010 21:02

thanx

reserved & taged
________
TRAVEL INSURANCE ADVICE

CypherSTL 10 Jan 2010 21:57

Quote:

Originally Posted by Bouncer222 (Post 1951929)
Except eh yeah.. it shows up wrong in profile, but you already know that.

And what is the points system about exactly??

In previous editions a few people were asking to be able to assign a point value to awards. I will most likely expand on this feature in coming releases.

Quote:

Originally Posted by DigitalDark (Post 1951940)
Issue: in Mod Control Pannel
Parse error: syntax error, unexpected ';' in /public_html/foro/modcp/award.php on line 245

Thanks for the mod!

Will check into it. Thanks for the report.

Quote:

Originally Posted by Bouncer222 (Post 1951956)
I have a problem in my recommend awards page... The text doesn't show up because apperently it's black or something, how do I fix this?

Here are the images, first image is without text highlighted and second one I highlighted the text to reveal it. My site is www.brotherhoodofgamers.com

Let me know how I can fix this text not appearing, thanks.

Ahh. Looks like I need to format the text. I did all my testing on the default VB4 template. Look for this to be fixed in tomorrows update.

Quote:

Originally Posted by Inferno Dragon (Post 1952043)
Thanks for the vb4 release :) I have upgraded from YAWS v3.8 to v4.0 on my test board and it's working fine, I am only seeing those two issues which have been mentioned already:

1) Members profile page awards list output is messed up.
2) Award Manager in ModCP is notworking.
3) Awards List page needs little formatting (needs space between awards)
4) Postbit "Style 1" is not displaying just like it shows in the admincp preview i-e missing that box border.

I guess these are just minor bugs :) once again thanks a lot for such quick release.

"Style 1" used the <legend> formatting tab, which doesn't seem to work in VB4. I'll see if I can find a work around for that, or just adding a div border should also work. Look for this to be fixed in tomorrows update.

If the ModCP awards isn't working because of the unexpected ;, this will be fixed in tomorrows update.

----
Thanks for all the input guys,

ndut 10 Jan 2010 23:08

waiting for final version :)
thank you

ProFifaLeagues 10 Jan 2010 23:15

Me too,this was a great mod on 3.8 and cant wait to have it running a1 on 4.0

kylek 10 Jan 2010 23:24

Will the ability to have awards displayed in the signature area be returning for this version? We use the postbit display and find the signature area is better if members have a lot of awards.

Just upgraded to this version and all looks okay so far.

Alien 10 Jan 2010 23:28

One of my must haves, I'm extremely grateful you've decided to update this!

I'll probably go ahead and install tomorrow's release!

elwachiman 10 Jan 2010 23:38

reserved & taged tnks ,waiting for running in vb4

Trek 11 Jan 2010 01:41

I use this on my 3.8 site and this is one of those mods I considered high priority for going to VB4, nice to see it updated!

Tagged for when I finally upgrade (let's hope tomorrow patch is good. heh)

CypherSTL 11 Jan 2010 02:18

Quote:

Originally Posted by kylek (Post 1952312)
Will the ability to have awards displayed in the signature area be returning for this version? We use the postbit display and find the signature area is better if members have a lot of awards.

Just upgraded to this version and all looks okay so far.

The signature output of the awards is working, however it's doubling up on the output for some odd reason.

GrossKopf 11 Jan 2010 06:36

Cool. My members loved this before we upgraded. Can't wait to put it back on!

CypherSTL 11 Jan 2010 07:40

1 Attachment(s)
Fixed So Far:
  • modCP/Awards now working
  • Tweaked display output on Awards listings, now a much cleaner look
  • Black Font for some text has been fixed
I'm currently working on the Profile Tabs to get it to display data properly, right now it's displaying on every tab for some reason.

I'll also be tweaking the "Styles" for output into the postbits.

Once I get these all taken care of, I'll release it here for download.

Attached is a screenshot of what the main awards.php output looks like currently.

silverfox_uw 11 Jan 2010 08:15

cool, can not wait

DigitalDark 11 Jan 2010 08:20

CypherSTL, can you add some spaces between the name and category of medals and delete some "extra" categories?
Look

https://www.vbulletin.org/forum/exte...010/01/101.jpg

The category of both medals is "Videojuegos" but there are more words...
Default, Usuarios, Especiales, ED Awards, Halloween, are other categories but this medals aren't in these categories....

I know that making this mod its a lot of work. I like this. Thanks for your help!

CypherSTL 11 Jan 2010 08:45

DigitalDark,

The category display listings have been fixed in the version I will be releasing Monday afternoon/evening. I have also added spacing between the awards it displays.

CypherSTL 11 Jan 2010 11:44

YaAS 4.0.0 BETA 2 is now published for download.

Of course, report any bugs.

See first post for more details.

philr 11 Jan 2010 12:46

Thanks for realsing the update for V4, this has kinda made my forum complete. Have only installed on test froum at the moment until it is off Beta. One of the best mods around

absy 11 Jan 2010 13:55

Installed ty, but I get this error:
Quote:

MySQL Error : Mixing of GROUP columns (MIN(),MAX(),COUNT(),...) with no GROUP columns is illegal if there is no GROUP BY clause
Can anyone help please?

bart6767 11 Jan 2010 14:03

I get this at the bottom of the page ?

Members who received this award: 1
-- BEGIN TEMPLATE: awards_awardusers_bit --> , Bhoy_Molloy

http://www.randalstowncsc.net/awards.php

Is there a fix for this ?

RK1gaming 11 Jan 2010 14:18

nice jobs getting this ready for VB4 - I will wait for a nice full release but looking good so far on my test forum

Thunderbird8 11 Jan 2010 14:29

If an admin or a moderator attempts to give an award to a username with an apostrophe in it, the database query will get malformed and fail. This also affects 3.8. On the 3.8 setup I help run, I added an addslashes() around $vbulletin->GPC['awardusername'] line, as I wasn't aware of the escape_string function at the time.

CypherSTL 11 Jan 2010 14:41

Quote:

Originally Posted by absy (Post 1952668)
Installed ty, but I get this error:

Is this on a brand new fresh install, or upgrade?

Quote:

Originally Posted by bart6767 (Post 1952675)
I get this at the bottom of the page ?

Members who received this award: 1
-- BEGIN TEMPLATE: awards_awardusers_bit --> , Bhoy_Molloy

http://www.randalstowncsc.net/awards.php

Is there a fix for this ?

What other mods do you have on your forum? I've never seen anything like "BEGIN TEMPLATE" being outputted anywhere.

Quote:

Originally Posted by Thunderbird8 (Post 1952692)
If an admin or a moderator attempts to give an award to a username with an apostrophe in it, the database query will get malformed and fail. This also affects 3.8. On the 3.8 setup I help run, I added an addslashes() around $vbulletin->GPC['awardusername'] line, as I wasn't aware of the escape_string function at the time.

Ah, yes. I did have it marked down to fix by adding the escape_string function. I will get it updated.

absy 11 Jan 2010 14:44

Quote:

Is this on a brand new fresh install, or upgrade?
Its a fresh install, on a test version of my forum, the error is the same on the default skin and my custom skin

Googled the error, dont know if this helps:
Quote:

#

If the ONLY_FULL_GROUP_BY SQL mode is enabled, an error occurs:

mysql> SET sql_mode = 'ONLY_FULL_GROUP_BY';
Query OK, 0 rows affected (0.00 sec)

mysql> SELECT owner, COUNT(*) FROM pet;
ERROR 1140 (42000): Mixing of GROUP columns (MIN(),MAX(),COUNT()...)
with no GROUP columns is illegal if there is no GROUP BY clause

#

If ONLY_FULL_GROUP_BY is not enabled, the query is processed by treating all rows as a single group, but the value selected for each named column is indeterminate. The server is free to select the value from any row:

CypherSTL 11 Jan 2010 14:54

Bart, I did notice another error on your site, particularly with the Profile Tab. I left out a conditional statement in the output code for that.

For those who downloaded the BETA2 Zip file before this post, please re-download and import the XML.

CypherSTL 11 Jan 2010 14:55

Quote:

Originally Posted by absy (Post 1952700)
Its a fresh install, on a test version of my forum, the error is the same on the default skin and my custom skin

Googled the error, dont know if this helps:

Trying to see if I can duplicate it.

--
There is a SUM statement, which adds up the total amount of points. That could be where it is erroring out on. Did you make that setting custom on your database, or what?

absy 11 Jan 2010 15:02

not that I know, i disabled the points system and it works fine, so I am not worrired since I do not want to use the points, but it may be others might, thank you so much for working on this, itsa great part of our forum

CypherSTL 11 Jan 2010 15:07

@absy: I've tried it so far with fresh installed on VB 4.0PL1 using the normal mysql extension, and the mysqli extension. I myself cannot duplicate this. Anyone else running into this?

absy 11 Jan 2010 15:11

As I said, I am quite happy not to have a points system, if you would like to go on my test site and re enable the points and investigate there please do. If its just a quirk with my sql i wouldnt worry its an awesome mod

pm me if you want to go on my forum

CypherSTL 11 Jan 2010 15:17

I sent you a PM absy with a link to an XML. See if it's fixed in that if you don't mind.

CypherSTL 11 Jan 2010 15:26

Is anyone else having this problem with the points system being enabled and getting the SQL Error? I have a possible fix that I'm wanting to test before I update the actual .zip package.

I'm unable to duplicate the error on my test machines.

DigitalDark 11 Jan 2010 15:28

I use beta 2 and I've found a little bug in the private messages. I've seen the changes... very good work in beta 2

Image of the bug:
With moderators and admins ocurrs but with standard users not..
https://www.vbulletin.org/forum/external/2010/01/98.jpg

Image disabling the mod:

https://www.vbulletin.org/forum/external/2010/01/99.jpg

Another thing is the medal description in profile...

https://www.vbulletin.org/forum/exte...010/01/100.jpg

I think that there is a issue with the css nothing more... Thanks for your help!

PD: I don't have this sql error. I use ucash and I think that everithing is right despite of this details.

CypherSTL 11 Jan 2010 15:36

Digital. I did catch the Profile Tab bug and a few template's wern't caching. Those have been fixed in the current Beta2 Zip file. Try to redownload it and reimport the XML from that and see what it does.

Also, what postbit location are you using?

DigitalDark 11 Jan 2010 15:48

I'm using traditional postbit like vbulletin.org, and another thing is... this the signature is crazy hehe
I've reimported the product but still show this...
https://www.vbulletin.org/forum/external/2010/01/97.jpg

absy 11 Jan 2010 15:51

my issue solved thanks :)

CypherSTL 11 Jan 2010 15:54

Quote:

Originally Posted by DigitalDark (Post 1952744)
I'm using traditional postbit like vbulletin.org, and another thing is... this the signature is crazy hehe
I've reimported the product but still show this...

Does it also do it on the Default Style? If you saying it only does it to Moderators and Admins, but not to standard users, sounds like something else is trying to interfere with the code.

DigitalDark 11 Jan 2010 15:59

The image is too big but you can see the error with default style. Sorry the error happens with all users I thing. Look that :

http://i49.tinypic.com/4loi2a.jpg

Thanks!

GrossKopf 11 Jan 2010 17:09

1 Attachment(s)
Just found a problem. I have moderators able to give awards. I went into the Moderator panel for my forums. When I go to the Mod panel and click on "Give award to user", the page is blank to the right of the mod panel menu.

I'm attaching a screenshot.

Bouncer222 11 Jan 2010 17:58

There is also a problem with the postbit_legacy. Look at this link here: http://www.brotherhoodofgamers.com/s...to-post-wins-D

As you can see, when the awards are enabled, the background gray image behind the posts is cut off at the post which the user "Chompster" posted.

go to that link and look for the first post from the top named chompster, as you can see under his post the background gray stylevar (I think you can call it a stylevar i dont know) stops under his post, also reply, quote etc buttons are under his post when they shouldnt be there and his medals dont appear in BOTH his posts on that page.

How do I fix this or is this a bug?

Thanks.

Bouncer222 11 Jan 2010 18:00

Just an addition to my previous post, the reason it cuts out a square where the medals should be is because the user hasn't received any medals, so if they have no medals it's going to mess up the post like that.

DigitalDark 11 Jan 2010 18:01

I thing that there is a css issue. Actually I use horizontal posbit and the errors are like yours....
We must wait to another release of this great mod!

GrossKopf 11 Jan 2010 18:14

Quote:

Originally Posted by GrossKopf (Post 1952797)
Just found a problem. I have moderators able to give awards. I went into the Moderator panel for my forums. When I go to the Mod panel and click on "Give award to user", the page is blank to the right of the mod panel menu.

I'm attaching a screenshot.

Nevermind. New version fixes it.

GrossKopf 11 Jan 2010 18:22

Ok, got another problem. Awards aren't showing up in the user profile if I click on the award in a forum post:

http://flotgaming.net/forums/member....rds#aw_issue10

Clicking on the Awards tab in the profile works fine:

http://flotgaming.net/forums/member....f&tab=myawards

DigitalDark 11 Jan 2010 18:30

Ummm a user of my forum reported me this error... But I was solved byself... Try to reactivate the plugin and give the user more medals... Good luck!

Bouncer222 11 Jan 2010 18:38

Can you also make it so that if an award is not active it shouldn't be displayed in postbit_legacy aka any posts or anywhere on the site at all? Kinda doesn't make sense why would it show on the site if it's inactive, not just the awards page.

Thanks.

Veer 11 Jan 2010 18:42

3 Attachment(s)
Beta 2 style bugs:

If I use Postbit: Style 1 in postbit i get this result:
Attachment 109741

If I use the same in postbit_legacy, result is:
Attachment 109742

If I use Postbit: Style 2 I get the buttons like this:
Attachment 109743

abualk 11 Jan 2010 19:18

I am waiting the final version.

Thanks

bigdjam 11 Jan 2010 20:27

thank you

upgrade from 3.8.4 to VB4 succeful

Inferno Dragon 11 Jan 2010 20:57

Quote:

Originally Posted by CypherSTL (Post 1952243)
"Style 1" used the <legend> formatting tab, which doesn't seem to work in VB4. I'll see if I can find a work around for that, or just adding a div border should also work. Look for this to be fixed in tomorrows update.

I did this in the the awards postbit template and it's working fine now:
<fieldset style="border: 1px solid rgb(15, 16, 19);"><legend>

CypherSTL 12 Jan 2010 00:49

Quote:

Originally Posted by Bouncer222 (Post 1952858)
Just an addition to my previous post, the reason it cuts out a square where the medals should be is because the user hasn't received any medals, so if they have no medals it's going to mess up the post like that.

I'll tweak the conditional on displaying if the user has 0 awards.

Quote:

Originally Posted by GrossKopf (Post 1952870)
Ok, got another problem. Awards aren't showing up in the user profile if I click on the award in a forum post:

http://flotgaming.net/forums/member....rds#aw_issue10

Clicking on the Awards tab in the profile works fine:

http://flotgaming.net/forums/member....f&tab=myawards

Yes, that I do believe is a bug in vB 4.0. A few other users in other forums, and vB.com have posted on that.

Quote:

Originally Posted by Veer (Post 1952889)
Beta 2 style bugs:

If I use Postbit: Style 1 in postbit i get this result:
Attachment 109741

If I use the same in postbit_legacy, result is:
Attachment 109742

If I use Postbit: Style 2 I get the buttons like this:
Attachment 109743

With some of the CSS Style changes in vB4 it does seem that some issues exist. When I wrap only the awards with a border, it tries to wrap the majority of the postbit. I will check to see if I can better isolate this.
---
Again, thank you guys for helping me get this most tested and getting a lot of the bugs worked out in preparation for Gold release.

Sorry about bailing on the forums earlier today, my Internet went down and just came back up not too long ago.

For the users that were getting the SQL Grouping error, what MySQL version are you running? Although, I did fix it I do believe in the updated XML.

kylek 12 Jan 2010 01:44

Is there by any chance any known conflicts with other mods? No matter what I try I can get nothing to show medal display in the postbit area. Using default style and the postbit template has not been altered. Medals show fine in the profile display.

Are they all added via hooks or is there anyway to be able to manually place them?

CypherSTL 12 Jan 2010 05:53

Disable all other mods except for YaAS and see what happens.

And yes, all areas that the awards can display in the postbit are displayed using template hooks.

CypherSTL 12 Jan 2010 07:29

Quote:

Originally Posted by bart6767 (Post 1952675)
I get this at the bottom of the page ?

Members who received this award: 1
-- BEGIN TEMPLATE: awards_awardusers_bit --> , Bhoy_Molloy

http://www.randalstowncsc.net/awards.php

Is there a fix for this ?

In your AdminCP.
AdminCP -> vBulletin Options -> General Settings -> Add Template Name in HTML Comments

Set to Off.

kylek 12 Jan 2010 07:39

Quote:

Originally Posted by CypherSTL (Post 1953262)
Disable all other mods except for YaAS and see what happens.


Bingo. Found the mod that conflicts with this - Add Ignore User To Postbit Dropdown.

When that one is enabled it blocks the awards from appearing in all locations of the postbit.

argothiusz 12 Jan 2010 08:25

Can you make an auto award function so it's award member who has joined for certain date or reached certain post count?

Thanks

CypherSTL 12 Jan 2010 09:49

Quote:

Originally Posted by argothiusz (Post 1953308)
Can you make an auto award function so it's award member who has joined for certain date or reached certain post count?

Thanks

That would require coding a cron script. That currently isn't on my list to complete right now.

You could code on yourself that would do that. Eventually, it will most likely make its way into future versions. However, currently I'm more focused on bug fixes in our beta release.

CypherSTL 12 Jan 2010 11:37

YaAS BETA 3 Released

Check first post for the change log. I do believe I have everyones bugs fixed that have been reported so far.

If you've edited your Awards CSS Template, be sure to copy all the data from the "Default CSS Data.txt" over your existing template.

CypherSTL 12 Jan 2010 11:45

Please do not request additional features at this time. I'm working as hard I can right now to simply get all the bugs out of the awards system on vBulletin 4.0.

After the mod is considered stable, and ready for production use, I will work on additional features as necessary. Thank you for your understanding.

Veer 12 Jan 2010 12:28

Quote:

Originally Posted by CypherSTL (Post 1953393)
Please do not request additional features at this time. I'm working as hard I can right now to simply get all the bugs out of the awards system on vBulletin 4.0.

After the mod is considered stable, and ready for production use, I will work on additional features as necessary. Thank you for your understanding.

Yes, exactly. First we need a stable vb4 version.

Thank you CypherSTL for your hard work, I'm updating BETA 3 and will let you know my feedback shortly.

DigitalDark 12 Jan 2010 13:03

All the bugs that I've reported has been solved! Thanks man! I will report if I found any more...
Another thing that would be great is to allow a group of members to give medals. Thanks.

Edit: The mod cp in not working again, the same parse error
I solved it adding the awards.php of the Beta2 I don't know if this is correct...

CypherSTL 12 Jan 2010 13:18

Quote:

Originally Posted by DigitalDark (Post 1953437)
All the bugs that I've reported has been solved! Thanks man! I will report if I found any more...
Another thing that would be great is to allow a group of members to give medals. Thanks.

Edit: The mod cp in not working again, the same parse error
I solved it adding the awards.php of the Beta2 I don't know if this is correct...

Yeah. I just reuploaded the BETA3 Zip with the correct ModCP Awards file. For some reason I keep getting that mixed up with one of my others.

Sorry about that.

Bouncer222 12 Jan 2010 14:39

What's the default css data.txt for?

Bouncer222 12 Jan 2010 14:49

so far so good, updated.

Question: I want to have all of my forum members' avatars show on top of their medals and rank image, where do I move what code in posbit_legacy?

DigitalDark 12 Jan 2010 17:50

I've found a little bug. In postbit, when I click to a medal it links to me to the Award Profile Tab but is empty. When I click directly to the Awards Tab then the medals appear. Thanks!

Veer 12 Jan 2010 18:05

Quote:

Originally Posted by DigitalDark (Post 1953651)
I've found a little bug. In postbit, when I click to a medal it links to me to the Award Profile Tab but is empty. When I click directly to the Awards Tab then the medals appear. Thanks!

Yes, same here with beta 3.

CypherSTL 12 Jan 2010 23:03

Quote:

Originally Posted by DigitalDark (Post 1953651)
I've found a little bug. In postbit, when I click to a medal it links to me to the Award Profile Tab but is empty. When I click directly to the Awards Tab then the medals appear. Thanks!

Quote:

Originally Posted by Veer (Post 1953661)
Yes, same here with beta 3.

Again, as I've pointed out before. This is a bug with vBulletin, and should be fixed in the next release of vBulletin.

--
I'm currently installing vB 4.0.1 on my development board to check compatibility, and check the profile tab bug.

CypherSTL 12 Jan 2010 23:31

I installed vB 4.0.1 on my test board and it seems to have killed all custom profile tabs completely, even profile tabs from other mods.

bart6767 12 Jan 2010 23:33

everything works fine only for this page .

http://www.randalstowncsc.net/awards.php

COL NIL SATIS 12 Jan 2010 23:37

This was my fave ever mod on 3.8.4...!! absolute class..will get this tomorrow for sure!! thanks for this guys

CypherSTL 12 Jan 2010 23:38

Quote:

Originally Posted by bart6767 (Post 1953936)
everything works fine only for this page .

http://www.randalstowncsc.net/awards.php

It's been stated in this thread how to get rid of the template comments.

DigitalDark 12 Jan 2010 23:43

Quote:

Originally Posted by CypherSTL (Post 1953930)
I installed vB 4.0.1 on my test board and it seems to have killed all custom profile tabs completely, even profile tabs from other mods.

What? The tabs have dissappear?Are we in danger?

bart6767 12 Jan 2010 23:43

Quote:

Originally Posted by CypherSTL (Post 1953939)
It's been stated in this thread how to get rid of the template comments.

Thanks found it .

keep up the good work .

CypherSTL 12 Jan 2010 23:48

Quote:

Originally Posted by DigitalDark (Post 1953943)
What? The tabs have dissappear?Are we in danger?

I'm hoping it's just a bug with vB 4.0.1. According to debug mode on my test board, it's still caching all of the templates required to display the Tab, and the information within the tab.

CypherSTL 13 Jan 2010 00:02

It seems that vB 4.0.1 now has Tab Ordering. So, once I get the tabs going again, I'll update it.

DigitalDark 13 Jan 2010 00:05

Umm the Awards Tab has dissappeared right... But in the last version the tabs appeared. Maybe some change in the template. I'm very new in vBulletin ,but you can try a diferential search in the template in order to find what is changed respect the previous version. Sorry if I am saying stupid things...

CypherSTL 13 Jan 2010 00:08

I've reverted all of the templates in my Default Style, so they're in sync with vB 4.0.1. I believe this has something do with the "Tab Ordering" that was added into 4.0.1. Still trying to find out how to actually enter in the data for the tab ordering to see if it displays at that point.

CypherSTL 13 Jan 2010 01:05

Alright, well, I need to heat out to work, so I'll work on this some more when I get back.

All I can say, if you guys haven't updated to vB 4 yet, don't, it's a piece of junk IMO.

CypherSTL 13 Jan 2010 07:14

YaAS RC1 Released.

4.0.0 RC1 RELEASE: (01/13/2010 1:15AM CST)

* Fixed - Award Tab Display for vBulletin 4.0.1.

pretke 13 Jan 2010 12:05

Very nice addon. MEGA THX

Sayid 13 Jan 2010 16:15

hmm so what is the benefit of point system? I mean what does it calculate ? it depends on what ?

I like to see an auto award feature depends on posts number , reputation or points for example, and happy to see it upgraded

GreigM 13 Jan 2010 16:28

Great mod, our members loved it on 3.8 and will do again on vb4, I have set the awards to show on the userinfo left, is there a manual way to place the awards below the instant messaging icons?

absy 13 Jan 2010 16:50

This is a great mod, should be in the vb4 as default, thanks agian for all your hard work

VTXCafe.com 13 Jan 2010 17:12

Quote:

Originally Posted by CypherSTL (Post 1953990)
Alright, well, I need to heat out to work, so I'll work on this some more when I get back.

All I can say, if you guys haven't updated to vB 4 yet, don't, it's a piece of junk IMO.

I'm starting to agree...I pre-bought 2 o the suite versions and I have no plans on upgrading my other forums till I have to or till I can go with a different product. So many bugs and things screwing up it's pathetic.


All times are GMT. The time now is 10:04.

Powered by vBulletin® Version 3.8.14
Copyright © 2020, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.