vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=253516

★Slap 18 Nov 2010 19:18

Quote:

Originally Posted by kall (Post 2123044)
What is the content of your .htaccess file, and where is it located?

The .htaccess file is located in the root of my vBulletin, in vbseo_sitemap/data i cannot access it the htaccess file says "deny from all" checked in notepad.

Leica.Robbiani 18 Nov 2010 21:10

Hi Jigsaw,

overwrite the .htaccess in the vbseo_sitemap/data directory with the file in the "docs (do not upload) directory.

For the 404-issue I have tested this:

Quote:

RewriteEngine On
RewriteRule ^((urllist|sitemap).*\.(xml|txt)(\.gz)?)$ http://www.MYSITE.com/vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]
This seems working. Now I have to wait until the Google Webmaster Tools are telling me their meaning.

Best regards

L.R.

★Slap 19 Nov 2010 00:24

Quote:

Originally Posted by Chuta (Post 2123053)
Hello,

Please make sure that 'data/' folder has set permissions to 777. Also please be sure that you have the following structure in your .htaccess file:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Perhaps you are missing the 'RewriteEngine On' line.



As both Brian and me stated above, this is for security purposes. Nobody needs to access to that URL via web browser.

Make sure you are sending the correct sitemap index URL. Also you may want to be interested on reading this:

http://www.vbulletin.org/forum/showp...&postcount=137

All done, but still the same thing, i edited the .htaccess in the data folder and set the folder to 777, should i also recurse in sub directories too?, I uploaded everything the htaccess folder into root, includes and vbseo_sitemap folder, everything is working fine, apart from the sitemap links showing me a 404 error.

m!dn!ght 19 Nov 2010 09:17

Quote:

i edited the .htaccess in the data folder
put .htaccess file in forum root not in data folder
yourdomain.com/.htaccess

★Slap 19 Nov 2010 16:32

Quote:

Originally Posted by m!dn!ght (Post 2123441)
put .htaccess file in forum root not in data folder
yourdomain.com/.htaccess

I'm not sure if i included this but i did add the .htaccess folder in forum foot, the htaccess file which is in the data folder still remains, as it was like that once i downloaded, it. It said deny from all but one of the vBSEO staff told me to change it so i did but still nothing, the htaccess file is still located in data, and the htaccess folder is still in forum root (Unedited).

jarni 19 Nov 2010 19:57

Im having the same problem for some reason it always thinks that my sitemap is in Sitemap Index: http://m2mscoop.com/forum/sitemap_index.xml.gz

As my forum is in my root directory, that folder doesn't even exist. Is there a way to have the sitemap installed into my root directory? I think it worked 1 time but never since then.

jarni 19 Nov 2010 20:52

now I get this

General HTTP error: 404 not found
We encountered an error while trying to access your Sitemap. Please ensure your Sitemap follows our guidelines and can be accessed at the location you provided and then resubmit.
HTTP Error: 404
Problem detected on: Nov 19, 2010


It is only for the /sitemap_forum_1.xml.gz
Errors Sitemap Nov 19, 2010 106
all the other sitemap files seem to work fine

A.Chakery 19 Nov 2010 21:26

Working great and also a great combination with vBseo Plugin.

thanks vbseo ;)

A.Chakery 19 Nov 2010 21:29

Quote:

Originally Posted by jarni (Post 2123647)
now I get this

General HTTP error: 404 not found
We encountered an error while trying to access your Sitemap. Please ensure your Sitemap follows our guidelines and can be accessed at the location you provided and then resubmit.
HTTP Error: 404
Problem detected on: Nov 19, 2010


It is only for the /sitemap_forum_1.xml.gz
Errors Sitemap Nov 19, 2010 106
all the other sitemap files seem to work fine

Hi,

Dont worry its normal. its not related to this plugin. Its related to Google webmaster tools and it will take some time to get solved.

;)

mgcom 20 Nov 2010 12:16

Quote:

Originally Posted by UIQarena (Post 2123655)
Hi,

Dont worry its normal. its not related to this plugin. Its related to Google webmaster tools and it will take some time to get solved.

;)

I'm getting the same, will i leave the sitemaps submitted to google ? are they serving any purpose ?

eng999 20 Nov 2010 17:36

how can i make topics will be always in sitemap without i make run sitemap after every topic???

mradlin 20 Nov 2010 17:51

Installed.
Thanks

lodos0677 20 Nov 2010 21:18

installed.Very good.

idwpub 21 Nov 2010 05:41

I've installed and i'm getting the following when I run the generator -

Quote:

Warning: array_merge() [function.array-merge]: Argument #2 is not an array in /xxxx/xxxx/public_html/mysite/forum/global.php(28) : eval()'d code on line 58

LbR 21 Nov 2010 09:37

Brilliant thing way way better then default module of vBulletin :) VBSEO rocks


All times are GMT. The time now is 19:17.

Powered by vBulletin® Version 3.8.14
Copyright © 2020, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.