vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=324562

Plugin Error
by TopFloorDjs
02 Mar 2017 03:08

I am trying to register a variable and use data from a php file to display

hook location: init_startup
forumhome > {vb:raw shoutstats}

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Unfortunately with this code i get this error

PHP Warning: require_once(): http:// wrapper is disabled in the server configuration by allow_url_include=0 in ..../includes/init.php(351) : eval()'d code on line 4

I have disabled the plugin right now but i would like to get this to work.

Ive also tried

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

instead of require_once & in hook location : global_bootstrap_init_start

PHP Warning: include(): http:// wrapper is disabled in the server configuration by allow_url_include=0 in ..../includes/class_bootstrap.php(103) : eval()'d code on line 2

Dave 02 Mar 2017 14:08

You should not use the include/require functions to get data from a remote file.
If you want to get data from a remote file, use file_get_contents:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

This will fetch the output of the PHP file.

If the file is on your local server, use:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

This will execute the PHP code.


All times are GMT. The time now is 00:16.

Powered by vBulletin® Version 3.8.14
Copyright © 2021, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.