vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=243460

Spiders Display on Forumhome and Who's Online for vb4
by Boofo
28 May 2010 11:45

5 Attachment(s)
Spider Display for vB 4
Version 1.1.3
(By Boofo)

What does this product do?
This product will display the number of spiders on Forumhome and Who's Online. It will also add the count behind the spider name on Forumhome if there is more than one of a certain spider [ i.e. Google (3) ].

Credits:
A big thank you goes out to Adrian for helping me come up with the fix for this for vB 4.1.2, and straightening me out on keys in an array. Also, thanks to Paul M and Mosh for the comma fix for 4.1.8. Another thanks goes out to Mosh for the image file as well as making the mod work with all versions of vB 4. And yet another thank you goes out to HMBeaty for helping me find the fix for vB 4.1.10 and testing it thoroughly.

Version Information:
Version 1.0.0 --Initial release for vB 4
Version 1.0.1 --The count variable was wrong for the spider plural convention. Thanks goes out to Mosh for catching it. Also, the spiders_vbulletin.xml file has been updated to a more recent version, and the link for it below has been changed to another site that is keeping it up to date better than the original spiders list.
Version 1.0.2 --Fixed double comma issue with vB 4.0.5 in IE8.
Version 1.0.3 --Fixed issue with spiders displaying in a vertical listing in some browsers. The phrase ",with 0 spiders" will no longer show when there are no spider names listed.
Version 1.0.4 --Fixed to work with vB 4.1.2. Also, the "spiders_vbulletin.xml" file has been updated to the latest version as of February 15, 2011. => vBulletin 4.1.2 only
Version 1.0.5 --Added a setting to change the color of the spider name in the listing. Added a setting for Allowed Usergroups who can view spiders in the listing. Added a "View Map" link that will show up behind the spider count (or guest count if no spiders are currently on the site) on both the Forumhome and Who's Online. This link will only be visible if you have the "Digital Point User Map" mod installed. The spiders_vbulletin.xml file has also been updated to the latest version as of February 25, 2011. => vBulletin 4.1.2 only
Version 1.0.6 --Removed font color setting and added Style Variable setting for the Spider Display Font Color, so it can be set for each style separately. Set the dependency minversion to 4.1.2 in the xml file so there would be no improper version installs anymore. The spiders_vbulletin.xml file has also been updated to the latest version as of March 15, 2011. => vBulletin 4.1.2 only
Version 1.0.7 --Now fully phrased, as requested. => vBulletin 4.1.2 only
Version 1.0.8 --Should now work with all versions of vB 4, from 4.0.0 and up, including 4.1.8. Added a spider image to show before each spider, if the setting is enabled. It is off by default. The "spiders_vbulletin.xml" file has been updated to the latest version as of November 29, 2011.
Version 1.0.9 --Added a white spider icon image to go with styles that are dark. A setting has been added to choose what color image (black or white) you want to display before each spider name in the listing. The "spiders_vbulletin.xml" file has been updated to the latest version as of January 1, 2012.
Version 1.1.0 --Removed setting to choose the color of the spider icon and replaced it with a new style variable for the path to what spider image you wish to display for each style.
Version 1.1.1 --Added a setting to set the vertical alignment of the Spider Image. Added some more spider images.
Version 1.1.2 --Fixed to work on vB 4.1.10.
version 1.1.3 --Fixed to work with DragonByte Tech InfoPanels version 2.04 and above only.

NOTE: The word "Spider" or "Spiders" will no longer show up after each spider name listed in the activeusers listing on the Forumhome.

Installation overview:
----------------------------
1 Product XML (6 Plugins, 15 Phrases, 3 Settings, 2 Style Variables)
1 spiders_vbulletin.xml (located in the upload/includes/xml directory of this product ZIP file)
6 Spider Image files (located in the upload/images/misc directory of this product ZIP file)

Installation Instructions:
----------------------------
1. Upload the spider image files to the forums/images/misc directory on your site.

2. Upload spiders_vbulletin.xml to the forums/includes/xml directory on your site.

NOTE: Go to the following link for spiders_vbulletin.xml updates: http://www.wolfshead-solutions.com/spiders-list

3. Go to 'Admin CP -> Settings -> Options -> Who's Online Options -> Enable Spider Display' and make sure it is set to 'Yes'

4. Go to your Admin CP
Scroll down to 'Plugin System'
Click 'Manage Products'
Click 'Add/Import Product'
Click the 'Browse' button, and locate the 'product-boofo_spiderdisplay.xml' file on your computer

5. Go to your Admin CP -> vBulletin Options -> 'Spiders Display on Forumhome and Who's Online' and set the following options:
Spiders Display : Allowed Usergroups: These usergroups can view the Spiders Display on Forumhome. (Default is: '0' - All Usergroups)
Spiders Display : Show Spider Icon: Show Spider Icon to the left of each spider? (Default is: '1' - Yes)
Spiders Display : Spider Icon Vertical Position: Set the vertical-align property of the Spider Image. (Default is: 'bottom')

6. Style Variables:
Go to your Admin CP -> Styles & Templates -> Style Manager -> Style Variable Editor -> Click Go Button -> Boofo -> boofo_spiders_color
Enter the color code of the font color that you want the spiders to show up in.
Go to your Admin CP -> Styles & Templates -> Style Manager -> Style Variable Editor -> Click Go Button -> Boofo -> boofo_spiders_icon_image
This is your spiders display icon image. Set to the path of the spiders display icon image you want to use.

NOTE: You will need to do this for all styles.
-----------------------------------------------------

Done!
Enjoy!



Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Xencored 28 May 2010 13:07

Thanks matey :)

Mosh 28 May 2010 13:51

1 Attachment(s)
Hey Bob,

Thanks for the hack, I will use this over the other one I was using :)

One problem though, on the forumhome page when the number of spiders is greater than 1, it still displays "spider" rather than "spiders" (see attached screenshot).

Oh, one other thing, you may want to use my new spider list service to grab your spiders, as my list has more spiders on it, and it is more current (link in my signature) ;)

Mosh.

PS: I also added your hack as a recommended hack to display spiders in my spider list FAQ ;)

Boofo 28 May 2010 14:05

Problem fixed and new version uploaded. Thanks, Mosh, for catching it. ;)

Mosh 28 May 2010 15:16

All working fine now, thanks for getting out an update so fast :)

Boofo 28 May 2010 15:32

And, again, thank you for catching it, sir. ;)

Reycer 28 May 2010 18:00

ok, looks good, but it's counting all of my guests as spiders. I resolved their IP's and that's how I found out it was doing that.

yep
by your24hourstore
29 May 2010 17:33

Quote:

Originally Posted by mdelcour (Post 2044691)
ok, looks good, but it's counting all of my guests as spiders. I resolved their IP's and that's how I found out it was doing that.

me too just tested it. im sure he can fix that though :>

im interested to see how many new spiders in wolfs list :>

Boofo 29 May 2010 17:56

harleyparts, I'm not sure what you mean. It works fine for me and the others who have tested it. Have you tried resolving the IP to see what the ident string is saying? If so, then please PM me and I will see what is happening in your situation.

well
by your24hourstore
29 May 2010 18:46

i just installed it and then i went to twitter and posted a bunch of links to my site i was flooded with spiders but all came up as guest 56 spiders 0

but i know they are spiders. had two guests on when i did it

i will reinstall it
heres what it says right now
There are currently 36 users online. 1 members and 35 guests, with 0 spiders

Most users ever online was 94, 05-22-2010 at 07:58 PM.

Boofo 29 May 2010 19:02

Did you resolve the user agent on the who's online to see for sure if they weren't spiders? What did the who's online show? They should match up.

Also, PM me somewhere I can send a test fix and we'll see if this catches it if they donlt match up.

no i didn't resolve them
by your24hourstore
29 May 2010 20:35

have you ever done what i said, goto twitter and unm, put a Bunch of links to your site threads in as tweets?

usually a flood of spiders will hit your site I have never resolved them to see who they are, i just use it to test the spider mod in whats going on, i used to use another one.

but i just made this new site, and i installed yours. thanks by the way.

the only reason i said it wasn't working is that other guy said his wasn't so i flooded twitter, and here they came. but all showed up as guests. heck i dunno they may not be spiders LOL

I just always thought they were, the other mod i used to use always showed them as spiders.

i guess i will do it again and see if i can find out who they are.

heres who it is
by your24hourstore
29 May 2010 20:46

1 Attachment(s)
heres screen of them little devils oh wow

it just started showing them thats strange...but hey maybe it was just guests showing up when i tweeted that

they are differently showing up as spiders BRO good job and thanks. already rated it MOTM and great



added: now that i see yours working i realize the other mod wasn't showing guests it was showing them as spiders..LOL

Boofo 29 May 2010 21:02

I don't have a twitter account and have no desire to have one, to be honest. Not my thing, I guess.

As far as going there and posting links, I would venture to say what you saw earlier is ACTUAL people linking back to the site from the twitter post. Spiders are quick, but they don't act that fast usually. I added some jokes to my site earlier, as I knew it would draw some spiders. I was trying to test the hack after your post. I got a Google spider about 30 minutes later, which is on par.

The best way to test it is compare the amount of spiders on the forumhome and the who's online. If that matches up, then everything is working right. I don't add any code to the who's online as that is all vb doing the spiders there. I just add the total count. But I do add code for pulling the spiders on the forumhome as well as the total count. I have been using this product since way back in 3.5 and it hasn't failed me yet. ;)

Reycer 01 Jun 2010 20:13

Quote:

Originally Posted by Boofo (Post 2045216)
I don't have a twitter account and have no desire to have one, to be honest. Not my thing, I guess.

As far as going there and posting links, I would venture to say what you saw earlier is ACTUAL people linking back to the site from the twitter post. Spiders are quick, but they don't act that fast usually. I added some jokes to my site earlier, as I knew it would draw some spiders. I was trying to test the hack after your post. I got a Google spider about 30 minutes later, which is on par.

The best way to test it is compare the amount of spiders on the forumhome and the who's online. If that matches up, then everything is working right. I don't add any code to the who's online as that is all vb doing the spiders there. I just add the total count. But I do add code for pulling the spiders on the forumhome as well as the total count. I have been using this product since way back in 3.5 and it hasn't failed me yet. ;)

I've installed this now on 2 forums, on one forum it shows no spiders and on the other forum is shows everyone but the members as spiders. weird.


All times are GMT. The time now is 11:23.

Powered by vBulletin® Version 3.8.13
Copyright © 2019, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.