vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=231407

linuxututs 05 Jan 2010 19:58

Update went fine for me.

Sooo Glad you have it looking like the old 3.8.x's version again. ( Love the drop down description ! )

I had noticed this yesterday or the day before, but the RSS link is wrong.
it's showing
Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

.
Darn, this editor isn't letting me paste the correct link here at vb.org....( /{vb:raw LDM_catinfo.rss_feed] ) There that's it..... :)

Thanks for the help and again for a super Mod.

Thanks,

EDIT:

Ok, I tried overwritting the rss2 plugin and then I get this error when trying to visit Links/Download page.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

or
"Fatal error: [] operator not supported for strings in /var/www/vhosts/mydomain.com/httpdocs/includes/local_links_main_links.php(668) : eval()'d code on line 196"

Already tried deleting it, and that brought back everything, but when I uploaded the plugin, it did the same thing.

Thanks Andrew,

No pagination links?
by Deviant K1
05 Jan 2010 22:18

Hi Andrew. I discovered a small problem and wanted to let you know. There are no pagination links available if there more than 10 files in the category. I went to the Entry Display category in the LDM settings page and made sure that the entry in links per page was set to 0. Is there something else that I am missing?

E.T. 05 Jan 2010 22:28

2 Attachment(s)
Hi there,

Upgrade went well, and for a darker style it looks much better now.

Discover 2 things sofar...

Cannot see how the download in a section (missing an icon )
Alignment is not correct for catagories without sub catagories

Did I miss something perhaps ?

See screenshots

AndrewD 06 Jan 2010 03:45

Quote:

Originally Posted by Deviant K1 (Post 1948235)
Hi Andrew. I discovered a small problem and wanted to let you know. There are no pagination links available if there more than 10 files in the category. I went to the Entry Display category in the LDM settings page and made sure that the entry in links per page was set to 0. Is there something else that I am missing?

Confirmed.

There is a key piece of code at the very centre of LDM, which builds the main entry displays. It has become horribly complex and I made a change ;) Sorry - will have it fixed today, I hope.

AndrewD 06 Jan 2010 04:14

Quote:

Originally Posted by linuxututs (Post 1948120)
Update went fine for me.

Sooo Glad you have it looking like the old 3.8.x's version again. ( Love the drop down description ! )

I had noticed this yesterday or the day before, but the RSS link is wrong.
it's showing
Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

.
Darn, this editor isn't letting me paste the correct link here at vb.org....( /{vb:raw LDM_catinfo.rss_feed] ) There that's it..... :)

Thanks for the help and again for a super Mod.

Thanks,

EDIT:

Ok, I tried overwritting the rss2 plugin and then I get this error when trying to visit Links/Download page.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

or
"Fatal error: [] operator not supported for strings in /var/www/vhosts/mydomain.com/httpdocs/includes/local_links_main_links.php(668) : eval()'d code on line 196"

Already tried deleting it, and that brought back everything, but when I uploaded the plugin, it did the same thing.

Thanks Andrew,

Confirmed, will be fixed later today.

AndrewD 06 Jan 2010 04:52

Quote:

Originally Posted by E.T. (Post 1948243)
Hi there,

Upgrade went well, and for a darker style it looks much better now.

Discover 2 things sofar...

Cannot see how the download in a section (missing an icon )
Alignment is not correct for catagories without sub catagories

Did I miss something perhaps ?

See screenshots

First problem confirmed, and related to the problem reported by Deviant K1. Will be fixed later today.

I can't reproduce the second problem - do you mind if I take a look at your site (PM me details if so).

E.T. 06 Jan 2010 10:20

Quote:

Originally Posted by AndrewD (Post 1948466)
First problem confirmed, and related to the problem reported by Deviant K1. Will be fixed later today.

I can't reproduce the second problem - do you mind if I take a look at your site (PM me details if so).

No I don't mind at all :)

Your login details are in your PM box.

Thanks

AndrewD 06 Jan 2010 10:37

Quote:

Originally Posted by abdelghani68 (Post 1947919)
thanks. I can't import, "phrases_fr" there is an error, and with the product "product-eirma_ldm_fr" I have problems with the caracters "é, è.." it's write for exemple "téléchargements" and the right is "téléchargements"

I have had great difficulties with languages, because the vbulletin infrastructure is (by default) only partly set up to deal with these. I am able to install all language versions correctly on my test vb 4.0 system, but I have had to make a small change to one of the vb files to accept this. I will provide instructions in the translations directory when I update the 3.0.1 LDM release, which should be later today.

Ldm 3.0.1
by AndrewD
06 Jan 2010 16:44

I've reuploaded version 3.0.1 in the main post to fix the problems reported last night:

- missing page navs
- missing download icons for non-media files
- layout problems with catbit with some browsers
- bad url with rss icon

Please note that I have withdrawn the product files from the translations, and just provided phrase files, generally in both ansi and utf8 formats.

Sorry for any inconvenience.

E.T. 06 Jan 2010 17:10

Hi AndrewD,

I've reupload the files into the forum but still no icons...

Could you please check the files ?

cheers,
Marcel

edit...., reuploaded again and download icon is available now

IE catbit is still the same

raaowdot 06 Jan 2010 22:45

1 Attachment(s)
Hi, Thanks for the update as this is mine main mod on my site and I would not upgrade to 4 unless I can get it to work. Good work on a great mod.

I have a problem though....

I create a test site with a fresh install of both vb and LDM and it works fine. However I've now upgrade the site and for some reason the images still show the old versions and some are missing. i think the template/style has not updated.

I've redownload from here, reupload all fine and reran the install to no effect. Any Ideas?

JWL 07 Jan 2010 02:23

This is absolutly great, I have yet to really set it up, but this is the item I was looking for.

Being a Pro OHV Access Activist Website, this is going to be great for my members to upload and download video of Meetings, minutes and fliers, including Video of the ECO-Terrorist groups who want everyone out of the wilderness

AndrewD 07 Jan 2010 02:29

2 Attachment(s)
Quote:

Originally Posted by raaowdot (Post 1949118)
Hi, Thanks for the update as this is mine main mod on my site and I would not upgrade to 4 unless I can get it to work. Good work on a great mod.

I have a problem though....

I create a test site with a fresh install of both vb and LDM and it works fine. However I've now upgrade the site and for some reason the images still show the old versions and some are missing. i think the template/style has not updated.

I've redownload from here, reupload all fine and reran the install to no effect. Any Ideas?

Yes, you need to change the setting "file_icons_dir" on the LDM admin/settings page. The new icons are stored in images/ldm-silk-icons/. There is an alternative set of icons available in the release zip in extras/icon-sets/ldm-ox-icons. These are somewhat larger than the silk icons but you may prefer them, depending on the rest of your style (see attachments - the first shows the ox icons, the second, the silk icons). To use them, upload into images/ldm-ox-icons and set file_icons_dir accordingly.

Sorry for any confusion here - new installations pick up the new icon directory automatically but upgraded forums have to be set manually.

fayax 07 Jan 2010 02:35

Quote:

Originally Posted by Deviant K1 (Post 1944687)
I have re-opened my site if you still want to check out the LDM. --> LINK
Just click on the "Video Gallery" tab on the navbar.

I did notice one syntax error that only pop up when I first visit my LDM but it goes by so quickly that I don't get a chance to see the full error message. My guess it's one of the extras acting weird. It only happens if I clear out my cookies in my browser (Firefox), and re-visit my LDM page. I'll try to get a screenshot of it and post it.

Asides from that it works great. Just as it did on my vB 3.8.4 board :).

Excellent site.

Can you point me in the right direction to how I can get that download button. Right now I have some files up there, clicking on them opens then in a new tab but I would like to have a download button like yours. :)

Thanks.

AndrewD 07 Jan 2010 03:28

Quote:

Originally Posted by fayax (Post 1949242)
Excellent site.

Can you point me in the right direction to how I can get that download button. Right now I have some files up there, clicking on them opens then in a new tab but I would like to have a download button like yours. :)

Thanks.

Have you added the filetypes you want to download to the vbulletin attachments table?

If you don't do this, LDM assumes the entries are 'links' (to open in a new window). See the wiki.


All times are GMT. The time now is 14:07.

Powered by vBulletin® Version 3.8.14
Copyright © 2020, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.