vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=249277

thenamesgould 20 Dec 2011 04:51

Quote:

Originally Posted by dartho (Post 2278781)
Is that to say you did this, and then all was cool?

Sorry for the slow reply. Yep, that's right. :)

Mr_Running 20 Dec 2011 13:44

Thank you Dartho for the Lightweight Mobile Style.
Installed and currently checking it out. :)

I have the default vB google ads and I would like to remove the header and footer ads and keep the post ad.

How do I remove the header and footer Ads from the Lightweight Mobile Style?

dartho 20 Dec 2011 23:20

Quote:

Originally Posted by Mr_Running (Post 2279375)
Thank you Dartho for the Lightweight Mobile Style.
Installed and currently checking it out. :)

I have the default vB google ads and I would like to remove the header and footer ads and keep the post ad.

How do I remove the header and footer Ads from the Lightweight Mobile Style?

edit thoise templates and search for and remove the ad hooks. They start have ad_location in the line, so you can search on this text

The Rocketeer 20 Dec 2011 23:45

Dartho, you didn't answer my question :)
Also I was trying to improve the cms's look by removing the sidebars and any widget boxes, Can you tell me how? and after logging in the Copyright appears on top of the CMS..


also, i noticed, for some reason the vbulletin mobile detection script doesn't work properly for opera mini and a few other smart phone / iphone like devices? I set this skin as the mobile ski but its not changing. visiting my site using opera mini I get the default style, instead of the mobile style.

heres the opera mini simulator: http://www.opera.com/developer/tools/mini/


thanks

dartho 21 Dec 2011 02:49

1 Attachment(s)
Sorry - didn;t see this post:
Quote:

Originally Posted by The Rocketeer (Post 2279267)
i see. :o which css file is that? having a hard time finding it in the header and navbar templates. :confused:

Also how do you disable the cms sidebar for the mobile style?
I tried adding the below code to the Lightweight Style Options but didn't work

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


the lightweight.css.php file which you would have uploaded to your forum root. Does the following path resolve on your site? /images/misc/mobilelogo.png - that's where the logo lives

As for the sidebar - I can't get a sidebar to show? However, gice the following code a try: $show['sidebar']=0; - might work, might not ...

The CMS isn't that straight forward to work out, otherwise it would be in this style. It really depends on your layouts I think. I have a very basic CMS setup working on my test site. I'll attach the style here and you can test and get back to me. Same rules apply - backup/test etc. before going live or overwriting you existing lightweight style. Best bet is to add it as a child style of light weight for testing, then if you're happy you can re-import it and merge into existing.

Let me know how it goes

dartho 21 Dec 2011 02:50

@Rocketeer - As for the mobile device detection - dunno. You could edit the init.php file and manually modify the detection code to pickup those devices, but I think you probably need to lodge a support ticket with vBulletin.com

The Rocketeer 21 Dec 2011 10:00

Thank you Dartho, Yes that solves the logo problem. I also figured out that having the Text Option enabled in the Liteweight styles options causes the image to be replaced by text. (missed that setting before haha) :)

Now about the sidebar, I am actually referring to the CMS Sidebar, Grids or Widgets as you call it, you know the ones that appear in your CMS such as Menu, Polls, recent Forum posts etc?? I am trying to disable that or any widgets to appear in the CMS home page. That would make it look clean and pretty much complete.

I tried the CMSONLY style you gave me. Installed it as a Child Style of light weight, didn't notice any difference until when I went to my CMS / Homepage, I noticed that it doesn't show any articles. The header, nav and footer is there but the content is not present, and only shows this $column[1] .. I went inside the vbcms_grid_1 and vbcms_grid_2 and noticed it had a lot less code, only this actually..


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

so maybe you have a few lines of code gone missing there ?

And thanks I will probably open up a support ticket with vBulletin about their Mobile Detection Script not working with Opera Mini and this or any other style.

Happy Holidays :)

dartho 21 Dec 2011 10:42

Can't really offer much more - I don't know much about CMS or sidebars at all - I don't actually use it (CMS), or vBuylletin 4 for that matter. That CMS Style works on the simple CMS setup I have on my test site (http://vbdev.org)

The Rocketeer 21 Dec 2011 10:57

Thanks Dartho. I am working on the CMS part, trying to see if it can be improved.
But I think you might have given me the wrong vbulletin-style-lightweight-1.0.3a-CMSONLY.xml version. lol. I fixed it a bit but I think its missing some codes on the vbcms_grid templates.

Mine Looks like this style on your test site: http://vbdev.org/?styleid=16

I think it should look like this one instead? - http://vbdev.org/?styleid=7

- notice on your test site how on styleid=16 there's no articles showing and it just shows $column[1], but on styleid=7 it shows the articles properly? Thats what I am talking about, styleid=16 must be the one you gave me, thats missing some edits.

:)

dartho 21 Dec 2011 11:40

Actually - I think it is something to do with vBulletin's template system as opposed me exporting incorrectly.

If I export styleid 7 on my test site, i do not get CMS customisations to that style (although viewing it, you can see they are there). If during the export process I select CMS as the product, we end up with that blank page with column[1] on it...


Here's what I had to do to make it work.
Import the Lightweight Style to a new style
Import the CMSONLY style and merge with lightweight style imported above
Import lightweight style again and merge with lightweight style above

See how that goes ...

The Rocketeer 21 Dec 2011 12:06

No Dartho, That merging technique didn't work out very well :(
But I have made a list of minor changes and code edits to make it work and look like styleid 7.

I will see how that goes and if I can post them here, so others like me can improve the look of their CMS. Maybe you can include them in the next update of this style. I really wish the merging thing worked though.

Let me know if you find any code edits worth mentioning or other ways to do this.

dartho 21 Dec 2011 12:14

Quote:

Originally Posted by The Rocketeer (Post 2279682)
Maybe you can include them in the next update of this style. I really wish the merging thing worked though.

That's the thing - I can;t include them as vBulletin doesnlt export them with the style!


have a look in that CMSONLY XML file to see the templates and code I used on vbdev - add these in manually and I';m sure it will work out.

The issue seems to be a vbulletin bug perhaps? I've posted asking for assistance with it

rajcolmo 21 Dec 2011 17:46

Updated to 4.1.9 then went to install this from the latest version and got this:

This file was created using a different version of vBulletin from the one you are running.

Your version: 4.1.9
File version: 4.1.8

fly 21 Dec 2011 18:38

Quote:

Originally Posted by rajcolmo (Post 2279773)
Updated to 4.1.9 then went to install this from the latest version and got this:

This file was created using a different version of vBulletin from the one you are running.

Your version: 4.1.9
File version: 4.1.8

So check the box to ignore the version.

rajcolmo 21 Dec 2011 23:39

duh... missed that... thanks~!


All times are GMT. The time now is 18:53.

Powered by vBulletin® Version 3.8.14
Copyright © 2021, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.