vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=248470

[GlowHost] Spam-O-Matic for vB 3.8 (StopForumSpam, Akismet, Auto-Moderation and more)
by GlowHost.com
12 Aug 2010 19:39

5 Attachment(s)
We have released a mod for your vBulletin 3.8 that should stop almost all forum spam on your vBulletin boards. It is basically an (anti)Social Networking RBL to keep your forums clean!

This version is BETA and was developed specifically for vBulletin 4. However we believe this should work on vBulletin 3.8 so we have put it here for you in case you want to try a more robust Spam solution than what is currently available.

BETA is not a good word, this is more of an "Unsupported Backport" for earlier versions of vB.

The "REAL" Spam-O-Matic system was developed for vB4. This version is for you guys and gals that need to spend less time managing the spamers on your board(s). We hope it helps! The important features should work.

The original mod for vB 4 is located here:
http://www.vbulletin.org/forum/showthread.php?t=248042

IF YOU RUN vB4, MAKE SURE YOU ARE IN THE RIGHT THREAD!
Look at the URL above,
(sorry for caps)

This version is for vBulletin 4.x though has been reported to work on 3.6+
We only offer support on vBulletin 4.x as the 4.x version will have features not possible in the 3.x series.

This module has the ability to submit new spammer details to the StopForumSpam or Akismet databases automatically, all without any new templates or manual template modifications! :up:

Just install the product in the product manager, upload a few files, configure the system and you are done. (Estimated time: 5-10 minutes)

How it works:
New registrations are checked against the known spammer database at StopForumSpam.com. If the email, IP, or username exists in their database, the user (or bot as the case may be) is denied registration on your forums. If they make it past the SFS check, they are checked against several Automatic Moderation rules, and are also checked against the Akismet service for known comment spam.

A) StopForumSpam:
The StopForumSpam Module lets you:
  • Check a registrant's IP address.
  • Check a registrant's email address.
  • Check a registrants Username.
  • Disable or enable any of the above checks.
  • Block and log, or, allow and log known spammers.
  • All registration attempts are logged for your viewing pleasure.
  • Several other performance tuning options
If they are not found in the StopForumSpam database or are allowed registration by your rules, their registration details are passed to the built-in vBulletin registration system. (Human verification, etc)

It is completely invisible to humans who are registering that this process is taking place. Bots are stopped dead in their tracks.

If a spammer is able to sneak past the first line of defense, and manages to post, then there are secondary and tertiary protections.

B) Auto-Moderation:
Auto Moderation lets you:
  • Define how many URLs a new member can post before being sent to moderation.
  • Define keywords that will send a post to Auto-moderation (viagra, porn, meds, etc)
  • Define minimum post count to avoid Auto-moderation.
  • Excludes admin and moderators from Auto-moderation.
  • Completely disable Auto-moderation if you don't want it.
B) Akismet Service
Spammers that make it past the StopForumSpam and Auto-Moderation will be checked against the Akismet service. If they manage to make a post, and then are found on Akismet, they can be auto-moderated.

The Akismet settings let you:
  • Set the number of posts that Akismet will check from each user. After this number is exceeded, Akismet checking will be disabled for that user.
  • Auto-Submit spammers that post on your boards back to the Akismet service so that other forums and blogs do not do not receive the same spam.
  • Completely disable the Akismet service.
Punitive Actions:
If you find a spammer has made it past your 3 lines of defense, and has managed to post on your forum, then you can help the community...

The spammer's details can be sent to the Stop Forum Spam and Akismet databases automatically, preventing them from registering or posting on other forums. When other forums do the same, the protection is reciprocated.

Simply moderate a post and choose the option to "Delete Posts As Spam..." an then choose the option to "Ban User." Banning the user sends their details to either Akismet, StopForumSpam, (or both) depending on how you set it up.

The next version will add a "Spam-O-Matic" option to the Postbit Moderation Tools menu to better streamline the process and make it two-click process instead of the long and cumbersome way that vBulletin Ban options are presented now. This new menu option will be available only for vBulletin 4.x series.

API Keys:
API Keys are NOT required for this system to stop spammers on your forums.

A StopForumSpam API key is required if you want to contribute to the StopForumSpam blacklists by adding your spammers to their database. By submitting spammers you help keep other forums and blogs clean.

An Akismet API key is required if you want to enable any Akismet auto-moderation features in this module.

You can obtain a Stop Forum Spam API key which is free from stopforumspam.com.

Get your StopForumSpam API Key Here

You can obtain an Akismet API key from Akismet.com.
Akismet offers free and paid API keys so choose your version based on your situation.

Get your Akismet API Key Here

Why it is better than the other anti-spam solutions on vBulletin.org:
  • Works with all of vBulletin 4 functions including Facebook automatic registration.
  • Report spammers that you find to the Stop Forum Spam Database.
  • Report spammers that you find to the Akismet Database.
  • Built-in Auto-moderation.
  • Auto-moderation rules based on post count.
  • Auto-moderation rules based keywords.
  • Auto-moderation rules based Akismet results.
  • Enable or disable any actions that you do not want.
  • Customizable "Registration Rejected" message.
  • Consolidates 3 popular methods of spam prevention into one product.
  • No Manual Template Modifications!
  • Supported!
======================
Compatibility:

vBulletin 4.0.x - but for 4.x you should GO HERE instead.

vBulletin 3x versions that have been reported to work:

*vBulletin 3.8.4 Patch Level 2
*vBulletin 3.8.5
*vBulletin 3.8.6 Patch Level 1
*vBulletin 3.8.7
*vBulletin 3.8.7 Patch Level 1
*vBulletin 3.8.7 Patch Level 2 (with this mod)



(Add your version here by sending us a PM or post in the thread!)

Should you decide to install this on an vB3, we are interested in your feedback. Let us know if it works or fails miserably. :)

======================
Reported Conflicts or reproducible known issues:

None at this time for this release.

======================
Modifications:

2 table alterations

9 hooks used:

- register_addmember_process
- register_addmember_complete
- userdata_presave
- useradmin_edit_column1
- userdata_delete
- userdata_postsave
- newpost_process
- threadfpdata_presave
- postdata_presave

No new templates or template modifications!

Uploads:
4 files. (2 PHP, 2 XML)
1 Product Manager Upload
======================

=====================
Donations:

If you like this mod, sure, you can donate.
But the best donation would be to nominate us for MOTM, to tell your friends and others about this mod, and if you are in need of web hosting, order it from GlowHost.com to show your thanks.

We hope you enjoy the mod, spread the word to keep all of our forums clean. :up:

=====================
Installation:

1) Download the attached file
2) Mark As Installed
3) Extract the zip file, and view the readme file.

If you like this mod, please nominate us for Mod Of The Month

=====================


Original concept credits go to the authors of vBStopForumSpam and MonkeyStop

Phalynx 13 Aug 2010 13:47

Thanks for sharing, will try this later on my 3.8 boards.

Phalynx 14 Aug 2010 19:16

Got this error with vBulletin 3.8.4:
PHP Fatal error: Using $this when not in object context in includes\functions_vbghsfs.php on line 459

URL was:
http://www.xxx.xxx/inlinemod.php?do=dodeletespam

Phalynx 14 Aug 2010 19:19

Next error:
PHP Parse error: parse error in \includes\class_dm_threadpost.php(1649) : eval()'d code on line 13

Modification uninstalled for now, as I cannot delete posts as spam nor ban these users. By the way, these posts were done by a 2 year account. That's why I want to delete such users.

Phalynx 16 Aug 2010 19:43

Any update on this?

GlowHost.com 21 Aug 2010 08:56

You might try the version 1.2.3 for vB4 as a possible solution or disable the akismet reporting.

GlowHost.com 26 Aug 2010 02:37

Sorry to keep you guys waiting on the vBulletin 3.8 series but my main priority has been vB 4.x

That is why I marked this mod as unsupported. However:

We have released 1.2.4 which should clear up a few bugs for you.

It has been reported to run on:
*vBulletin 3.8.6 Patch Level 1*
*vBulletin 3.8.4 Patch Level 2*

So I suspect it works fine on versions of 3.8 in general.

The supported version of Spam-O-Matic with a bunch of new features and made for vBulletin 4 is located here:
http://www.vbulletin.org/forum/showthread.php?t=248042

Any feedback is better than no feedback.

If you install this mod, please mark it as installed.

Cheers :)

Phalynx 26 Aug 2010 08:45

Thank you!

digicom 27 Aug 2010 01:42

Excellent :up:

Iguana Goddess 27 Aug 2010 16:48

Sounds great. Tagged for now, will check it out later.

Uber_Tiny 29 Aug 2010 08:52

Getting the error:

A conflict was detected in the bitfields. You cannot continue with the installation of this product until this has been fixed. The conflicts found were:

* Bitfield Collision: canpostnonmembergroup = canalwayspostmessage

What??

How do I fix this?

reflekt 01 Sep 2010 07:33

Has appeared to install successfully on 3.8.6 pl1.

Does this check PMs and blog entries as well as forum posts?

tobaro 04 Sep 2010 12:43

using it now on 3.8.6 Patch Level 1. Works fine, BUT: if a user tries to register again at the same window, just changing password, the registration works.
What I did:
registered using a spam mail from "Stop Forum Spam".
Got denie message. works.
refreshed the window and used new password with same email address.
Registration works.

a bug?

GlowHost.com 04 Sep 2010 13:34

Quote:

Originally Posted by reflekt (Post 2092299)
Has appeared to install successfully on 3.8.6 pl1.

Does this check PMs and blog entries as well as forum posts?

Well, you are in the wrong thread if you are asking about blog posts. This version of the mod is older and for vBulletin 3.x

Blogs are part of 4.x AFAIR

The supported version of Spam-O-Matic for vB4 deletes threads, posts, PM, and Calendar Events.

Blogs are in the works for a later 2.x release. But we need support to develop further...

Quote:

Originally Posted by tobaro (Post 2093606)
using it now on 3.8.6 Patch Level 1. Works fine, BUT: if a user tries to register again at the same window, just changing password, the registration works.
What I did:
registered using a spam mail from "Stop Forum Spam".
Got denie message. works.
refreshed the window and used new password with same email address.
Registration works.

a bug?

Could be, thanks for the report. I can't really test on 3.8 though as I have finally updated all of our boards to 4 series. I will see if I can dupe what you talk about on vB4 and if the same thing happens then we can backport a patch for the 3.x series in this thread.

GlowHost.com 04 Sep 2010 13:36

Quote:

Originally Posted by tobaro (Post 2093606)
using it now on 3.8.6 Patch Level 1. Works fine, BUT: if a user tries to register again at the same window, just changing password, the registration works.
What I did:
registered using a spam mail from "Stop Forum Spam".
Got denie message. works.
refreshed the window and used new password with same email address.
Registration works.

a bug?

PS What browser and version?

tobaro 04 Sep 2010 21:55

I used google chrome, newest version for this test.

GlowHost.com 04 Sep 2010 22:19

Great, thanks. I will try to check this out tomorrow as soon as I have a few free minutes.

Again, thanks for the report. Detailed reports make for speedy fixes. :D

tobaro 04 Sep 2010 22:21

no problem. take your time. mod works beside this bug very great, stopped today already about 20 spammers.

GlowHost.com 08 Sep 2010 12:50

Version 1.2.5 is released which fixes a bug with automatic submissions to the new StopForumSpam site.

Marty McFly 08 Sep 2010 19:50

This doesn't work on vBulletin 3.8.6 Patch Level 1.

Every time a new post is made it gives:

Parse error: syntax error, unexpected T_BOOLEAN_OR in /home/*****/public_html/board/includes/functions_newpost.php(414) : eval()'d code on line 5

Parse error: syntax error, unexpected T_BOOLEAN_OR in /home/*****/public_html/board/includes/class_dm_threadpost.php(1649) : eval()'d code on line 16

Unable to add cookies, header already sent.
File: /home/*****/public_html/board/includes/functions_newpost.php(414) : eval()'d code
Line: 5

When I disable the product, it works fine.

GlowHost.com 08 Sep 2010 20:01

What version did you try to install? 1.2.4 is known to work well on that version.

digicom 08 Sep 2010 23:17

I have this installed On vBulletin 3.8.6 Patch Level 1 and vBulletin 3.8.4 Patch Level 2
Never had any problems, also just upgraded to 1.2.5 with no issues :up:

Quote:

Originally Posted by Marty McFly (Post 2095542)
This doesn't work on vBulletin 3.8.6 Patch Level 1.
Every time a new post is made it gives:

Parse error: syntax error, unexpected T_BOOLEAN_OR in /home/*****/public_html/board/includes/functions_newpost.php(414) : eval()'d code on line 5

Parse error: syntax error, unexpected T_BOOLEAN_OR in /home/*****/public_html/board/includes/class_dm_threadpost.php(1649) : eval()'d code on line 16

Unable to add cookies, header already sent.
File: /home/*****/public_html/board/includes/functions_newpost.php(414) : eval()'d code
Line: 5

When I disable the product, it works fine.


Cappuccino 09 Sep 2010 00:36

nice work

I get the same errors
by Blueracer66
14 Sep 2010 06:35

Quote:

Originally Posted by Marty McFly (Post 2095542)
This doesn't work on vBulletin 3.8.6 Patch Level 1.

Every time a new post is made it gives:

Parse error: syntax error, unexpected T_BOOLEAN_OR in /home/*****/public_html/board/includes/functions_newpost.php(414) : eval()'d code on line 5

Parse error: syntax error, unexpected T_BOOLEAN_OR in /home/*****/public_html/board/includes/class_dm_threadpost.php(1649) : eval()'d code on line 16

Unable to add cookies, header already sent.
File: /home/*****/public_html/board/includes/functions_newpost.php(414) : eval()'d code
Line: 5

When I disable the product, it works fine.

I get the same errors as well. This seems like what I really need but there errors are annoying... Thanks for the mod though! Looking forward for an update! I have vBulletin 3.8.6 Patch Level 1 and mod version 1.2.5 :rolleyes:

GlowHost.com 14 Sep 2010 09:25

You can try an earlier version if you have errors on your 3.x forums. There will be no more releases of this mod for vBulletin 3.x

Spam-O-Matic Version 2.0 is currently being tested on vBulletin 4.0

BirdOPrey5 14 Sep 2010 20:14

Quote:

Originally Posted by GlowHost.com (Post 2097998)
You can try an earlier version if you have errors on your 3.x forums. There will be no more releases of this mod for vBulletin 3.x

So it's never leaving beta? :(

GlowHost.com 14 Sep 2010 20:30

The original mod was written for vBulletin4 but I realized that it also worked on the earlier versions based on user reports so I opened this mod up for you guys on the older boards so that you at least have some spam protections before you move to vB4.

The mod is well out of beta in the vB4 series and version 2 is near ready for release :) Actually, this month it was nominated for mod of the month, it doesn't look like we will make it though :)

Maybe we will have another shot when version 2 for vB4 comes out.

That mod is located here:
http://www.vbulletin.org/forum/showthread.php?t=248042

It is supported and actively maintained.

Uninstalled
by Blueracer66
15 Sep 2010 16:38

Well, this mod seems like what I needed but I will never upgraded to vB 4.0 as I don't like it and neither do most of my users. I installed http://www.vbulletin.org/forum/showthread.php?t=176481 to replace this mod. Anyway, thanks for help the community. If I ever start a vB 4.0-powered community I'll give this mod a try again. Peace. :)

GlowHost.com 23 Sep 2010 15:30

That is a good solution for the 3.8 and earlier boards if you are having issues installing this version on your 3.x series boards. There are a lot less functions than Spam-O-Matic but it does a good job of preventing spam signups and is what Spam-O-Matic was based on.

If any of you are going to be running vB4 make sure to check out this thread:
http://www.vbulletin.org/forum/showt...t=Spam-O-Matic

It is a better solution for the 4.x series boards, and lots of additional features.

alehawk 29 Sep 2010 21:12

Quote:

Originally Posted by Marty McFly (Post 2095542)
This doesn't work on vBulletin 3.8.6 Patch Level 1.

Every time a new post is made it gives:

Parse error: syntax error, unexpected T_BOOLEAN_OR in /home/*****/public_html/board/includes/functions_newpost.php(414) : eval()'d code on line 5

Parse error: syntax error, unexpected T_BOOLEAN_OR in /home/*****/public_html/board/includes/class_dm_threadpost.php(1649) : eval()'d code on line 16

Unable to add cookies, header already sent.
File: /home/*****/public_html/board/includes/functions_newpost.php(414) : eval()'d code
Line: 5

When I disable the product, it works fine.

I got the same problem and replacing with the last version over 3.0 worked.

GlowHost.com 30 Sep 2010 18:01

Version 1.2.8 is available which should fix many bugs for 3.x vBulletin boards.

You can download it at the official thread here;
http://www.vbulletin.org/forum/showthread.php?t=248042

GlowHost.com 30 Sep 2010 18:11

Please wait before installing 1.2.8 on 3.x boards, I need to confirm some things and will post back shortly.

GlowHost.com 30 Sep 2010 19:08

Ok, you guys should be good to go for install. Good luck.

PS, Last day to vote for us for MOTM!

http://www.vbulletin.org/forum/showthread.php?t=249712

Please show your support at the link above. Thank you!

digicom 30 Sep 2010 22:55

Thanks Installed :up:
Quote:

Originally Posted by GlowHost.com (Post 2105184)
Ok, you guys should be good to go for install. Good luck.


abhimation 16 Dec 2010 16:14

http://img204.imageshack.us/img204/2678/59043656.jpg

Installed! Still got spammers and this error while removing them...

I want to install this...
by Blueracer66
16 Dec 2010 16:33

But I will wait a bit more. I am subscribed to this thread. :)

GlowHost.com 16 Dec 2010 21:40

Quote:

Originally Posted by abhimation (Post 2134830)
http://img204.imageshack.us/img204/2678/59043656.jpg

Installed! Still got spammers and this error while removing them...

What version of vB do you use and what version of the mod did you install?

abhimation 17 Dec 2010 05:06

vBulletin - 3.8.2 & Mod version - 1.2.0

GlowHost.com 17 Dec 2010 05:19

Yeah, I am not sure if it will support all the way back to 3.8.2 the earliest known versions thus far are in the 3.8.4 and later releases. If anyone else can confirm working in 3.8.2 or earlier please let us know.

Meanwhile those of you with the version 4 and higher boards can see here

Does it work on vBulletin 3.8.6 Patch Level 1?
by Blueracer66
21 Dec 2010 00:56

Has anyone installed this on vBulletin 3.8.6 Patch Level 1? If so, is it working correctly? Thanks!

Parse error: syntax error, unexpected T_BOOLEAN_OR
by Blueracer66
30 Dec 2010 18:00

My users and I get the following error when posting a thread or reply.

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

This error doesn't happen when I disable the mod.

papalph 07 Jan 2011 18:13

It doesn't appear that this mod handles the ACP or the MCP being anything other than /admincp or /modcp. We moved ours (to stop people from tracking us down with inurl: searches) and it's not taking that move into account. VB knows that it's moved, I'm pretty sure that there is a variable that you could use to find out the right URL.

1TN LSYJ 08 Jan 2011 01:21

1 Attachment(s)
when I installed this on my 3.8.6 patch level 1, I get this error message when I try post a thread:

any ideas?

GlowHost.com 08 Jan 2011 01:31

Never seen that one before but it seems like you should try to re-upload the files and make sure they are in the correct place per the install instructions.

realmr 08 Jan 2011 15:39

is 1.2.0 is the right version to be used for 3.8 series forums ? or can we install 1.2.8 as well ?

GlowHost.com 08 Jan 2011 20:07

The latest versions should work. Not sure about 1.2.0 but some people have reported success with it.

bplinson 08 Jan 2011 20:31

I just installed 1.2.8 on my 3.8.5 board and it seems to be working fine. It says version 1.2.7 in the plugins manager though. File I downloaded is named - GlowHost_-_Spam-O-Matic_v1.2.8_VB3_VB4.zip

I put in my stopforumspam API key but it does not seem to be doing anything. This was on version 1.2.0 though and I will see if it works with the 1.2.7

Geek Specialtie 10 Jan 2011 05:05

Quote:

Originally Posted by papalph (Post 2145509)
It doesn't appear that this mod handles the ACP or the MCP being anything other than /admincp or /modcp. We moved ours (to stop people from tracking us down with inurl: searches) and it's not taking that move into account. VB knows that it's moved, I'm pretty sure that there is a variable that you could use to find out the right URL.


Same for me - I moved my admincp and modcp.

I edited the hardcoded paths to modcp in the /includes/functions_ghsom.php file to reflect where they are and seems to be working fine (3.8.6 patch level 1 - Spam-O-Matic v 1.2.8)

Found it twice on line 317 and 562

BTW great work! This will be saving me time spent moderating new users for sure.

bplinson 10 Jan 2011 17:45

Thanks Geek....that did the trick.

tlwwolfseye 10 Jan 2011 23:24

Since I installed this Mod on one of the sites I am responsible for, I get these errors when posting threads. :(

Quote:

Parse error: syntax error, unexpected T_BOOLEAN_OR in /www/htdocs/w00b4375/board/includes/functions_newpost.php(400) : eval()'d code on line 56

Parse error: syntax error, unexpected T_BOOLEAN_OR in /www/htdocs/w00b4375/board/includes/class_dm_threadpost.php(1649) : eval()'d code on line 4
Quote:

Unable to add cookies, header already sent.
File: /www/htdocs/w00b4375/board/includes/functions_newpost.php(400) : eval()'d code
Line: 5
That happend immediately after installing this Mod. Before I had the old vBStopForumSpam installed, but deinstalled that first and remove all the old files.

This Board is still 3.8.4 PL2 btw.
Any ideas ?

As soon as I disabled your mod, everything was fine again. :(

BirdOPrey5 11 Jan 2011 00:39

Guys, read post # 7 in this thread... the author's official supported version is now in this thread: http://www.vbulletin.org/forum/showthread.php?t=248042

If you're going to get support it's going to be in that thread.

SB Staff 12 Jan 2011 15:45

People who have installed this mod - have you found that it helped cut out the spammers registering on your site?

bplinson 12 Jan 2011 17:40

It has stopped 99% of the ones hitting my site.

Baldy 13 Jan 2011 20:12

My forums are huge and we were dying from a deluge of spammers. It's the single best thing we've ever installed and I'm gonna donate $200, which is probably a cheap-out considering how it has lifted our mod team's spirits.

My boards are 3.8.5.

The only thing is we upped the number of links n00bs could post because they love to post pics and img links seem to count.

GlowHost.com 13 Jan 2011 22:40

Quote:

Originally Posted by Baldy (Post 2148581)
My forums are huge and we were dying from a deluge of spammers. It's the single best thing we've ever installed and I'm gonna donate $200, which is probably a cheap-out considering how it has lifted our mod team's spirits.

Wow, thanks for that. I will be waiting anxiously :)

Dj Smuggla 15 Jan 2011 13:32

This mod is great, its helped my forum a lot. In the last few weeks my forum has been bombarded with spammers, i installed this mod 2 days ago & just 1 spammer has got in...

Thanks a lot GlowHost

Im using:
v1.2.8 with 3.8.6 Patch Level 1

FAST50 05 Feb 2011 19:22

I installed this mod a month ago and spammers are still able to register. So I took a further step: I banned GMAIL email accounts for new registrations and that slowed the spammers down a lot.

The spammers are still getting through the registration process although it's not a bad as it was. Is there any way to stop these spammer idiots?

BTW, I recently (about a month ago) updated VB from 3.5.3 to 3.8.4 and that's when the spammers started FLOODING in. When we are using VB 3.5.3, with captcha and NOSPAM! running, it stopped them all.

hugh_ 11 Feb 2011 01:49

Glowhost are you planning to also update this release to version 2.0?

GlowHost.com 11 Feb 2011 07:18

Hi,

Version 2.0 will be for vBulletin 4.0+ only.

Unfortunately no, we find its a better choice to make code for current versions and systems than trying to do that for older stuff. It becomes harder to debug working backwards and for older software, that is why almost nobody does it (for long.) Any other releases for 1.x will be for any security releases otherwise development has stopped on it and is no longer supported.

Slam Da Brakes 13 Feb 2011 03:15

Sorry really wanted this to work, unfortunately I have had to uninstall it

3.8.4 PL 2 using version 1.2.0 . Parse syntax errors after posting. Installed 1.2.8 - more Parse error: syntax error, unexpected T_BOOLEAN_ after logging out.

Probably should really upgrade my board to 4.0 anyway.

m0rk 13 Feb 2011 12:53

Installed this a little over 24hrs ago, and by my figures it's stopped about 800 spammers registering... really good.

Joey805 13 Feb 2011 22:43

Do you have a version 2.0 for VB3? I'm still running into the RSS issue with version 1.28

Baldy 15 Feb 2011 18:17

Quote:

Originally Posted by GlowHost.com (Post 2148641)
Wow, thanks for that. I will be waiting anxiously :)

I'm having trouble figuring out where to donate. Can you point me to an email address to send a Paypal?

This plugin has made the moderators of our two boards so very happy...

GlowHost.com 15 Feb 2011 21:17

Quote:

Originally Posted by Baldy (Post 2162867)
I'm having trouble figuring out where to donate. Can you point me to an email address to send a Paypal?

This plugin has made the moderators of our two boards so very happy...

I don't theink the mentioned donation ever arrived :(

But for Baldy and anyone else interested, at the top of this page on the right is a link called "Support Developer" If you click that you can enter in the relevant details. This link should focus your browser on the link top right of screen:

http://www.vbulletin.org/forum/showt...ojs=1#gtdonate

Thanks for your support!

Joey805 20 Feb 2011 21:48

So no update for vb 3.8?

:(

ThunderVamp9 01 Mar 2011 04:09

Very impressed with this add-on, in 22 hours it's blocked 113 attempted registrations.

zepcom 02 Mar 2011 20:10

Also wanted to pile on for the "no vbb3.8 support" .... we get the parse error "/includes/functions_newpost.php(414) : eval()'d code on line 5" on our 3.8.7 board.

I would consider donating if the OP would at least fix the bugs in the 3.8 code that he released. It's fine by me if future "feature enhancement" revisions only support vbb4, but where we are at, we would like to stick with vbb3 for various reasons.

Are you SURE, OP, that you are giving up on the 3.8 version of this mod that you released?

My full error code is as follows: (Running vBB 3.8.7 and SOM 1.25. also has same problem with SOM 1.20 previously tried)

Quote:

Parse error: syntax error, unexpected T_BOOLEAN_OR in includes/functions_newpost.php(414) : eval()'d code on line 5
Please advise.

GlowHost.com 02 Mar 2011 20:26

Yes I am sure. we are coding for current and future versions right now. I am not sure your error is directly related to SOM though. You might try disabling all mods except SOM and see if the error goes away, if not you might need to look closer at any template edits you have made.

Phaedrus 04 Mar 2011 09:26

Loaded it, got an error, unloaded, reloaded...

Working. I had it installed for about 5 minutes, it already rejected one spammer.

King Justice 08 Mar 2011 04:52

WHY IS THERE A GOOGLE AD IN THE INLINE MOD? YOUR SCRIPT CAN GET SITES BANNED DOING THIS CRAP, HOW DO I REMOVE YOUR AD?

It happens when you try to Delete a post as spam and then ban a user. I was TRYING to help the stopforumspam database by doing this since it automatically adds the users details int eh database, only to be slowed down and my own AdSense account jeopardized by this unethical sneaky BS.

How do I remove the ad?! :mad: Take it out! :mad:

BirdOPrey5 08 Mar 2011 13:05

Can you post a screenshot of this ad because I don't have any ad nor do I see anything in the code to show an ad?

GlowHost.com 08 Mar 2011 15:24

Quote:

Originally Posted by BirdOPrey5 (Post 2170881)
Can you post a screenshot of this ad because I don't have any ad nor do I see anything in the code to show an ad?

You took the words out of my mouth. There are no ads of any sort in the 3.8 version of the mod.

King Justice 09 Mar 2011 01:18

Quote:

Originally Posted by King Justice (Post 2170790)
WHY IS THERE A GOOGLE AD IN THE INLINE MOD? YOUR SCRIPT CAN GET SITES BANNED DOING THIS CRAP, HOW DO I REMOVE YOUR AD?

It happens when you try to Delete a post as spam and then ban a user. I was TRYING to help the stopforumspam database by doing this since it automatically adds the users details int eh database, only to be slowed down and my own AdSense account jeopardized by this unethical sneaky BS.

How do I remove the ad?! :mad: Take it out! :mad:

http://www.imagespace.us/images/3xgw...5cg3z4btw3.png

:mad:

GlowHost.com 09 Mar 2011 04:56

That is definitely not part of Spam-O-Matic. You can check the source code yourself. If that is showing up your board has other problems.

Slugger00001 09 Mar 2011 21:02

also shows up on my site, I just never said anything about it.and i've never once put a google ad code on my website. so its not something thats in my code.

GlowHost.com 09 Mar 2011 21:12

Not sure, but I would anticipate if you guys are running older forums that a security update was probably missed. As I mentioned, you can check the source code for this mod. There is no adwords code in it.

King Justice 11 Mar 2011 23:13

Quote:

Originally Posted by GlowHost.com (Post 2171540)
Not sure, but I would anticipate if you guys are running older forums that a security update was probably missed. As I mentioned, you can check the source code for this mod. There is no adwords code in it.

No it's not. Don't even try that BS. I'm reporting this mod. This is BS. You're lucky I don't report you to AdSense.

GlowHost.com 11 Mar 2011 23:22

I invite you to report me to adsense. I don't even have an adsense account.

Can someone here who understands PHP code look at the sources and tell this guy its not this mod?

Wtf?
by Blueracer66
11 Mar 2011 23:39

Quote:

Originally Posted by GlowHost.com (Post 2172374)
I invite you to report me to adsense. I don't even have an adsense account.

Can someone here who understands PHP code look at the sources and tell this guy its not this mod?

I don't see the AdSense code anywhere. I think he's B.S.ing. Perhaps he downloaded it from a different site? :confused:

GlowHost.com 11 Mar 2011 23:45

Thank you for helping to verify BlueRacer66.

You have a good point, I have seen a lot of bootleg versions of this floating around the web. Its possible someone stuffed adsense code in one of those unofficial versions. This mod should only be downloaded from vBulletin.org.

No problem.
by Blueracer66
11 Mar 2011 23:51

Quote:

Originally Posted by GlowHost.com (Post 2172382)
Thank you for helping to verify BlueRacer66.

You have a good point, I have seen a lot of bootleg versions of this floating around the web. Its possible someone stuffed adsense code in one of those unofficial versions. This mod should only be downloaded from vBulletin.org.

I agree with you. People are pretty ingenious nowadays when trying to make money.

Anyway, thank you for sharing this script with us. I hope you don't drop support for it as I have no plans to upgrade to vBulletin 4.0 (I am happy with vBulletin 3.8.7). :p

BirdOPrey5 11 Mar 2011 23:54

Quote:

Originally Posted by King Justice (Post 2172370)
No it's not. Don't even try that BS. I'm reporting this mod. This is BS. You're lucky I don't report you to AdSense.

I'd be curious if you and or the other guy can VIEW SOURCE of your page with the ad, and copy and paste here all the Google Adsense code present. I'd be curious to see if it's an ad from the same place.

I have again looked through this code, I am 100% sure this mod does not by itself add any type of ad to your forum. I am a little less sure however that StopForumSpam.com or AKISMET doesn't send some type of data to this mod that may contain an ad in it.

I really doubt this is the case but IF there was an ad being inserted it's from one of them, not this mod per say.

King Justice if you truly feel this mod should be reviewed you can use the "Report Post" image in the top post and report the mod, include your concerns. That will let the mods here know your concerns. Someone with more skills than I may take a look.

GlowHost.com 12 Mar 2011 00:17

Quote:

Originally Posted by Blueracer66 (Post 2172384)
Anyway, thank you for sharing this script with us. I hope you don't drop support for it as I have no plans to upgrade to vBulletin 4.0 (I am happy with vBulletin 3.8.7). :p

You are welcome :)

Well, this version isn't "officially" supported anymore but I definitely won't be pulling this site offline.

Quote:

Originally Posted by BirdOPrey5 (Post 2172385)
I have again looked through this code, I am 100% sure this mod does not by itself add any type of ad to your forum. I am a little less sure however that StopForumSpam.com or AKISMET doesn't send some type of data to this mod that may contain an ad in it.

Thanks to you as well BirdOPrey5 for taking time to analyze the source code.

I am pretty sure Akismet doesn't do this since that is part of wordpress and I can imagine the backlash that would have. I don't see how SFS would be able to stuff this in either. We would have a ton of complaints from the SOM 4.0 thread and I haven't heard anything over there.

Those guys would be better off taking the adwords ID from the source code and reporting it to adsense so whoever is doing that will have their account shut down.

FIM 14 Mar 2011 23:17

Great Mod :)

Joey805 16 Mar 2011 05:24

What would you charge me to fix the RSS bug for this mod in VB3? I use RSS alot but cannot at all with this mod. It moderates everything.

GlowHost.com 16 Mar 2011 05:32

Is that the only thing you want fixed? Do you want to let the public have access to it for download here or it will be only for you?

Tigerdude 17 Mar 2011 04:31

First, thank you for this. I pray that it works because I have a f-ing spam bot that has been killing me and my staff.

I'm getting an error when I select Delete post as spam. After going through the motions and selecting "ban user" I get

Fatal error: Using $this when not in object context in /home/myaccount/public_html/my_vbulletin_root_folder/includes/functions_vbghsfs.php on line 459

Any ideas?

Thanks again.

Joey805 18 Mar 2011 05:10

What else needs to be fixed? I dont care if the public has access to it or not honestly. I just want it to work. It's a bug which is killin me from being able to use this great mod.

:)

SebNL 22 Mar 2011 19:41

Hello !

Great mod, really. I installed it on vB 3.7.2 and it worked right away.

I have encountered a peculiar problem though.

Since I activated memcache, the plugin doesn't work anymore.

To activate memcache support, I simply uncommented these lines in vb's config.php :

Quote:

// It is also necessary to specify the hostname or IP address and the p$

$config['Datastore']['class'] = 'vB_Datastore_Memcached';
$i = 0;
// First Server
$i++;
$config['Misc']['memcacheserver'][$i] = '127.0.0.1';
$config['Misc']['memcacheport'][$i] = 11211;
$config['Misc']['memcachepersistent'][$i] = true;
$config['Misc']['memcacheweight'][$i] = 1;
$config['Misc']['memcachetimeout'][$i] = 1;
$config['Misc']['memcacheretry_interval'][$i] = 15;
And then, spammers again!

Looking at Spam-o-matic's control panel, I thought maybe to enter 127.0.0.1 and port 11211 as a proxy, but that didn't change anything.

Of course I understand this version is unsupported, but maybe it'll interest you. And I was intrigued by the fact that I couldn't find a trace of this problem by googling.

If anyone has a clue, all help is welcome. :o

souperman 22 Mar 2011 22:52

I have a problem with this mod. I'm running 3.8.6 and when I go to edit user details and scroll to the glowhost options, I can't ban the user. I click submit and the user is not banned. I'm wondering if it reports them to SFS.com too. Any ideas?

souperman 23 Mar 2011 00:12

I fixed it, you have to change the path of your modcp in the functions_ghsom.php file if it's different from the default.

souperman 01 Apr 2011 10:55

Here's some keywords to add to your filter list :)

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


420 03 Apr 2011 03:19

Which one do we use for VB 3.86, the most recent 1.2.8?
Quote:

GlowHost_-_Spam-O-Matic_v1.2.0_VB3-8.zip (15.6 KB, 224 downloads)
File Type: %1$s GlowHost_-_Spam-O-Matic_v1.2.4_VB3_VB4.zip (15.7 KB, 30 downloads)
File Type: %1$s GlowHost_-_Spam-O-Matic_v1.2.5_VB3_VB4.zip (15.5 KB, 29 downloads)
File Type: %1$s GlowHost_-_Spam-O-Matic_v1.2.8_VB3_VB4.zip (15.6 KB, 308 downloads)
File Type: %1$s changelog.txt (1.8 KB, 61 downloads)

GlowHost.com 03 Apr 2011 03:27

Yes, if it works. Then if it doesn't you can try earlier versions.

Vinyljunky 06 Apr 2011 10:03

I have instaled it How can I test it on my site?

thanks

VJ

Vinyljunky 11 Apr 2011 17:24

I now have it installed and hopefully working :up:

How do I access the logs?

Thanks

VJ

Milez 13 Apr 2011 10:39

This is a great mod and I am grateful for it's release. Was the only thing that saved my forum!

However just to help a bit with the user who reported the Adsense code, this is in fact being passed after you do an in-line ban. It looks as though it is being passed from stopforumspam on a successful submit of an IP. See below:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Try it yourself by submitting a spam post in-line and then hitting escape on the screen that appears next to stop the browser from redirecting.

SorentoUltimate 22 Apr 2011 16:27

I plan to install to my vBulletin 3.8.7 forum but i have some questions

Quote:

Originally Posted by Joey805 (Post 2162284)
Do you have a version 2.0 for VB3? I'm still running into the RSS issue with version 1.28

What are the problem with RSS becuse i also have a lot of RSS Feed to my foeum making Threads with news.

Quote:

Originally Posted by Milez (Post 2184139)
This is a great mod and I am grateful for it's release. Was the only thing that saved my forum!

However just to help a bit with the user who reported the Adsense code, this is in fact being passed after you do an in-line ban. It looks as though it is being passed from stopforumspam on a successful submit of an IP. See below:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Try it yourself by submitting a spam post in-line and then hitting escape on the screen that appears next to stop the browser from redirecting.

Any idea how to make not to take that AdSense Code ???

ikorolis 22 Apr 2011 23:55

i am using stopforumspam and happy to stop spam.

now i give you one change your mod.

ikorolis 24 Apr 2011 20:51

anyone find this ad code? where?

sorry coder your mod is good but i am force to unistalled and reason is BETA stage , install stopforumspam mod , dont like comments say ad sense code.


All times are GMT. The time now is 05:18.

Powered by vBulletin® Version 3.8.14
Copyright © 2021, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.