vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=328256

Yilmaz - Automatic Topic Tagger vB5
by yilmaz
01 Oct 2020 18:55

6 Attachment(s)
Automatic Topic Tagger (Compatible 5.6.x)

The first vBulletin 5 connect auto tagger, auto tagger will automatically generate the tags from the content title, It's also will work in the background to update the old content in your forum, And generate the tags for all of your old content, Don't worry you don't have to run any scripts to generate the old content tags it will do all of this for you in the background.

Video showing how the scheduled task works https://youtu.be/RN_d54uIElw


Multiple Selected tags delete feature

No issues left in version 1.1.4

========================================
How to install:
========================================
Upload the content of "Yilmaz - Automatic Topic Tagger vB5" to your root.
that's all it.
enjoy..
-----


========================================
How to uninstall:
========================================
1. Remove the package "yilmazautotagger" that located in /core/packages/
2. Go to "Manage Products" in the admincp and delete the product named "Yilmaz - Automatic Topic Tagger vB5"

How to update:
========================================
After uploading files
-Import XML file (as product) through AdminCP: Plugin System > Manage Products > [Add/Import Product]
OR import the XML file from your server

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Please Mark as Installed if you use this. :)
Donations always appreciated. :up:

Blackhorse 01 Nov 2020 04:57

What about other files such as cron, api, xml don't we upload?

yilmaz 01 Nov 2020 15:22

Quote:

Originally Posted by Blackhorse (Post 2604483)
What about other files such as cron, api, xml don't we upload?

When you upload the downloaded file to ftp, it will be installed automatically.

Scheduled task automatically generates missing topic tags.

Blackhorse 01 Nov 2020 17:04

Quote:

Originally Posted by yilmaz (Post 2604489)
When you upload the downloaded file to ftp, it will be installed automatically.

Scheduled task automatically generates missing topic tags.

Thank you yilmaz, where can i follow up to confirm it is working?

I don't see change right mow in cron jobs or in tagging pages.

migratoria 31 Jan 2021 19:21

I uploaded the files contained in the upload_to_root folder.
What should we do about the api cron and xml folders?

In the options what we have to put on:
"Content Type: Enter the Content Type to be tagged"

yilmaz 31 Jan 2021 19:53

Quote:

Originally Posted by migratoria (Post 2606035)
I uploaded the files contained in the upload_to_root folder.
What should we do about the api cron and xml folders?

In the options what we have to put on:
"Content Type: Enter the Content Type to be tagged"

Don't do anything.
Leave it to time, there will be no untagged topics

DamasGate 06 Feb 2021 12:35

Installed and working, It is good if an exception is made for numbers and words are less than three letters to be NOT taged.

Thank you very much,

milforum 06 Feb 2021 17:29

Unfortunately it doesn't work for me, and it's been running several days.

Every 10 minutes, when it is set to run, I receive an e-mail with unreadable content and the title: "Subject: Cron <[email protected]> /usr/local/bin/php /home/myuser/public_html/includes/vbcron.php"


I'm not sure if this is related, but my public_html/error_log is getting huge. 10-20 times every second it gets error messages like these:

[06-Feb-2021 18:23:03 Europe/Berlin] PHP Warning: include(/home/myuser/public_html/core/cache/template/template7387.php): failed to open stream: No such file or directory in /home/myuser/public_html/includes/vb5/template.php on line 405
[06-Feb-2021 18:23:03 Europe/Berlin] PHP Warning: include(): Failed opening '/home/myuser/public_html/core/cache/template/template7387.php' for inclusion (include_path='.:/opt/alt/php74/usr/share/pear') in /home/myuser/public_html/includes/vb5/template.php on line 405

milforum 08 Feb 2021 18:47

The last error was due to that I had the forum set to cache the templates as files rather than relying on the database. However, somehow one of the templates didn't write correctly to the file system so every time the software tried to call it, it couldn't find it. By turning off that option, that missing file isn't called.

This fixed another one of my problems with another product, but it seems that the automatic topic tagger still doesn't work. I assume it is not meant to give me an e-mail as mentioned in the previous post every 10 minutes?

milforum 09 Feb 2021 17:17

To elaborate: Every 10 minutes CRON gives me an e-mail with the following title and unreadable contents: /usr/local/bin/php /home/myuser/public_html/includes/vbcron.php . I'm assuming this is an error message.

The tagger has been running for several days without any visible results, and I'd really like to get all my threads tagged. Any idea what this could be?

yilmaz 09 Feb 2021 18:18

1 Attachment(s)
Quote:

Originally Posted by milforum (Post 2606155)
To elaborate: Every 10 minutes CRON gives me an e-mail with the following title and unreadable contents: /usr/local/bin/php /home/myuser/public_html/includes/vbcron.php . I'm assuming this is an error message.

The tagger has been running for several days without any visible results, and I'd really like to get all my threads tagged. Any idea what this could be?

Is there a similar error code in the incoming e-mail

https://www.vbulletin.org/forum/atta...1&d=1612894695

milforum 09 Feb 2021 19:46

I'm not sure. The e-mail client says, "There are no parts that can be shown inline." I can't find any contents in the e-mail, just the address fields and timestamp.

milforum 10 Feb 2021 17:49

It seems to be an e-mail that is sent every time a CRON job which provides output runs, so it might be OK. But how can I see what your product produces every time it runs? The tag list is still empty.

Events 11 Feb 2021 04:50

For me it worked once, then its not running anymore. When I looked into the scheduled tasks log there is nothing for the auto tagger.

milforum 11 Feb 2021 06:47

Yes, strange. It is scheduled to run every 10 minutes with logging, but the log is empty.


All times are GMT. The time now is 04:51.

Powered by vBulletin® Version 3.8.14
Copyright © 2021, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.