vBulletin Mods

The Official vBulletin Modifications Site

Migrate from vb4 to 5. Now have 'blank' screen
by jnrdavo
07 Jan 2021 05:32

Hey guys,
I've successfully migrated a site from vb4 to vb5 after a years consideration.

All went well, and it's been working fine all day. I've started to play around with the widgets (?)/blocks on the right hand side. All looks good.

I then went and changed a block/widget (from memory, all I selected was 'hide user icons', but now when I go to the site, I just get a blank page!

Anybody got any suggestions? I can go to the admin URL fine, and change settings etc, but not sure how to 'resolve/revert' back what I've done.

Any help REALLY appreciated.

Sorry, missed the site name: http://www.ozbmw.com

yilmaz 07 Jan 2021 05:48

Hello jnrdavo
Please try to deactivate it by file.


In order to do this,
Open your config.php file and add the following code directly below it in <?php

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

This is how it looks:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

If the same problem persists, I recommend trying the update again. There may have been a defect in the previous update.

jnrdavo 07 Jan 2021 20:24

thanks for the quick reply.

Same issue, I just get blank. It does go to correct URL though..

I'll try the upgrade again..

--------------- Added 07 Jan 2021 at 20:32 ---------------

Same issue unfortunately after upgrade.

Strange however, I can go to specific pages..



It's just the 'front page' that is stuffed. Any way to 'revert' that? I'm sure it's one of the 'blocks' on the right hand side that is causing it..

Can these be 'removed' via SQL (I have full access to the server and a 'bit' of experience in sql).

yilmaz 07 Jan 2021 21:36

1 Attachment(s)
It can be done through SQL.
Enter phpMyAdmine.
Browse the FROM widgetinstance table.

First, download a backup of the widgetinstanceid table to your computer as sql.

Click on widgetinstanceid and the most recently added widget comes first.
Remove the recently added widget from there.


jnrdavo 07 Jan 2021 22:22

1 Attachment(s)
Ok, I can see what I've done now. I've somehow created a 'search' widget... it would have not been able to load due to too much content..

So, once I remove all the widgets, the site works. So I then started one by one to remove them, and it started to work (I would have another browser open and CTRL-F5 to refresh).. BUT, what seems to be happening is that the widgetinstance table keeps on 'self growing'.... obvioulsly to do with me having the search widget... Now just need to work out which one it is !

yilmaz 07 Jan 2021 22:30

The search widget result limit is too high.

Enter the widget to edit, limit the result limit.
Example type 10

jnrdavo 07 Jan 2021 22:35

1 Attachment(s)
I would If I could get in to it :-)

All I've got is the ability to edit SQL at the moment. I can't work out which one to edit to 'remove' it..

If I remove all of them (or leave a few), it still seems to 'grow' the table..

yilmaz 07 Jan 2021 22:44

SearchTitle widgetinstanceid is the one with 7

jnrdavo 07 Jan 2021 22:54

Firstly, I really appreciate your help yilmaz (I've done a donate!).

I tried to delete 7, but I still can't see the home page. I'm confused as to which widgets to leave, and which ones to delete. I've tried to get it right, but then I end up with nothing on the screen, so stuffing it up completely (and I just do a restore and try again!)

--------------- Added 07 Jan 2021 at 23:03 ---------------

Ok, so I've got the site back and running.

I ran a search in widgetsinstance for "%searchJSON%" and removed those. Now I can actually see the site again!

I've still got a lot of entries in the table that I don't think I need/belong there.

You don't have any idea of what the defaults are do you?

yilmaz 07 Jan 2021 23:14

You make the settings from sitebuilder.
The widget is updated to the SQL table with the correct settings

jnrdavo 07 Jan 2021 23:28

no problem yiulmaz.

I'm going to build a brand new temp site and then check out the 'default' values in widgetinstanceid . That should fix it!

Again, thanks for your help.

All times are GMT. The time now is 13:32.

Powered by vBulletin® Version 3.8.14
Copyright © 2021, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.