vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=266142

cdoyle 12 Sep 2015 15:05

hi,
I've been looking through the thread, and not seeing an answer to this, but I could just be missing it.

So I created a new mailing list on m forum, and have it set to be default for registered users. But it seems to only be adding new users as they sign up. What do I need to do, for all the current members? How do I get them subscribed?

cdoyle 24 Sep 2015 17:51

Quote:

Originally Posted by cdoyle (Post 2554913)
hi,
I've been looking through the thread, and not seeing an answer to this, but I could just be missing it.

So I created a new mailing list on m forum, and have it set to be default for registered users. But it seems to only be adding new users as they sign up. What do I need to do, for all the current members? How do I get them subscribed?

anyone know the answer to this?

DragonByte Tech 24 Sep 2015 18:01

Did you set the default as you created the list, or did you edit it later? It won't work if you edit it later.


Fillip

cdoyle 24 Sep 2015 18:14

Where do you set the default as you create the list?
I only see that option after I've already hit save, and then go back into the list to edit.

cdoyle 27 Sep 2015 15:27

Quote:

Originally Posted by DragonByte Tech (Post 2555685)
Did you set the default as you created the list, or did you edit it later? It won't work if you edit it later.


Fillip

I tried creating a new list and I don't see anywhere to set the defaults. Not until after the list is already created?

Where do I set the default for which users I want subscribed at the time of creation of the list?

cdoyle 02 Oct 2015 20:16

I can't figure this out, how do I get all my existing members subscribed to the list?
I really want to send out a newsletter, but right now all of my older members won't get it.

DragonByte Tech 05 Oct 2015 17:26

vBMail v2.1.3 Patch Level 1

Bug Fixes:
  • Inactive reminders are no longer sent to users who have opted out of admin emails


Fillip

DragonByte Tech 05 Oct 2015 17:32

Quote:

Originally Posted by cdoyle (Post 2556128)
I can't figure this out, how do I get all my existing members subscribed to the list?
I really want to send out a newsletter, but right now all of my older members won't get it.

The first time you create a mailing list, all users on the default subscribe list will be subscribed, unless you are running the Pro version which has subscription confirmation. They will then need to click a link in their email to confirm their desire to subscribe.


Fillip

cdoyle 06 Oct 2015 17:53

Quote:

Originally Posted by DragonByte Tech (Post 2556337)
The first time you create a mailing list, all users on the default subscribe list will be subscribed, unless you are running the Pro version which has subscription confirmation. They will then need to click a link in their email to confirm their desire to subscribe.


Fillip

Should all those users appear when viewing the list?

I create a new list, set all registered users as the default group, but when I view the group it shows nobody. Then as new users join the forum, they will appear in the list.

How can I confirm that all previous members are subscribed?

cdoyle 13 Oct 2015 18:24

Quote:

Originally Posted by cdoyle (Post 2556452)
Should all those users appear when viewing the list?

I create a new list, set all registered users as the default group, but when I view the group it shows nobody. Then as new users join the forum, they will appear in the list.

How can I confirm that all previous members are subscribed?

Can anyone answer this?
I really want to use this mod, but if I can't confirm that it's going to all my registered users, then I'm going to have to uninstall.

DragonByte Tech 13 Oct 2015 18:31

If, when you create a new list and tick the "default subscribed" box for the select usergroups, they do not show up in the Subscribed Users list, then please PM me with an FTP and AdminCP account so I can look into this on-site.


Fillip

pjkcards 20 Oct 2015 11:39

Quote:

Originally Posted by DragonByte Tech (Post 2556956)
If, when you create a new list and tick the "default subscribed" box for the select usergroups, they do not show up in the Subscribed Users list, then please PM me with an FTP and AdminCP account so I can look into this on-site.

After clicking "Add New List", I don't see any box to check for "default subscribed". Where is this? This is all I see:
https://www.dropbox.com/s/ifduzu4x2o...41.59.png?dl=0
Edit: I found it. You setup the mailing list, then edit it, and check the box under the "default subscribed" column. Then you can see all the users are subscribed.

A question questions:
1) Where do you actually setup and send emails? I don't see any place to create an email.
2) hat is the point of the Manage Keywords section?

Thanks for your time.

super_dork 23 Oct 2015 21:12

Do you have information about the max number of subscribers who can be emailed? I have a mailing list of about 4000 users and I got a 500 error after it seemingly timed out. I was able to send test messages without issue.

cdoyle 26 Oct 2015 15:17

Does this mod work for everyone else?
I still can't seem to figure out how to get existing members subscribed to my send list. I was hoping to send out a newsletter soon, but I need it to go to all my members in hopes to draw them back to the site.

I've tried every option I see, I just want to know if this is happening to everyone or just me.

DragonByte Tech 09 Nov 2015 20:57

vBMail v2.1.3 Patch Level 2

Bug Fixes:
  • Fixed an issue where having multiple mailing lists could render the "Default Subscribed" functionality unusable


Fillip

DragonByte Tech 23 Nov 2015 21:05

vBMail v2.1.3 Patch Level 3

Bug Fixes:
  • In certain scenarios, the "Default Subscribed" flag would be disregarded when saving the permissions


Fillip

cdoyle 02 Dec 2015 11:49

Question on HTML emails.

1. Are you supposed to paste the HTML directly into the editor? The reason I ask is, if I do this, email clients appear to display the emails for the most part OK. But if a user goes to the forum and clicks on the archive, all they see is HTML.

2. somewhere in this thread, I saw that you are supposed to put the doctype within the <body> is that correct?

SC3 17 Dec 2015 09:46

This might be a really stupid question, but how can I send mail using this?

SC3 17 Dec 2015 09:55

Ah, I found it. /vbmail.php

Skaut 17 Dec 2015 11:27

Quote:

Originally Posted by DragonByte Tech (Post 2559237)
vBMail v2.1.3 Patch Level 3

Bug Fixes:
  • In certain scenarios, the "Default Subscribed" flag would be disregarded when saving the permissions


Fillip

Can you please explain why is this in Addons sections of your OP: Poor Man's Bounced Email Handler

Is it really necessary, I had a feeling your solution was complete. What is it missing that you advise people to install that 2nd mod as well? Please let me know because I am considering buying your PRO version to support your development.

DragonByte Tech 18 Dec 2015 21:57

vBMail v2.1.3 Patch Level 4

Bug Fixes:
  • Sending a HTML email via WYSIWYG would not display the email correctly in the mail history


Fillip

DragonByte Tech 18 Dec 2015 21:58

Quote:

Originally Posted by Skaut (Post 2560661)
Can you please explain why is this in Addons sections of your OP: Poor Man's Bounced Email Handler

Is it really necessary, I had a feeling your solution was complete. What is it missing that you advise people to install that 2nd mod as well? Please let me know because I am considering buying your PRO version to support your development.

Sorry, I don't know where you get the "Poor Man's Bounced Email Handler" from?

This product will check for bounced email from users and remove email features from their account, as well as preventing the mails you send via vBMail from being delivered to users who have reached the bounced mail threshold.


Fillip

kevius 25 Dec 2015 14:00

Hello

Fine mod but... it's not possible to send a picture into the message ?

Merry Xmas, Fred

Scimia 22 Jan 2016 18:18

I've installed this plugin but every page of the plugin gives me this error:

Invalid action. Go back.

How to fix this?

DragonByte Tech 22 Jan 2016 18:21

Quote:

Originally Posted by kevius (Post 2561156)
Hello

Fine mod but... it's not possible to send a picture into the message ?

Merry Xmas, Fred

Hi Fred,

I believe using the IMG BBCode will work :)

There's no attachment support at this time, though.

Quote:

Originally Posted by Scimia (Post 2563205)
I've installed this plugin but every page of the plugin gives me this error:

Invalid action. Go back.

How to fix this?

Hi there,

This is most commonly caused by an incorrect upload. Could you please double-check that you have dragged and dropped the contents of the "upload" folder to your forum's folder?


Fillip

BadgerDog 26 Feb 2016 12:41

I apologize to the vBulletin staff, but I'm at a loss what to do to get some support for their paid product.

What a poorly designed customer support system on their main site... I've tried to post this four times there under their "open ticket" function and it still wouldn't appear anywhere. I even tried a PM to Belazor and it wouldn't accept that... and yes, I was logged in, as would be obvious since it let me download updates to my paid products. It just keeps going back to their home page.

=======================================================

I simply was trying to upgrade (since I have a lifetime license which I believe is the PRO version since thatís the paid version) from 1.20 installed to vBMail v2.1.3pl4.

I uploaded the new files as recommended..

I made the modification to class_mail.php as recommended..

==================
3. Open ./includes/class_mail.php and find:
$this->smtpSocket = fsockopen(($this->secure == 'ssl' ? 'ssl://' : 'tcp://') . $this->smtpHost, $this->smtpPort, $errno, $errstr, 30);

Add above:
static $hook_code = false;
if ($hook_code === false)
{
$hook_code = vBulletinHook::fetch_hook('dbtech_vbmail_smtp_exec_send');
}
if ($hook_code)
{
eval($hook_code);
}
=====================

This is all I did .. I never got as far as importing the product XMLÖ

Immediately started getting this error which crashed the whole site and I couldn't even get into AdminCP any longer.

tech_vbmail_mailinglist', ); ?>xtracache); } } ?>
Parse error: syntax error, unexpected '}' in /usr/www/apache/htdocs/milsurps/dbtech/vbmail/hooks/global_start.php on line 65


I contacted my Unix support person, since I'm a neophyte with coding. He modified a vBulletin config file so he could get back into our AdminCP and he disabled vBmail plugin which is still showing v1.20 of vB. I then restored all if the old vBMail 1.20 upload files, but I'm afraid to re-enable this thing at all now. My Unix tech recommended I don't do anything else, as he said it might crash the site again.

What I donít understand is that when I went to do the change in class_mail.php, which appears as an instruction for both v.120 and v2.1.3pl4. my class_mail.php version that existed under v1.20, DID NOT already have that change?

Yet, I was running 1.20 fine and sending newletters to our various advisory groups?

Regardless, I added the suggested code to my native class_mail.php under vBulletin 4.13PL8, so I could do your vBmail v2.1.3pl4 upgrade and that's when our site blew up. It was almost immediately when I made that change, so Iím not sure what that means?

So, I have no idea why 1.20 was working if that change was never made and now I can't use either version of our paid product.

Regardless, I do need to get either the old version or new version running again for our members, so what would you recommend I do?

Thanks for your helpÖ

Regards,
Doug

DragonByte Tech 26 Feb 2016 13:40

Quote:

Originally Posted by BadgerDog (Post 2565635)
What a poorly designed customer support system on their main site... I've tried to post this four times there under their "open ticket" function and it still wouldn't appear anywhere. I even tried a PM to Belazor and it wouldn't accept that... and yes, I was logged in, as would be obvious since it let me download updates to my paid products. It just keeps going back to their home page.

Hi there,

I'm sorry for the difficulties you're having with our support ticket system. I have investigated our server logs, and the contents of your message was triggering a ModSecurity rule designed to prevent PHP Injection exploits. To read more about ModSecurity, if you're unfamiliar, you can click this link: https://www.modsecurity.org/

I have now disabled the offending rule, so you should experience no further problems posting support tickets @ our site :)

Quote:

Originally Posted by BadgerDog (Post 2565635)
tech_vbmail_mailinglist', ); ?>xtracache); } } ?>
Parse error: syntax error, unexpected '}' in /usr/www/apache/htdocs/milsurps/dbtech/vbmail/hooks/global_start.php on line 65

This looks like a corrupted / interrupted upload of the global_start file.

If you PM me with an FTP and AdminCP account over @ www.dragonbyte-tech.com (not here @ vB.org), I'll upgrade the mod for you :)


Fillip

BadgerDog 26 Feb 2016 14:05

Quote:

Originally Posted by DragonByte Tech (Post 2565639)
Hi there,

I'm sorry for the difficulties you're having with our support ticket system. I have investigated our server logs, and the contents of your message was triggering a ModSecurity rule designed to prevent PHP Injection exploits. To read more about ModSecurity, if you're unfamiliar, you can click this link: https://www.modsecurity.org/

An error message other than just returning to the home page would have been informative, saving all of us a lot of time .. ;)

I will PM you on your site the information ...

Thanks again to Vbulletin.org staff for permitting my post here .. :up:

Regards,
Doug

DragonByte Tech 26 Feb 2016 14:14

Quote:

Originally Posted by BadgerDog (Post 2565641)
An error message other than just returning to the home page would have been informative, saving all of us a lot of time .. ;)

Unfortunately I don't believe I can control this, as we run cPanel/WHM and I can't find a location to change this.


Fillip

Alan_SP 26 Feb 2016 15:06

Quote:

Originally Posted by BadgerDog (Post 2565641)
An error message other than just returning to the home page would have been informative, saving all of us a lot of time .. ;)

Mod security isn't designed this way. :( It purposely obfuscates failures, leaving impression that everything worked fine from hackers side.

You can't just like that change the way it works. And it really has strange set of rules by default. You need to work really hard on all rules to get it working without problems on site like DBTech's (they had need for many things in posts, like php code, html code, paths to directories (linux or more rarely windows)).

All in all, mod security is more of a hindrance than security. Of course, someone who took really long time maybe can found set of rules that would give additional security without blocking genuine people posting their problems.

But... this is not the place for detailed discussion about mod security.

DragonByte Tech 26 Feb 2016 16:55

Quote:

Originally Posted by Alan_SP (Post 2565646)
You can't just like that change the way it works. And it really has strange set of rules by default. You need to work really hard on all rules to get it working without problems on site like DBTech's (they had need for many things in posts, like php code, html code, paths to directories (linux or more rarely windows)).

All in all, mod security is more of a hindrance than security. Of course, someone who took really long time maybe can found set of rules that would give additional security without blocking genuine people posting their problems.

You are so right. I lost count of how many hours I sat staring at the live ModSec log view when we recently switched servers and installed the new version of cPanel that had built-in ModSec support instead of it being something the host controlled via their Managed Hosting option.

That was like 5-6 months ago.

I'd say our rule set is pretty stable right now though, the message Doug tried to post was quite specific and I can't say I blame them for thinking it was suspicious (sorry Doug! It's that trench coat and the blackened sunglasses, you do look a bit shifty... ;) ).

That being said, by default ModSec appears to come with rules that are only suitable for sites that offer absolutely no user input whatsoever, which is rare these days.


Fillip

BadgerDog 26 Feb 2016 17:16

Well, we could spend a lot of time here talking about security, but I'd prefer some help getting my site live again with the paid version of vBmail. :D

As requested, I left the information I think you require as a PM on your site and I've been standing by, so let me know what else you need. Thanks .. ;)

Tangential to vBmail crashing our site on upgrade, I also thought that while waiting, I'd do some cleanup of other mods not being used. One of those is free version of Dragonbyte Gallery, which when I clicked UN-install also crashed with an error, interestingly enough, pointing to vBmail., which is why I'm raising it here in this thread.

I simply wanted to un-install Dragonbyte Gallery, so I selected the un-install option under plugins...


Quote:

• Deleted CMS Widget: Dragonbyte Gallery
• Reverted Table: user
• Reverted Table: usergroup
• Deleted Table: dbtech_gallery_albums
• Deleted Table: dbtech_gallery_categories
• Deleted Table: dbtech_gallery_cat_subscribers
• Deleted Table: dbtech_gallery_comments
• Deleted Table: dbtech_gallery_cust_fields
• Deleted Table: dbtech_gallery_favorites
• Deleted Table: dbtech_gallery_images
• Deleted Table: dbtech_gallery_instances
• Deleted Table: dbtech_gallery_modules
• Deleted Table: dbtech_gallery_rating
• Deleted Table: dbtech_gallery_user_subscribers
• Deleted Table: dbtech_gallery_views
Rebuild Style Information
Updating style information for each style

<snip for privacy> all template un-install updates went fine and said DONE at the end

Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING in /usr/www/xxxx/xxxx/xxxx/includes/block/dbtech_vbmail_form.php on line 124
I have no idea why these two products would be co-dependent (cross marketing?), but I've also left you a PM to get some help fixing that which went wrong during a simple clicking of Dragonbyte Gallery un-install button.

Regards,
Doug

DragonByte Tech 27 Feb 2016 17:07

The vBMail upgrade went fine, I suspect that also takes care of the block issue since that was most likely caused by the same corrupted upload :)


Fillip

Wir3tap 13 Mar 2016 10:22

On Vbulletin 4.2.3 got this on importing of XML:
XML Error: Processing Instruction not finished at Line 205

DragonByte Tech 13 Mar 2016 15:12

Quote:

Originally Posted by Wir3tap (Post 2567106)
On Vbulletin 4.2.3 got this on importing of XML:
XML Error: Processing Instruction not finished at Line 205

Hi there,

What version of PHP are you running?


Fillip

Anders64 26 Apr 2016 16:02

Im getting this erro upon first install, what am i doing wrong?

/home/ddcdcdc/www/forums/dbtech/vbmail/includes/class_install.php appears to be missing!

DragonByte Tech 26 Apr 2016 16:03

Quote:

Originally Posted by Anders64 (Post 2569639)
Im getting this erro upon first install, what am i doing wrong?

/home/ddcdcdc/www/forums/dbtech/vbmail/includes/class_install.php appears to be missing!

Upload the contents of the upload folder to your forums folder, not the upload folder itself.


Fillip

keyla31 03 Jun 2016 00:23

Does this deal with bounces from the other emailing systems in vbulletin? I have a newsletter that gors out that gets a lot of bounces, will it deactivate those that bounces as well?

keyla31 03 Jun 2016 00:24

I have 50000 users is there any fast way to add them all to the email list?

DragonByte Tech 03 Jun 2016 00:45

Quote:

Originally Posted by keyla31 (Post 2571569)
Does this deal with bounces from the other emailing systems in vbulletin? I have a newsletter that gors out that gets a lot of bounces, will it deactivate those that bounces as well?

It won't unsubscribe from other email systems, sorry :(

Quote:

Originally Posted by keyla31 (Post 2571570)
I have 50000 users is there any fast way to add them all to the email list?

You can use the Default Subscribed flag :)


Fillip

anihil2 29 Oct 2016 11:33

Hello, I found one issue with vBMail. When user click on unsubscribe link in email he/she will get feedback pool before getting unscubscribe. Lets assume that at this time noone else did unsubscribe. After user unsubscribed in View Mail History admin should see for this specific mail only one person in 'Unsubscribed Users' column. That is correct if user used unsubscribe link only once. But if user go to this unsubscribe link without even setting feedback option it will automatically increment this 'Unsubscribed Users' counter. In my example below I have one user test which press link unsubscribe several times and I get:
https://www.vbulletin.org/forum/external/2016/10/3.jpg

Could it be fixed to count only users that actually unsubscribed from mailing list and not how many time they clikc on unsubscribe link?

anihil2 29 Oct 2016 12:22

Quote:

Originally Posted by anihil2 (Post 2577431)
Hello, I found one issue with vBMail. When user click on unsubscribe link in email he/she will get feedback pool before getting unscubscribe. Lets assume that at this time noone else did unsubscribe. After user unsubscribed in View Mail History admin should see for this specific mail only one person in 'Unsubscribed Users' column. That is correct if user used unsubscribe link only once. But if user go to this unsubscribe link without even setting feedback option it will automatically increment this 'Unsubscribed Users' counter. In my example below I have one user test which press link unsubscribe several times and I get:
https://www.vbulletin.org/forum/external/2016/10/3.jpg

Could it be fixed to count only users that actually unsubscribed from mailing list and not how many time they clikc on unsubscribe link?

Didn't have time to wait for fix :) so I fix it myself. Fix description below.

In file dbtech\vbmail\actions\mailinglists.php from lines 1053-1069 move code:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Before line 1043 which is:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

After change it code should look like this:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

What this change will give you?
When user hit link with unsubscribe it will increment counter "Unsubscribed Users" only when user flag in database change from Subscribed to Unsubscribed. If user try to hit unsubscribe link again it will not increment this counter anymore.

I hope this will help someone.

anihil2 29 Oct 2016 15:59

Sorry with spamming with messages.

I installed this addon on vB version 4.2.3 Patch Level 2 without any issues.
I tried the same installation files on vB version 4.2.3 and it did install without any issues. But after I try to go to vbmail.php I get message:
"The vBMail product has been deactivated by an administrator."

Anyone know what might be wrong?

DragonByte Tech 04 Nov 2016 20:31

Quote:

Originally Posted by anihil2 (Post 2577444)
Sorry with spamming with messages.

I installed this addon on vB version 4.2.3 Patch Level 2 without any issues.
I tried the same installation files on vB version 4.2.3 and it did install without any issues. But after I try to go to vbmail.php I get message:
"The vBMail product has been deactivated by an administrator."

Anyone know what might be wrong?

This means the product has been disabled in the Product Manager in vBulletin.


Fillip

tuRiver 05 Jan 2017 00:08

Does this mod add the ability to send weekly digest (with hot/top threads) etc.. ?

ivanp 18 Jun 2017 12:25

vBulletin 4.2.5 reports "PHP Fatal error: Call to undefined method vB_DataManager::vB_DataManager()"

The following files should be changed:

dbtech/vbmail/includes/class_dm_keyword.php
dbtech/vbmail/includes/class_dm_feedback.php
dbtech/vbmail/includes/class_dm_message.php
dbtech/vbmail/includes/class_dm_mailinglist.php

FROM:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

TO:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


DragonByte Tech 18 Jun 2017 12:26

This has been resolved in the latest version @ our site, vB.org hasn't been updated yet.


Fillip


All times are GMT. The time now is 00:35.

Powered by vBulletin® Version 3.8.14
Copyright © 2021, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.