vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=324885

BadgerDog 07 Apr 2017 10:51

1 Attachment(s)
Follow up... :)

I was able to delete videos you added when you were testing without a problem...

The delete problem and crashing error happens with that very first video that DOES NOT have a thumbnail associated with it and says "Preview Not Available"

Also note (see attached pic) that there's only two videos in my Video Club, but it's showing three thumbnail pics, two of which are associated with just one video, the one that won't delete?

Hope this helps you track down the bug...

Regards,
Doug

paradoxG(r)eek 07 Apr 2017 10:58

2 Attachment(s)
Quote:

Originally Posted by BadgerDog (Post 2584945)
Follow up... :)

I was able to delete videos you added when you were testing without a problem...

There is missing a vb library file there so upload the attached files for sure.

Quote:

Originally Posted by BadgerDog (Post 2584945)
The delete problem and crashing error happens with that very first video that DOES NOT have a thumbnail associated with it and says "Preview Not Available"

I don't think that this is the case, but I also did some changes at that place.

Quote:

Originally Posted by BadgerDog (Post 2584945)
Also note (see attached pic) that there's only two videos in my Video Club, but it's showing three thumbnail pics, two of which are associated with just one video, the one that won't delete?

That's the problem with the Free sliders :) .... It's a bug of the slider when the amount of slides are less than 4. If they're more than 4 then everything is ok. I'll give a look to find a better one.

Quote:

Originally Posted by BadgerDog (Post 2584945)
Hope this helps you track down the bug...

Regards,
Doug

Thank you

ver. 1.0.3 available for download
by paradoxG(r)eek
07 Apr 2017 11:06

There was a bug if you tried to delete a video with thread commenting system. Please download ver. 1.0.3 and upload video.php and video_usercp.php

Also if you deleted any video with "No Preview Available" you must upload again the file:
videoclub/thumbs/nopreview.png

Sorry for troubles
Chris

BadgerDog 07 Apr 2017 11:18

Quote:

Originally Posted by paradoxG(r)eek (Post 2584947)
There was a bug if you tried to delete a video with thread commenting system. Please download ver. 1.0.3 and upload video.php and video_usercp.php

Also if you deleted any video with "No Preview Available" you must upload again the file:
videoclub/thumbs/nopreview.png

Sorry for troubles
Chris

Chris..

Which versions of upload video.php and video_usercp.php do you want me to upload?

The ones in the 1.0.3 or the ones in the post you left for me?

paradoxG(r)eek 07 Apr 2017 11:21

Quote:

Originally Posted by BadgerDog (Post 2584948)
Chris..

Which versions of upload video.php and video_usercp.php do you want me to upload?

The ones in the 1.0.3 or the ones in the post you left for me?

They are same. I post them first here and then I zipped the files for release.

BadgerDog 07 Apr 2017 11:28

1 Attachment(s)
Quote:

Originally Posted by paradoxG(r)eek (Post 2584947)
Also if you deleted any video with "No Preview Available" you must upload again the file:
videoclub/thumbs/nopreview.png

Sorry for troubles
Chris

No problem.. I don't mind helping you test this, as I think our members will really enjoy it once we go live.. :)

Ok, I checked and the file you refer to is (and always was) thee, so I don't think that's causing the massive error dump? (see attached)

Regards,
Doug

BadgerDog 07 Apr 2017 11:29

Quote:

Originally Posted by paradoxG(r)eek (Post 2584950)
They are same. I post them first here and then I zipped the files for release.

Understood.. thanks .. :)

BadgerDog 07 Apr 2017 11:32

Quote:

Originally Posted by BadgerDog (Post 2584952)
Understood.. thanks .. :)

Chris... should I upload ALL the files in 1.0.3, or just the two you indicate?

BadgerDog 07 Apr 2017 11:37

Just uploading the two replacement video.php and video_usercp.php from 1.0.3 and trying to delete that "No Preview Available" video still dumps this massive error..

Quote:

Fatal error: Existing data passed is not an array
Called set_existing in [path]/video.php on line 1105
in [path]/includes/class_dm.php on line 265
#0 vb_error_handler(256, Existing data passed is not an array
Called set_existing in /var/www/html/mywebsite/video.php on line 1105
, /var/www/html/mywebsite/includes/class_dm.php, 265, Array ([existing] => ,[line] =>
Called set_existing in /var/www/html/mywebsite/video.php on line 1105

paradoxG(r)eek 07 Apr 2017 11:49

Quote:

Originally Posted by BadgerDog (Post 2584954)
Just uploading the two replacement video.php and video_usercp.php from 1.0.3 and trying to delete that "No Preview Available" video still dumps this massive error..

The easy fix is to delete it from phpMyAdmin or to wait some hours. The problem is that when you post that video, something halted the procedure and it created a thread for it (maybe you had thread commenting enabled at that time).

Now is trying to delete the thread but somewhere messed. I'll also give a look if there is different code in 4.1.x for deleting threads than in 4.2.x. Because for me it works.

BadgerDog 07 Apr 2017 12:06

Quote:

Originally Posted by paradoxG(r)eek (Post 2584955)
The easy fix is to delete it from phpMyAdmin or to wait some hours. The problem is that when you post that video, something halted the procedure and it created a thread for it (maybe you had thread commenting enabled at that time).

Now is trying to delete the thread but somewhere messed. I'll also give a look if there is different code in 4.1.x for deleting threads than in 4.2.x. Because for me it works.

Yes, the option of comment to a thread was originally enabled by program default (shouldn't be) before I understood what it was going to do.

Once I discovered it created a thread in my HOME forum (where there's no permission to do so), I permanently deleted that with vBulletin's moderator permanent delete function as I didn't want members to be seeing it, which went fine with no errors.

I hope this hasn't corrupted my SQL database because I don't know have phpMyAdmin and I wouldn't know how to use it anyway ... how do I fix this now?

You said: "or to wait some hours." ... it's already been 24 hours so I'm not sure what I'm waiting for?

Regards,
Doug

BadgerDog 07 Apr 2017 12:11

Chris...

At this point, should I uninstall the whole mod and then re-install 1.0.3?

Will that fix this issue and not corrupt my SQL database?

Regards,
Doug

lillylissy 07 Apr 2017 12:36

In my site there is still another problem.

In "video_usercp" the first page is correctly displayed.
-> /video_usercp.php?do=myvideos

The following pages remain empty.
-> /video_usercp.php?do=myvideo&page=2
-> /video_usercp.php?do=myvideo&page=3

Perhaps a SEO problem?

paradoxG(r)eek 07 Apr 2017 14:48

Quote:

Originally Posted by BadgerDog (Post 2584956)
You said: "or to wait some hours." ... it's already been 24 hours so I'm not sure what I'm waiting for?

Regards,
Doug

Already been 24 hours???:confused: It's just a couple of hours since that post.

In anycase. If you deleted the thread on your own (and not letting the script delete it automatically) this is the error. Never do it with automatic created threads from any mod because you never know what other actions maybe let behind unfinished.

Yes, is better to uninstall and start from scratch. If you find any issue PM phpMyAdmin details to give a look.

paradoxG(r)eek 07 Apr 2017 14:52

1 Attachment(s)
Quote:

Originally Posted by lillylissy (Post 2584960)
In my site there is still another problem.

In "video_usercp" the first page is correctly displayed.
-> /video_usercp.php?do=myvideos

The following pages remain empty.
-> /video_usercp.php?do=myvideo&page=2
-> /video_usercp.php?do=myvideo&page=3

Perhaps a SEO problem?

Not a SEO problem but rather eyes without coffee:rolleyes: Its myvideo& instead myvideos&

Please upload the attached file.


All times are GMT. The time now is 08:40.

Powered by vBulletin® Version 3.8.14
Copyright © 2021, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.