vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=201283

Cyb - ChatBox
by Valter
10 Jan 2009 15:28

8 Attachment(s)
Info:
Powerful AJAX-based ChatBox for vBulletin.


Main Features:
-One step installation (no file uploads, no manual template modifications required)
-Put ChatBox on any forum page by setting script name and adding variable to desired template
-"ChatBox Full" (always available on separate page)
-"Messages Archive" (available on separate page, with options to edit/delete messages)
-"ChatBox Search"
-Option to block usergroups from viewing ChatBox
-Option to delete messages older than x hours automatically
-"ChatBox Statistics" (new messages since last visit, messages in last x hours, total messages, top x chatters,...)
-View users active in ChatBox (available in CBFull and Archive)
-Text formatting options (color, weight, style, decoration,...)
-Advanced Smiliebox
-Smiliebox options: total smilies available, smilies per row, smilie clipping, disable smilies...
-A lot of customizable stuff, including: set new/old status icons, time/date format, box height, message order, auto-refresh intervals,...
-One-click actions: View all messages posted by user X, Delete all messages posted by user x, Ban/unban user from ChatBox, View last message posted by user X, View your last message, View first unread message
-"/me" action (used when you want to refer to yourself in the "third person")
...and more...

See screenshots for more details.


Installation:
1. Import XML file (as product): AdminCP > Plugin System > Manage Products > [Add/Import Product]
2. OPTIONAL (custom placement on forum page)
Open desired template and put "$cybchatbox" to desired line.


To set options:
Go to: AdminCP > vBulletin Options > Cyb - ChatBox


To have ChatBox enabled on desired page:
1. THIS_SCRIPT must be defined in php file (by default all important vBulletin files has this)
2. Hack options - You must add THIS_SCRIPT value for target page to "Show ChatBox on" setting field
3. Main template called on target page must contain "$cybchatbox" variable

To have ChatBox enabled on vBa CMPS:
1. Hack options - Add "adv_index" to "Show ChatBox on" setting field (values in this field should be separated by commas) > Save
2. vBa CMPS Default Settings - add "cybchatbox" to "Portal Output Global Variables" field (values in this field should be separated by carriage return) > Save
3. [Optional] Template "adv_portal" - add "$cybchatbox" to line where you want ChatBox to appear (for example below "$navbar") > Save


Versions:
v1.0 - Sep 15. 2007.
-First version
v1.1-v1.6 - Sep/Oct 2007.
-Bug fixes, improvements, several new options added,...
v1.7 - Oct 07. 2007.
-Released at vB.org
v1.8 - Oct 11. 2007.
-Fixed bug where moderators can not delete messages
-New: Set auto-refresh interval for messages
-New: Set auto-refresh interval for active users
-New: Option to enable auto-refresh for guests
-New: Option to reverse message order (newest at bottom)
v1.8.1 - Oct 11. 2007.
-Fixed bug where colspan in Archive is not set correctly for moderators
-Added ability to disable date in mesages (simply leave date field blank)
-Added option to have ChatBox always collapsed by default (ChatBox Full not affected)
v1.8.2 - Oct 12. 2007.
-Fixed bug (reversed message order gives wrong results)
-New: Set timecut in minutes for active users listing
-New: Automatically parse links in messages (can be disabled)
v1.8.3 - Oct 13. 2007.
-Auto-prune setting field restored
-Fixed bug where some users are logged-out after posting message
-Improved detection and listing of active users
-If user is active in ChatBox it will be shown in profile and wol list
v1.9 - Oct 15. 2007.
-New: Not all smilies are loaded on startup. Set how many of them you want to show before user clicks "More".
-New: "/me" user action ("/me" in submitted message will be replaced by author's username, and message appears in color you set)
-Minor bug fixes
v1.9.1 - Oct 15. 2007.
-Fixed bug from previous version where message area height not follows your settings properly
v1.9.2 - Nov 06. 2007.
-New option in user menu: View messages posted by user
-Option to allow users to delete their own messages
-Fixed bug where admin with primary usergroup different than 6 is not able to delete all messages
-Fixed bug where links to member profiles in messages are broken at "/member.php"
-"Delete Selected" moved to phrases
v1.9.3 - Nov 20. 2007.
-New: Set groups able to view Chatbox but not post messages
-New: Set groups able to edit/delete all messages, and ban/unban users from ChatBox
-New: Customize color list in message posting interface
-New: Ban list
-Fixed default text color
-Fixed some compatibility issues for "/me" action
-Fixed bug where some users get db error when importing product
-Fixed bug where you need to refresh page after "Busy" message to continue chatting
-Minor bug fixes
v1.9.4 - Nov 21. 2007.
-Fixed bug with changing colors in IE
-Some code optimization done
v1.9.5 - Nov 26. 2007.
-Fixed bugs with stripping html tags and "/me" action
v1.9.6 - Nov 29. 2007.
-New: ChatBox Search
-New: Click on message icon in main box to open message for editing/deletion
-Fixed bug with page navigation
-Minor bug fixes/code improvements
v1.9.7 - Dec 01. 2007.
-New: Find first unread message
-New: Find your last message
-New: Find last message by user X
v1.9.8 - Dec 05. 2007.
-New: Ban certain BB tags from being used in the ChatBox
-New feature in user messages view: "Locate this message in Archive"
-New: Message icons in Main box now opens Archive where requested message is highlighted
-New in "Top Chatters": Click on number to view chatter messages
-New in "My Messages": Click on number to view your own messages
-Fixed bug where space after username is lost in "/me" action message
v1.9.9 - Dec 06. 2007.
-New: Users with post count less than X can not view ChatBox
-New: Log/view/resolve IP addresses in CB messages
-Fixed bug with searching last message by user X
v2.0 - Apr 30. 2008.
-New: "Locate message in Archive" option in search results
-CSRF protection added
-Compatible with vBulletin 3.7 Gold (may not work with Beta/RC releases)
v2.1 - Jun 24. 2008.
-Fixed bug (users always shown using their primary group display parameters)
-Fixed bug (if there are whitespaces in banned tags setting it will not work properly)
-You can now choose which usergroups are able to moderate ChatBox (not just switch between 5/6/7)
-"Below Forums" added to auto-insert locations (ForumHome only)
-New: Option to disable parsing of manually entered smilie codes
-New: Disable message time in ChatBox (Archive not affected)
-New: Submit button added
-New: Option to change text size (display)
-New: Option to set width of [code], [php] and [html] BB code blocks in ChatBox
-New: Limit message lenght
-Several minor bug fixes/code improvements
v2.2 - Jul 10. 2008.
-New: auto-hiding Status bar to inform you about ChatBox activities
-Improved ChatBox performance
-Improved char counter compatibility/look
v2.3 - Sep 22. 2008.
-Fixed XSS vulnerability in ChatBox Search
-Improved Tags Banning feature
-Fixed bug (user can add forbidden tags by editing already posted message)
-Fixed bug (user blocked by low post count can access ChatBox on separate page if url is known)
-Fixed bug (page shifting on refresh in IE)
-Fixed bug (Smilies menu breaks row on expand in Opera)
-Minor bug fixes


MARK AS INSTALLED to get support and updates.

Kitmitsu 10 Jan 2009 15:32

Thanks once again Cyb.

veenuisthebest 10 Jan 2009 15:41

I hope this one has no changes than this one, as both are 2.3
http://www.vbulletin.org/forum/showthread.php?t=177552

thanks

-=Leb=- 10 Jan 2009 16:04

Finally :)

SuperTaz 10 Jan 2009 16:20

Thank you.

Saviour 10 Jan 2009 17:49

Cyb...

Two things:

1. How to rename the navbar link from "ChatBox Full" to simply "Chat"
2. How to put the navbar link in the new "Community" link of the navbar

Update...

Sorry, but I found out how to do this on my own. Directions are listed below for those interested:

1. Login to your Admin CP/Languages & Phrases/Phrase Manger. Locate the following phrase: cybcb_chatbox_full and edit it to your preference.

2. First of all, do not check the setting in this mod to add a link in the navbar. Instead, edit the navbar template in each style:

Locate:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Add above:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

That's all there is to it.

Saviour 11 Jan 2009 00:53

Cyb...

Text colors aren't working...

Update...

Nevermind.

Navigation...
by Saviour
11 Jan 2009 01:19

2 Attachment(s)
Cyb...

First of all, let me apologize for all these posts, back to back.

Please take a look at the following attachments. As you can see, when the ChatBox page loads, it doesn't show the navigation tree correctly...as compared to the memberlist navigation tree (image attached, as well).

Is there a fix for this?

James Argo 12 Jan 2009 00:11

I haven't had any chance to update my live forum in production server to 3.8.0, but I did in my testing server. This mod is the first mod to install and it worked as nice as in 3.7 family before.

Soon my production server will update to 3.8.0, and this mod will definitely be installed there!

Thumbs up Cyb! :cool:

* James Argo clicked install *

Nadavy 12 Jan 2009 04:41

When we do this are all former chatbox posts lost?

Valter 12 Jan 2009 04:58

ChatBox messages are lost if you:
- uninstall hack
- click "Delete All Messages" in ChatBox menu

So if you do regular upgrade with 'overwrite' checked, then messages will not be lost.

christicehurst 12 Jan 2009 10:43

The mod stays on Loading the whole time.

Saviour 12 Jan 2009 12:18

2 Attachment(s)
Cyb...

Since you were on and didn't reply to this post: http://www.vbulletin.org/forum/showp...22&postcount=8

I'll have to bump the question...

If a user navigates to the ChatBox, the Navigation tree doesn't display correctly. It only shows the [bbtitle]...in my case "Glitch PC Forums". It should show "Glitch PC Forums > ChatBox". Take a look at the images I attached in the post I've referred to so that you get a better understanding of what I'm referring to.

However, if a user navigates to the ChatBox archive page, then the navigation tree does appear correctly. Although it shows "Coder" under my rank here...I'm not that great of a coder. The closest I can figure...is that there's a problem with the XML file coding. When a user navigates to the ChatBox page...it should show this in the navigation tree, but it doesn't. Like I said...it does show correctly if I navigate to the "ChatBox Archive" page...however, on that page it shows "Glitch PC Forums > ChatBox". Shouldn't it read "Glitch PC Forums > ChatBox Archive"?

I've added updated attachments to this post, so that you can see where the problem lies. The first image's navigation tree (circled) should show that I'm on the ChatBox page, but it doesn't. The second image is when I'm on the ChatBox Archive page, but it reads "ChatBox" only...when it should read "ChatBox Archive"...correct?

Again...I feel the issue lies somewhere in the product's XML file, but I don't want to go screwing around with it...for fear I may break the mod.

So...as I have asked you before...is there a fix for this?


Thank you for your time.

Vaupell 12 Jan 2009 12:51

tx installed, just didnt figure out how to add it to Vba 3.1
not the same install options as descriped. but works fine.

optrex 13 Jan 2009 08:44

Quote:

Originally Posted by christicehurst (Post 1709485)
The mod stays on Loading the whole time.

I have the same issue

Saviour 13 Jan 2009 16:22

Bump...

http://www.vbulletin.org/forum/showp...8&postcount=13

Saviour 14 Jan 2009 00:54

In reference to my previous support request...

Never mind. Product uninstalled.

Lynne 14 Jan 2009 01:04

Quote:

Originally Posted by Saviour (Post 1709548)
So...as I have asked you before...is there a fix for this?


Thank you for your time.

Just do exactly what he did for the archive page.

(Find code like this and modify as below.)

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Nadavy 14 Jan 2009 03:57

In the future it would be nice to be able to report messages people post. If not in the main box, perhaps in the chatbox archive? You could even select a spread of messages if they posted it over a couple messages.

txbritt 14 Jan 2009 21:48

I love this add on a lot because not only is it an easy to get your members attention it is fully customizable.

Saviour 14 Jan 2009 23:35

Lynne...

Thank you, so much...all is now good. I'm glad someone took the time to help me out. May the help you gave me come back to you ten-fold.

All the best!

optrex 15 Jan 2009 03:05

how do you prevent users from being able to edit their own posts?

mastertek2000 19 Jan 2009 11:32

how can i get this installed globe so it show up on all pages thanks

boandmichele 19 Jan 2009 14:32

Quote:

Originally Posted by mastertek2000 (Post 1717684)
how can i get this installed globe so it show up on all pages thanks

go to vbulletin options > cyb-chatbox

find the field that says "index", should be labeled as:
Quote:

Show ChatBox on (comma separated THIS_SCRIPT locations)
Blank to show on all pages (not recommended because of server load)
delete the word "index" and it will now be on every page.

mastertek2000 19 Jan 2009 14:48

Quote:

Originally Posted by boandmichele (Post 1717819)
go to vbulletin options > cyb-chatbox

find the field that says "index", should be labeled as:


delete the word "index" and it will now be on every page.

i don't see that no where are u sure about this ??????????

algor65 19 Jan 2009 17:24

How was solved the problem with the security token? I had this problem too and I had to uninstall this Chatbox, although it was very nice

Quote:

*installed*

But it isn't working correctly. I'm still getting the security token error. I've upgraded to the gold 3.7.0 version -- I completely uninstalled and then reinstalled the chat box but I still get the error

Your submission could not be processed because a security token was missing or mismatched.

If this occurred unexpectedly, please inform the administrator and describe the action you performed before you received this error.

ETA: It works ok in Internet Explorer, but gives the security token error for *some* foxfire users (myself included)


cykelmyggen 19 Jan 2009 17:51

Quote:

Originally Posted by optrex (Post 1710646)
I have the same issue

me too...:( Luckily I kept an old version 2.0, which is the only one I managed to run on my board. Its running fine on 3.8.0:up:

mastertek2000 19 Jan 2009 18:18

yup going to remove this one this one

boandmichele 19 Jan 2009 19:22

Quote:

Originally Posted by mastertek2000 (Post 1717831)
i don't see that no where are u sure about this ??????????

yeah its in the options dropdown, just pick the chatbox category. i copied and pasted it from there, and have done it before on my site.

mastertek2000 19 Jan 2009 20:36

Quote:

Originally Posted by boandmichele (Post 1718074)
yeah its in the options dropdown, just pick the chatbox category. i copied and pasted it from there, and have done it before on my site.

i don't see it

Nadavy 19 Jan 2009 22:59

Cyb you should add a report feature to the chatbox!

ValsiSro 20 Jan 2009 02:13

i want to use this chat on an external page ... in my site www.valsis.ro there

Dream 20 Jan 2009 05:05

if this chatbox used pages instead of an archive (which I never understood why an archive anyway) I would consider dumping mine on my boards.

cjddrum1 23 Jan 2009 02:00

my smilies and text colors do not work :(

RedHacker 23 Jan 2009 04:05

I dont understand this but the ChatBox working excellent.. Open desired template and put "$cybchatbox" to desired line.

Tolas 23 Jan 2009 15:18

Quote:

Originally Posted by mastertek2000 (Post 1718126)
i don't see it

go into the Options for Cyb - Chatbox in your admin panel

look for:


Show ChatBox on (comma separated THIS_SCRIPT locations)
Blank to show on all pages (not recommended because of server load)

The default will have Index listed in the box on that line. If you remove it, it will make the chat load on every page of your site.


Cybernetec,

Any way to add functionality of private chats? I would love to make it so our users could initiate prive chats in a pop up window or even a tab in chatbox itself.

This mod works great though, no issues and like all your other mods could not be easier to install & setup. Thanks for all your hard work.

Trek 23 Jan 2009 19:10

No smilies seem to be working for me, any ideas?

Also, what is the format used for the date/time values?

I used this page for reference: http://us2.php.net/manual/sl/function.strftime.php

But it doesn't appear to sync up.

Basically I'm looking for the time format of: 3:30pm

Trek 23 Jan 2009 20:16

Just an update, the smilies display in the archive, just not the chatbox. Nothing is displayed in place of where the smiley is supposed to be.

dmknights 24 Jan 2009 17:00

Will try this later
Thanks

bornoffire 27 Jan 2009 12:59

What do i need to do exactly to get this in ibproarcade

Trek 27 Jan 2009 19:00

Quote:

Originally Posted by Trek (Post 1722598)
Just an update, the smilies display in the archive, just not the chatbox. Nothing is displayed in place of where the smiley is supposed to be.

Anything on this at all?

macc 27 Jan 2009 19:31

Hello!

Have problem with time on chat box - show incorrect time - about 10 minutes difference!(use H:i - format)
have last version 3.8.

some help?

reg
macc

Nadavy 28 Jan 2009 02:58

When people whose names are long post in the chatbox, it alligns the chatbox oddly and pushes all the text further to the right. =/
Still think we need a reporting feature!

torqueforums 28 Jan 2009 13:53

I'm having issues with the install. The xml file just hangs and will not load. Any ideas?

Scratch that.... For what ever reason the .xml file won't load from the browse button on either my mac or pc but it loads just fine when i manually place it in the includes/xml folder on the server.


Thanks

DanCan 28 Jan 2009 16:27

Great product. Everything works fine...

except for a mysql 1146 error message when users log off from the board


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Any way to fix this bug?

Trek 28 Jan 2009 16:50

Quote:

Originally Posted by macc (Post 1726347)
Hello!

Have problem with time on chat box - show incorrect time - about 10 minutes difference!(use H:i - format)
have last version 3.8.

some help?

reg
macc

Since it's a 10 minute difference and not a timezone difference, more than likely the time on your web server is incorrect as this is where the time would be pulled from.

macc 28 Jan 2009 17:37

Quote:

Originally Posted by Trek (Post 1727281)
Since it's a 10 minute difference and not a timezone difference, more than likely the time on your web server is incorrect as this is where the time would be pulled from.

Thanks for reply ...you have right ... time on my board is also incorrect - how to fix that?

regards

macc

Trek 28 Jan 2009 18:19

Quote:

Originally Posted by macc (Post 1727317)
Thanks for reply ...you have right ... time on my board is also incorrect - how to fix that?

regards

macc

You'll need to contact whoever you have web hosting with and ask them to fix the time.

Valter 29 Jan 2009 03:06

Quote:

Originally Posted by DanCan (Post 1727266)
Great product. Everything works fine...

except for a mysql 1146 error message when users log off from the board


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Any way to fix this bug?

'ajax_chat_online' is not part of this product.

DonHouston 29 Jan 2009 19:46

is anyone having issues when people post images or smileys in the box that the box starts to jump?

i assume its related to the refreshing, but when i use newest at the bottom and a image is posted alot of times the box will scroll to the center

Trek 29 Jan 2009 20:04

Quote:

Originally Posted by DonHouston (Post 1728305)
is anyone having issues when people post images or smileys in the box that the box starts to jump?

i assume its related to the refreshing, but when i use newest at the bottom and a image is posted alot of times the box will scroll to the center

I can't get it to display the smilies, they are replaced with nothing. However in the archive, they display as they should of in the main chat window. So... sorry I can't help ya, but.. there might be some issues in that area anyway.

stejoh 29 Jan 2009 20:09

I want to have th Chatbox at the main Social Groups page
.../forum/group.php

Can't figure out what template to edit?!
Can anyone help me?

Vaupell 30 Jan 2009 01:25

uninstalled was slowing the forum load time down by alot
and removed navigation links to subforums.

after uninstall navigation links came back and forum speed went considerly up to almost instant.

mbnoob 30 Jan 2009 20:53

users can edit their own messages.

how can I disable the function?

THX

DonHouston 30 Jan 2009 22:09

should be able to disable it by usergroups in the options

BlackJacket 31 Jan 2009 21:04

Installed! great mod.

Is there a way i can make colors exclusive to Moderators and Administrators?

Maybe a default color for them?

Thanks for the great mod! Its very nice.

HayleyP 04 Feb 2009 08:37

I don't want users to be able to edit what they've said. Can anyone help with that? :)

suggestion
by shabab-on-line
05 Feb 2009 13:29

Hi guys,

I have a suggestion .

Is there any way to let the chat display an announcement each XX minutes ?
It's like an advertising shows on a Bold or just like the words written with (/me) command.

It will be good if you could considered it in your future adding list.

Thanks for the great Chat. :)

BlackJacket 05 Feb 2009 16:11

My refreshing Messages always freezes...

Thanks mod its A1
by fragg
06 Feb 2009 03:24

Thanks for the mod its A1 for the live of me i cant work out how to integrate it to the arcade any help would be most appreciative

Onone 06 Feb 2009 11:41

Tnx but After i installed the hack i get a error. the error is:

Your submission could not be processed because a security token was missing.
If this occurred unexpectedly, please <a href="{1}">inform the administrator</a> and describe the action you performed before you received this error.

how do i fix it?

adusei 07 Feb 2009 09:53

1 Attachment(s)
First of all: THX a lot for this very nice Addon. Really great.

Unfortunately it seems not to work proper on IE6+7, as for Firefox it runs very nicely.

So, need urgent help to fix the IE display prob as to be seen in the attachment.

Since this is not solved, I cannot use the ChatBox :erm:

Best,

adusei

dopey1 08 Feb 2009 08:18

admin using IE can not access the archive, gets a blue box, and a error saying can not connect to.., works fine on fire fox, and other browsers, need a fix, since half of our mods/admin use the sucky IE browser. Uninstalled for now, till fix comes out

Allan 08 Feb 2009 17:48

1 Attachment(s)
French Language :)

Translator: Sofia and Allan (Team vBr)

Y-ZOOM 08 Feb 2009 19:40

Hi

i wanna say something

this hack not complated with IE ,, make my browser hanging and slow

but with fire fox it's great

please if you can fix this it's a bad issue


and thanks a lot sir


bye

sunrunner_pei 09 Feb 2009 00:41

I installed this a few days ago, and as far as I knew it's been working flawlessly, with one exception... At least once each night, new posts made in chat show up in the incorrect order. It's as if the timestamps are incorrect. I just experienced it for the first time a moment ago. Any ideas?

Y-ZOOM 10 Feb 2009 07:35

no support in this thread ?????????

Quote:

i wanna say something

this hack not complated with IE ,, make my browser hanging and slow

but with fire fox it's great

please if you can fix this it's a bad issue

????????????????????

lille L 10 Feb 2009 08:05

I have this on my forum, I am running 3.8
It works fine in SAfari, Firefox and IE. Thanks for a great add :D

Just one thing.. is it possible to turn of the edit choice? So the users cant edit them selves? I tried to turn of edit i n admincp, but they are still editing themselves.

ForYou 10 Feb 2009 11:13

Hello Cyb...

If i need to put this in Arcade forum main page how can i do that ,

http://www.dardasha.ps/montada/arcade.php

&

http://www.dardasha.ps/montada/ibproarcade.php

this is very important thing for me ,

Regards

plzzz
by fragg
10 Feb 2009 12:46

I cant work out how to integrate it to the arcade any help would be most appreciative i pay for addon i don't mind !

ascender 10 Feb 2009 21:14

Just wondering, I installed this and its working fine, but a couple of users have said they can't see any smileys in the box. What's strange is that they're both using different browsers, have both cleared their cache etc, so is there anything else that could be causing the problem?

Thanks,

Mike.

Serk 11 Feb 2009 05:41

Howdy and THANK YOU for an excellent program! (Marked installed)

Feature request if it's not too much trouble - We have different classes of users on our site, assigned different usergroups, as many sites do. Would it be possible to assign either a text, or a color change to the different usergroups?

I.E. New users names are green, senior users names are black, moderators are blue, etc?

Thank you!

Trek 11 Feb 2009 19:17

Quote:

Originally Posted by ascender (Post 1740149)
Just wondering, I installed this and its working fine, but a couple of users have said they can't see any smileys in the box. What's strange is that they're both using different browsers, have both cleared their cache etc, so is there anything else that could be causing the problem?

Thanks,

Mike.

Are you using vBA or a custom style? I had the same problem and it was due to the custom replacement variables being used in my style, combined with vBA. Basically, I had to go into the vBA setup again (the installer, you can rerun it) and select the images rebuild. It'll show you what paths are wrong. Then you manually edit those to point to the smilies. The easiest way to find out this was the problem is that if you looked at the archive, the smilies appeared, but not in the main chat box.

Anyway, hope that helps, I got zero support for the problem here, but finally figured it out myself.

benny92000 12 Feb 2009 02:02

Good chatbox, the main thing is the server load prob. If you leave it at 10 it eats up server load, if you change it to above 10, then the chats will not update often, and the chatbox won't be as effective. A idle feature would be great, but thanks for this chatbox, it is the best on vBulletin.

wmlvb 12 Feb 2009 07:08

I noticed question have not been answered for a while. Is there support for this chatbox?

My question is. Is there a way to have private chats? Thanks

kellyandmark04 12 Feb 2009 07:41

Private Chats would be awesome!!!!!!!!!!! Just like the IP Board Chatbox.


My Shoutbox works, but the archive button doesn't.

benny92000 13 Feb 2009 04:14

Quote:

Originally Posted by wmlvb (Post 1741504)
I noticed question have not been answered for a while. Is there support for this chatbox?

My question is. Is there a way to have private chats? Thanks

No there isn't. I have uninstalled this chatbox because of server load, and the layout of it. I changed the layout of it to look like inferno, but it was a little choppy. :p Anyway, thanks for this great mod Cyb, i will wait for a future version of it, with perhaps a better layout.

ascender 13 Feb 2009 08:46

Quote:

Originally Posted by Trek (Post 1741055)
Are you using vBA or a custom style? I had the same problem and it was due to the custom replacement variables being used in my style, combined with vBA. Basically, I had to go into the vBA setup again (the installer, you can rerun it) and select the images rebuild. It'll show you what paths are wrong. Then you manually edit those to point to the smilies. The easiest way to find out this was the problem is that if you looked at the archive, the smilies appeared, but not in the main chat box.

Anyway, hope that helps, I got zero support for the problem here, but finally figured it out myself.

Thanks very much for your post. Yes, we are running a custom style.

Do you know why its only a few users who are unable to see the smileys? I'd have thought a problem like the above with paths being wrong would affect all users of the board?

Tolas 13 Feb 2009 19:41

Quote:

Originally Posted by Serk (Post 1740438)
Howdy and THANK YOU for an excellent program! (Marked installed)

Feature request if it's not too much trouble - We have different classes of users on our site, assigned different usergroups, as many sites do. Would it be possible to assign either a text, or a color change to the different usergroups?

I.E. New users names are green, senior users names are black, moderators are blue, etc?

Thank you!


The names should appear in chat as the same color they would on your board. All of my users's names in chat match whatever they are normally. I can easily see what group they belong to when they talk. Shouldn't need to change anything in chatbox or add features to accomplish it.

Jedric 14 Feb 2009 10:19

Installed :)

n.sinha.p 15 Feb 2009 05:52

Seems to have a good majority of people using this according to this thread:

Certainly will try.

sherwood 15 Feb 2009 11:08

Is anyone else having problems with the chatbox in 3.8.1?

adusei 15 Feb 2009 17:30

Quote:

Originally Posted by sherwood (Post 1744661)
Is anyone else having problems with the chatbox in 3.8.1?

Yup: http://www.vbulletin.org/forum/showp...3&postcount=62

...unfortunaltely no reply to this prob yet... :(

khurtsiya 16 Feb 2009 12:10

Integrated in CMPS, but chat is just always Loading...

How to fix this?

Tolas 16 Feb 2009 14:42

I am running 3.8.1 and it's working great for me. No problems at all.

khurtsiya 18 Feb 2009 10:36

Quote:

Originally Posted by Tolas (Post 1745863)
I am running 3.8.1 and it's working great for me. No problems at all.

No problems at all too, but I am talking about homepage, where I use vBAdvanced CMPS.

It is just "Loading..." there...

chrisnufcfan 19 Feb 2009 01:46

Installed.
Thankyou.

itsheinz 19 Feb 2009 08:01

Thanks for this i just installed in my forum...

sinanmoda 20 Feb 2009 13:05

Tank you

redlabour 21 Feb 2009 08:38

Small Problem with vBSEO

Usernames are ignoring the Rewrite URLs. :(

alldylan 21 Feb 2009 11:40

I love this mod but I'm having problems with server loads and problems with IE. I run 3.8.1

cleverone 21 Feb 2009 20:59

Just installed a chatbox in my forum, and also have a image resizing mod installed. When the chatbox refreshes... it tweaks out the image in the chatbox (trying to enlarge the image but resizing real quick). This happens fast and every time it refreshes. How can i correct this problem. Seems like an easy fix, just not to sure where to start. Thanks in advance!

I'm running 3.8, w/ Cyb - ChatBox & nCode Image Resizer

Nadeemjp 22 Feb 2009 00:09

hi need help:

in my link of chatbox full in the nav bar i dont have the drop down menu for moderation, hence we are really in trouble because cant moderate the messages. any help?

ForumUser210 22 Feb 2009 01:57

When browsing page of Chatbox Full, the header breadcrumb does not update to include a link back to index.

For example, when you visit Chatbox Archive, you will see Forum Index -> Chatbox, but on Chatbox Full you simply see Forum Index.

Anyone know how I can change the nav bar?

ForumUser210 22 Feb 2009 06:18

I don't like the alternating colors in the background of the smiley menu. Should have just used the same smiley menu from the forum post form.

Frogsong 22 Feb 2009 09:11

I have it installed on my forum version 3.8.1 and it's working great. Even with our custom style and custom buglies (our version of smilies)

I do have one question though. Is there a way to list users in chat in the box on the forum page without having to actually click on the live chat box to see if anyone is there?

emailapphost 22 Feb 2009 10:23

I need a separate chat room for each of my 20+ forums on my board.
Can that be done? Do have 20 DIFFERENT chats going simultaneously?

ForumUser210 23 Feb 2009 08:31

Whoever wrote this chatbox -- they are bad with CSS.

There is repetitive inline CSS everywhere. The size, as well as complexity of the templates, could have been shrunken significantly by using class tags.

It's impossible for me to edit the template.

sherwood 23 Feb 2009 18:45

Quote:

Originally Posted by adusei (Post 1744956)
Yup: http://www.vbulletin.org/forum/showp...3&postcount=62

...unfortunaltely no reply to this prob yet... :(

thats not what happened to mine..

mine shoed all the bbcode instead of actually showing it as colored or whatever..

benny92000 24 Feb 2009 06:08

Well IMO, all this mod needs is an idle feature and the layout like the inferno and i would love it, but until then i'll stay with old, unsupported inferno. Cyb--best vBulletin coder, sure he will come up with something.


All times are GMT. The time now is 06:15.

Powered by vBulletin® Version 3.8.14
Copyright © 2021, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.