vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=282647

Reputation Point Chooser FREE by BOP5 (Choose how much rep to give when leaving rep)
by BirdOPrey5
09 May 2012 02:11

5 Attachment(s)
Brought to you by BirdOPrey5
www.Qapla.com


Updated to Version 1.2.1

This is the FREE version. It does everything the old 3.x version of this mod used to do.
This is NOT an update of that mod- it has been coded from scratch specifically for VB 4.x.

Demo: www.qapla.com/mods/forum.php - Leave rep on any post.

A GOLD Version with additional options is available at Qapla.com.

The GOLD version allows for custom rep multipliers (Multiply the amount of rep a user is allowed to give.) (Independent positive rep and negative rep values.)

The GOLD version also allows for per-usergroup enabling of the mod.

Both the FREE and GOLD versions share these features:
  • A single select field with all possible positive and negative rep values.
  • If negative reputation is enabled a note will automatically be displayed explaining the difference. (Editable phrase)
  • If a user chooses a positive or negative value the appropriate "Approve" or "Disapprove" radio button will automatically be checked.
  • Check to make sure user can't use "hacking" tools to specify more rep than allowed.
  • Tested on latest Chrome, Firefox, Opera, Safari, and IE9.

This has been tested as far back as VB 4.0.8, 4.1.10. and on the latest 4.1.12 version without issue. It has not been tested on VB versions prior to 4.0.8.

As usual all text presented to the user is fully phrased for easy translation.

German Translation Courtesy Of: Alex@bulletin (Version 1.2)

------------------------------------------------------

Please "Mark as Installed" if you use this. :)
Donations always appreciated. :up:
Nominate MOTM if you LOVE it! ;)

BirdOPrey5 09 May 2012 02:14

Reserved.

goxy63 09 May 2012 02:46

Tagged, nominated, rated

Thanks

faisaly.com 09 May 2012 02:49

nothing appears in the drop down box for me... i have the reputation system enabled using vb4.1.11 is there a basic setup i can use to see if it works...

BirdOPrey5 09 May 2012 03:15

Quote:

Originally Posted by faisaly.com (Post 2327498)
nothing appears in the drop down box for me... i have the reputation system enabled using vb4.1.11 is there a basic setup i can use to see if it works...

Try using the default style and see if you see it.

Did you enable the mod in settings?

faisaly.com 09 May 2012 03:18

mod enabled rep system set to yes and tested on default style...

Browser = firefox

Maybe an example of the built in rep system admincp/options/user reputation options setup would help, i could havepoints set up wrong?

edit this typo in your post... It has not been rested on VB versions prior to 4.0.8. - tested

BirdOPrey5 09 May 2012 03:35

Thanks for pointing out the typo-

When you say the drop-down box, you mean where you would pick a value right? (+3, +2, +1, 0. -1, -2, etc..) ??

I see your site is in Arabic (if it's your username) - can you make an account for me (username: BirdOPrey5) so I can see it first hand?

PM me a password.

faisaly.com 09 May 2012 03:39

I am using it on my other site... and using english, no numbers are represented... PM sent...

BirdOPrey5 09 May 2012 03:58

Quote:

Originally Posted by faisaly.com (Post 2327524)
I am using it on my other site... and using english, no numbers are represented... PM sent...

Weird...

If you go to the Admin CP -> Products & Plugins -> Plugin Manager

Edit the plugin: Build Rep Options

Change the "Hook Location" from reputation_form_start to reputation_start

Does that fix the issue?

faisaly.com 09 May 2012 04:05

Not working after following those steps... it was set on reputation_form and changed to reputation_start... still a no go!

New Joe 09 May 2012 04:08

Would this still work even if we have negative rep turned off?

DM BoNeZ 09 May 2012 05:26

yes im having the same problem the drop down box wont show
im running vb 4.1.7...
thanks for making it too :D hope you get it fixed...



Will be buying the gold version once fully working :P

mitch84 09 May 2012 06:43

1 Attachment(s)
installed on vb 4.1.11 but numbers don't appear
tested with style by defaut + 2 themes
language french or english, same results

BirdOPrey5 09 May 2012 09:57

Sorry guys, I have it working on 3 VB 4.x forums- 4.0.8, 4.1.10, and my site (Qapla.com) which is 4.1.12.

Let me install a fresh 4.x on my local machine and see what is up.

Stand by.

BirdOPrey5 09 May 2012 12:15

OK, released version 1.1, fixed a couple of things I saw wrong- would have been annoying but shouldn't have caused the issues you've seen.

I've changed some code in regards to building the number list I hope it helps.

BUT Here's the thing.

I've now installed this on 5 VB 4.x forums- VB 4.0.8 and two VB 4.1.12 production servers. ALSO one VB 4.1.12 FRESH INSTALL and one VB 4.1.10 FRESH INSTALL.

I've used both Litespeed/Apache and Linux/Apache servers.

And in all 5 cases the mod is working just fine. Tested it as an Admin, tested it as a user, and as a mod. I've tested it with reputation enabled and off, and reputation negative reputation enabled and off- and I cannot reproduce the missing numbers issue.

If this version 1.1 doesn't fix the issue for you please if you're willing PM me with an Admin account I can access on your site to trouble-shoot this further.

If anyone out there DOES get this working PLEASE PLEASE PLEASE report that in this thread too- so I know I'm not (that) crazy. :D

Quote:

Originally Posted by New Joe (Post 2327532)
Would this still work even if we have negative rep turned off?

Yes, especially now in the 1.1 version.


All times are GMT. The time now is 17:33.

Powered by vBulletin® Version 3.8.13
Copyright © 2019, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.