vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=208324

wcguy 04 Apr 2009 04:31

It's an either or setting in the ACP under image settings....

hambil 04 Apr 2009 04:31

I'll double check it, but I don't think that changes anything php wise.

Edit: I just changed it on my board and it had no effect on Egg Avatar.

wcguy 04 Apr 2009 04:35

I changed it too, and no joy. I do have vboptimize installed, is that causing issues?

hambil 04 Apr 2009 04:38

No. It runs fine with vb Optimise. If fact, version 2.5 (the next release) actually has support for vB Optimise to reduce the number of queries and speed things up.

Run a phpinfo and make sure you see something like this:
http://img6.imageshack.us/img6/7963/gdsupport.jpg

wcguy 04 Apr 2009 06:43

I've confirmed php version 5.2.5,

I've confirmed that I definetily do not have GD installed, and do have imagemagik installed

Version return code is 1

Version: ImageMagick 6.4.8-9 2009-01-29 Q16 OpenMP http://www.imagemagick.org
Copyright: Copyright (C) 1999-2009 ImageMagick Studio LLC


since vbulletin support documentation implies that imagemagik is the preferred image handler, can you support it?

hambil 04 Apr 2009 06:51

Quote:

Originally Posted by wcguy (Post 1783510)
I've confirmed php version 5.2.5,

I've confirmed that I definetily do not have GD installed, and do have imagemagik installed

Version return code is 1

Version: ImageMagick 6.4.8-9 2009-01-29 Q16 OpenMP http://www.imagemagick.org
Copyright: Copyright (C) 1999-2009 ImageMagick Studio LLC


since vbulletin support documentation implies that imagemagik is the preferred image handler, can you support it?

Yes, I will add support for ImageMagick in the 2.5 release.

wcguy 04 Apr 2009 06:55

Thanks!

down.low 04 Apr 2009 11:00

https://www.vbulletin.org/forum/

I'm having this problem as well, have you found out what might be causing this- I sure cant.

hambil 04 Apr 2009 11:02

Quote:

Originally Posted by down.low (Post 1783574)
I'm having this problem as well, have you found out what might be causing this- I sure cant.

I'd be glad to take as look if either of you want to PM me some login details.

Loony1973 04 Apr 2009 17:50

Quote:

Originally Posted by down.low (Post 1775186)
I have the registered users set up as follows:
http://i472.photobucket.com/albums/r...n/tkeggreg.jpg
|
__________________|__________________
I have mods/admins group set up as follows:
http://i472.photobucket.com/albums/r...n/tkeggmod.jpg

The problem I'm having:

Registered users can not see/ or clean an egged avatar.

If a mod eggs a mod, both mods can see it- not registered users.

If a mod eggs a user- a different mod can see the egging- not registered users.

I love the mod but I only want VIP's to use it, and Registered users "only view" the eggings until they become VIP,.....


Was this intentionally made this way, or was it just a mishap? Any way to make it so the reg users "can" view, "can" cleanothers, & "not" egg, ?? Setting it up like this makes registered users not see anything at all.....

Apologies if this has already been answered, I have a similar setup with usergroups and wanted the same feature....here's how I worked around it:

Replace the plug-in code as instructed here:

http://www.vbulletin.org/forum/showp...&postcount=263

Set your usergroups that you wish to see the eggs to have permission to both throw eggs and view egged avatars.

In your postbit/postbit legacy template, wrap a conditional statement around the $eggavatar_button. Mine is as follows:

Quote:

<if condition="is_member_of($bbuserinfo, 5, 6, 25)">

$eggavatar_button
</if>
So, although other usergroups can theoretically throw eggs, unless their usergroup is listed in the conditional above, the button to do so doesn't appear in their postbit.

This is a quick fix, and the author may incorporate this into their next update of what I believe is mod of the year, never mind the month .

Hope this helps anyone with the same problem.

gonabs 04 Apr 2009 18:41

Hello TK and gratx for this amazing mod :D
By the way, The down.low's problem is happening to me too and I know when happend.

When I activate using credits all items run off the table. If I turn egg credits option off, items come back inside table.

What can I do?
Thanks in advance!

hambil 04 Apr 2009 19:23

Quote:

Originally Posted by gonabs (Post 1783783)
Hello TK and gratx for this amazing mod :D
By the way, The down.low's problem is happening to me too and I know when happend.

When I activate using credits all items run off the table. If I turn egg credits option off, items come back inside table.

What can I do?
Thanks in advance!

Awesome! A clue! I run with credits, and don't have this problem, but it DOES give me some ideas as what to look at/for. Access to your board would be VERY helpful. If you are willing PM me some admin login details.

hambil 04 Apr 2009 23:43

Quote:

Originally Posted by Loony1973 (Post 1783750)
Apologies if this has already been answered, I have a similar setup with usergroups and wanted the same feature....here's how I worked around it:

Replace the plug-in code as instructed here:

http://www.vbulletin.org/forum/showp...&postcount=263

Set your usergroups that you wish to see the eggs to have permission to both throw eggs and view egged avatars.

In your postbit/postbit legacy template, wrap a conditional statement around the $eggavatar_button. Mine is as follows:



So, although other usergroups can theoretically throw eggs, unless their usergroup is listed in the conditional above, the button to do so doesn't appear in their postbit.

This is a quick fix, and the author may incorporate this into their next update of what I believe is mod of the year, never mind the month .

Hope this helps anyone with the same problem.

You're making my head spin :p

What I will say is the permissions are pretty self explanatory and should work as defined. I will be double and triple checking that they do in the upcoming 2.5 release.

If you want a permissions setup that simply does not exist in the current release, please explain it like I'm an idiot, because I'm confused.

CFodder 05 Apr 2009 03:07

Great mod thanks Hambil :D.

Sooner95 05 Apr 2009 04:03

holy crap this is hilarious.. Nice work! Install clicked.


All times are GMT. The time now is 09:36.

Powered by vBulletin® Version 3.8.14
Copyright © 2021, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.