vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=249277

deverill2010 20 Feb 2012 12:01

Ok set up vb detection script but my iPhone still doesnt automatically use your style.

Is this where I need to apply these fixes? - http://www.vbulletin.org/forum/showp...&postcount=746

dartho 20 Feb 2012 22:01

Yep - that's the one

deverill2010 20 Feb 2012 22:32

Yep edited but the iPhone still isn't being picked up and transferred to the your light skin even though I have that set for old and new devices and I have it so users can't change styles so it's on force but it still isn't showing.

dartho 22 Feb 2012 05:03

Do you have the styles checked as user selectable? (ticks next to their name in Style Manager)

deverill2010 22 Feb 2012 06:13

Yep my desktop n mobile are ticked in style manager.

dartho 22 Feb 2012 09:30

I'm not sure what could be causing your issue. I could look at your site if you like?

deverill2010 22 Feb 2012 12:12

If you could dartho that would be great.

I've had someone on the VB forum say they can view my site in the mobile style (I'm not sure what phone they are using) but the style doesn't come up on my iPhone 3GS..

I'll PM you now. Ty

paul07thebig 24 Feb 2012 00:23

Only the homepage of the forums works for me? I click a thread and it goes to my normal style. Any ideas?

dartho 24 Feb 2012 06:26

Yep - this: http://tracker.vbulletin.com/browse/VBIV-13851

Which I belive can be worked around by this http://www.vbulletin.org/forum/showt...99#post2289299

Nirjonadda 24 Feb 2012 12:01

vBulletin Message
This file was created using a different version of vBulletin from the one you are running.
Your version: 4.1.10
File version: 4.1.8

dartho 24 Feb 2012 12:19

Correct.

However, should you wish to install this you can select 'Yes' on the "Ignore Style Version" option.

ejup2009 26 Feb 2012 04:10

magnifico trabajo.. funciona maravillosamente bien en la versịn 4.1.9.. la pagina web se visualiza muy rapida desde un BlackBerry.

Gracias... excelente aporte

ejup2009 26 Feb 2012 04:13

Quote:

Originally Posted by Nirjonadda (Post 2302936)
vBulletin Message
This file was created using a different version of vBulletin from the one you are running.
Your version: 4.1.10
File version: 4.1.8

edit file vbulletin-style-4.1.8-lightweight-1.0.3.xml using notepad and modify 4.1.8 by 4.1.10.

note : excuseme but I dont very much speak English. Thanks you.

paul07thebig 26 Feb 2012 20:19

Where would I found init.php?

Thanks

deverill2010 26 Feb 2012 20:21

In your includes folder.

Hippy 26 Feb 2012 20:54

Quote:

Originally Posted by paul07thebig (Post 2303690)
Where would I found init.php?

Thanks

includes folder

sadiq6210 28 Feb 2012 05:55

Can I use it in RTL forum?

dartho 28 Feb 2012 07:34

I have seen it installed in RTL forums, and it *looked* like it was working (I cannot read arabic) so I would guess the answer is yes.

ringo88 28 Feb 2012 23:25

Great Work!!

But I have a question. Appereantly since I installed this skin and made it the default choice for mobile devices I had a decrease in the mobile visits count from Google Analytics. I put the code in the headerinclude_bottom instead of headerinclude as suggested in many places (it works well with the other normal styles).

Is it right? Or is that the problem?? In which template do I have to put the G.Analytics code?

Thank you very much.

P.S.: Any way to show the ajax chatbox in this style??

dartho 29 Feb 2012 04:01

Dunno - check your site in the lightweight style and see if the Google Analytics code is there or not. I put it in the footer on mine, but I guess you could put it in the header

re: chatbox - probably, let us know when you work it out as others have asked from time to time.

Bounce 01 Mar 2012 19:59

some nice features in the newer version dartho,

how do I add a "PM" button, next to edit etc?

Bounce 01 Mar 2012 20:12

also the "whats going on" section is missing now, and how do i remove the adverts :(

Hippy 01 Mar 2012 20:40

Quote:

Originally Posted by Bounce (Post 2305148)
also the "whats going on" section is missing now, and how do i remove the adverts :(

search the thread your answer is in here not to far back or add the addon posted in the first post

dartho 01 Mar 2012 22:29

Quote:

Originally Posted by Bounce (Post 2305148)
also the "whats going on" section is missing now, and how do i remove the adverts :(

There shouldn't be any ads and the what's going on should be working in the latest version. Ads were left in by mistake and an updated version with them removed was uploaded within an hour or so (as soon as I found out). The whats going on box should also work in the latest version?

autoescala 02 Mar 2012 11:35

Today, I test the premium mobile style included in the new release 4.1.11 of VB, i don't like!!! Its ugly and heavy load on Android Galaxy S versus dartho light skin, I prefer the dartho style.

The only thing I don't know how to change is the underline style of the text in this skin, it would be more beautyful if you improve a lite the boxes when u are inside a sub-forum.

Some similar like this: http://www.bowlandcentral.com/forum/...hp?styleid=167

this custom style based on your work, is very very nice....

Bounce 02 Mar 2012 20:20

Quote:

Originally Posted by dartho (Post 2305200)
There shouldn't be any ads and the what's going on should be working in the latest version. Ads were left in by mistake and an updated version with them removed was uploaded within an hour or so (as soon as I found out). The whats going on box should also work in the latest version?

thanks mate, any thoughts on post 826
http://www.vbulletin.org/forum/showp...&postcount=826

dartho 02 Mar 2012 23:56

Where did you want the PM button - next to the edit, reply buttons on postbit?

Hippy 03 Mar 2012 00:47

I would like to add a post thank..
what code would you need to see from that mod ?
thanks

dartho 03 Mar 2012 02:41

See this post for Abe1's Post Thanks Hack integration: http://www.vbulletin.org/forum/showt...43#post2305643


This probably needs a bit of tweaking, but here goes:

edit post_thanks_box template in the lightweight style and replace contents with:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

edit post_thanks_button template in lightweight style and replace contents with:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

edit post_thanks_postbit template in the lightweight style and replace contents with:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

edit postbit and postbit_legacy templates in lightweight style , search for

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

and replace with

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

I think that should just about do it - assuming it is this hack: http://www.vbulletin.org/forum/showthread.php?t=165673 that you have installed

caveat: this may introduce other hacks into the lightweight style which use the postbit_end and postbit_control hooks

Hippy 03 Mar 2012 02:53

yep will test it out in the am .. thanks for your time dartho

Filgga 03 Mar 2012 02:54

^^^^
Thanks dartho for the above info; can the vBSEO Like system be added in the same manner?

Filgga 03 Mar 2012 03:01

Quote:

Originally Posted by dartho (Post 2301514)
Nowadays I generaly tell people to use vBulletin's built in one - then I don't have to support it :)

Your version for detection of devices was superb, used to detect iPad either. The vBulletin's buit-in one does not.

dartho 03 Mar 2012 04:03

Quote:

Originally Posted by Filgga (Post 2305567)
^^^^
Thanks dartho for the above info; can the vBSEO Like system be added in the same manner?

Link me to a copy and I can look when I get a chance

Hippy 03 Mar 2012 04:10

Quote:

Originally Posted by dartho (Post 2305563)
This probably needs a bit of tweaking, but here goes:

edit post_thanks_box template in the lightweight style and replace contents with:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

edit post_thanks_button template in lightweight style and replace contents with:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

edit post_thanks_postbit template in the lightweight style and replace contents with:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

edit postbit and postbit_legacy templates in lightweight style , search for

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

and replace with

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

I think that should just about do it - assuming it is this hack: http://www.vbulletin.org/forum/showthread.php?t=165673 that you have installed

caveat: this may introduce other hacks into the lightweight style which use the postbit_end and postbit_control hooks

the code posted is old
anyway updated to vb4
would be I guess (below)
but still don't work

post_thanks_box

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

post_thanks_button


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


post_thanks_postbit

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

postbit and postbit_legacy templates in lightweight style I don't have

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

and the hooks would be

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

but the hooks are not working from what I can tell.. or something else..

:confused:

dartho 03 Mar 2012 04:40

ah - sorry, I did that under 3.8.7 as that's what I use :)

I will have look a tthe vb4 vesion

dartho 03 Mar 2012 07:22

Should be able to get something up tonight for this...

thenamesgould 03 Mar 2012 09:36

Dartho, if you have the time and inclination, it would be amazing if you could have a look at adding this thanks hack for vb4 ... http://www.vbulletin.org/forum/showthread.php?t=243510

dartho 03 Mar 2012 11:12

Integrating Abe1's post thanks add-on into the lightweight style.

replace the following templates with the code provided (in the lightweight style only!!)
post_thanks_box

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

post_thanks_button

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

post_thanks_postbit

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Edit both the postbit & postbit_legacy templates as follows

Search for:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Add the following immediately above:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Then go to end of template and paste in:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

and your done!

dartho 03 Mar 2012 11:24

Just noticed something else with the style in general - my last update only included updates to the postbit_legacy template which should have been made to both postbit and postbit_legacy (they are meant to be identical). I suggest overwriting the postbit template copying with the contents of the postbit_legacy template.

Hippy 03 Mar 2012 11:59

Quote:

Originally Posted by dartho (Post 2305643)
Integrating Abe1's post thanks add-on into the mobile style.

replace the following templates with the code provided (in the lightweight style only!!)
post_thanks_box

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

post_thanks_button

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

post_thanks_postbit

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Edit both the postbit & postbit_legacy templates as follows

Search for:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Add the following immediately above:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Then go to end of template and paste in:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

and your done!

your the best .. worked like a charm

I have dbtech_bookmark and thread system and like you said this will bring on other mods
now showing a image but not working from what I can tell
this is the code ..in template dbtech_bookmark_post
whats do I change ..and will there be other changes to other templates
thanks again


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

<span class="seperator">&nbsp;</span>

dartho 03 Mar 2012 12:03

You could just delete the contents of that template in the lightweight style to stop it showing, same should work for most other add-ons that start appearing because of the addition of hooks.

BTW - I modified the code for the post_thanks_box template above so that it only shows the post thanks box when someone has actually posted thanks

dartho 03 Mar 2012 12:09

Alternatively if you wanted to integrate the post thanks hack, and not put the hooks in, you can put the code from post_thanks_box in place of {vb:raw template_hook.postbit_end} in the postbit templates and put the code from post_thanks_button in place of {vb:raw template_hook.postbit_controls}

Hippy 03 Mar 2012 12:14

Quote:

Originally Posted by dartho (Post 2305659)
You could just delete the contents of that template in the lightweight style to stop it showing, same should work for most other add-ons that start appearing because of the addition of hooks.

BTW - I modified the code for the post_thanks_box template above so that it only shows the post thanks box when someone has actually posted thanks

thanks you!!!!!!!!!!!!!!

Quote:

Originally Posted by dartho (Post 2305665)
Alternatively if you wanted to integrate the post thanks hack, and not put the hooks in, you can put the code from post_thanks_box in place of {vb:raw template_hook.postbit_end} in the postbit templates and put the code from post_thanks_button in place of {vb:raw template_hook.postbit_controls}

got ya that bud ..

Hippy 03 Mar 2012 12:37

if you add the contents from post_thanks_button in place of {vb:raw template_hook.postbit_controls}
the button shows up on everyone ..
If you have it set so you can thank yourself it is showing
then if clicked you get the you don't have permission to do this act or what ever it says.
any ideas would be greatly appreciated

dartho 03 Mar 2012 12:37

Quote:

Originally Posted by autoescala (Post 2305312)
The only thing I don't know how to change is the underline style of the text in this skin, it would be more beautyful if you improve a lite the boxes when u are inside a sub-forum.

Some similar like this: http://www.bowlandcentral.com/forum/...hp?styleid=167

this custom style based on your work, is very very nice....

To remove underlines and make style changes etc, edit the CSS file. To remove underlines form ALL linkes, edit the lightweight.css.php file, search for


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

and add

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

immediately above it.


I have tried to leave the style as simple as possible, whilst still being functional, to make it easy for admins to tailor it for their site as Mark has done.

dartho 03 Mar 2012 12:43

Quote:

Originally Posted by Hippy (Post 2305681)
if you add the contents from post_thanks_button in place of {vb:raw template_hook.postbit_controls}
the button shows up on everyone ..
If you have it set so you can thank yourself it is showing
then if clicked you get the you don't have permission to do this act or what ever it says.
any ideas would be greatly appreciated

Ah - I didn't think oif permissiosn etc....

try wrapping the following conditional around it:


<vb:if condition="$display_thanks_image=='none'">

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

</vb:if>

tareqbd 03 Mar 2012 14:53

Well bro, I made the thanks work. But user has to press the button 2/3 times and refresh the page. Because I am using hide option integrated with Abe1's thanks hack, in normal version once user press thank, the hidden content automatically show without refreshing the page but in mobile version it needs to refresh and press thanks more times. Can I make it ajax based or if I can change anything which will make it automatically and user will get rid of pressing the button every time or refresh the page.

Thank you.

dartho 03 Mar 2012 23:27

I don't know what the hide option is, the above code seems to work fine from my mobile phone.

tareqbd 04 Mar 2012 01:16

Quote:

Originally Posted by dartho (Post 2305895)
I don't know what the hide option is, the above code seems to work fine from my mobile phone.

http://www.vbulletin.org/forum/showthread.php?t=271979
bro above is the mod I am talking about. thanks.

F&R 05 Mar 2012 17:25

Hello dartho

I have just upgraded to vb4 4.1.11

In order to avoid the moaning in control panel about templates, I deleted the lightweight style, upgraded to 4.1.11 and then uploaded the lightweight style and the options add on.

Thing is, it doesn't look anything like what it did before. Gone is the desktop button at the top, adding a title to the options doesn't remove the logo, and the logo is vbulletin not your mobile logo.

What on earth did I do wrong? Or is it 4.1.11 doing something?

Uploaded again and this time it worked... seems that what I was looking at was the vb4 version... not as nice as yours.

Bounce 05 Mar 2012 19:33

Quote:

Originally Posted by dartho (Post 2305527)
Where did you want the PM button - next to the edit, reply buttons on postbit?

yes please :up:

I'm also having problems with a blue text that I haveon the usernames and forum titles, i've had a look in the css but cant see anything :(

Crotan 05 Mar 2012 23:03

Thank you for providing this lightweight style, and keeping it supported. Vbulletin should of had their "premium" mobile style available to license holders well before 4.1.11

For the time being that's what I'm using because of how it handles cms articles, where as this style doesn't.

dartho 06 Mar 2012 00:01

Quote:

Originally Posted by Bounce (Post 2306517)
yes please :up:

I'm also having problems with a blue text that I haveon the usernames and forum titles, i've had a look in the css but cant see anything :(

re: blue text - try edit the CSS file, search for:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

and replace with

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

as for the PM button, I'm havbing issues getting the PM recipient to be recognised - I'll have a look and get back to you

sportsfroma2 06 Mar 2012 03:23

I just upgraded from vb 4.1.10 to 4.1.11, lightweight style is still running great in it... Although I wasn't exactly just how to handle the template merge issues (I reverted a couple, then I figured I shouldn't have done that), so I just reinstalled the style to make the warnings go away, lol

dartho 06 Mar 2012 09:38

That's one way of doing it. From the FAQ on post #2


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Bounce 06 Mar 2012 15:22

Quote:

Originally Posted by dartho (Post 2306610)
re: blue text - try edit the CSS file, search for:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

and replace with

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

as for the PM button, I'm havbing issues getting the PM recipient to be recognised - I'll have a look and get back to you

Thanks will try that when I get in and thanks if you could, I have a piece of code from another add on that I have on the style but it doesn't look right and isn't like a button!

Posted from my moby phone





:D

Hippy 07 Mar 2012 01:17

dartho how can last activity be added to whos online
thnaks

dartho 07 Mar 2012 06:50

Isn;tthat already there? Here's my whosonlinebit template


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Hippy 08 Mar 2012 04:09

last activity meaning the time.. not the place ..
my template must of been from a older version..
but it did the same thing..
but with your still no time.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


dartho 08 Mar 2012 09:18

Slip the following in there somewhere


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Maybe immediately after
Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Hippy 08 Mar 2012 11:02

Thanks dartho I'll give it a go when I GET home. Thanks

autoescala 09 Mar 2012 08:05

Dear Dartho,

Thank you very much to help me to remove the underline properties of the text.

I have 2 questions more:

I installed the new version, and I can't see the "PC Mode" button, only appears the button "Log out" is normal ?

second, where or how can I put the adsense codes to see the banners up the navbar and in footer ??

In the new 4.1.11 version if you configure the new "google adsense"option in Ads, appears banners in all templates with the same size.

I want to do the same but without using this option, because this options , no difference between PC and mobile templates. I want to put the mobile adsense code for mobile in a part of this nice style....

here is an example:

https://www.vbulletin.org/forum/external/2012/03/35.png

I hope I explained well...

Best regards, thanks in advance

Bounce 09 Mar 2012 17:50

Quote:

Originally Posted by autoescala (Post 2307786)

I installed the new version, and I can't see the "PC Mode" button, only appears the button "Log out" is normal ?

did you install http://www.vbulletin.org/forum/showthread.php?t=249339 ?

That has the option to Add a link to the default style

autoescala 12 Mar 2012 08:57

Thanks Bounce, I will try this!!

Filgga 12 Mar 2012 15:19

Quote:

Originally Posted by dartho (Post 2305643)
Integrating Abe1's post thanks add-on into the lightweight style.

replace the following templates with the code provided (in the lightweight style only!!)
post_thanks_box

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

post_thanks_button

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

post_thanks_postbit

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Edit both the postbit & postbit_legacy templates as follows

Search for:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Add the following immediately above:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Then go to end of template and paste in:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

and your done!

Hi dartho,

Can this be employed for the vBSEO_like button?

dartho 13 Mar 2012 03:38

Same answer as the first time you asked, Filgga :)
Quote:

Originally Posted by dartho (Post 2305584)
Link me to a copy and I can look when I get a chance


Filgga 13 Mar 2012 03:50

Quote:

Originally Posted by dartho (Post 2309015)
Same answer as the first time you asked, Filgga :)

Done,

Thanks.

Timac LEO 14 Mar 2012 05:42

Update vbulletin 4.1.11?

Hippy 14 Mar 2012 10:38

works fine with vb4.1.11

Bounce 11 Apr 2012 21:15

Quote (Reply) is broken in vb 4.1.12

doesnt quote! :(

tambo 14 Apr 2012 11:35

I've got this running, but I was wondering if it is possible to move the lightweight.css.php file to another location, rather than root?

Would I have to edit something in the templates or xml file?

Why would I want to ask this? Not all Admins on our board have root access, but access to different parts of the server, based on their interests/expertise. It would be good to give the person responsible for styling access to the CSS file, without giving them root access.

EDIT: Never mind. I got it.

Use 'Replacement Variable Manager' in ACP.

Replace:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

with

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

...and then move the lightweight.css.php file to that location.

You'll then need to edit the CSS file 'Logo Image Location' to locate the logo image from root (as it's no longer relative). So, in my case:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

...or wherever you want to put it. There's probably an easier way. :D

Great mod by the way. Very impressive.

etca 15 Apr 2012 04:22

2 Attachment(s)
dear dartho,

how to fix this? my vbul. 4.1.12
1. on 4.1.12, clicking quote on mobile style wont include the quoted message.
2. empty page, there are no 1, 2, 3 ... . see the attachment.

dartho 16 Apr 2012 23:44

I just updated my test site (vbdev.org) and have none of the problems reported above? Anyone else?

@Semprot - if you want to try and add reputation, the button code would be something like this:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Alan_SP 18 Apr 2012 09:09

Quote:

Originally Posted by semprot (Post 2320882)
if i upload lightweight style as normal style (i didnt select mobile as parent), quote is working, but it wont appear on "Style & Language Settings" >> "Default Style for Old Mobile Browsers"

You could use http://www.vbulletin.org/forum/showthread.php?t=249339, I have it installed and there you could set this style as default.

I tested it on computer, not mobile phone, so I'm not sure that this style will actually get selected for mobile devices.

Bounce 18 Apr 2012 20:11

Quote:

Originally Posted by semprot (Post 2320882)
More update :
  • if i upload lightweight style as normal style (i didnt select mobile as parent), quote is working, but it wont appear on "Style & Language Settings" >> "Default Style for Old Mobile Browsers"
  • If i upload it as mobile style, quote is not working, but it will appear on "Style & Language Settings" >> "Default Style for Old Mobile Browsers".

Yip, quotes dont work if style is parent of mobile styles default

does work if it has no parent.
:up:

Bounce 19 Apr 2012 20:26

cancel that, i still dont have this working :(

Alan_SP 20 Apr 2012 10:02

Strange. I installed as new style, after that I deleted old one. Quoting works for me, only I changed phrase from reply to reply_with_quote (postbit_legacy).

I didn't noticed problems so far, but it's still too early to tell for sure that there are no problems.

etca 21 Apr 2012 22:07

Quote:

Originally Posted by semprot (Post 2321880)
still having problem with quote?
I suggest you to delete old lightweight style & re-add it with non-mobile no-parent.

thx. solved on my prob :)

The Rocketeer 24 Apr 2012 11:14

2 Attachment(s)
Hi, I think we are finally ready to move on to the default vBulletin theme, But before that I wanted to share the vB CMS Article pages, I saved these two files, AFAIK this worked well with our CMS and should work with your too.

All the best and thanks for the Style and effort. :up:

djbaxter 27 Apr 2012 12:53

I have the vB Mobile Style as default in 4.1.12 PL1.

However, at least one member is expressing an option to use this mobile style instead.

Two questions:

1. If I add this as a mobile style it shows a number of uncached templates. How can I fix this? (If I add it as a new full style, the templates are cached but that seems like it would be confusing to users.)

2. There seems to be no way to make this the default mobile style now that the vB Mobile Style is installed, and in either this mobile style or the vB Default Mobile Style, there seems to be no way to choose an alternate mobile style - just mobile or full forum default style. How can I add this as an option?

Alan_SP 28 Apr 2012 13:43

Just two posts before yours is answer: http://www.vbulletin.org/forum/showp...&postcount=888

Install this mod and you'll be able to set this style as default for mobile devices. Just turn off vB's default system for setting default mobile style for mobile devices.

djbaxter 28 Apr 2012 14:03

But I don't want to disallow users from using the vBulletin mobile version. I just want to add the option for mobile users to select this one.

I have the Suite. Now the CMS doesn't get a lot of use and blogs are currently disabled so the forum is the main focus, but this style, unlike the vBulletin mobile style, doesn't provide for anything but the forum.

Suggestions?

dartho 29 Apr 2012 09:34

Quote:

Originally Posted by djbaxter (Post 2324019)
I have the vB Mobile Style as default in 4.1.12 PL1.

However, at least one member is expressing an option to use this mobile style instead.

Two questions:

1. If I add this as a mobile style it shows a number of uncached templates. How can I fix this? (If I add it as a new full style, the templates are cached but that seems like it would be confusing to users.)

2. There seems to be no way to make this the default mobile style now that the vB Mobile Style is installed, and in either this mobile style or the vB Default Mobile Style, there seems to be no way to choose an alternate mobile style - just mobile or full forum default style. How can I add this as an option?

1. Uncached templates are from vBulletin removing templates that are in teh non-mobile default (or more correctly MASTER) style. It would seem they then proc3eed to hide these templates form the style manager :confused: I think the way to reolve this would be to deleted those templates from the XML file before installing it.

2. On my test site I can happily select both this style and vBulletins Mobile style as default style for both old and/or modern mobile browsers?

In order to have links to other mobile styles, you will need to make edits to templates (probably footer) and add in links there. It would appear that vBulletin have removed the style chooser code from the mobile styles? A plugin would have to be written to create this or you may be able to manually add the code to your style.

A plugin could also be conceivably written to detect visitors viewing your CMS from this style and flick them over to vBulletins style?

Alan_SP 29 Apr 2012 11:34

Quote:

Originally Posted by djbaxter (Post 2324305)
I have the Suite. Now the CMS doesn't get a lot of use and blogs are currently disabled so the forum is the main focus, but this style, unlike the vBulletin mobile style, doesn't provide for anything but the forum.

Actually it does. You can look at CMS, Blog, I even look at VaultWiki articles with this style. It is not optimized, but it is usable. Test it yourself. Add direct links in navbar manually as I did and you'll see that it works.

djbaxter 30 Apr 2012 03:32

Quote:

Originally Posted by Alan_SP (Post 2324560)
Actually it does. You can look at CMS, Blog, I even look at VaultWiki articles with this style. It is not optimized, but it is usable. Test it yourself. Add direct links in navbar manually as I did and you'll see that it works.

Thank you. I'll look into this further...

However, even with the Options add-on installed, my iPhone will not select this style as default unless I fully delete the vBulletin Default Mobile Style. Setting the vBulletin Stytle options to "None" for Mobile does not work.

Does that correspond with your experience?

djbaxter 30 Apr 2012 03:41

Also are you saying to use VB4 - Mobile Phone / iPhone / PDA Detection and Style Assignment instead of Lightweight Style Options for "Lightweight Style"?

Dartho seems to have several versions of everything which is confusing...

dartho 30 Apr 2012 09:25

Quote:

Originally Posted by djbaxter (Post 2324766)
Also are you saying to use VB4 - Mobile Phone / iPhone / PDA Detection and Style Assignment instead of Lightweight Style Options for "Lightweight Style"?

Dartho seems to have several versions of everything which is confusing...

Nope - only one version of each thing. The 2 you list are 2 different products. One is mobile detection script (vBulletin now has one of it's own) and the other is an extension to this style which adds optional customisations (which you would otherwise have to manually edit templates or add plugins to create).

Alan_SP 30 Apr 2012 13:11

Quote:

Originally Posted by djbaxter (Post 2324766)

I use both. :)

With first I selected which style is default for mobile devices and my users reported that this style gets selected, but I disabled vB own options. I'm on vB4.1.12PL1.

djbaxter 30 Apr 2012 13:53

Quote:

Originally Posted by Alan_SP (Post 2324846)
I use both. :)

With first I selected which style is default for mobile devices and my users reported that this style gets selected, but I disabled vB own options. I'm on vB4.1.12PL1.

When you say "disabled" do you mean uninstall? or how exactly did you disable the vB options? I am also on 4.1.12 PL1.

edytwinky 01 May 2012 03:52

Does this mod allow for users to vote in polls?

Alan_SP 01 May 2012 19:51

Quote:

Originally Posted by djbaxter (Post 2324863)
When you say "disabled" do you mean uninstall? or how exactly did you disable the vB options? I am also on 4.1.12 PL1.

Just put it to None, you have two options in ACP->Settings->Options->Style & Language Settings:

Default Style for Old Mobile Browsers
Default Style for Modern Mobile Browsers

There you can choose style you want automatically selected when user's browsing from mobile. Put it to none (or use it, than you don't need mod from dartho). In some vB versions there was bug and this didn't worked. Not sure in which version it was corrected if it is corrected. I'm using dartho's mod and it works.

Merriweather 08 May 2012 04:19

Something is going on with the pagenav. For instance, I am seeing:

Thread Title Here > (25) ()

Where "25" is the number of posts, and the parenthesis is supposed to have the page navigation links, but it's showing up blank. It will show (...Last Page) if there are at least 50 posts, but for 10 - 49 posts, I get blank parenthesis.

Ideas?

dartho 08 May 2012 13:46

If you red over the last couple pages, there have been some issues reported which seem to be resolved by reinstalling as a new style?

Merriweather 15 May 2012 00:46

I tried that to no avail. I'm thinking it might be because I installed it as a mobile style vs a regular style?

Hippy 16 May 2012 00:55

after updating to vb4.1.12 pl1 it's not caching any templates.

I have 8WayRun.Com - Micro Debug Stats installed since day one and you can see if a template is not being cached.. as so

this is 8wayrun's screenshot from his mod as a example of whats happening
http://www.vbulletin.org/forum/attac...5&d=1271813205

this only start to display a long list of stock and mod template after the latest..

I am not sure what vb changed for this to happen..

any ideas ?

djbaxter 16 May 2012 01:26

Quote:

Originally Posted by Hippy (Post 2329723)
after updating to vb4.1.12 pl1 it's not caching any templates.

I have 8WayRun.Com - Micro Debug Stats installed since day one and you can see if a template is not being cached.. as so

this is 8wayrun's screenshot from his mod as a example of whats happening
http://www.vbulletin.org/forum/attac...5&d=1271813205

this only start to display a long list of stock and mod template after the latest..

I am not sure what vb changed for this to happen..

any ideas ?

Yep. Re-import the XML for the style.

Hippy 16 May 2012 01:33

I did and lost all the templates that where not edited from when we did the post thanks..
I had to add them back manually
but that did not fix it
I even deleted it and imported it again...

dartho 16 May 2012 08:42

I think the way to resolve the uncached templates would be to deleted those templates from the XML file before importing the style. I've been pretty busy lately and haven;t had teh time to sit down and have a proper look as yet ...

Hippy 18 May 2012 21:59

thanks .. But seems they are missing .. I think one of the vb updated moved it to a mobile style and if it wasn't a edited template it did away with it
so adding them back I think will fix it ..
Not sure if thats the correct way tho..
life first .. and see what you come up with

thanks for the support

S_E_A 19 May 2012 14:44

Receive an Array error message when checking users online on 4.1.12. Anyone else had this problem?

Cheers


All times are GMT. The time now is 13:27.

Powered by vBulletin® Version 3.8.14
Copyright © 2022, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.