vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=236069

VSa - Advanced Forum Rules
by Valter
16 Feb 2010 23:04

7 Attachment(s)
Info:
Advanced Forum Rules system for vBulletin.

Main Features:
-Rules shown on separate page (no file uploads required)
-Several sets of rules can be created and applied to individual forums
-Choose between BB codes and HTML in rules
-Options to force users to accept Forum Rules before can view forums or threads, post replies, PMs, or e-mails...
-Option to replace registration rules with this product ones
-Option to reset user acceptance status when infraction is received

View screenshots.


Installation:
-Import XML file (as product): AdminCP > Plugin System > Manage Products > [Add/Import Product]


To set options:
Go to: AdminCP > vBulletin Options > VSa - Advanced Forum Rules


Versions:
v1.0 - Oct 06. 2005.
-First version
v4.0.2 - May 08. 2009.
-Latest vB 3.x version
v5.0 - Feb 17. 2010.
-Updated for vB 4
-Code optimized, some bugs fixed
v5.0.1 - Apr 18. 2010.
-Fixed: Link to Rules in forumdisplay
-Fixed: Ordered list parsing in Rules
v5.0.2 - Nov 21 2010.
-Fixed: Uncached template
-Fixed: Style issues on Rules page
-Fixed: Style issues on Manage Rules pages
-Fixed: Minor bugs
v5.0.3 - May 04 2011.
-Fixed: Security bug
v5.0.4 - May 06 2011.
-Fixed: vbseo users not able to switch rules
v5.0.5 - May 18 2011.
-Fixed: Security bug
-Improved rule acceptance check
v5.0.6 - May 22 2012.
-Compatible with vBulletin 4.2
-Increased number of maximum rule sets
-Fixed some minor bugs
v5.0.7 - May 26 2012.
-Fixed: Navbar link
v5.0.8 - Sep 17 2012.
-Fixed: Incorrect acceptance status for some users

Valter 16 Feb 2010 23:08

If you have Advanced Forum Rules for 3.x installed:
- Save your Rules to TXT document, to have it in case something goes wrong during upgrade
- This product will automatically save your old rules to a new table (used by vB4 version)
- Remove old version after upgrade if everything works as expected

Please report any bugs you discover.
Mark as Installed, and/or nominate/rate if you like it.

BlackJacket 16 Feb 2010 23:15

Thanks Valter! This is much needed. Tagged

LuckyNeo 16 Feb 2010 23:28

Cool! Thanks a lot! this is FIVE and install! You are the one of the BEST!
And please, Advanced Registration :)

AzzidReign 16 Feb 2010 23:52

Thank you!!! Very nice mod.

fogjuice 17 Feb 2010 00:06

awesome, you're a hero

GeorgeB85 17 Feb 2010 00:26

Valter:

Been waiting for this for a long time! My thanks goes to you and SteveM both for this hack!

Trumpetrhapsody 17 Feb 2010 01:47

So glad this finally got ported, thanks!


One issue.... a number ordered list using the [ list=1 ] code isn't adding the numbers for some reason.

Supramania 17 Feb 2010 02:23

When I click on the "Manage Rules" link in the mod in the Admin CP, it opens the smile manager?

The link is:

http://www.mysite.com/forums/misc.php?do=vsaafr_mng

GeorgeB85 17 Feb 2010 03:02

Valter:

Forgot to mention. One thing that would be awesome is to be able to edit the rules text such as bold, hyper links, etc with out doing all the html coding. A set up like when you are posting a new thread or something.

Fastbird 17 Feb 2010 05:06

Is there any way to have all the rules show up when clicking "Forum Rules" in the navbar? I have it setup in different rule categories and the users have to manually view each rule category. I'd like to keep it separated by category, but I guess I'll put all the rules in one massive category if I have to.

dacho 17 Feb 2010 07:20

thanx man

Is it possible to allow the spider to skip the rules and explore the content?

Gnoll 17 Feb 2010 07:39

Tagged for future use :) - cool system

Skyrider 17 Feb 2010 07:43

Thank u! :D

Bellethiel 17 Feb 2010 08:44

It seems that the bb code for a unsorted list doesnīt work properly. Besides from that itīs great :3

RedTrinity 17 Feb 2010 09:00

Quote:

Originally Posted by Supramania (Post 1984247)
When I click on the "Manage Rules" link in the mod in the Admin CP, it opens the smile manager?

The link is:

http://www.mysite.com/forums/misc.php?do=vsaafr_mng

Doing the same for me too :confused:

Quote:

Originally Posted by Fastbird (Post 1984301)
Is there any way to have all the rules show up when clicking "Forum Rules" in the navbar? I have it setup in different rule categories and the users have to manually view each rule category. I'd like to keep it separated by category, but I guess I'll put all the rules in one massive category if I have to.

I'd like this too :)

Valter 17 Feb 2010 09:51

Are you a member of usergroup 6-Admin?

You must be to access these pages...

RedTrinity 17 Feb 2010 09:55

Quote:

Originally Posted by Valter (Post 1984410)
Are you a member of usergroup 6-Admin?

You must be to access these pages...

Yep :) And it does let me edit the pages if I go in via the "manage rules" link on the actual rules page. Just takes me to the smilies page if I use the link of the same name/type in the AdminCP, which is a little odd.

mitch84 17 Feb 2010 10:24

1 Attachment(s)
hi, this hack work on vb4.0.2? please look my navbar,thx

PeteBlume 17 Feb 2010 11:23

Hey,

is there any possibility to restrict the Access to DownloadsII, if the user doesn't accept the Forum- Rules?

Thenk you

ProFifaLeagues 17 Feb 2010 11:29

superb mod many thanks installed!

Skyrider 17 Feb 2010 13:37

1 Attachment(s)
Here's a small bug for you (see attachment)

GeorgeB85 17 Feb 2010 13:48

Quote:

Originally Posted by FF|Skyrider (Post 1984548)
Here's a small bug for you (see attachment)

Not sure if this is on your end, or another mod is conflicting with this one, as I do not have this issue.

The alignment is a bit off which is a little odd.

Front Range 4x4 17 Feb 2010 14:08

Quote:

Originally Posted by Supramania (Post 1984247)
When I click on the "Manage Rules" link in the mod in the Admin CP, it opens the smile manager?

Happens to me too.

Skyrider 17 Feb 2010 14:13

I did noticed the following feature:
Quote:

Reset acceptance status when user received infraction
Would be great if we can set our own rules for them to read when a infraction has been given.

cloferba 17 Feb 2010 14:27

Quote:

Originally Posted by dacho (Post 1984339)
thanx man

Is it possible to allow the spider to skip the rules and explore the content?

yes! it should..

try to allow guest to see all the forums without accept rules (spiders are not registered)

i know a forum which has this mod (for 3.8.4) and spiders can explore all site

Skyrider 17 Feb 2010 14:50

Quote:

Originally Posted by cloferba (Post 1984592)
yes! it should..

try to allow guest to see all the forums without accept rules (spiders are not registered)

i know a forum which has this mod (for 3.8.4) and spiders can explore all site

Answer to Dacho:

Before Accepting Rules User Can Not --> View Forums [untag]

OR

Usergroups excluded from restrictions (comma separated ID list) --> 1 (unregistered users)

BUG
I've also found a bug! I just added a new rule and specified a forum. How ever, I removed it because people not withint that usergroup saw the rules! And now people within that section are stuck of accepting the same rules over and over again. how do I solve this?

Supramania 17 Feb 2010 15:59

Quote:

Originally Posted by Valter (Post 1984410)
Are you a member of usergroup 6-Admin?

You must be to access these pages...

Yes, I'm userid=1 as well.

PinkLiquorice 17 Feb 2010 18:14

Thank you!

Neptun 17 Feb 2010 20:45

great hack - i have been waiting for this ! i hope valter will fix the bugs soon that i can use the hack with my vb 4.x suite ;)

thxx for your work

TCB 18 Feb 2010 11:58

installing it as I type... thanks a lot :D

meschiash 18 Feb 2010 17:55

1 Attachment(s)
Super, great mod. Thanks.

For interested. Full polish language translation.

ndut 19 Feb 2010 01:53

nice

PeteBlume 19 Feb 2010 16:31

Anybody some ideas to integrate Downloads II with a Plugin?
It is realy possible for our forum, to restrict the access to Downloads II if rules not accepted... :(

Supramania 19 Feb 2010 16:54

Valter,

Any help for my issue?

Videx 21 Feb 2010 01:11

Quote:

Originally Posted by Supramania (Post 1986554)
Valter,

Any help for my issue?

http://www.vbulletin.org/forum/showp...&postcount=181

Videx 21 Feb 2010 01:15

I don't want my current users to have to accept the rules again. But the option "Reset Acceptance Status For All Members" doesn't make it clear if it's going to accomplish that if I press the button.

I mean, is there an option to set all current users as having accepted Rules?

Valter 21 Feb 2010 01:49

This is automatically done on upgrade. (General Rules).

"Reset Acceptance Status For All Members" will force them all to re-accept.

Videx 21 Feb 2010 01:54

Quote:

Originally Posted by Valter (Post 1987727)
This is automatically done on upgrade. (General Rules).

"Reset Acceptance Status For All Members" will force them all to re-accept.

That clears up what I suspected - "reset" in this case means to clear their prior acceptance.

But I'm sorry I don't understand about upgrading. I uninstalled all my add-ons when upgrading to 4.0.1, so I didn't actually 'upgrade' this mod, I installed it new. So they're all going to have to re-accept? Not a big deal, just wondering.

Neptun 21 Feb 2010 16:38

installed and nominated - i love this hack ! its the most usefull !

Question to coder:

Is there a possibility to add to the "Before Accepting Rules User Can Not" functions that the user can not see the CMS or blogs ?! this will be very userfull for me too !

ONE BUG !
HTML Code is not possible in the "Show 'More Rules' drop-down menu on Rules page" function - can you fix this ?! or is this not possible ?!

or can i display two rule sets together ?

ascott 21 Feb 2010 20:12

Quote:

Originally Posted by mitch84 (Post 1984423)
hi, this hack work on vb4.0.2? please look my navbar,thx

I get the same as mitch84, Forum Rules displays twice, seems to be a conflict with microNEWSLETTER. Turn off the newsletter and the Forum Rules displays correctly.
Any fix for this?

Videx 22 Feb 2010 02:34

Sure enough, this evening all hell broke loose as one old time member absolutely refused to 'sign' the rules, and told everyone she could to do the same (this mod doesn't prevent Shoutbox use). I think she feels she's being singled out. Ah well...

COL NIL SATIS 25 Feb 2010 14:41

Valter ...again my man...you are seriously blowing me away with these mods ..!! love it :)

steve71 27 Feb 2010 12:55

Great mod thanks....running on 4.0.2

SwollenCranium 27 Feb 2010 21:17

When I click on the "Manage Rules" link in the mod in the Admin CP, it opens the smile manager?

This has been noted several times by other people.

This ONLY seems to happen if I attempt to access that page while the hack is enabled. I'd prefer to be able to edit things while its NOT active .. ya know.

What is the fix for this?

GeorgeB85 27 Feb 2010 21:23

To everyone who has the issue with the smilies. Put this at the end of your domain misc.php?do=vsarules

GeorgeB85 27 Feb 2010 21:24

Quote:

Originally Posted by SwollenCranium (Post 1993180)

This ONLY seems to happen if I attempt to access that page while the hack is enabled. I'd prefer to be able to edit things while its NOT active .. ya know.

What is the fix for this?

If you don't have the hack enabled, and go to the part of your site where the forum rules would generally show, you will get the smiley's page. The only way to correct this as of right now is to have the hack enabled,

BlackJacket 28 Feb 2010 18:48

I do not see the force users to read the rules again option on the user's profile. This mod was installed but i did not force everyone to read the rules so could it be that the user's have not accepted the rules so therefore i cannot force them to accept?

Also when i have the add forum rules to navbar enabled, it will double (showing 2 forum rules) when viewing profiles, etc...

Thanks :)

gyaronn 28 Feb 2010 19:21

thank you

SwollenCranium 01 Mar 2010 01:13

Quote:

Originally Posted by GeorgeB85 (Post 1993191)
If you don't have the hack enabled, and go to the part of your site where the forum rules would generally show, you will get the smiley's page. The only way to correct this as of right now is to have the hack enabled,


Yeah .. gee thanks guy, this is EXACTLY what I said.

Uninstalled. :down:

Videx 01 Mar 2010 01:53

Quote:

Originally Posted by SwollenCranium (Post 1994144)
Yeah .. gee thanks guy, this is EXACTLY what I said.

Uninstalled. :down:

Yes, it's kind of ridiculous to install a Rules mod and then want to have it disabled while you debate the rules that will go in it. In our case we've got a working set of rules so it was a simple matter to copy and paste them into this mod as soon as I installed it.

Valter 01 Mar 2010 20:17

Quote:

Originally Posted by SwollenCranium (Post 1994144)
Uninstalled. :down:

Thank You.

Trumpetrhapsody 01 Mar 2010 21:17

Any update on getting ordered lists working?

It's nice to be able to tag someone and say "You broke rule number X". Right now neither BBcode nor HTML will put numbers in front of text.

Videx 01 Mar 2010 21:27

Quote:

Originally Posted by Trumpetrhapsody (Post 1994706)
It's nice to be able to tag someone and say "You broke rule number X". Right now neither BBcode nor HTML will put numbers in front of text.

Good point; our main 19 rules are all numbered, and there are a few numbered lists in subsections. It's really not that difficult to do by hand.

Trumpetrhapsody 01 Mar 2010 21:31

Quote:

Originally Posted by Videx (Post 1994716)
It's really not that difficult to do by hand.

No no, I'm saying it won't LET me do it by hand... I've tried the[*] notation, and disabled BBcode and used <ul><li></li></ul> and neither work.

SwollenCranium 01 Mar 2010 23:03

Quote:

Originally Posted by Valter (Post 1994680)
Thank You.


Most welcome.

Videx 01 Mar 2010 23:23

Quote:

Originally Posted by Trumpetrhapsody (Post 1994721)
No no, I'm saying it won't LET me do it by hand... I've tried the[*] notation, and disabled BBcode and used <ul><li></li></ul> and neither work.

1) Have you tried
2) simply writing
3) the numbers
4) by hand?

Valter 01 Mar 2010 23:23

Quote:

Originally Posted by Trumpetrhapsody (Post 1994706)
Any update on getting ordered lists working?

Bug confirmed. BB Parsing works for other codes, but not for[LIST], which is strange, but I'll check this when I have some time. Please be patient, I have busy days again...

Trumpetrhapsody 01 Mar 2010 23:47

Quote:

Originally Posted by Videx (Post 1994795)
1) Have you tried
2) simply writing
3) the numbers
4) by hand?

Oh... well that's cheating :P

Quote:

Originally Posted by Valter (Post 1994796)
Bug confirmed. BB Parsing works for other codes, but not for[LIST], which is strange, but I'll check this when I have some time. Please be patient, I have busy days again...

Awesome, thanks. Just wanted to make sure it was acknowledged and in the works.

Alibass 02 Mar 2010 02:34

Is there a log to the members who agree to the rules and if so how do you get to it?

Valter 02 Mar 2010 23:24

There is no such log, but you can view in member profiles if they agreed and with which rule sets.

TimberFloorAu 05 Mar 2010 11:20

Any fix for this yet Valter.

All we get is Smilies showing.

GeorgeB85 05 Mar 2010 13:07

Quote:

Originally Posted by TimberFloorAu (Post 1997663)
Any fix for this yet Valter.

All we get is Smilies showing.

Enable the product. All you will get is smilies if the mod is disabled via admincp.

TimberFloorAu 05 Mar 2010 13:26

It is disabled, and no issues.

It is when it is enabled we have the smilies

TimberFloorAu 05 Mar 2010 13:50

1 Attachment(s)
Ok I have recoded it.

It should now work.

Upload > allow overwrite

Delete the colour value for the forum navbar link.

Apart from that working A1 for us ;)

TimberFloorAu 05 Mar 2010 20:41

New Product uploaded 7:39am ( Check Post Above )

Fixes menu issue of the ( >Forum Rules ) now appears as ( Forum Rules )
Fixes the Smilies Issue. Edited php code which wasnt written correctly.

30 Members have tested our edited version so far, not a problem yet, and no smilies ;)

* to fix: redirect url on rules acceptance.

adreen 06 Mar 2010 12:47

Quote:

All posts must be written in English.
Don't spam/abuse any other member via e-mail or Private Messages.
how to change this?
my forum is not in english language
i only need the members to abide the rules in a certain forums only, not all forum.

Videx 06 Mar 2010 15:09

Quote:

Originally Posted by adreen (Post 1998405)
how to change this?
my forum is not in english language
i only need the members to abide the rules in a certain forums only, not all forum.

Obviously you're supposed to enter your own rules. Use the link at the bottom of the Options - "Manage Rules".

nci 07 Mar 2010 03:11

Cool,Installed,Thanks a lot .

Chickenpotpie 07 Mar 2010 19:37

I'm going to tag this for now, but looks like something I would really need to implement.

-CP

TimberFloorAu 07 Mar 2010 21:01

Quote:

Originally Posted by Chickenpotpie (Post 1999299)
I'm going to tag this for now, but looks like something I would really need to implement.

-CP


If you get issues with Smilie page showing: replace product with this http://www.vbulletin.org/forum/showp...1&postcount=65

and await proper update from Valter. We have this working 100% now

Fastbird 08 Mar 2010 01:01

For some reason, I'm getting a ton of users emailing me saying that they are forced to view the rules, which I have that set up that way, and are saying that the button to accept them is not showing up.

Is this a known issue?

TimberFloorAu 08 Mar 2010 01:20

Quote:

Originally Posted by Fastbird (Post 1999505)
For some reason, I'm getting a ton of users emailing me saying that they are forced to view the rules, which I have that set up that way, and are saying that the button to accept them is not showing up.

Is this a known issue?

I dont see it either.

In the product file:

What do you have at line 151


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

This is our code ( which we redid to get it working )

milaszewski 08 Mar 2010 10:09

Unfortunately this mod doesn't work well with CMS comments. It is probably a good idea to exclude forum VBCMS comments from the rules.

stator 12 Mar 2010 13:05

How Can I enable my moderators to use this function ?

Thnx in advance

War.Frog 12 Mar 2010 15:47

Quote:

Originally Posted by TimberFloorAu (Post 1999354)
If you get issues with Smilie page showing: replace product with this http://www.vbulletin.org/forum/showp...1&postcount=65

and await proper update from Valter. We have this working 100% now

What was your fix for this? There's a similar issue with Valter's Advanced Registration hack - the Smilie FAQ shows up no matter what link I click. This definitely sounds related.

TimberFloorAu 12 Mar 2010 23:03

Quote:

Originally Posted by War.Frog (Post 2002222)
What was your fix for this? There's a similar issue with Valter's Advanced Registration hack - the Smilie FAQ shows up no matter what link I click. This definitely sounds related.


His php code is screwed up, so i re did it :)

Have you used my fix ? it should work 100%

War.Frog 13 Mar 2010 01:26

Quote:

Originally Posted by TimberFloorAu (Post 2002458)
His php code is screwed up, so i re did it :)

Have you used my fix ? it should work 100%

Your fix is for the advanced forum rules hack though. There's a similar issue with the Advanced Registration hack (going to the smilies page). Is there something I can change to fix that hack too?

TimberFloorAu 13 Mar 2010 02:01

Check back in this thread, I listed the fix i did for firebird ( cant remember their name )

Fix failed
by letusdazzleu
22 Mar 2010 01:27

Did anyone get this working? I applied the latest file and also tried the fix but still get the smilies if I turn the mod off.

IF I turn the mod on, I get this....


Warning: array_merge() [function.array-merge]: Argument #1 is not an array in [path]/global.php(355) : eval()'d code on line 158

Fatal error: Class 'vB_Template' not found in /home/<myroot>/public_html/<my folder>/misc.php(100) : eval()'d code on line 952

GeorgeB85 22 Mar 2010 04:15

I dont get why you all are having so many issues. Check your other mods, perhaps that is where the issue is laying because all of his mods work great for me.

losedude 23 Mar 2010 16:38

I've found a minor problem which I need to fix. I have a black forum theme, the text "I have read, and agree to abide by the XXXX rules" is shown in black, making it impossible to read, how can I change the font color ?

Videx 23 Mar 2010 21:09

Quote:

Originally Posted by losedude (Post 2008818)
I've found a minor problem which I need to fix. I have a black forum theme, the text "I have read, and agree to abide by the XXXX rules" is shown in black, making it impossible to read, how can I change the font color ?

Discounting the bug in lists, just use bbcode. But even in lists html should work.

http://www.google.com/search?q=how+change+color+bbcode
http://www.google.com/search?q=how+change+color+html

munsonfan15 24 Mar 2010 13:20

I installed this but when I try to assign a rule set to a forum it wont save. I click on the forum I want it in, then hit submit. The page reloads and nothing is checked off - this results in people have to accept the ruls no matter what forum they are in. Any help with this?

munsonfan15 25 Mar 2010 17:00

??????

GeorgeB85 26 Mar 2010 02:54

Valter:

Is there any way currently or a future upgrade that will make new registered users accept forum rules/guidelines before doing anything on the forum.

I am learning that the rules only covers the forum and I think user profiles, but that is all. Is there a way to ensure it covers the entire site?

losedude 28 Mar 2010 15:38

Quote:

Originally Posted by Videx (Post 2008953)
Discounting the bug in lists, just use bbcode. But even in lists html should work.

http://www.google.com/search?q=how+change+color+bbcode
http://www.google.com/search?q=how+change+color+html


Yes but where am I supposed to edit the code ?

The message " I have read, and agree to abide by the rules" >> Check box on the side & submit button, aren't in the HTML code with the rest of the rules.

Videx 28 Mar 2010 16:00

Quote:

Originally Posted by losedude (Post 2011643)
Yes but where am I supposed to edit the code ?

The message " I have read, and agree to abide by the rules" >> Check box on the side & submit button, aren't in the HTML code with the rest of the rules.

Most everything in vb is in phrases. AdminCP>Languages and Phrases>Search in Phrases.

nkumaran 28 Mar 2010 17:11

Great mod, thnx.

losedude 28 Mar 2010 21:02

Thanks Videx :)

TCB 30 Mar 2010 22:06

Thanks :D

There's one thing not working: the ordered list isn't showing. When I add the code for the ordered listing, after submitting this listing, it doesn't show. But I see in this topic that this problem has already been submitted weeks ago.

Does this work with other people? I think it's an important part of showing the rules, since this is basically always a sorted list?

BiZiMDiYaR 02 Apr 2010 20:41

Hi,

Strangly I as admin see the rules... but I can't accept them. Other users don;t even see the rules, let alone to accept them :).

Why is this.. ? Any idea.. I logged in as a user, clicked on the forum rules and the page did not display the accept rules page and also didn't show the rules... but when I look at users profile, you can see that see didn;t accept the forum rules.. So strange :).

Should I reinstall this .. ? or.. ?

Thanks.

BiZiMDiYaR 08 Apr 2010 23:21

No Update ?

fluidswork 09 Apr 2010 17:33

Just awesome

CvP 10 Apr 2010 07:24

I want to install this but can someone tell me if there's any other problem/bug than that ordered list not working?

djbaxter 15 Apr 2010 10:55

Quote:

Originally Posted by Trumpetrhapsody (Post 1994706)
Any update on getting ordered lists working?

It's nice to be able to tag someone and say "You broke rule number X". Right now neither BBcode nor HTML will put numbers in front of text.

Quote:

Originally Posted by Videx (Post 1994716)
Good point; our main 19 rules are all numbered, and there are a few numbered lists in subsections. It's really not that difficult to do by hand.

Quote:

Originally Posted by Trumpetrhapsody (Post 1994721)
No no, I'm saying it won't LET me do it by hand... I've tried the[*] notation, and disabled BBcode and used <ul><li></li></ul> and neither work.

Quote:

Originally Posted by Valter (Post 1994796)
Bug confirmed. BB Parsing works for other codes, but not for[LIST], which is strange, but I'll check this when I have some time. Please be patient, I have busy days again...

Quote:

Originally Posted by TCB (Post 2013105)
Thanks :D

There's one thing not working: the ordered list isn't showing. When I add the code for the ordered listing, after submitting this listing, it doesn't show. But I see in this topic that this problem has already been submitted weeks ago.

Does this work with other people? I think it's an important part of showing the rules, since this is basically always a sorted list?

This isn't a problem with Valter's mod, since it happens on two other mods I wanted to install plus a custom static page I created myself. I don't know the solution but the problem is with the vBulletin 4.x code or CSS, which effectively cripples certain features including ordred or unordered lists.

Whether this is a bug or by design isn't clear, although if the latter I cannot understand the rationale for disabling certain BBCode or HTML features.

New Version!
by Valter
18 Apr 2010 13:37

v5.0.1 - Apr 18. 2010.
-Fixed: Link to Rules in forumdisplay
-Fixed: Ordered list parsing in Rules

To upgrade:
-Import XML, allow overwrite
-If you have modified product templates, revert them

djbaxter 18 Apr 2010 16:08

Quote:

Fixed: Ordered list parsing in Rules
How did you do this?

I have another mod and a custom page where this isn't working...

BiZiMDiYaR 18 Apr 2010 16:38

Hi,

I have installed this and no problems, but I am not able to get the users to see the accept forum rules button... I have checked this also with another nick, but still it only shows, user has not accepted the forum rules...

Even when I click on the forum rules link, I just see the link, but nothing to accept the forum rules, is this correct ???

Thanks.

p.s. I have also done a full reset, sothat everybody needs to accept it again, but this also didn't work. Any clue ?

steve1966 18 Apr 2010 17:07

Quote:

Originally Posted by BiZiMDiYaR (Post 2023231)
Hi,

I have installed this and no problems, but I am not able to get the users to see the accept forum rules button... I have checked this also with another nick, but still it only shows, user has not accepted the forum rules...

Even when I click on the forum rules link, I just see the link, but nothing to accept the forum rules, is this correct ???

Thanks.

p.s. I have also done a full reset, sothat everybody needs to accept it again, but this also didn't work. Any clue ?

Hello its working ok on my forum thanks valter


All times are GMT. The time now is 04:31.

Powered by vBulletin® Version 3.8.14
Copyright © 2021, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.