vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=327637

PHP Code error
by Hostboard
08 Nov 2019 00:22

Upgraded my server to PHP 7.1 and found Project Tools has at least 1 compatibility issue and was hoping someone could assist in correcting it

The error
[] operator not supported for strings on line 448 in /home/hostboard/public_html/forums/issuelist.php
#0 {main}


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

The issue I believe is the last line and the [].

x iJailBreak x 16 Nov 2019 00:52

Quote:

Originally Posted by Hostboard (Post 2601170)
Upgraded my server to PHP 7.1 and found Project Tools has at least 1 compatibility issue and was hoping someone could assist in correcting it

The error
[] operator not supported for strings on line 448 in /home/hostboard/public_html/forums/issuelist.php
#0 {main}


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

The issue I believe is the last line and the [].

Looks like $post_issue_options is already defined as a string. I assume this is present in the latest build of Project Tools? I'll spin it up in my 7.3 environment and see if I can figure it out if so.

Hostboard 17 Nov 2019 20:50

Quote:

Originally Posted by x iJailBreak x (Post 2601244)
Looks like $post_issue_options is already defined as a string. I assume this is present in the latest build of Project Tools? I'll spin it up in my 7.3 environment and see if I can figure it out if so.

If you need a copy of PT 2.3.1 let me know...


All times are GMT. The time now is 22:08.

Powered by vBulletin® Version 3.8.14
Copyright © 2020, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.