vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=228618

New Latest Album Pictures - Forum Home
by Atakan KOC
22 Nov 2009 17:46

2 Attachment(s)
NEW Latest Album Pictures - Forum Home

It shows the pictures added to the albums on the main page. It shows only the public mentioned files. If not shows the reasons are: vbulletin settings show albums must be enabled.

The user grup that owns the pictures must be enabled show picture setting. Or there is no picture to show.

Additionally you can slect the number of pictures that can be shown.

Hope it works for you as I like it very much.

install

Go to your admin cp, then:
Plugin System -> Manage Products -> [Add/Import Product] -> Select 'product-newalbum.xml' from your computer then press 'Import'

Modifications Info

Plugin : 2
Phrases : 9
Template : 2
Setting : 3
Query : 1 Query

Latest Posts Setting

Go to your admin cp, then:
vBulletin Options -> New Album Picture ->

Versions:
v1.0 -First release

DiLSuZ 22 Nov 2009 17:54

Thanks Atakan Bey .. :)

rtyagis 22 Nov 2009 18:57

Reserved for future. :up:

The Coon 22 Nov 2009 19:32

Works fine. THX!

Suggestion: Display of the names/descriptions of the photos under them?

Atakan KOC 22 Nov 2009 19:46

Quote:

Originally Posted by The Coon (Post 1919045)
Works fine. THX!

Suggestion: Display of the names/descriptions of the photos under them?

future....

The Coon 22 Nov 2009 19:48

I will be patient ... ;)

Veer 22 Nov 2009 19:52

Can we show the pictures in different sections like Navbar Bellow, Forums Above, Forums Below etc?

forumsonsuz 22 Nov 2009 22:16

teşekkürler atakan

halkum 22 Nov 2009 22:19

Now we just need the "All Albums" mod.

gator777 22 Nov 2009 22:39

Quote:

Originally Posted by Veer (Post 1919063)
Can we show the pictures in different sections like Navbar Bellow, Forums Above, Forums Below etc?

Yes, please! That would be nice. :D

Zaiaku 23 Nov 2009 00:22

Quote:

Originally Posted by Veer (Post 1919063)
Can we show the pictures in different sections like Navbar Bellow, Forums Above, Forums Below etc?

+1 on that one please! I would really like this.

yilmaz 23 Nov 2009 01:16

İşte Atakan KOÇ farkı;
That difference Atakan KOC;

Dr.osamA 23 Nov 2009 01:27

Waiting for the latest version of the full advantages

thnk you man

MikesSite 23 Nov 2009 01:33

Looks good, can't wait for some more options! Also want to be able to move this below the navbar.

masons 23 Nov 2009 05:43

Below navbar is a must for a mod like this,

But I am very happy to finally see something for the albums, it seems like vb4 does not care about the albums at all.

Marek58 23 Nov 2009 09:17

1 Attachment(s)
Polish version


sematopdemir 23 Nov 2009 10:06

Thanks Atakan Bey

SİMAR 23 Nov 2009 17:49

Atakan KOC; thanks

obiefan 24 Nov 2009 19:25

Using the stock vb4 theme, this does not display on my forum home even though I have set the display album to "yes"

Any thoughts?

Zaiaku 25 Nov 2009 16:26

OK have a question, does this display the latest or random pics?

Title of the page says latest, the screensho says random.

VonDoom 28 Nov 2009 10:13

Quote:

Originally Posted by Zaiaku (Post 1920740)
OK have a question, does this display the latest or random pics?

Title of the page says latest, the screensho says random.

Either way its up to you. Just set it in options in your ACP

Display Type: Latest Picture or random picture

abroad 28 Nov 2009 12:37

This should be available for the frontpage on the CMS. Not for the forum where nobody can see it at the bottom.

gertoo 28 Nov 2009 20:44

Quote:

Originally Posted by abroad (Post 1922000)
This should be available for the frontpage on the CMS. Not for the forum where nobody can see it at the bottom.

I second that

Thanks for your work though.

Vaupell 28 Nov 2009 20:51

Quote:

Originally Posted by gertoo (Post 1922143)
I second that

Thanks for your work though.

Thinking as a widget so you can place it where you want.

mondiuk 28 Nov 2009 22:43

Something extra to use for forum home page.

Its grait but few more options to chose where you whant to show them like top or bottem will bee nice..

Nice job..

webspider 30 Nov 2009 03:13

Nice job! Maybe in future more advanced permissions like non paid users can see thumbs as well.

nicky.82uk 01 Dec 2009 00:47

nice work thx man

gurler 01 Dec 2009 03:41

is it available only for the registered users?
sadece kayıtlı kullanıcılar görebiliyor şuan için nasıl herkese açık yapabilirim bunu ?

Entonadoscl 02 Dec 2009 19:16

don't work for me...css box was completely deformed =(


vb4 beta 4 here

cyclical 02 Dec 2009 23:01

Works for me VB4 Beta 4 here...

I also would like the option to show it at the top of the forum instead of the bottom.

SonicGT 03 Dec 2009 22:29

Quote:

Originally Posted by cyclical (Post 1924313)
Works for me VB4 Beta 4 here...

I also would like the option to show it at the top of the forum instead of the bottom.

Agreed, or a way to custom place it into the page where you like.

cyclical 05 Dec 2009 15:52

Quote:

Originally Posted by SonicGT (Post 1924907)
Agreed, or a way to custom place it into the page where you like.

lol... I have a mustang website as well.

Definately having a few different options would be great.

SonicGT 05 Dec 2009 16:14

With beta 5 this mod is now missing some of the vb4 style, its missing the border properly

pozo 06 Dec 2009 16:05

Quote:

Originally Posted by SonicGT (Post 1925714)
With beta 5 this mod is now missing some of the vb4 style, its missing the border properly

Same problem...
Can somebody help us with a code fix? :confused:

BBR-APBT 06 Dec 2009 18:27

Quote:

Originally Posted by pozo (Post 1926295)
Same problem...
Can somebody help us with a code fix? :confused:

Replace the templates with the following code.

Template newalbum_print

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Template newalbum_picture

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


P.S. This will also add the code for the album name and the user the photo belongs too.

pozo 06 Dec 2009 18:36

Thank you so much, it looks perfect! :up: :up:

By the way... Is there any possibility to put that box above the forums/categories?

BBR-APBT 06 Dec 2009 18:46

Quote:

Originally Posted by pozo (Post 1926373)
Thank you so much, it looks perfect! :up: :up:

By the way... Is there any possibility to put that box above the forums/categories?

Sure, but this isn't my mod to post major changes to. I am sure when vbulletin 4.0 hits gold he will update this just as it was before so it has different places to put it.

I think he left it limited for the vBulletin beta releases. He already had the code in place to display the album name and album owner. I just added the code to the template on my fix for beta5.

I was just trying to help with a fix till this mods coder gets around to update it.

MrEyes 07 Dec 2009 20:49

Unless I am missing something, which is entirely possible, the mod doesn't currently respect profile privacy settings. As an example, if a member selects that only friends can see their album the thumbnails from that album may still be displayed. Arguably if the member has selected that option then the thumbnails shouldn't be displayed either.

To fix this the main SQL select needs to change to include:

LEFT OUTER JOIN profileblockprivacy AS pbp ON (pbp.userid = album.userid AND pbp.blockid = 'album')

and

AND (pbp.requirement = 0 OR pbp.requirement IS null)

odonel 08 Dec 2009 14:04

it messes the layout on fixed width forum if more than 3 pictures, any fix ?

BBR-APBT 09 Dec 2009 18:17

Is any one else having a problem with the all images not loading every time? On every page reload I have at least one image not load.

odonel 09 Dec 2009 18:42

I do too apbt

iadmirevb 11 Dec 2009 04:07

The display of the names/descriptions,etc of the photos should be on a nice tooltip effect... you already the yui library... it´s more elegant ...

lovechandigarh 12 Dec 2009 08:01

We'll appreciate if you update the product for the latest vb4 version.

cyclical 12 Dec 2009 19:42

Quote:

Originally Posted by lovechandigarh (Post 1929197)
We'll appreciate if you update the product for the latest vb4 version.


I agree :)

BBR-APBT 12 Dec 2009 20:29

It works just fine on RC2, Just replace the code I posted above for the templates.

wildweaselmi 17 Dec 2009 14:19

Thanks for the mod... I have it installed and like it.

If I could improve it I would:
1. Have an option to have it on my CMS as well
2. Have the ability to restrict to certain albums (this would be WAY COOL)

Thanks again... very happy it doesn't show private albums, this would be devestating

laddo 17 Dec 2009 15:13

Caused a database error for me.

RK1gaming 17 Dec 2009 16:02

it would be great if you could code it so we can decided where to place it like

Below Navbar
Above Forums
Below Forums
Below Who's Online

and able to assign permissions to it

pozo 18 Dec 2009 12:05

Little problem...
Since I've installed this mod, all members on forumhome have the status "watching attachment" in who's online...
Is there any possibility to fix the problem?

Dexter55 19 Dec 2009 16:42

Hello !

First, congratulations for your work, it's a great mod.

I'm running RC4, and actually the mod isn't taking the CSS style, i hope you update it.

:)

abroad 19 Dec 2009 18:30

this mod overlaps the right and left borders of the "What's Going On?" Box. Can you fix this?

Easific 21 Dec 2009 10:14

Quote:

Originally Posted by wildweaselmi (Post 1932188)
Thanks for the mod... I have it installed and like it.

If I could improve it I would:
1. Have an option to have it on my CMS as well

This would be nice to have along with the ability to publish it below the navbar.

fayax 21 Dec 2009 17:56

Excellent Mod!

This might be slightly off topic but maybe someone can help me.
There was this other mod that would make "whats going on?" stretch all the way across the width of the website. Can you show me which one it was so my latest album pics looks better.

BBR-APBT 21 Dec 2009 19:20

Quote:

Originally Posted by fayax (Post 1934639)
Excellent Mod!

This might be slightly off topic but maybe someone can help me.
There was this other mod that would make "whats going on?" stretch all the way across the width of the website. Can you show me which one it was so my latest album pics looks better.

http://www.vbulletin.org/forum/showt...43#post1933943

VonDoom 21 Dec 2009 19:52

This has always been one of my favorite addons but serves no real purpose in WGO. i suppose i need to get off my lazy butt and look at the guts of this XML, and see what can be done about that.

compact123 23 Dec 2009 00:58

please update it for vb4 gold :)

dcuellar 24 Dec 2009 01:31

Would be cool to have this look nicer. It just looks like it doesn't go there. I don't know, call me stupid.

pozo 24 Dec 2009 02:07

Quote:

Originally Posted by dcuellar (Post 1936903)
Would be cool to have this look nicer. It just looks like it doesn't go there. I don't know, call me stupid.

The following post should help you :)


Quote:

Originally Posted by BBR-APBT (Post 1926370)
Replace the templates with the following code.

Template newalbum_print

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Template newalbum_picture

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


P.S. This will also add the code for the album name and the user the photo belongs too.


dcuellar 24 Dec 2009 02:20

Quote:

Originally Posted by pozo (Post 1936911)
The following post should help you :)

Anyone have a pic of what this looks like?

pozo 24 Dec 2009 02:22

1 Attachment(s)
Quote:

Originally Posted by dcuellar (Post 1936914)
Anyone have a pic of what this looks like?

See attachment
It fits very nice into the WGO-Box :)

dcuellar 24 Dec 2009 02:32

Thank you. I will reinstall it now.

dcuellar 24 Dec 2009 02:57

2 Attachment(s)
Here's what I did.

Replace contents of template newalbum_print with (same as before):

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Replace contents of template newalbum_picture with:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.



And put the attached image within your 'root/images/misc' directory.

M3xital 24 Dec 2009 10:03

Thanks Atakan!!

skariko 24 Dec 2009 11:02

It doesn't work on my VB 4.0 Gold.

Doctor Death 24 Dec 2009 11:29

Great mod. Could you please put in the gray lines on the left and right to match the VB template? Thanks again, great work.

maximutt 26 Dec 2009 09:49

Can someone confirm that this is working on vB 4.0 Gold?

junaid 26 Dec 2009 10:36

How I can set thumbnails pixel ?

Smiler2009 26 Dec 2009 12:13

Quote:

Originally Posted by maximutt (Post 1938466)
Can someone confirm that this is working on vB 4.0 Gold?

Definately works as advertised here vB 4 PL1

So glad to see this mod arrive, just need the "All Albums" Mod now or an update from vB to the album system and it will be really good.

Jeff

radmoose 26 Dec 2009 12:40

Installed...

A few things come to mind...

  • All of the images have an alt tag of "269". Would prefer it to be photo info such as username, album name and photo name.
  • Would like to see the username and album name below each picture.
  • Would prefer a set height instead of free flowing the images in.
  • Add separator line below section.

Zaiaku 26 Dec 2009 15:46

Still working fine for me on vb4 Gold PL1 although you need to update the auto template since that part of vb css was changed.

movslow 27 Dec 2009 06:19

What does it take for this to show under the navbar?

voglermc 27 Dec 2009 12:30

Quote:

Originally Posted by movslow (Post 1939149)
What does it take for this to show under the navbar?

+1 for this feature

Veer 27 Dec 2009 15:08

+2 for this

pozo 28 Dec 2009 01:29

Quote:

Originally Posted by Veer (Post 1939384)
+2 for this

+3 for this

movslow 28 Dec 2009 05:45

Quote:

Originally Posted by pozo (Post 1939831)
+3 for this

+4, lol.
:up:

Doctor Death 28 Dec 2009 16:14

1 Attachment(s)
Would really like to see the gray lines on the left and right be restored if at all possible.

kf4eok 28 Dec 2009 17:33

I like this
installed

radmoose 28 Dec 2009 22:16

One other suggestion...

The Product URL and Version Check URL should be filled in so it would be easy to find updates.

movslow 29 Dec 2009 18:44

Quote:

Originally Posted by movslow (Post 1939149)
What does it take for this to show under the navbar?

Updates in regards to this matter?

movslow 02 Jan 2010 02:11

Bump ?
:confused:

TrailRecon 02 Jan 2010 02:41

Quote:

Originally Posted by dcuellar (Post 1936934)
Here's what I did.

Replace contents of template newalbum_print with (same as before):

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Replace contents of template newalbum_picture with:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.



And put the attached image within your 'root/images/misc' directory.

Awesome! thank you for that..looks great!

I added {vb:raw lpicture.title} as the alt. For some reason I could not get the caption rawphrase to operate for the alt. any ideas?

And for anybody that has their thumps set larger you can add height="70px" to the image anchor to force the size

Thanks once again guys! <clicks installed>

Preserved-steam 03 Jan 2010 00:37

Quote:

Originally Posted by Doctor Death (Post 1940424)
Would really like to see the gray lines on the left and right be restored if at all possible.

Im having the same problem, but ive seen that other people are not having a problem so im not sure, does anyone have an idea why this is happening?

TrailRecon 03 Jan 2010 03:54

Might want to take a look again at post 34 and 35 :D

kkKunan 03 Jan 2010 19:28

Thanks!!:up:

movslow 03 Jan 2010 19:44

Quote:

Originally Posted by movslow (Post 1944463)
Bump ?
:confused:

Nobody care?

garretbyrne 03 Jan 2010 20:12

Quote:

Originally Posted by TrailRecon (Post 1944492)
Awesome! thank you for that..looks great!

I added {vb:raw lpicture.title} as the alt. For some reason I could not get the caption rawphrase to operate for the alt. any ideas?

And for anybody that has their thumps set larger you can add height="70px" to the image anchor to force the size

Thanks once again guys! <clicks installed>

Hi I was wondering where would I edit the settings?? Is it in the xml or some template but what is the template called..

Cheers Mate

TrailRecon 03 Jan 2010 22:13

Quote:

Originally Posted by garretbyrne (Post 1946195)
Hi I was wondering where would I edit the settings?? Is it in the xml or some template but what is the template called..

Cheers Mate

well, for settings you would go to admincp>Settings>OPtions>Newalbum Picture

for template information, see the other previous posts. They listed the templates for different alterations.

+1 to the OP for uploading this. Thank you

garretbyrne 05 Jan 2010 00:31

I don't know where the templates are located thats my issue..

Cheers

[EDIT] I've found the templates and made the change.. for others who might be lost the templates mentioned are location in New Posting Templates..

Cheers

abdulbasitsaeed 05 Jan 2010 06:05

Installed and works fine. Hope that the author would be releasing a version with all the above mentioned fixes in it too. :)

Quote:

Originally Posted by BBR-APBT (Post 1926370)
Replace the templates with the following code.

Template newalbum_print

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Template newalbum_picture

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


P.S. This will also add the code for the album name and the user the photo belongs too.

Thank you very much for this fix. :)

movslow 06 Jan 2010 18:27

Bump for updates.

compuminus 09 Jan 2010 01:04

Yes, please update. This does not work in vB 4 Gold. An error in the formatting causes it to be placed on top of everything in the "What's Going On" box.

Also, it would be nice if the version for vB 4 had all of the functionality of your earlier release for vB 3.8. This includes being able to choose the location, such as the "navbar below", "forums below", etc. options from before.

It's a very useful and simple add-on . . . if it only worked . . .

Zaiaku 09 Jan 2010 01:15

It does work on Gold. Too many people have it installed for it not too, including my self. I have 3 sites running vb4 gold pl1 and its working just fine.

compuminus 09 Jan 2010 02:11

OK, it is running better than I thought, but there's still one incompatibility:

The container div that is added needs to have class="wgo_subblock" in addition to the existing id="wgo_onlineusers". Depending on your style settings, this missing class can cause the album photos block to look odd compared to the other content . . .

svoeric 09 Jan 2010 02:42

would like to see an option to have it on CMS pages as well (maybe this would be a widget ?)

also, gotta have that option to move it to the top.
Thanks for the mod, works great!

microlight 09 Jan 2010 11:29

I agree wholeheartedly I would like to see this as a widget for the CMS

COL NIL SATIS 09 Jan 2010 15:53

installed but the bottom of the forum breaks up???

aberg 09 Jan 2010 21:41

I don't see the thumbnails (only red cross) in vbulletin 4 gold

jandb 10 Jan 2010 22:40

Would like this to be under the nav bar. Any idea when this will be updated?

COL NIL SATIS 10 Jan 2010 22:48

Quote:

Originally Posted by compuminus (Post 1950791)
OK, it is running better than I thought, but there's still one incompatibility:

The container div that is added needs to have class="wgo_subblock" in addition to the existing id="wgo_onlineusers". Depending on your style settings, this missing class can cause the album photos block to look odd compared to the other content . . .

where would i add that??

gbechtel 11 Jan 2010 00:44

Quote:

Originally Posted by compuminus (Post 1950791)
OK, it is running better than I thought, but there's still one incompatibility:

The container div that is added needs to have class="wgo_subblock" in addition to the existing id="wgo_onlineusers". Depending on your style settings, this missing class can cause the album photos block to look odd compared to the other content . . .


Agreed, for those that need this in template newalbum_print

Find:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Change to:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.



All times are GMT. The time now is 18:20.

Powered by vBulletin® Version 3.8.13
Copyright © 2019, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.