vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=327081

Locked out of my server and nobody knows why.
by Scalemotorcars
07 Feb 2019 16:08

Ok, so I'll try and condense this. A few days ago I got locked out of my hosting and nobody can figure out why. My site still works fine its just MY IP that can't access any part of the server. I have other programs running on the server and I can't access those either. I also can't access Cpanel, and I can't FTP into the hosting. (this eliminates an htaccess block, besides I haven't messed with those files in years.)

If I VPN I can get to my site and its CP but it's a huge pain the *** This is what's been checked.

As mentioned above I can get my site & CP using an online VPN (I don't use a VPN normally) I didn't accidentally ban my IP and I even completely turned off IP banning, cleared the cache and no luck still locked out.

I've tried three browsers, all cleared cache, and no luck.

I rebooted my PC three times because why not. No luck...

I made sure all adblocking was disabled and again cleared cache and nothing.

I have a DNS trap and turned it off and nothing. I even removed it from my network and still nothing.

I've fully reset my modem/router and spent 2 hours on the phone with my internet providers top tech resetting everything and still no luck.

I've hardwired around the router bypassing any wifi and nothing.

I disabled plugins and nothing. (by the way, all the plugins have been running on the site for years).

I tried to Ping the server from my CMD and failed every time.

The only thing that changed on the site in months is a few CSS tweaks to clean up some of the divs.

Now the main event recently is my site was hit with a DOS attack about a week ago but I blocked all the IP's causing the attack. Again I made sure 100% none of them were from me or my server/hosting. Besides, I used the site for about a week before I couldn't access it so that's not it. And again I completely disabled the IP blocking and I was still locked out.

I also get hit by Registration Spam bots every few minutes almost every day. I was going to make some changed to register.pho but as mentioned I can't get to any of the files or Cp to do it effectively and I didn't make any changes to it before being locked out.

Did I mention that my hosting has gone over all there DNS blocking and reset all passwords to their servers and they can't find the issue either. They are still working on it but Its been 2 days with no updates.

So, in short, My IP and my servers IP refuse to talk to each other. If I go to Starbucks it works fine. If I use my Cellphones data plan it works fine. Its just my physical IP thats locked out.

Does anyone have any idea what else I could check?

[email protected] 07 Feb 2019 16:39

Being locked out of CPanel would indicate a CPhulk or CSF block on your IP.

If you have SSH access you can check the CSF status of the affected IP with

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Replace 127.0.0.1 with the affected IP

Scalemotorcars 07 Feb 2019 17:13

I know they checked the CSF for a block on the IP and didn't see anything. They also mentioned checking a higher level block and it didn't show anything either. Not sure what a CPHulk it Ill pass that along to the hosting.

As for SSH, I have no clue how to set that up. I didn't think you could SSH into a server remotely.

--------------- Added 07 Feb 2019 at 18:03 ---------------

I tried to SSH into the server with Putty and it timed out like everything else.

final kaoss 07 Feb 2019 18:34

If you're certain that it's CPHulk, then have a look at this. (You'll have to ask your host to follow those steps or DiY with a vpn)
https://help.crucial.com.au/hc/en-gb...rom-my-server-

Alan_SP 07 Feb 2019 20:08

To me, it's looking like your IP's blocked on server level.

It can be done in multiple ways, so I can't say how exactly is in your case, but I'd would look on server level, not forum level.

The usual suspect is firewall (on server level, i.e. IPtables).

Scalemotorcars 07 Feb 2019 20:11

Well, that didn't work. I can't VPN into Cpanel it has some kind of block on it also. All I get is a white page.

I tried several times to SHH and nothing. I tried with Putty and Filezilla. Nothing on either. they just time out.

For now, I'll send the info on CPHulk to the host. Not sure why it would block me since I never failed any of the login attempts. Everything was working fine then all of a sudden blocked.

Any other ideas?

--------------- Added 07 Feb 2019 at 20:13 ---------------

Quote:

Originally Posted by Alan_SP (Post 2598420)
To me, it's looking like your IP's blocked on server level.

It can be done in multiple ways, so I can't say how exactly is in your case, but I'd would look on server level, not forum level.

The usual suspect is firewall (on server level, i.e. IPtables).

That's what I was thinking also. I've already had the tech at my hosting check the server level IP blocking and he couldn't find anything. He also checked a higher level admin blocking and couldn't find it there either.

snakes1100 07 Feb 2019 21:24

The only FW on a cpanel box by default is cphulk, so if yo udidnt have him whitelist your IP there, then you should, along with CSF if you installed it.

Id have him disable cphulk, csf & the OS's defautl FW just incase it some how got activated as well, as you didnt list what OS it has on it.

blind-eddie 09 Feb 2019 02:19

I had a similar incident. Turns out my ip was blacklisted due to not having a static ip.

Do a tracert, if you are blacklisted, your hops will fail just before your host.

Scalemotorcars 09 Feb 2019 14:24

Quote:

Originally Posted by blind-eddie (Post 2598431)
I had a similar incident. Turns out my ip was blacklisted due to not having a static ip.

Do a tracert, if you are blacklisted, your hops will fail just before your host.

I did a tracert and that narrowed it down. It looks like one of the nodes before my server has blacklisted my IP. No clue if it has anything to do with it being static or not. Still waiting on the host to whitelist.

Scalemotorcars 11 Feb 2019 21:22

My hosting finally whitelisted my IP for the server blocking it. Turned out it was a node before my server that blacklisted me. Thanks again to everyone for their suggestions.


All times are GMT. The time now is 05:21.

Powered by vBulletin® Version 3.8.14
Copyright © 2020, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.