vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=326895

ibProArcade v2.7.6+ (released 11th November 2018)
by MrZeropage
11 Nov 2018 22:11

Dear ibProArcade-Fans,

this is another Update on the professional Arcade-System for vBulletin :cool:

I strongly recommend EVERYBODY to upgrade to this latest version v2.7.6+

Support is only provided if you use this latest release !

Get your copy of the new ibProArcade v2.7.6+ here

https://www.vbulletin.org/forum/external/2005/11/15.jpg

YES, ibProArcade has reached the modern standards and is now compatible to PHP 7 :cool:


Improvements:
* automatic detection for mysql/mysqli (take setting from vB /config.php)
* if you experience connection problems, set $CONNECTFIX to 1 (in /arcade.php)
(seems to be general problem with MariaDB ?)
* automatic Arcade-Tab in vB4 NavBar (working with vB 4.2 and later)
* username markup everywhere in ibProArcade (Usergroup-setting in vBulletin)
* improved check for updates in AdminCP>Arcade
* several small improvements to make the world a little better

Bugs fixed:
* AdminCP Mass-Installer working again
* page-selector was gone if enables categories and just one category



If you are new to ibProArcade and do a fresh Installation, just read the included Instructions. Make sure to read the ones that correspond to your vBulletin-Version!


For those who upgrade their ibProArcade v2.5.x/v2.6.x/v2.7.x do the following:
  • upload and overwrite all (!) PHP-Files from Archive's /upload-Folder
  • if you are using vBulletin 3.5.x/3.6.x/3.7.x/3.8.x/4.x.x update the Product "ibProArcade":
    • Enter AdminCP
    • Open Menu-Group "PlugIn-System"
    • Click "Manage Products"
    • Click "Add/Import Products"
    • Enter the Path to the Product-XML-File: ./includes/xml/product-ibproarcade.xml
    • Set "Overwrite Product" to YES (very important, this does the Update!)
    • Click IMPORT
    • Confirm the Import of that Product
  • if you are using vBulletin 3.0.x use the Installer:
    • upload /installer.php to your forum's root
    • run installer.php
    • delete installer.php from your forum's root
  • you're done :cool:
Make sure you upload and overwrite ALL files from the UPLOAD-folder in the ZIP-archive!


If you are upgrading from vBulletin 3.x to 4.x make sure to read the included HTML-Installation-Instructions and do the template-changes for vBulletin 4.x !


Please report any Bugs, Faults, Errors, Suggestions, Ideas, Feature-Requests ect. in the Support-Forum in the "Premium Modification"-Section here at vbulletin.org



To express your support for this product, I am happy about any small donation which you can easily send via your AdminCP -> Arcade -> Information :)


CREDITS:
THANKS ALOT to stangger5 for his continued support and help here in the forums and on this product, thx mate!
Also a big THANK YOU to everybody else supporting, helping, testing and suggesting in this project :)


Please remember to click INSTALL, thanks!


Stay tuned & enjoy :)

Marcel
aka MrZeropage

boss22 11 Nov 2018 22:34

Get this error when should import product file


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Thanks for update!

--------------- Added 11 Nov 2018 at 22:42 ---------------

Database error when try arcade settings in admin cp


ERROR: Cannot find database oldlrhvz_bulletin

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


MrZeropage 11 Nov 2018 22:57

XML-problem fixed... like I already told you in your PM :)

database... you have MariaDB running? I think it was your site needing this port-modification to connect properly, right? Please send me FTP-access and AdminCP-access again via PM and I check this out

boss22 11 Nov 2018 23:04

done

MrZeropage 11 Nov 2018 23:39

Sorry for three times updating the ZIP-file, now all is fine and working fine.

All problems from "boss22" also solved :)

boss22 11 Nov 2018 23:42

:) :) Thanks

MarkFL 12 Nov 2018 02:55

Quote:

Originally Posted by MrZeropage (Post 2597344)
Sorry for three times updating the ZIP-file, now all is fine and working fine.

LOL! I've been there more than once myself...thanks for all your hard work. :D

gnrx 12 Nov 2018 13:51

Great news! :)
I go to download and try.
Only a doubt:
Indicate this improvement:
* automatic Arcade-Tab in vB4 NavBar (working with vB 4.2 and later)
in this case, we no longer need the ibProArcade Navbar vb4.2 product?

Thanks for your work!

MrZeropage 12 Nov 2018 15:42

Quote:

Originally Posted by gnrx (Post 2597354)
* automatic Arcade-Tab in vB4 NavBar (working with vB 4.2 and later)
in this case, we no longer need the ibProArcade Navbar vb4.2 product?

That is correct, it is now implemented in ibProArcade itself, thanks to stangger5 (again) for this.
I adapted it a little bit in sorting and functions, so is a new menu-layout, but you don't need any additional product/addon for this.

gnrx 12 Nov 2018 18:46

Ok, thanks!
I update to 2.7.6, uninstall ibProArcade Navbar vb4.2.

I test since few minutes, all work fine, great work and thanks for this work!!


All times are GMT. The time now is 19:26.

Powered by vBulletin® Version 3.8.14
Copyright © 2020, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.