vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=208324

[tk] Egg Avatar
by hambil
14 Mar 2009 17:25

http://img23.imageshack.us/img23/475...vatarlogot.gif

A Support Project using the vBulletin Project Tool has been created to support this mod. Please make use of it if you can. Timely support will still be given in this thread, however, use of the project tool is appreciated because:
  1. I paid for it :p
  2. It makes searching for problems already asked by other users, and possibly solved, much easier than this long thread.
  3. It helps organize and manage issues for me, which will become even more useful as I release more mods.

Description:
Ever want to throw something at someone when you read a post? Now you can! Eggs, kisses, bullets, and more.

Video Demonstration Link

Special Notes:
  • Due to some complicated issues involving the coding for animated gifs, largely black eggs (like the bullethole) do not display properly. All that is required, if you make or find your own eggs, is that large black areas be converted to a dark grey or dark blue. I've already done this with the newest bullethole.gif, and as you can see it's not a big issue but I wanted to make everyone aware of it.
  • If you wish to uninstall please upgrade to the lastest version first, as older versions may not uninstall cleanly.

Upcoming 2.5 new features
  • Automatic (optional) integration with [tk] Post Notes (post note of "Username: Threw a <thing> at you." or "Username: Gave you a <thing>" etc.
  • Long promised post stats (how many times a post has been egged, etc.)

Features:
  • Fully Phrased.
  • Fully AJAX.
  • Can be configured to work with any credits system, or not use credits (default).
  • Comes configured for vbCredits (just turn on 'Enable Credits' in the admincp options).
  • Integrated with vB Optimise.
  • Manage your own egg images (enable/disable/delete/add).
  • Optionally have eggings effect user reputation.
  • Optional 'Who Egged Me' display in UserCP.
  • 'Eggs' can be cleaned away.
  • Entire avatars can be wiped clean.
  • Usergroup support for viewing, using, cleaning own and cleaning others.
  • Very configurable.
  • Handles animated avatars (animation stops when egged, starts again when cleaned).
  • Fully supports both GD and ImageMagick. Animated avatars do not stop in ImageMagick.
  • Optional Statistics in What's Going On.

Install:
Download the [tk] EggAvatar_2.3.4.zip file.
Unzip and upload all files in the upload directory to your forum root.
Import the product file in your admincp.
Make sure to set usergroup permissions - all are turned off by default.

Install vbAdvanced Module:
Import and configure the eggblock.xml module via vbAdvanced in your admincp.

Upgrade:
Download the [tk] EggAvatar_2.3.4.zip file.
Unzip and upload all files in the upload directory to your forum root.
Import the product file in your admincp - make sure Allow Overwrite is set to 'yes'.

Version History:
1.0 Original Version
1.1 Support for animated avatars
1.1.1 Fixed a couple minor bugs
1.2.0 Fixed a couple bugs and added file system support for avatar storage.
1.2.1 Fixed bug where function not compiled into standard php 4 was being called.
1.2.2 Fixed bug that cause out of place cost info on popup. Fixed so images no longer lose color when thrown.
1.2.3 Fixed some phrasing. Fixed (?) the bug causes database errors for some users.
2.0 Egg Manager (enable, disable, upload your own eggs). Egg tracking (who egged me). Optional reputation change on egging. Numerous small bug fixes, including PNG support.
2.0.1 Fixed bug with editing existing eggs in admincp.
2.0.2 Fixed bug with EI scrolling menu.
2.0.3 Added some missing phrases.
2.0.4 Fixed IE display problem. Put code in admincp image upload to only allow gifs and to resize if needed (max 50x50).
2.1.0 Full support for animated avatars. Eggs uploaded to the eggs directory but not in the database now show in the Egg Image Manager and can be added. Added Who's Online support. Fixed possible bug with missing dateline from url.
2.1.1 Fixed problem where PHP 5 function was being called.
2.2.0 Fixed problem with cleaned avatars missing dateline (really this time). Dropped back to partial animated gif support (animation stops when egged, starts when cleaned). Added checks and error messages to help with invalid path settings. Fixed bug that caused images not to display in popup. Fixed popup to display properly in all browsers no matter how many eggs are added.
2.2.1 Added additional error checking to the image manager. Fixed the upload button in the image manager.
2.2.2 Fixed uninstall issue. Fixed a couple words that weren't phrased.
2.3 Fixed permissions issues. Fixed a couple more words that weren't phrased. Added support for ImageMagick. Added support for vB Optimise. Added statistics on forum home. Changed the fade time so the eggs won't fade if the user hasn't logged in to see them yet.
2.3.1 Fixed bug in vB Optimise integration.
2.3.2 Fixed bug if paths to avatars has a leading '/'.
2.3.3 Another attempt at fixing the pop 'eggs out of the box' issue. Probably my last for a while. Good luck, cross fingers.
2.3.4 Fixes a "can't view if can't egg" permissions problem that has been plaguing some users. Adds a vbAdvanced Module.

Beta Testing Team! Thanks!
acegames

Do not be afraid to click the install button, or whatever :p

Donations (THANKS!):
£10.00 GBP by acegames
$10.00 USD by rule0
$10.00 USD by drupy
$10.00 USD by aztecboi2003
$10.00 USD by TandyServices
$10.00 USD by hIBEES

hambil 14 Mar 2009 17:26

I knew I reserved the first post for a reason :p

Additional Items:

Submitted by Saviour

http://imgcash1.imageshack.us/img187...clamationl.gifhttp://img72.imageshack.us/img72/5504/coffeemugm.gifhttp://img410.imageshack.us/img410/9...mbsdown48c.gifhttp://img72.imageshack.us/img72/2120/thumbsup48y.gifhttp://img258.imageshack.us/img258/4441/smilesad48n.gifhttp://img254.imageshack.us/img254/8813/home48t.gif
http://img187.imageshack.us/img187/7802/heinekenk.gifhttp://img440.imageshack.us/img440/1271/heart48v.gifhttp://img187.imageshack.us/img187/4...clamationl.gifhttp://img246.imageshack.us/img246/3850/book48s.gifhttp://img258.imageshack.us/img258/6641/beer48n.gifhttp://img187.imageshack.us/img187/1477/trashfullw.gif

Submitted by drupy

http://imgcash6.imageshack.us/img106...ifier2icon.gifhttp://imgcash1.imageshack.us/img140...oybooticon.gifhttp://imgcash4.imageshack.us/img155...chair2icon.gifhttp://imgcash6.imageshack.us/img102...bucketicon.gifhttp://imgcash6.imageshack.us/img518/300/bomb1icon.gif

Submitted by rinkrat
http://imgcash4.imageshack.us/img16/2414/bandaid.gifhttp://imgcash3.imageshack.us/img24/...wballsplat.gifhttp://imgcash1.imageshack.us/img14/1033/mmpoop.gifhttp://imgcash6.imageshack.us/img232/3194/stop1.gif

glorify 14 Mar 2009 17:33

Looks pretty cool man. Anyway to straight up egg a post, as far as the body of the post over the words?

hambil 14 Mar 2009 17:36

No, just the avatar

itsheinz 14 Mar 2009 17:37

waaa why database error.

KevinL 14 Mar 2009 17:41

LOL!!!!!

This is pretty cool! haha

itsheinz 14 Mar 2009 17:48

its database error why,help me.

hambil 14 Mar 2009 18:03

Quote:

Originally Posted by itsheinz (Post 1768017)
its database error why,help me.

Can you be more specific, or PM me?

itsheinz 14 Mar 2009 18:11

when im going to click the green icon it will become database error.how is that?
Does this plugin folder should be independent?

Reycer 14 Mar 2009 18:12

ok, I imported everything like normal but it isn't working. The usergroup permissions are on, but when I select the green button to "egg" someone, all I get is the drop down menu as if I had clicked on their username. If you want to try it out, www.lacledeforum.com/forums/index.php
username: temp1
pass: 12345

DobieGillis© 14 Mar 2009 18:14

anyone get this to work before I experimnet?

hambil 14 Mar 2009 18:18

Quote:

Originally Posted by mdelcour (Post 1768028)
ok, I imported everything like normal but it isn't working. The usergroup permissions are on, but when I select the green button to "egg" someone, all I get is the drop down menu as if I had clicked on their username. If you want to try it out, www.lacledeforum.com/forums/index.php
username: temp1
pass: 12345

Actually, just found a bug. One sec and I'll reupload lol.

hambil 14 Mar 2009 18:22

Uninstall and reinstall the latest file.

hambil 14 Mar 2009 18:24

The first few installs of a brand new mod always drive me nuts :) Even when I try it on a clean board first I seem to miss something or another *sigh*

DobieGillis© 14 Mar 2009 18:30

Quote:

Originally Posted by hambil (Post 1768039)
The first few installs of a brand new mod always drive me nuts :) Even when I try it on a clean board first I seem to miss something or another *sigh*

is it ok to try this now?

hambil 14 Mar 2009 18:31

Yes, it should work :)

Reycer 14 Mar 2009 18:32

ok, it works now. Thanks

Reycer 14 Mar 2009 18:35

errr....new problem. It caused all of my animated Avatars to quit working.

DobieGillis© 14 Mar 2009 18:35

Doh! Think I'll wait this one out

hambil 14 Mar 2009 18:37

It's not going to work with animated avatars. Best I can do is see if there is a way to check if an avatar is animated and not allow it to be thrown at. Well, it will work, but it will kill their animation.

Reycer 14 Mar 2009 18:39

Quote:

Originally Posted by hambil (Post 1768055)
It's not going to work with animated avatars. Best I can do is see if there is a way to check if an avatar is animated and not allow it to be thrown at. Well, it will work, but it will kill their animation.

Darn, that does it for my forum then. Alot of my users, use animated Avatars.

DobieGillis© 14 Mar 2009 18:40

Quote:

Originally Posted by mdelcour (Post 1768058)
Darn, that does it for my forum then. Alot of my users, use animated Avatars.

mine too, everything is animated. Bummer! Sounded like such a cool mod.

Reycer 14 Mar 2009 18:41

wish it could be fixed so that this stuff could be thrown at posts.

FiMeTi 14 Mar 2009 18:44

Quote:

Originally Posted by mdelcour (Post 1768061)
wish it could be fixed so that this stuff could be thrown at posts.

lol! That would be funny :)
Nice idea tho. Good job!

hambil 14 Mar 2009 19:08

Quote:

Originally Posted by mdelcour (Post 1768058)
Darn, that does it for my forum then. Alot of my users, use animated Avatars.

Okay, there was more I could do that I thought.

It detects animated avatars and they work now. They freeze when 'egged', and will start moving again as soon as they are clean.

ArnyVee 14 Mar 2009 19:47

Is there a demo for this mod?

Sounds like a fun mod for a forum to have. :)

rob01 14 Mar 2009 20:47

why the avatar stops working?


i only see nickname avatar

nascartr 14 Mar 2009 21:14

When I activate this product the avatars show red x's. When it's disabled they're fine. I have all avatars saved in the file directory instead of database.

hambil 14 Mar 2009 21:29

I'll have to check it with non custom avatars and avatars saved in the file system. It should work, but I'll run it through it's paces and fix anything I do find.

nascartr 14 Mar 2009 21:32

ok, I appreciate it. All of ours are custom but like I said, saved in the file system.

as7apcool 14 Mar 2009 21:35

thanks alot

smnoel 14 Mar 2009 21:59

Same here. My avatars stopped working. showing an X instead of the avatar.

RedDevil 14 Mar 2009 22:01

Ive installed this mod, I have a problem.

When i turned it on all my members avatars are not displayed, turn it off they are.

anyone had this problem if you need an account to check hambil i can pm you one

hambil 14 Mar 2009 22:10

Quote:

Originally Posted by Red-Devil (Post 1768238)
Ive installed this mod, I have a problem.

When i turned it on all my members avatars are not displayed, turn it off they are.

anyone had this problem if you need an account to check hambil i can pm you one

That would be great.

RedDevil 14 Mar 2009 22:15

Quote:

Originally Posted by hambil (Post 1768243)
That would be great.

you have a pm :)

glorify 14 Mar 2009 22:17

Quote:

Originally Posted by hambil (Post 1768055)
It's not going to work with animated avatars. Best I can do is see if there is a way to check if an avatar is animated and not allow it to be thrown at. Well, it will work, but it will kill their animation.

Make the avatar a background, it should still work. I use Profile Photos on forumhome, and I use rounded corners on top of them for effect. Animations still come thru.

hambil 14 Mar 2009 22:22

Quote:

Originally Posted by glorify (Post 1768249)
Make the avatar a background, it should still work. I use Profile Photos on forumhome, and I use rounded corners on top of them for effect. Animations still come thru.

I think there is more I can do with animations, and it's on the list - right now it's at least usable (animated avatar stops when egged, starts again when cleaned).

hambil 14 Mar 2009 22:23

Quote:

Originally Posted by Red-Devil (Post 1768248)
you have a pm :)

The problem does indeed seem to be with custom avatars stored in the file system. I will get on this right away and have a fix up as soon as I can. Thx.

RedDevil 14 Mar 2009 22:26

Quote:

Originally Posted by hambil (Post 1768252)
The problem does indeed seem to be with custom avatars stored in the file system. I will get on this right away and have a fix up as soon as I can. Thx.


Np glad to help, if you need any more help let me know

DobieGillis© 14 Mar 2009 22:26

cool! Can't wait.

digicom 14 Mar 2009 23:21

Installed Apprciated :up:

smnoel 14 Mar 2009 23:35

Waiting for the fix to install. :) nice hack. Can't wait to try it out.

Bulldog Stang 14 Mar 2009 23:41

I am having the same problem as most here. It is not displaying the avatar after install. Awaiting the fix as I think this is a pretty fun hack/mod for my members ...

hoopsta 14 Mar 2009 23:54

this looks cool

hambil 15 Mar 2009 05:15

Good news. I've discovered a way to make it work with the file system, and just about any other setup. It will also work with animated avatars without stopping the animation. It's in progress now, and will be in the next point release within the day.

smnoel 15 Mar 2009 05:44

Excellent! Thanks. :)

legion! 15 Mar 2009 06:10

My members will indeed love this i have it installed and working fine! on 3.7 and 3.8

nascartr 15 Mar 2009 06:18

So will the updated version be released later that supports file system avatars or was this 1.1.1 update supposed to because mine still aren't working.

hambil 15 Mar 2009 06:43

Quote:

Originally Posted by nascartr (Post 1768456)
So will the updated version be released later that supports file system avatars or was this 1.1.1 update supposed to because mine still aren't working.

The version to come will support file system. The 1.1.1 release was a bug release.

Hornstar 15 Mar 2009 10:02

looking forward to the next update then :)

Booth 15 Mar 2009 11:46

Really cool but I can't use yet because my avatars are stored in the file system. Can't wait for the next version! Will definitely install.

Very cool and fun mod!

RedeemedWarrior 15 Mar 2009 12:44

could it be configured to allow just one or two of the options? is that possible if i say just wanted the tomato option as stuff to throw

hambil 15 Mar 2009 12:52

Quote:

Originally Posted by RedeemedWarrior (Post 1768597)
could it be configured to allow just one or two of the options? is that possible if i say just wanted the tomato option as stuff to throw

Not yet. I *just* figured out how to handle the file system and am coding that as we speak. Then after a short rest I intended to make the images user customizable for version 1.3. You'll be able to enable or disable images, set their individual costs, upload your own new images, etc.

First things first though. There's always new features waiting lol.

hambil 15 Mar 2009 15:42

1.2.0 is released.

Some minor bug fixes, and support for avatars stored in the file system added.

smnoel 15 Mar 2009 16:01

Button not showing up to egg folks after installing it. :(

smnoel 15 Mar 2009 16:02

Doh Never mind. I changed the permissions in the group manager! Awesome. :)

Emunator 15 Mar 2009 18:54

Quote:

Originally Posted by hambil (Post 1768721)
1.2.0 is released.

Some minor bug fixes, and support for avatars stored in the file system added.

Still not working for me with avatars in file system.

Booth 15 Mar 2009 19:14

Quote:

Originally Posted by Emunator (Post 1768940)
Still not working for me with avatars in file system.

Not working for me either, avatars just don't show up :(

RedDevil 15 Mar 2009 20:12

working here now :) mine are in file system

hambil 15 Mar 2009 20:47

Quote:

Originally Posted by Emunator (Post 1768940)
Still not working for me with avatars in file system.

Quote:

Originally Posted by Booth (Post 1768957)
Not working for me either, avatars just don't show up :(

What result are you getting? Are you both seeing the same thing?

nascartr 15 Mar 2009 21:59

I had it installed and when it's activated but no permissions are set things work fine but once I updated the permissions for all usergroups to be able to use all features the avatars turned into red x's.

djilou 15 Mar 2009 22:48

Fatal error: Call to undefined function: exif_imagetype() in /eggavatar.php on line 195

hambil 16 Mar 2009 00:33

Quote:

Originally Posted by djilou (Post 1769100)
Fatal error: Call to undefined function: exif_imagetype() in /eggavatar.php on line 195

Did not realize that wasn't compiled in by default. Fixed now. Thanks.

Sunka 16 Mar 2009 00:39


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

______________________________________________________________________

Also, if I click on sign (icon) to egg someon, then is not opened egg menu (from this mod) but opened is user menu (when you click on username next to avatar --- look at the picture below).
Database error come only when I click on icon for egg someone and open in new tab.
My database have prefix - is that maybe problem?

https://www.vbulletin.org/forum/external/2009/03/80.jpg

Sunka 16 Mar 2009 00:42

Also, how to move this MOD options down in vBulletin options?
I have look in product file, but have not find displayorder for that

hambil 16 Mar 2009 00:45

Quote:

Originally Posted by Sunka (Post 1769186)
Database error in vBulletin 3.8.1:

I'm not sure what would cause that. Try a complete uninstall/reinstall.

hambil 16 Mar 2009 00:47

Quote:

Originally Posted by Sunka (Post 1769188)
Also, how to move this MOD options down in vBulletin options?
I have look in product file, but have not find displayorder for that

Find the line
Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

and change the display order.

Sunka 16 Mar 2009 00:49

I tried, also install this new one v1.2.1

Still the same, only database error is diferent


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


hambil 16 Mar 2009 00:54

Sounds like the javascript file isn't getting injected. That happens in the global_setup_complete hook.

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Make sure the hook isn't getting stepped on by another mod - and that your style didn't strip out $headinclude.

Sunka 16 Mar 2009 00:57

Uh, and how to do that?
Would you like to PM you, admin username and password to look yourself?
I do not know what to look

hambil 16 Mar 2009 01:01

Quote:

Originally Posted by Sunka (Post 1769199)
Uh, and how to do that?
Would you like to PM you, admin username and password to look yourself?
I do not know what to look

Sure, glad to help.

Sunka 16 Mar 2009 01:05

Done...
You have PM

smnoel 16 Mar 2009 01:15

Does this integrate with vb credits? I tried playing a little with the credits but was not successful. :(

hambil 16 Mar 2009 01:21

Quote:

Originally Posted by smnoel (Post 1769216)
Does this integrate with vb credits? I tried playing a little with the credits but was not successful. :(

Yes, I have vbcredits on my system, and it works without any configuration needed. Just enable credits use in the Egg Avatar options.

hambil 16 Mar 2009 01:22

Quote:

Originally Posted by Sunka (Post 1769205)
Done...
You have PM

Okay, it's fixed, and I found what appears to be a more reliable way to inject the javascript - which I will include in the next version. Thanks. Enjoy.

Sunka 16 Mar 2009 01:35

Thank you...nominated, installed, very happy...

Also, I noticed when (before you manage it) you going to update MOD (select Allow Overwrite) then database error come too.
First need to uninstall, then I could to install newer version

jack-d 16 Mar 2009 01:36

I suppose this might be nice, if it worked for all. I get nothing but the dreaded red x and I have the avs in the db.

Uninstalled

nascartr 16 Mar 2009 01:44

1 Attachment(s)
Finally got it to work correctly but I am wondering how I would remove the ", 50 credits to clean, 150 to clean all. " text above the windows since I don't use the credits option.

beerhead 16 Mar 2009 01:48

Looking forward to the next release. Sounds like fun.

hambil 16 Mar 2009 01:59

Quote:

Originally Posted by nascartr (Post 1769245)
Finally got it to work correctly but I am wondering how I would remove the ", 50 credits to clean, 150 to clean all. " text above the windows since I don't use the credits option.

That bug has been fixed already - just uninstall and reinstall the latest version :)

whitetigergrowl 16 Mar 2009 05:16

Amazing what happens when you try and egg yourself. >_> lol You get egg in the face alright.

rinkrat 16 Mar 2009 05:38

OMG this freakin rules! I love the throw kisses! Works great.

rinkrat 16 Mar 2009 05:56

OK, when you egg yourself there is a nasty database error. Can you fix it so you can either egg yourself or not be able to click the link?


Database error in vBulletin 3.8.1:

Invalid SQL:
SELECT count(eggtype) as totaleggs FROM eggavatar WHERE userid = AND cleaned = 0 AND UNIX_TIMESTAMP( ) <= (dateline + 3600);

MySQL Error : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND cleaned = 0 AND UNIX_TIMESTAMP( ) <= (dateline + 3600)' at line 1
Error Number : 1064
Request Date : Sunday, March 15th 2009 @ 10:52:46 PM
Error Date : Sunday, March 15th 2009 @ 10:52:47 PM
Script : /bbs/eggavatar.php?do=addegg&p=1437306
Referrer : /bbs/f27/106476.html#post1437306
IP Address : 24.112.11.11
Username : rinkrat
Classname : vb_database
MySQL Version : 4.1.20

hambil 16 Mar 2009 06:07

2 Attachment(s)
You should not be able to egg yourself - the problem must be something else. What you should see is either a nothing to do error message, or options to clean if appropriate. See attachments.

djilou 16 Mar 2009 09:32

Quote:

Originally Posted by hambil (Post 1769179)
Did not realize that wasn't compiled in by default. Fixed now. Thanks.

Thanks for the fix,
but when I try to upgrade I got this error :

Invalid SQL:
ALTER TABLE usergroup ADD eggavatarpermissions INT(10) UNSIGNED DEFAULT '0' NOT NULL;

MySQL Error : Duplicate column name 'eggavatarpermissions'
Error Number : 1060
Request Date : Monday, March 16th 2009 @ 09:29:54 AM
Error Date : Monday, March 16th 2009 @ 09:29:54 AM
Script : /admincp/plugin.php?do=productimport
Referrer : /admincp/plugin.php?do=productadd

hambil 16 Mar 2009 09:43

It didn't uninstall properly. Uninstall it, and reinstall. If it still doesn't work them you'll have to manually delete the column eggavatarpermissions from your database (though I'm not sure why uninstalling first wouldn't do that for you).

hambil 16 Mar 2009 09:43

Actually, if you wait 10 mins I've got a minor update on the way anyway. :p

hambil 16 Mar 2009 09:57

Minor update just put up. Fixes popup/cost display bug, and fixes images losing color when placed on some avatars.

djilou 16 Mar 2009 10:19

Thank you :)

Sunka 16 Mar 2009 10:27

Updated...working OK
Animated avatars are not animated more! But I take that like good options

hambil 16 Mar 2009 10:30

Quote:

Originally Posted by Sunka (Post 1769473)
Updated...working OK
Animated avatars are not animated more! But I take that like good options

You mean they stop being animated when egged? They should go back to being animated when cleaned.

This is on the list of things I will fix eventually, but, I may leave the current way as an option when I do.

Either way, not really a bug.

Sunka 16 Mar 2009 10:33

Yes, they are back animated when they are cleaned...but I like that when they are egged, they stop animation...it is OK

Do you think to do something same for signatures (egged signtures :) )

TandyServices 16 Mar 2009 10:55

Nice like it.. The only thing I see that I really don't like and maybe you could help me figure it out is I have it cost 25 to throw. and wanted 100 to clean all. maybe 25 to clean one.. but mine says 25 credits to egg, 100 credits to clean, 25 to clean all.??

hambil 16 Mar 2009 11:14

Quote:

Originally Posted by TandyServices (Post 1769497)
Nice like it.. The only thing I see that I really don't like and maybe you could help me figure it out is I have it cost 25 to throw. and wanted 100 to clean all. maybe 25 to clean one.. but mine says 25 credits to egg, 100 credits to clean, 25 to clean all.??

You are correct - thank you. I fixed it. I didn't bother with a point release since I had just released this version and it's a minor fix. If you already have 1.2.2 installed then don't reinstall, just unzip the zip file and upload the files again.

TandyServices 16 Mar 2009 11:25

Cool fixed.. Thanks alot and my members love it.. Great work.. Keep it up..

djilou 16 Mar 2009 13:37

I'm getting this error from time to time :

Invalid SQL:
SELECT count(eggtype) as totaleggs FROM eggavatar WHERE userid = AND cleaned = 0 AND UNIX_TIMESTAMP( ) <= (dateline + 3600);

MySQL Error : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND cleaned = 0 AND UNIX_TIMESTAMP( ) <= (dateline + 3600)' at line 1
Error Number : 1064

hambil 16 Mar 2009 14:42

Quote:

Originally Posted by djilou (Post 1769580)
I'm getting this error from time to time :

Invalid SQL:
SELECT count(eggtype) as totaleggs FROM eggavatar WHERE userid = AND cleaned = 0 AND UNIX_TIMESTAMP( ) <= (dateline + 3600);

MySQL Error : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND cleaned = 0 AND UNIX_TIMESTAMP( ) <= (dateline + 3600)' at line 1
Error Number : 1064

Interesting. Can you watch for a pattern - maybe we can narrow down when it is happening.

rinkrat 16 Mar 2009 15:57

Quote:

Originally Posted by hambil (Post 1769371)
You should not be able to egg yourself - the problem must be something else. What you should see is either a nothing to do error message, or options to clean if appropriate. See attachments.

All I do is clisk the green glob on my own avatar and it gives

MySQL Error : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND cleaned = 0 AND UNIX_TIMESTAMP( ) <= (dateline + 3600)' at line 1

Error Number : 1064
Request Date : Sunday, March 15th 2009 @ 10:52:46 PM
Error Date : Sunday, March 15th 2009 @ 10:52:47 PM
Script : /bbs/eggavatar.php?do=addegg&p=1437306

rinkrat 16 Mar 2009 16:01

Quote:

Originally Posted by hambil (Post 1769446)
It didn't uninstall properly. Uninstall it, and reinstall. If it still doesn't work them you'll have to manually delete the column eggavatarpermissions from your database (though I'm not sure why uninstalling first wouldn't do that for you).


Same thing happened to me on upgrade so I had to uninstall and then reinstall to upgrade which wiped all the previous eggings.

hambil 16 Mar 2009 16:03

Hmmm. I'm going to put in a generic error message for no user id, but I'll also see if I can figure out what might be causing the specific issue. I'll keep you posted. It works fine for all other actions (egging someone else, cleaning someone else, etc?)


All times are GMT. The time now is 02:54.

Powered by vBulletin® Version 3.8.14
Copyright © 2021, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.