vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=139920

v3 Arcade works fine, but can't get ibPro running.
by TriAxis
20 Feb 2007 07:44

Hello.

Here is my problem.

I have been running V3 arcade without any problem and have decided to check out ibPro. I would like to use the converter, but I can't even get the basic arcade running.

I followed the instructions of a fresh install with no errors during the import under Manage Products. And no issues editing the templates. I have the Arcade listed successfully in the AdminCp.

But when I click on "Arcade Main Settings" in the Admin CP I get this error:

Quote:

Warning: mysql_connect() [function.mysql-connect]: Can't connect to MySQL server on 'localhost' (10061) in \arcade\functions\dbclass.php on line 42

Warning: mysql_select_db(): supplied argument is not a valid MySQL-Link resource in \arcade\functions\dbclass.php on line 45
ERROR: Cannot find database vbulletin
Warning: mysql_query(): supplied argument is not a valid MySQL-Link resource in \arcade\functions\dbclass.php on line 184

The mySQL error that is returned is:

Quote:

mySQL query error: SELECT * FROM games_settings
mySQL error:
mySQL error code:
Date: Tuesday 20th of February 2007


I am running this on my own server so I have full administrator control. I have checked file level permissions and while just trying to get this to work I have given "All Users" modify permission on the Arcade folder and all sub folders.

I have edited the dbclass.php file and manually added my database info on lines 5 through 9 with the correct database name, user id, password, and host name.

I have also verified that he user defined on line 6 has full access to the database in mySQL 5.0.

I have searched and read through these forums looking for similar errors but nothing I have tried so far has fixed anything.

So if anyone has any ideas of what else I might try I would sure appreciate it.

MrZeropage 20 Feb 2007 13:58

did you import the product-xml file ? It creates the DB-tables :)

TriAxis 21 Feb 2007 00:27

Yes I did import the product-ibproarcade.xml file and did not get any errors. I have even done it a second time. The instructions I have been following are the ones listed in Installation - vBulletin 3.5.x and 3.6.x - english.html.

I have looked at the database and it shows multiple games_"something" tables listed but I still get the same errors.

I have assigned the user I defined in the dbclass.php every schema privileges available for that database.

MrZeropage 21 Feb 2007 10:45

Hmmm, if you want let me take a look, just provide FTP + full AdminCP access via PM and I will check this...


All times are GMT. The time now is 23:26.

Powered by vBulletin® Version 3.8.13
Copyright © 2019, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.