vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=327461

Convert ISO-8859-1 to UTF-8
by lange
15 Aug 2019 18:44

For a clean/fresh install of vB 3.8.11 only.

Take a look at https://forum.vbulletin.com/forum/cu...tf-8-languages.

I am not a coder so use the procedure at your own risk but it works fine on my custom 3.8.11 (and on my previous vB versions).

.

--------------- Added 15 Aug 2019 at 23:55 ---------------

For the details.

Test the following procedure on a fresh vb3.8.11 install :

1) In your XML language file, replace the two ISO parameters by the following code:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

2) Save in UTF-8 (be sure to save in UTF-8, I used Beyond Compare tool to do it)
3) Import and overwrite your new language XML file in AdminCP
4) Change the HTML Character Set at UTF-8 for the languages and by example set fr-FR as Language Code in the other language if your first language is French
5) In the file includes/class_xml.php, replace the code:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

by the following code:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

It works fine on my custom vB 3.8.11 (and my previous vB3.8.x versions).

For the record, I used the UTF-8 to keep the french vBulletin accents in a UTF8 WordPress blog via an old WordPress-vBulletin bridge.

ShikiSuen 27 Nov 2019 21:26

These edits are far from sufficient.

Please also check all PHP files related to XML file generation / download. Otherwise, your exported XML files (can be languages, styles, your PMs, etc.) will still be in the ISO charset.

Also, if you want to do fresh installation, prior to that you can edit those MySQL-related files in the "install" folder to make sure that:

1. The newly created database is in "CHARSET utf8mb4 with COLLATE utf8mb4_unicode_520_ci".

2. All FULLINDEX parts are made WITH PARSER NGRAM to ensure that the content indexing with East-Asian languages become effective. (This also requires further edits of other PHP files to correctly parse double-byte contents.) // You can skip this step if you don't need to provide Chinese / Korean / Japanese support in your forum.

3. MySQL version at least 5.7.6. If MariaDB or Percona, please doublecheck compatibilities with "utf8mb4_unicode_520_ci" and NGRAM.

I guess you are good to go if everything addressed above is set.


All times are GMT. The time now is 12:49.

Powered by vBulletin® Version 3.8.13
Copyright © 2019, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.