vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=255898

Forum Goals with Animated Progress Bar
by BirdOPrey5
25 Dec 2010 23:16

5 Attachment(s)
This mod will display an animated progress bar on your forum index (FORUMHOME) showing your progress as your forum approaches a "goal" you set, either a number of posts or threads.

Demo: http://www.juot.net/forums/forum.php

Optionally you can set a date for the goal and it will display a countdown of days to reach the goal.

All text output is fully phrased so you can easily change the wording to your needs.

In addition the table is its own template, forumgoals, which you can further customize as needed.

You can also easily select a custom icon without needing to edit any templates.

Finally you can turn off the auto template injection and manually place the $forumgoals template variable anywhere on your FORUMHOME template.

Full instructions are included in the zip file.

This should work on 3.7.x and 3.8.x and possibly earlier versions as well.

The progress par requires JavaScript to display. If JS is off only a percentage will show.

The progress bar uses a freely distributed JavaScript library available here:
http://www.bram.us/projects/js_bramu...essbarhandler/
"The [JavaScrpt] is now released under a creative commons Attribution-ShareAlike 2.5 license."
  • 2 JavaScript and 2 images to upload
  • 1 custom template
  • 3 plugins
  • 10 phrases

4.x version - http://www.vbulletin.org/forum/showthread.php?t=257689

Please Mark as Installed if you use this!:)

BirdOPrey5 25 Dec 2010 23:17

Reserved.

tafreeh 26 Dec 2010 03:13

wow, can we get this for vb4 please :)

EddyMaxx 26 Dec 2010 03:38

Couldn't get it to work properly. I added the $forumgoals manually as well and nothing displayed.

I'm on 3.8.6. It must be conflicting with something.

Digital Jedi 26 Dec 2010 03:48

When I get a chance to catch up on some things, I'm going to give this a try. Might goad a few folks into posting.

BirdOPrey5 26 Dec 2010 03:58

Quote:

Originally Posted by EddyMaxx (Post 2139102)
Couldn't get it to work properly. I added the $forumgoals manually as well and nothing displayed.

I'm on 3.8.6. It must be conflicting with something.

Are you getting absolutely nothing to display?

Did you actually "set" a goal? If you don't change the goal from the default of 0 (zero) it won't show.

I made this on 3.8.6 and have it installed on 2 boards, one of them heavily modified...


Quote:

Originally Posted by tafreeh (Post 2139091)
wow, can we get this for vb4 please :)

Hopefully but every time I try to do something for VB4 something goes wrong and makes it take 10 times as long as it should...

EddyMaxx 26 Dec 2010 04:17

Yeah I set the goal to 150,000 posts to enable it and nothing appeared. Let me try it again.

BirdOPrey5 26 Dec 2010 04:21

Don't put commas into the number... just set it to 150000

EddyMaxx 26 Dec 2010 05:01

Yeah its definitely conflicting with something. Not sure what because I have a test site (slightly less modded then my live version) and it worked. So on my newer live version... there is something conflicting with it.

When I import the file... it just goes blank. In my test site it imports as it should and refreshes.

EddyMaxx 26 Dec 2010 05:13

Ok I figured it out Joe. It conflicts with the Today's Top Thread Starter(s) on Forum Home
mod.

http://www.vbulletin.org/forum/showthread.php?t=205483

I disabled that mod because I prefer this one. Thanks man!!

eido 26 Dec 2010 09:22

thx alot bro u r the best

BirdOPrey5 26 Dec 2010 12:22

Quote:

Originally Posted by EddyMaxx (Post 2139128)
Ok I figured it out Joe. It conflicts with the Today's Top Thread Starter(s) on Forum Home
mod.

http://www.vbulletin.org/forum/showthread.php?t=205483

I disabled that mod because I prefer this one. Thanks man!!

Cool, thanks a lot for this info... I will see if I can get both to work because someone else might have the same issue.

sulasno 26 Dec 2010 12:24

waiting for vB 4's version

BirdOPrey5 26 Dec 2010 13:07

EddyMaxx- I uninstalled my mod, installed the mod you linked to, and reinstalled my mod without issue. If you want to use both you may try re-installing the Top Thread Starts mod and see what's happening.

Reviewing the code there is nothing that should conflict off-hand.

Also I noticed the Top Thread Starter has 2 versions available, the newest one is V2, is that the one you were using?

EddyMaxx 26 Dec 2010 16:12

Joe... I tried it again and still didn't work. If I have "Top Thread" enabled... "Forum Goals" doesn't work and vice versa. Could be also my custom template.

But either way... I'm happy with this mod. :)


All times are GMT. The time now is 09:59.

Powered by vBulletin® Version 3.8.12
Copyright © 2019, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.