vBulletin Mods

The Official vBulletin Modifications Site

mute 10 Oct 2006 17:19

OOC, why'd you put the counter table in a different database than your vb forum, just standard practice?

orban 10 Oct 2006 17:22

Yes, and I intend to probably have more sphinx indices for other things in future. It has nothing to do with vB so I want it seperate.

mute 12 Oct 2006 17:27

Hm, I've got your latest changes running, but sorting results by date doesn't seem to be working, I get the same results if i choose relevancy or by date.

orban 12 Oct 2006 17:41

Sorry I once again forgot to update the downloadable includes/sphinx.php file again >.< Try now. Relevancy asc/desc doesn't work, it's always descending (highest relevant at top, obviously).

mute 12 Oct 2006 17:56

I just wget'd the sphinx.php (to make sure i wasn't caching), edited it to my liking, and my search results when selecting "Show as threads", "one month ago", "search all forums", and "sort by last post, descending" aren't sorted in any sort of method I can figure out, am I missing something?

orban 12 Oct 2006 18:05

It's working fine for me :(

Are you sure the search isn't getting cached?

mute 12 Oct 2006 18:23

This is why I shouldn't be working on an empty stomach! It is working as intended :)

Brains 12 Oct 2006 20:06

HOE LEE SHIYYYTEE!!!! This absolutely rocks. I was a little skeptical, but I went ahead and built the "worst case" index with Sphinx (no stopwords, 4.7M posts, min word length of 1) and tried some typically VERY difficult searches (from the command line). WOW... This sucker is unbelievably fast...

Time to stitch it into my forums. This is amazing, GREAT find, and THANK YOU for sharing!

ubuntu-geek 12 Oct 2006 21:02

updated and working awesome!

ALanJay 13 Oct 2006 17:30


Originally Posted by mute
Ah, I found the problem I think.

For whatever reason, on my initial index, despite having used --rotate, it is leaving *new* index files in my var dir:

[[email protected] var]# ls -la *new*
-rw-r--r-- 1 root root 1356935444 Oct 2 13:39 vbpost.new.spd
-rw-r--r-- 1 root root 10644727 Oct 2 13:39 vbpost.new.spi
-rw-r--r-- 1 root root 54322284 Oct 2 13:42 vbthread.new.spd
-rw-r--r-- 1 root root 879893 Oct 2 13:42 vbthread.new.spi

Sphinx won't search against these, but I'm not sure why they didn't roll over.

I found the same thing but just renamed the files without the ".new" and all was fine. :)

The sugestion to nuke everything and start again without searchd running didn't seem to work either.

This is a case where the first time you create stuff there is an issue but after that it all works fine - when I update the DELTA files there doesn't seem to be an issue.

orban 13 Oct 2006 17:32

Yeah maybe --rotate doesn't work when you create them first time.

ALanJay 13 Oct 2006 22:00

Curiously when I added anither database to the config file that sphinx database also refused to rotate just creating .new files looks like some kind of bug.

On another track has anyone tried accessing the sphinx searchd from another host?

I tried using the php api and at first test it refused to connect from a remote host but works when on the same machine (but referencing an IP address rather than localhost).

orban 13 Oct 2006 22:05


That rotate seems to be bugged mm...yeah..just if you have a new config file entry just create that one alone...without --rotate, first time.

ALanJay 13 Oct 2006 22:23


Originally Posted by orban

Turned out that as well as a place holder in sphinxapi.php the "localhost" was also hard coded into the test.php code provided :)


Originally Posted by orban
That rotate seems to be bugged mm...yeah..just if you have a new config file entry just create that one alone...without --rotate, first time.

Yes it is very odd. With the new database that I have added if I don't use --rotate it overwrites the current file but if I use --rotate it creates .new files (even subsequently). The other files are still in place and rotate correctly when I install the DELTA files on the main forum databases every 5 minutes.

So as you say a bit confising but other than that pretty impressive :)

An update to this - I relised that maye the problem is that searchd needs to be fuly restarted to re-read the config file before it knows about the new files and allows them to be rotated.

Starting a new data set in Sphinx seems to require:

1) creating without the --rotate flag
2) Stopping searchd completly (kill `cat /var/log/searchd.pid`)
3) restarting searchd with the updated config file sphinx.conf

After those changes things seem to once again work. :)

Hi another update / query

Well having managed to get sphinx up and running and the test.php element searching the data we thought we would try the next steps.

Unfortunately we are still using 3.0.x and the search.php has changed a huge amount :(

I don't suppose anyone has tried adding sphinx search to 3.0.x?

Looking at the changes suggested I can find c1 and c2 - though the variable names have changed along with c4 and c5.

Obviously with the variable name changes oban your very useful sphinx.php will need various changes to the variables.

But if anyone has tried this with 3.0.x please let me know :)

ALanJay 15 Oct 2006 22:06

Hi another update / comment / query :)

We seem to have managed to get things working with 3.0.x but when testing see:

Warning: assert() [function.assert]: Assertion failed in /includes/sphinxapi.php on line 209

This doesn't seem to be fatal in any way and the search function works any ideas what this is trying to achieve :)

Overall thanks to Oban for the code to make this all work it seems to do an excellent job.

All times are GMT. The time now is 23:33.

Powered by vBulletin® Version 3.8.14
Copyright © 2022, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.