vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=286795

Help, error class_core.php on line 417
by thienhi228
18 Aug 2012 12:32

1. Initially, the visit forum I get the message as follows:
Quote:

vBulletin datastore error caused by one or more of the following:

You may have uploaded vBulletin files without also running the vBulletin upgrade script. If you have not run the upgrade script, do so now.
The datastore cache may have been corrupted. Run Rebuild Bitfields from tools.php, which you can upload from the do_not_upload folder of the vBulletin package.

Fatal error: vBulletin datastore cache incomplete or corrupt in [path]\includes\init.php on line 252
2. I upload Tools.php to the directory install the receipt of the notice:
Quote:

Fatal error: Call to a member function fetch() on a non-object in E:\vBulletin\includes\class_bootstrap_framework.php on line 65
3. I've repaired class_bootstrap_framework.php, the
Quote:

// Check datastore
// This should be redundant as all routes are accessed via vB_Router
if (!sizeof($vbulletin->routes) AND VBINSTALL !== true)
{
$vbulletin->datastore->fetch(array('routes'));
}
To
Quote:

// Check datastore
// This should be redundant as all routes are accessed via vB_Router
//if (!sizeof($vbulletin->routes) AND VBINSTALL !== true)
//{
// $vbulletin->datastore->fetch(array('routes'));
//}
I then use the install/tools.php

I use [Bitfield Cache]

4. Then I visit forum get the message:
Quote:

Fatal error: The requested language does not exist, reset via tools.php. in [path]\includes\class_core.php on line 4020
5. In tools.php, I use [Default Language], then get the message
Quote:

Warning: mysql_query(): MySQL server has gone away in E:\vBulletin\includes\class_core.php on line 417

Warning: mysql_query(): Error reading result set's header in E:\vBulletin\includes\class_core.php on line 417
Then visit forum the White Page

Help me, please!

kh99 18 Aug 2012 12:38

The last messages look like maybe your mysql server crashed? I'm not sure what caused the other messages, but maybe if you can get to the admincp, try repairing the tables through the maintenance menu (or use phpmyadmin if you have that).

thienhi228 18 Aug 2012 13:14

You can guide the way repairing the tables (with phpmyadmin)?

Thank you!

kh99 18 Aug 2012 13:17

Select the database, and when you see the list of tables scroll to the bottom and click "Check All", then from the "With Selected" dropdown menu, choose "Repair Table".

I'm not really a database person, so I don't know if this will actually help or not, but I don't think it can hurt.

thienhi228 18 Aug 2012 13:31

After Repair Table, in Msg_text I met the following message:
Quote:

The storage engine for the table does not support r ...
: (

kh99 18 Aug 2012 13:34

That's OK, I guess some of them can't be repaired that way.

I should really let someone else help you - I don't know a lot about database admin.

Are you still getting white pages?

thienhi228 18 Aug 2012 13:35

It does not work, anyway thank you very much ^^

thienhi228 19 Aug 2012 14:58

The bug seems to be like has been correct, but my error new when accessing forum:
Quote:

Fatal error: The requested language does not exist, reset via tools.php. in [path]\includes\functions.php on line 1905
functions.php
Quote:

1903 if (!isset($vbphrase) AND $user['lang_options'] === null)
1904 {
1905 trigger_error('The requested language does not exist, reset via tools.php.', E_USER_ERROR);
1906 }
1907
1908 $user['languageid'] = (!empty($languageid) ? $languageid : $user['languageid']);
I am used tools.php import Language defaults and setting up [Default Language]-English but still was this error.
Help me, please!


All times are GMT. The time now is 03:32.

Powered by vBulletin® Version 3.8.14
Copyright © 2021, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.