vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=326910

Calahan 30 Oct 2020 01:02

1 Attachment(s)
Here are the plugin files

Dr.CustUmz 30 Oct 2020 01:16

I wasn't able to duplicate this error, although I may have a fix.

In forum
Change:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

To:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

let me know if this resolves this

Calahan 30 Oct 2020 09:47

Hello
Thanks for the fast help but it didn't change anything.
Could it be that the htaccess has to changed?

Calahan 02 Nov 2020 07:43

I'm using Fpm-fcgi on my new server.
May this be the reasons why the .php files aren't rewritten into .html?

Calahan 18 Aug 2021 10:46

Maybe some can help me again.
I had to change to a server with litespeed.
I can see the main page of the archive.
But when I click on a futher link I get a 404 error.
Any ideas why it doesn't work with litespeed?

Thanks

the error log
[ERROR] [18257] [185.60.100.100:35232] URI '/archiv/forum/123-2.html' refers to a static file with PATH_INFO [/123-2.html].

TheLastSuperman 01 Sep 2021 00:29

Quote:

Originally Posted by Calahan (Post 2607366)
Maybe some can help me again.
I had to change to a server with litespeed.
I can see the main page of the archive.
But when I click on a futher link I get a 404 error.
Any ideas why it doesn't work with litespeed?

Thanks

the error log
[ERROR] [18257] [185.60.100.100:35232] URI '/archiv/forum/123-2.html' refers to a static file with PATH_INFO [/123-2.html].

Are you also using a script to rewrite the URL's by chance? Reference:
https://serverfault.com/questions/10...lems-litespeed

If so, it would depend on exactly what script you're referring to, and depending upon your answer may require something along the lines of:
https://docs.nginx.com/nginx/admin-g...tatic-content/

You could add some custom rewrites to your .htaccess file, although that would take some tinkering and testing, and usually a script is required to do the rather complex rewrites (think autopilot and variables versus tons of manual rewrite entries, you want it automatically recognize new thread and post urls and display them accordingly). Side Note: Some major hosting platforms like WPEngine (specifically for WordPress sites) are no longer allowing .htaccess use starting with PHP7.4, while this doesn't apply to you it may at some point in time in the future, when other major hosting platforms may decide to take a similar stance and approach to security. Let's get ready for PHP8 though... you've been warned :p but no joking aside, most hosts will take quite a while to transition into 8, and you can always find a host that allows use of older PHP versions, while not the best route nor most secure, you can find them if you need them.

Calahan 01 Sep 2021 12:39

I am using this script
https://vbulletin.org/forum/showthread.php?t=83439


All times are GMT. The time now is 16:42.

Powered by vBulletin® Version 3.8.14
Copyright © 2022, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.