View Single Post
Old 30 Oct 2017, 02:26
thetechgenius's Avatar
thetechgenius thetechgenius is offline
Join Date: Jun 2014
ISPConfig, vB4, and Cloudflare free SSL?

Ok so I have been using vBulletin for a very long time now, but I haven't used my vB License in a few years, but I decided to start a new forum community using vB4, and yes I have a legit vB license.

I have a few dedicated servers that I built and manage myself. I have been using these servers for years without any major problems, well none that I can't fix myself. The servers are running ISPConfig 3 (CentOS 7) as the back-end and control panel.

Now I am trying to get my forum running with Cloudflare's Free SSL Plan. I have used cloudlfare's free ssl plan in the past, and it worked really well. I am pretty sure I have everything configured properly, but I could be wrong.

When I go to my forum using "HTTPS" I get the unsecured connection page because FireFox says the SSL Certificate is Self Signed. But I have disabled SSL for my forum domain in ISPConfig, because Cloudflare SSL doesn't need SSL enabled. I mean I have SSL installed and enabled on the Server, its just disabled/not running on my forum domain.

However, I can open a Private Window in FireFox and the forum domain loads completely fine and shows the correct SSL Certificate, which is a Comodo SSL Certificate issued by Cloudflare. And I can also go on my phone (Samsung Galaxy S6 Edge+) using FireFox mobile, and the forum domain shows up completely fine on there also, with the Green Lock in the address bar and everything.

The problem is FireFox on my PC without using Private Mode, it shows up as an "Untrusted Connection" page because firefox says the server/site is using a Self-Signed Certificate.

The URL to my forum -

The site of course loads fine without SSL/HTTPS -

I have already tried clearing the Cache, but that didn't work. I have even tried Clearing the entire cache in cloudflare for that domain, and that didn't work either.

Has anyone else had this problem? I don't think its a problem with the vBulletin Forum Software, but I thought I would post here to ask the vBulletin community anyway.

Thank you,

TheTechGenius.Net Official IRC Network (ONLINE)
Port: 6667
TTG IRC Web Client -
Reply With Quote