View Single Post
Old 21 Apr 2014, 21:53
ToddW ToddW is offline
Join Date: Sep 2004
Thumbs up GD Library not working | YES -- It's installed

General Info:

I am the 'owner' of the leased server (SoftLayer) (Linux/cPanel * WHM)
I can make any changes for testing myself.
My thought is somewhere in WHM or ConfigServer some setting is limiting the usage of GD via system security restrictions. However, I've yet to find this option/configuration...

Software in use:

CENTOS 6.5 x86_64 standard server1
WHM 11.42.1 with ConfigServer Security & Firewall - csf v6.48
GD Library
VBulletin 3.8.x & 4.x

I was just notified by one of my users that their photos were no longer resizing after the move(server migration) on their VBulletin site. The VB configuration is setup to use GD lib.

I verified GD was installed, and that SafeMode was not enabled.

Server GD Lib Information:
Your GD version is:bundled (2.1.0 compatible)GD Version | bundled (2.1.0 compatible)
FreeType Support | 1
FreeType Linkage | with freetype
T1Lib Support |
GIF Read Support | 1
GIF Create Support | 1
JPEG Support | 1
PNG Support | 1
WBMP Support | 1
XPM Support | 1
XBM Support | 1
JIS-mapped Japanese Font Support |

Safe Mode OFF
I also went into another VBulletin site on the same server and tested and it too says "Cannot Resize".

I even tried SafeMode Option in Vbulletin, and used various /tmp folders (777 perm) out of web-root but still no resizing.

There are no errors relating to this in the users' site error_log file.

However in: /usr/local/apache/logs/error_log I have this:

File does not exist: /home/user/public_html/404.shtml, referer:
/ 81e146c98196

Which I believe is just causing the 404 call because the attachment upload wasn't there as it should have been.

Why would GD be installed, and show that in phpinfo but not work in Vbulletin anymore?

(YES, GD is selected in VB)
Reply With Quote