View Single Post
  #1  
Old 04 Apr 2019, 17:49
copydown copydown is offline
 
Join Date: Jan 2014
vBulletin 4.2.5 DB error on usercp

when any of the members try to go to /usercp.php this DB error pops

I'm running vBulletin 4.2.5 with php 7.1, LiteSpeed Web Server
--------------------------------------
Database error in vBulletin 4.2.5 Beta 2:

Invalid SQL:

SELECT post.pagetext AS preview,
thread.threadid, thread.title AS threadtitle, thread.forumid, thread.pollid,
thread.open, thread.replycount, thread.postusername, thread.postuserid,
thread.prefixid, thread.taglist, thread.dateline, thread.views, thread.iconid AS threadiconid,
thread.notes, thread.visible, threadread.readtime AS threadread,
thread.lastpost, thread.lastposter, thread.lastposterid, thread.lastpostid

FROM lb_thread AS thread
LEFT JOIN threadread AS threadread ON (threadread.threadid = thread.threadid AND threadread.userid = 1
LEFT JOIN post AS post ON(post.postid = thread.firstpostid)


WHERE thread.threadid IN(12421)

ORDER BY lastpost DESC;

MySQL Error : You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'LEFT JOIN post AS post ON(post.postid = thread.firstpostid)


WHER' at line 10
Error Number : 1064
Request Date : Thursday, April 4th 2019 @ 05:43:31 PM
Error Date : Thursday, April 4th 2019 @ 05:43:31 PM
Script : http://***.net/usercp.php
Referrer : https://***.net/index.php
IP Address : 175.***.***.227
Username :
Classname : vB_Database_MySQLi
MySQL Version : 10.2.22-MariaDB-log-cll-lve
Server : ***.***.***.**
User Agent :
----------------------------------------


I tried replacing all the original files disabling all the plugins but nothing seemed to be worked. can anyone help me with this please

Last edited by copydown; 05 Apr 2019 at 11:58.
Reply With Quote