Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #16  
Old 06 Oct 2017, 13:43
scottphphq scottphphq is offline
 
Join Date: Jan 2008
Originally Posted by Paul M View Post
JFYI, I have PHP 7.2 installed on a test server, and changes in that will upset vB3.
I'm leaving IB, so I wont [officially] work on any 3.8.12, and I'm certain no one else will either.
Do you know what changes in 7.2 break vb3? Not asking for you to write any code, just if you know what it revolves around.

I'm looking at https://github.com/php/php-src/blob/...0RC3/UPGRADING
Reply With Quote
  #17  
Old 25 Nov 2017, 15:07
davidg davidg is offline
 
Join Date: Apr 2010
Originally Posted by Paul M View Post
The final release of 3.8.11 will be next week.
This allows vB3 to run on PHP 7.0 & PHP 7.1


JFYI, I have PHP 7.2 installed on a test server, and changes in that will upset vB3.
I'm leaving IB, so I wont [officially] work on any 3.8.12, and I'm certain no one else will either.
Paul if u leave vb3 wont be supported anymore?
Reply With Quote
  #18  
Old 25 Nov 2017, 15:59
Paul M's Avatar
Paul M Paul M is offline
 
Join Date: Sep 2004
Real name: Paul M
I have already left (six months ago).

AFAIK, No-one is supporting VB3 or VB4 other than for critical security issues.
I'm making my own 3.8.12 & 4.2.6 versions for php 7.2, there are a few issues.
__________________
Former vBulletin.org Staff Member


Cable Forum
Please do not PM me about custom work - I no longer undertake any.
Note: I will not answer support questions via e-mail or PM - please use the relevant thread or forum.
Reply With Quote
  #19  
Old 25 Nov 2017, 16:17
davidg davidg is offline
 
Join Date: Apr 2010
Originally Posted by Paul M View Post
I have already left (six months ago).

AFAIK, No-one is supporting VB3 or VB4 other than for critical security issues.
I'm making my own 3.8.12 & 4.2.6 versions for php 7.2, there are a few issues.
Nice to know u are keeping the good work Paul.
Do you intend to share your own version or it will be private?
Reply With Quote
  #20  
Old 27 Nov 2017, 00:13
Paul M's Avatar
Paul M Paul M is offline
 
Join Date: Sep 2004
Real name: Paul M
I havent decided yet, as I havent quite finished, there are a few bugs besides the actual 7.2 issues.

I don't think I'd be able to share it publicly, pretty sure IB would have kittens.
However, I suppose I could provide a private upgrade service to existing licence holders (for a small fee).

TBH, I havent really given it a lot of thought atm.
__________________
Former vBulletin.org Staff Member


Cable Forum
Please do not PM me about custom work - I no longer undertake any.
Note: I will not answer support questions via e-mail or PM - please use the relevant thread or forum.
Reply With Quote
  #21  
Old 21 Jan 2018, 23:25
hunter1985 hunter1985 is offline
 
Join Date: Oct 2012
Real name: Ryan
@Paul M

Well Paul I'm really sad that you left IB as well see that vB3 and vB4 won't be updated for PHP 7.2 support, I really don't know what to say... I've used vB since 2001 when I used vB Lite with the purple and orange designs back then. It took me over 16 years to build my personal vB site not to forget I had to pay for new vB 5 license when my 72 or $85 1 yr lease license expired 12 years ago. I hope you could offer private updates for vB4.
Reply With Quote
  #22  
Old 15 Apr 2018, 01:28
artaman artaman is offline
 
Join Date: Jun 2010
Is there still an option to get vb3 working with php7?..
Reply With Quote
  #23  
Old 15 Apr 2018, 03:29
MarkFL's Avatar
MarkFL MarkFL is offline
 
Join Date: Feb 2014
Real name: Mark
Originally Posted by artaman View Post
Is there still an option to get vb3 working with php7?..
vB 3.8.11 works with PHP 7.0.x and 7.1.x.
__________________
Former vBulletin.org Staff Member



Support for my products (as well as updates/new product publishing) has been moved to MHB - vBulletin Products and TAZ - Add-ons
Reply With Quote
  #24  
Old 21 Apr 2018, 02:12
treki treki is offline
 
Join Date: Jun 2015
Originally Posted by MarkFL View Post
vB 3.8.11 works with PHP 7.0.x and 7.1.x.
Yes. 3.8.11 is PHP7 ready
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


New To Site? Need Help?

All times are GMT. The time now is 22:55.

Layout Options | Width: Wide Color: