Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 09 May 2015, 07:51
WolfWiz WolfWiz is offline
 
Join Date: Mar 2007
Help 4.1.5 to 4.2.2

Just did the upgrade on Vb4 and all went smooth in scripting. However I am getting this when I try to access site and nothing else.

Warning: date() [function.date]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Denver' for 'MDT/-6.0/DST' instead in ..../includes/functions.php on line 5110
Unable to add cookies, header already sent.
File: /home1/tellyour/public_html/epidog/includes/class_core.php
Line: 5755

Can someone please help me.

THanks

--------------- Added 09 May 2015 at 09:07 ---------------

Disregard fixed!
Reply With Quote
  #2  
Old 09 May 2015, 09:47
WEBDosser's Avatar
WEBDosser WEBDosser is offline
 
Join Date: Oct 2001
This might help..
http://www.vbulletin.com/forum/forum...33#post4003333
Reply With Quote
  #3  
Old 10 May 2015, 02:44
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
This is a server configuration issue and should be set at the server level in the php.ini file. However you can override the issue by setting a locale in your config.php file.

See: http://php.net/manual/en/function.da...mezone-set.php

You would use something like:

date_default_timezone_set ('America/Los_Angeles');

You can find all timezones here: http://www.php.net/manual/en/timezones.php

Really should be set in the php.ini file in this section of code:

[Date]
; Defines the default timezone used by the date functions
; http://php.net/date.timezone
date.timezone = "America/Los_Angeles"

; http://php.net/date.default-latitude
date.default_latitude = 34.3981

; http://php.net/date.default-longitude
date.default_longitude = 118.1358

; http://php.net/date.sunrise-zenith
;date.sunrise_zenith = 90.583333

; http://php.net/date.sunset-zenith
;date.sunset_zenith = 90.583333

Turning display errors off would also eliminate the problem. They aren't errors, simply warnings. They are due to how PHP has changed over the years. Previous to vBulletin 4.2.2, they were suppressed because vBulletin didn't know how to deal with them. You can turn off the display of warnings in 4.2.2 by adding this line of code at the top of your config.php under <?:

define('SKIP_DS_ERRORS', true);
__________________
Former vBulletin.org Staff Member

Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 13:46.

Layout Options | Width: Wide Color: