Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 07 Mar 2016, 18:37
MishyMashy MishyMashy is offline
 
Join Date: Mar 2010
Unhappy Usergroups not seeing forum

I made a paid subscription usergroup and since then this has happened..

The paid usergroup can now see the hidden part of the forum that only staff members should see, even though all permissions are ticked properly. why can they view this section? and how do I fix it?

Now a moderator group cant see the forum that they should see even though the permissions are marked for them to see it. Why cant they see their section? and how do I fix it?

My brain is fried.

Thanks in advance.
__________________
Black Cat Wicca
Reply With Quote
  #2  
Old 08 Mar 2016, 02:18
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
Well, the obvious answer would be that the permissions are set incorrectly. So....

What primary usergroup are these paid subscribers in and what additional usergroups are they in?

What primary usergroup are your Staff in and what additional usergroups are they in?

For the Staff forums (that only Staff should see), what usergroups can see it?
__________________
Former vBulletin.org Staff Member

Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
  #3  
Old 08 Mar 2016, 07:35
HM666's Avatar
HM666 HM666 is offline
 
Join Date: Jan 2014
Real name: Len Kaiser
If you have issues setting separate permissions within the subscriptions page, then you can try doing it a bit different way. I'm assuming that is what you did. Your best bet is to set up your subscription, create a special usergroup for that subscription, and then modify ANY AND ALL permissions for forums here only: Forums & Moderators > Forum Permissions > Quick Forum Permission Setup. This way your other usergroups can see what they should and the new usergroup sees what you want as well. I personally NEVER change any permissions in the subscription page unless there is absolutely no other way to get what I want.
Reply With Quote
  #4  
Old 08 Mar 2016, 19:13
MishyMashy MishyMashy is offline
 
Join Date: Mar 2010
Originally Posted by Lynne View Post
Well, the obvious answer would be that the permissions are set incorrectly. So....

What primary usergroup are these paid subscribers in and what additional usergroups are they in?

What primary usergroup are your Staff in and what additional usergroups are they in?

For the Staff forums (that only Staff should see), what usergroups can see it?
Paid sub members = Primary=registered user, additonal = upgraded member

Super Moderators= I have never altered so that is still the default.

It all went haywire after doing the paid sub permissions.


HM666 I tried your way just now and nothing has changed.
__________________
Black Cat Wicca
Reply With Quote
  #5  
Old 08 Mar 2016, 20:44
HM666's Avatar
HM666 HM666 is offline
 
Join Date: Jan 2014
Real name: Len Kaiser
Originally Posted by MishyMashy View Post
Paid sub members = Primary=registered user, additonal = upgraded member

Super Moderators= I have never altered so that is still the default.

It all went haywire after doing the paid sub permissions.


HM666 I tried your way just now and nothing has changed.
Then something is conflicting somewhere. Have you disabled all the plugins and then tried again? Possibly something installed on the forum has created a conflict.

You will need a HTML editor like Dreamweaver or use NotePad. DO NOT use MS Word or Word Pad.

Global disable: open your includes>config.php file and find:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

and under place:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Save and upload again to your server in the includes directory.

If you find that it works after disabling the plugins globally then re-enable the plugins by putting // in front of the code so it looks like this:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Save and upload again.

Then you will have to go through your mods one by one until you find the one that is causing the conflict.
Reply With Quote
  #6  
Old 10 Mar 2016, 00:32
MishyMashy MishyMashy is offline
 
Join Date: Mar 2010
I think it may be fixed, looks like it is so far. thank you for the help.
__________________
Black Cat Wicca
Reply With Quote
  #7  
Old 10 Mar 2016, 00:46
HM666's Avatar
HM666 HM666 is offline
 
Join Date: Jan 2014
Real name: Len Kaiser
Originally Posted by MishyMashy View Post
I think it may be fixed, looks like it is so far. thank you for the help.
Glad its fixed
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 21:02.

Layout Options | Width: Wide Color: