Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Disable BBCode per Usergroup Details »
Disable BBCode per Usergroup
Mod Version: 1.1, by Alan @ CIT (Member) Alan @ CIT is offline
Developer Last Online: Apr 2012 I like it Show Printable Version Email this Page

This thread is in the Modification Graveyard.
vB Version: 3.5.4 Rating: (1 vote - 5.00 average) Installs: 20
Released: 07 Nov 2005 Last Update: 02 Dec 2005 Downloads: 5
Not Supported Uses Plugins  

Requested: http://www.vbulletin.org/forum/showthread.php?t=100012

What is it?
This add-on allows you to disable BBCode on a usergroup basis.

Features
It currently supports disabling BBCode for:
  • Posts (new threads, replies and post edits)
  • Signatures
  • Private Messages
You can disallow each of these per usergroup. By default, all usergroups are set to enabled.

Installation
  1. Upload bitfield_qbbcode.xml to /includes/xml in your forums directory
  2. Install product-cit_qbbcode.xml as normal
Uninstallation
  1. Delete bitfield_qbbcode.xml - if you don't do this first, you will recieve errors
  2. Un-install the product using Product Manager
Important: Unfortunately, my leased vBulletin licence has now expired, and I won't be renewing it until September which means I will be unable to reply to this thread, or update this mod until then. I'm hopeful that the great vBulletin.org community will step in to answer any questions in my absence though See you all in early September!

Download Now

Only licensed members can download files, Click Here for more information.

Show Your Support

  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Comments
  #2  
Old 07 Nov 2005, 19:10
Virtuosofriend Virtuosofriend is offline
 
Join Date: Nov 2004
very good.
__________________
: [ Admin: AgeRage.net ]
: [ Admin: MPCforum.com ]
Reply With Quote
  #3  
Old 07 Nov 2005, 19:23
WNxWakko's Avatar
WNxWakko WNxWakko is offline
 
Join Date: Apr 2003
I uploaded the Bitfield, Then ran the plugin, then I even rebuilt the bitfield and still the option is not showing anywhere in the usergroup.
__________________
WNxWakko
http://warriornation.net
Reply With Quote
  #4  
Old 07 Nov 2005, 19:32
Alan @ CIT Alan @ CIT is offline
 
Join Date: Nov 2004
Location: South UK
Real name: Alan
Strange. You definatly uploaded the bitfield_qbbcode.xml file to the /includes/xml directory in your forum?

If so, remove the bitfield file, then un-install the product from Product Manager, and try it again.

Also, do you recieve any errors? Either during the install/un-install, or when editing a usergroup?
__________________
IMPORTANT: I'm afraid that I no longer develop software / modifications for vBulletin. However, thank you to everyone who installed / supported my modifications!
Reply With Quote
  #5  
Old 07 Nov 2005, 20:25
WNxWakko's Avatar
WNxWakko WNxWakko is offline
 
Join Date: Apr 2003
I receive no errors. Yes the bitfiel_qbbcode.xml went into the correct directory.

Also after installing, for some reason IMG code and BB code was turned off board wide.
__________________
WNxWakko
http://warriornation.net
Reply With Quote
  #6  
Old 07 Nov 2005, 20:31
Alan @ CIT Alan @ CIT is offline
 
Join Date: Nov 2004
Location: South UK
Real name: Alan
And the options definatly aren't there when you edit a usergroup?

Should be a group entitled "BBCode Permissions", with 3 options below:

* Can Use BBCode in Posts
* Can Use BBCode in PMs
* Can Use BBCode in Signatures

Edit: It'll be right near the top somewhere.

Thanks,
Alan.
__________________
IMPORTANT: I'm afraid that I no longer develop software / modifications for vBulletin. However, thank you to everyone who installed / supported my modifications!

Last edited by Alan @ CIT; 07 Nov 2005 at 20:34.
Reply With Quote
  #7  
Old 07 Nov 2005, 20:39
Snake's Avatar
Snake Snake is offline
 
Join Date: Mar 2005
Location: Cleveland, OH
Real name: Josh
Very useful indeed. Thanks.
Reply With Quote
  #8  
Old 07 Nov 2005, 21:42
WNxWakko's Avatar
WNxWakko WNxWakko is offline
 
Join Date: Apr 2003
Nope, ive checked several usergroups, nothing there. Ive uninstalled, reinstalled and nothing. Your default yes dont work either. All my forums end up with img and bb off regardless to the forum permission settings which clearly say yes.

vB code is Off
Smilies are On
[IMG] code is Off
HTML code is Off

When I uninstall, my settings go back to normal being

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
__________________
WNxWakko
http://warriornation.net
Reply With Quote
  #9  
Old 07 Nov 2005, 23:47
Sinistra's Avatar
Sinistra Sinistra is offline
 
Join Date: Jun 2005
Yeah very useful thanks for the hack
Reply With Quote
  #10  
Old 08 Nov 2005, 07:32
Alan @ CIT Alan @ CIT is offline
 
Join Date: Nov 2004
Location: South UK
Real name: Alan
Wakko, sorry mate, don't know what to tell you - works fine here.
__________________
IMPORTANT: I'm afraid that I no longer develop software / modifications for vBulletin. However, thank you to everyone who installed / supported my modifications!
Reply With Quote
  #11  
Old 08 Nov 2005, 20:47
CHIngs CHIngs is offline
 
Join Date: Jun 2003
Real name: Ching Chong
Originally Posted by Alan @ CIT
Wakko, sorry mate, don't know what to tell you - works fine here.
CAN YOU SHOW A SCREENSHOT?

Because I installed it and I cannot see it.
Reply With Quote
  #12  
Old 08 Nov 2005, 21:22
WNxWakko's Avatar
WNxWakko WNxWakko is offline
 
Join Date: Apr 2003
screenshot what? Its not there, nothing to screenshot.
__________________
WNxWakko
http://warriornation.net
Reply With Quote
  #13  
Old 09 Nov 2005, 07:34
Alan @ CIT Alan @ CIT is offline
 
Join Date: Nov 2004
Location: South UK
Real name: Alan
Screenshot of the usergroup permissions, and where they're likely to be attached.
Attached Images
File Type: jpg bbcode_usergroup_1.jpg (110.3 KB, 51 views)
__________________
IMPORTANT: I'm afraid that I no longer develop software / modifications for vBulletin. However, thank you to everyone who installed / supported my modifications!
Reply With Quote
  #14  
Old 09 Nov 2005, 19:55
CHIngs CHIngs is offline
 
Join Date: Jun 2003
Real name: Ching Chong
Originally Posted by Alan @ CIT
Screenshot of the usergroup permissions, and where they're likely to be attached.
I know what the problem is, I think.

You are using version 3.5.0 of vBulletin, so it works, did you test it on 3.5.1?

The PHP part of it works as it is supposed to, but the HTML part isint.
Attached Images
File Type: gif vb.gif (58.8 KB, 20 views)

Last edited by CHIngs; 09 Nov 2005 at 20:03.
Reply With Quote
  #15  
Old 09 Nov 2005, 20:29
Alan @ CIT Alan @ CIT is offline
 
Join Date: Nov 2004
Location: South UK
Real name: Alan
Quite right, I've just upgraded to 3.5.1, and it isn't showing for me. Infact, most of the custom usergroup permissions for various hacks aren't showing on my test board.

I will investigate
__________________
IMPORTANT: I'm afraid that I no longer develop software / modifications for vBulletin. However, thank you to everyone who installed / supported my modifications!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 22:33.

Layout Options | Width: Wide Color: