Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Quick Reply Box Details »
Quick Reply Box
Mod Version: 1.00, by Chen (Member) Chen is offline
Developer Last Online: Mar 2009 I like it Show Printable Version Email this Page

This modification is in the archives.
vB Version: 2.3.x Rating: (24 votes - 4.96 average) Installs: 1206
Released: 29 Jan 2002 Last Update: Never Downloads: 55
Not Supported  

Here's an easy one, it barely took 4 minutes to do. :china:
This hack will add a quick replying box at the bottom of all threads, only if the user has permission to reply, so when you need to reply to something real quickly you don't need to click the Post Reply button and wait for the page to load.

Instructions are in the attached .txt file, and if you want a demo... just look below.

NOTE: For the vB 2.3.2 version please see this post.

Extras:
  • If you want users who have the Use Email Notification option ON, to automatically subscribe to threads they reply to with this hack, see this post.
  • If you want to add an option for each user to turn this feature on and off, please see this post.
  • If you want smilies in your quick reply box please see this post.

Download Now

Only licensed members can download files, Click Here for more information.

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Info Box - Adsense, Register, and Donations Box (Working Quick Reply) Cky47 vBulletin 3.6 Template Modifications 14 21 Dec 2006 16:44
Info Box - Adsense, Register, and Donations Box (Working Quick Reply) Cky47 vBulletin 3.5 Template Modifications 44 02 Jun 2006 23:57
Quick Reply Thread Management: Open/Close & Stick/Unstick in Quick Reply Box Nomb vBulletin 3.0 Full Releases 49 09 Nov 2005 23:34

  #1021  
Old 11 Jun 2003, 12:59
Boofo's Avatar
Boofo Boofo is offline
 
Join Date: Mar 2002
Real name: Rob
That looks great! If I could only come up with something like that, I'd be all set.
Reply With Quote
  #1022  
Old 11 Jun 2003, 14:23
GameZilla GameZilla is offline
 
Join Date: Oct 2001
vBulletin Message
No thread specified. If you followed a valid link, please notify the webmaster

mine keeps saying that whedn i try to reply using it
help plz
Reply With Quote
  #1023  
Old 11 Jun 2003, 15:18
Infopro Infopro is offline
 
Join Date: May 2003
IJ Quick Reply

Here's how ours came out.
http://infoprosjoint.net/fun/IJQR+.gif
Reply With Quote
  #1024  
Old 12 Jun 2003, 14:24
MacMorag MacMorag is offline
 
Join Date: Dec 2001
I have installed Firefly's Quick Reply Box hack - excellent hack.

In addition, I have enabled in-line thread-rating (by copying the contents of $newreply_ratethread and pasting them into $showthread_replybox) so that a thread can be rated as it is being replied to via the Quick Reply Box.

This works fine for registered users. The average rating is amended accordingly.

However, when an unregistered user rates a thread via the QRB there is no change to the average rating (rating by unreg members cast via the standard 'rate this thread' box work ok and the average is amended - so it doesn't look like it's a permissions problem).

I've checked all user/forum permissions, and all is as it should be - although I'm sure that it must have something to do with permissions.

I'm at a loss to find out why registered members can rate a thread while replying via the QRB, and unregistered members cannot.

Any hints? Thanks.
Reply With Quote
  #1025  
Old 13 Jun 2003, 01:47
pride7 pride7 is offline
 
Join Date: Feb 2003
Can this be done just for certain user groups?

Planning to make a separate thing for paying members. Can this be restricted to only be allowed for a certain user group?


Thanks,

Hans
Reply With Quote
  #1026  
Old 13 Jun 2003, 16:30
Jcaputo Jcaputo is offline
 
Join Date: May 2003
I keep getting a No thread specified error when I hit the button to quick post. Any help is greatly appreciated!
Reply With Quote
  #1027  
Old 14 Jun 2003, 00:38
silverlex02 silverlex02 is offline
 
Join Date: Jun 2003
Never mind I got it to work. This is the first hack I ever tried.

Last edited by silverlex02; 14 Jun 2003 at 00:58.
Reply With Quote
  #1028  
Old 14 Jun 2003, 01:30
mark@sb.ws mark@sb.ws is offline
 
Join Date: May 2002
Is there a way to stretch the box out just alittle farther to the right? Thanks in advance.
Reply With Quote
  #1029  
Old 14 Jun 2003, 10:09
Sabrina Sabrina is offline
 
Join Date: Aug 2002
Does this hack work with 2.3.0 ?
Reply With Quote
  #1030  
Old 14 Jun 2003, 11:02
Infopro Infopro is offline
 
Join Date: May 2003
Yes.
Reply With Quote
  #1031  
Old 14 Jun 2003, 18:44
tmapm tmapm is offline
 
Join Date: Apr 2002
I've done this hack and it works perfectly. However when I checked back on my board it says this error:

Warning: SAFE MODE Restriction in effect. The script whose uid is 511 is not allowed to access /proc/loadavg owned by uid 0 in /home/virtual/site9/fst/var/www/html/forum/global.php on line 194

Warning: fopen("/proc/loadavg", "r") - Success in /home/virtual/site9/fst/var/www/html/forum/global.php on line 194

Warning: fclose(): supplied argument is not a valid File-Handle resource in /home/virtual/site9/fst/var/www/html/forum/global.php on line 196

Warning: Cannot add header information - headers already sent by (output started at /home/virtual/site9/fst/var/www/html/forum/global.php:194) in /home/virtual/site9/fst/var/www/html/forum/admin/functions.php on line 1652

I tried uninstalling it but it is still there. Any ideas?
Reply With Quote
  #1032  
Old 14 Jun 2003, 19:16
Sabrina Sabrina is offline
 
Join Date: Aug 2002
well i installed it on 2.3.0 and the window was on top of the thread, and aslo, i tried to post and it didnt post at all.
Reply With Quote
  #1033  
Old 14 Jun 2003, 19:31
tmapm tmapm is offline
 
Join Date: Apr 2002
It is at the top of the thread because you didnt put it down far enough. There are two instances of <!-- first unread and next/prev -->. Look for the one near the bottom.

<!-- first unread and next/prev -->

<!--spacer-->
Reply With Quote
  #1034  
Old 14 Jun 2003, 20:25
Sabrina Sabrina is offline
 
Join Date: Aug 2002
Today at 02:31 PM tmapm said this in Post #1033
It is at the top of the thread because you didnt put it down far enough. There are two instances of <!-- first unread and next/prev -->. Look for the one near the bottom.

<!-- first unread and next/prev -->

<!--spacer-->
Ok it went to the bottom thanks..


Still have the problem that its not posting, i click reply and it takes me to a "page cannot be found"

?
Reply With Quote
  #1035  
Old 15 Jun 2003, 00:28
tmapm tmapm is offline
 
Join Date: Apr 2002
I searched further back in the thread and read this about your problem.

Nombsaid this:
Either turn on file_uploads on your webserver or remove the enctype from the <form> tag to avoid this.
P.S. I fixed my MYSQL errors. It had to do with another hack when I set my NIX to anything but 0.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 19:21.

Layout Options | Width: Wide Color: