Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
vRewrite - SEOed URLs for vBulletin Details »
vRewrite - SEOed URLs for vBulletin
Mod Version: 1.5.1, by Immortal (Member) Immortal is offline
Developer Last Online: May 2010 I like it Show Printable Version Email this Page

This modification is in the archives.
vB Version: 3.5.3 Rating: (20 votes - 4.55 average) Installs: 506
Released: 05 Jan 2006 Last Update: 16 May 2006 Downloads: 1766
Not Supported Uses Plugins Template Edits Additional Files  

About

vRewrite is an advance but simple system to rewrite vB's URLs. The rewrite system uses preg_match_all and str_replace to rewrite the URLs. It will rewrite any URLs that are dynamic ex: showthread.php?t= to /the-forum/title-of-the-forum-id.html. Why? SEs (Search Engines) rate results based on filename. Not only that, but most SEs give a "boost" to static URLs (what we do here) versus dynamic URLs. vRewrite accomplishes both of this, for all URLs that a search engine (or a guest) will see.

Installation

Please download vRewrite.zip and read install.html for more information on how to install it.

Requirements

vRewrite assumes that you are using Apache with the mod_rewrite module enabled, and running vBulletin 3.5.x. However, if you ask for support here on IIS' module or on vBulletin 3.0.x - I will be more then happy to assist you.

Contributions

I would like to thank Chroder and Cole for assisting me release vRewrite. I could not have released it if it wasn't for them.

I would like to thank the following people/boards for helping beta test vRewrite and making it a better product.

Gaming Ultimate, BP Gaming, NBS Designz Cyclez, Hosting-Talk and Forum University.

Copyright

I've spent many hours working and perfecting vRewrite. The only thing I ask you to do is if you use it, please keep the link back. If you wish to put it in your style instead, simply remove or comment out that line. However, if you use vRewrite you MUST link back. That is the only thing I ask.

Known Issues

There are no known issues with the latest release (1.0).

Support / Issues

If you have any problems or discover a bug please post here in this thread. I have also included my email in the install.html email for one-on-one support. The only thing I ask you is please do not post this email address publicly - it is my personal email.

Changelog

1.5 Release - vRewrite 1.5 has become stable, and all users under 1.5 RC3 and 1.0 need to upgrade. Support for 1.0 will no longer be offered, and you will be told simply to upgrade. Please continue to keep all bug and feature suggestions on the bug tracker at:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

1.1 Release - Several bug fixes, and a few new features. Details here.

03/26/06 - Updated the thread to reflect vRewrite 1.5 Beta links. vRewrite files has NOT changed.

03/11/06 - Updated the thread to take advantage of vB.org's new prefix feature. vRewrite itself has NOT changed.

1.0 Release (02/19/06) - I have released the much awaited 1.0. This is the first stable release of vRewrite. All users now should be safe installing vRewrite. For more information, and how to upgrade, please see here.

1.0 Preview (01/12/06) - I have released a preview version of 1.0. This is the final version before 1.0 is considered stable. I believe everything should work in this new preview, but one bug (see known issues). Please see here for more information and how to upgrade.

01/05/06 - Updated ZIP to include a fix for boards running a table prefix. You do not need to upgrade unless you previously had SQL errors. You can upgrade by importing the product and choose "Allow Overwrite".

Donations

Any donations are very much appreciated! I do this out of my free time and work many hours on it - all for free. Anything to help is always very welcomed

If you use vRewrite, please click Install. This helps you keep track of additional upgrades and shows to me that you care about vRewrite


You may not post vRewrite ZIP or any files contained in the ZIP on any website. You may not also post any support requests/give support on any website other then this one, without my permission. If you do so, you will get a DMCA for copyright infringement. I do not want this spread to pirated users. Please stop piracy and do not share the source outside of this thread and vB.org/com. Thanks.

Support will only be obtained at:
http://www.vbulletin.org/forum/forumdisplay.php?f=182

Download Now

Only licensed members can download files, Click Here for more information.

Addons

Supporters / CoAuthors

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Archive as sitemap with SEOed URLs (Fast 'n Easy) turkerm vBulletin 3.5 Add-ons 10 29 Sep 2006 09:33

  #1636  
Old 22 Dec 2006, 17:03
Ziki's Avatar
Ziki Ziki is offline
 
Join Date: Nov 2005
I have some problems with threads that contain - .They appear to not exist
__________________
My free mods~click here
Reply With Quote
  #1637  
Old 27 Dec 2006, 00:24
zeropaid's Avatar
zeropaid zeropaid is offline
 
Join Date: Nov 2004
Originally Posted by CustomizeVB View Post
I'm having a problem with this. The New Posts link won't work for me anymore, any suggestions?
I am having the same problem with the new posts and todays posts link. Anyone have a fix for this?

Also, not sure if related, but the quick edit functionality is now broken. I am running: 3.6.4
__________________
Fashion Style Boards

Last edited by zeropaid; 27 Dec 2006 at 00:41. Reason: add more info
Reply With Quote
  #1638  
Old 29 Dec 2006, 20:31
mtlcore mtlcore is offline
 
Join Date: Jul 2005
Loveed the hack but I wish to completely remove it from my forums. I have uninstalled the product, removed the htaccess.

How do I completely remove it? and how to rebuilt the links?
Reply With Quote
  #1639  
Old 29 Dec 2006, 20:40
mtlcore mtlcore is offline
 
Join Date: Jul 2005
http://www.vrewrite.com/vrewrite-sup...ything-67.html
Reply With Quote
  #1640  
Old 29 Dec 2006, 20:43
Ziki's Avatar
Ziki Ziki is offline
 
Join Date: Nov 2005
That's it.Only uninstall and remove
__________________
My free mods~click here
Reply With Quote
  #1641  
Old 29 Dec 2006, 21:05
mtlcore mtlcore is offline
 
Join Date: Jul 2005
Originally Posted by Ziki View Post
That's it.Only uninstall and remove
Doesn't it do anything to the database? because i still see my threads in the same format
Reply With Quote
  #1642  
Old 30 Dec 2006, 11:02
ferrarislave ferrarislave is offline
 
Join Date: Jul 2005
Does it rewrite search results?
Reply With Quote
  #1643  
Old 31 Dec 2006, 22:12
BuzuL's Avatar
BuzuL BuzuL is offline
 
Join Date: Oct 2006
Real name: AoKs
I have a problem about SEO. I set up seo but it have character problem. For example it shows " i " as "y". What can i do? Please help me. Thanks from now...
Reply With Quote
  #1644  
Old 02 Jan 2007, 06:54
zeropaid's Avatar
zeropaid zeropaid is offline
 
Join Date: Nov 2004
If you are having problems with the new posts and todays post redirecting to a 404, disable searches in your VBSEO options in admincp.
__________________
Fashion Style Boards
Reply With Quote
  #1645  
Old 06 Jan 2007, 03:45
X-Rated X-Rated is offline
 
Join Date: Jan 2007
I have set Vrewrite up to the forum but because the language is in Turkish some turkish alphabet characters such as " İ, Ğ, Ş " are being changed to different characters such as " Y, T.. etc". I have adjusted the encoding as " ISO-8859-2" in the XML file but it did not solve the problem. Anyway, I want the turkish alphabet characters to change such as =>>> Ş=S, İ=I , =C, Ğ=G, =U, =O" . It will be highly appreciated if you may help me about this problem. Thanx .
Reply With Quote
  #1646  
Old 10 Jan 2007, 19:06
wtricks's Avatar
wtricks wtricks is offline
 
Join Date: Aug 2006
Not working .. This is the error I get:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
I have uploaded the product, I have made the template changes and I think there's something weird with the .htaccess, but cannot put my finger on it.

Here is my .htaccess made after reading some of the posts here:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Last 3 lines are related to a 404 page and 2 redirects. Are these 3 lines the problem?

Where should I put the .htaccess? In the main directory? In the forums directory? Not working in any ...

Thank you in advance
__________________
Admin Forum
Forum management book, active community, support
Reply With Quote
  #1647  
Old 11 Jan 2007, 08:30
ferrarislave ferrarislave is offline
 
Join Date: Jul 2005
Im having a problem. The last post url's are not being rewritten....

They show up without the www so it's just http://t-simoniz-liquid-diamond-4187-new.html/

Also, I used deanc's mod before. All of my indexed pages are with deanc's mod... I need them 301'd to the new ones. How can I do this?

Here is deanc's old htacces...
RewriteRule ^f([0-9]+)-([A-Za-z0-9\-]+)\.html$ forumdisplay.php?f=$1 [L]
RewriteRule ^t([0-9]+)(((-p)([0-9]+))?)([A-Za-z0-9\-]+)\.html$ showthread.php?t=$1&page=$5&pp=10 [L]

the url to the forum is http://www.exotixboard.com

can anyone help?

Last edited by ferrarislave; 11 Jan 2007 at 08:38.
Reply With Quote
  #1648  
Old 16 Jan 2007, 00:44
King Justice King Justice is offline
 
Join Date: Apr 2006
I know this was perfect for vB 3.5, but am wondering if this still works for 3.6+
Reply With Quote
  #1649  
Old 14 Feb 2007, 08:10
dizzy100 dizzy100 is offline
 
Join Date: Mar 2006
**EDIT** sorry posted in the wrong mod

Last edited by dizzy100; 14 Feb 2007 at 13:43.
Reply With Quote
  #1650  
Old 14 Feb 2007, 21:23
chevy0 chevy0 is offline
 
Join Date: Apr 2004
does this work with lighttpd?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 02:38.

Layout Options | Width: Wide Color: