Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 06 Sep 2013, 07:42
owning_y0u owning_y0u is offline
 
Join Date: Dec 2008
Ridiculous that vbulletin 4.x isnt updated to support php 5.4

the past few weeks we made major efforts to consolidate our website and upgrade everything Core PHP software and that kinda stuff. Everything worked fine until we where running in php warnings and double posting errors in vbulletin 4.2.

Back in 2012 it was announced that php 5.3 is reaching its end of life status in the near future.
Since the early 2012 vBulletin staff has posted that a fix for php 5.4 was planned

vBulletin 5 is far away from being usable as professional forum software, IMHO. Problems with the basic user interface that makes it far less usable than even free open source solutions for a successful forum. I cannot have current users confounded and frustrated by the myriad of issues which are confusing or simply don't work as expected.

So what is a customer of vBulletin supposed to do?
All forum software that competes with vBulletin (includes free open source forums)- is compatible with php5.4

We have fixed the issue with parsings but vbulletin developers and the internet brands management should already have patched out the incompatibility of vbulletin 4.x with php 5.4
Reply With Quote
  #2  
Old 06 Sep 2013, 08:46
cellarius's Avatar
cellarius cellarius is offline
 
Join Date: Aug 2005
Real name: Sven
Why don't you bring this up on vbulletin.com? That's where the company is. This is only the addon site.
__________________
Please note that there will be no further updates to my addons, especially they will not be upgraded for vB5. I'm leaving vB, since IB choose to go the banana-way yet again.

http://www.roma-antiqua.de
Reply With Quote
  #3  
Old 06 Sep 2013, 11:21
RickyH RickyH is offline
 
Join Date: Dec 2011
I had issues for about 4 weeks after purchasing the license for vb 5 (with access to previous versions) due to PHP 5.3. I consulted vBulletin.com directly and they've somewhat assured me that they are working on a patch for 5.3, although i somehow doubt this will come anytime soon before vb 4 dies off anyways.
Reply With Quote
  #4  
Old 06 Sep 2013, 14:22
DF031 DF031 is offline
 
Join Date: Nov 2012
In the official VB forums they have indicated an ETA for PHP5.4 support.
Reply With Quote
  #5  
Old 06 Sep 2013, 14:58
cellarius's Avatar
cellarius cellarius is offline
 
Join Date: Aug 2005
Real name: Sven
Originally Posted by DF031 View Post
In the official VB forums they have indicated an ETA for PHP5.4 support.
Link?
__________________
Please note that there will be no further updates to my addons, especially they will not be upgraded for vB5. I'm leaving vB, since IB choose to go the banana-way yet again.

http://www.roma-antiqua.de
Reply With Quote
  #6  
Old 06 Sep 2013, 15:56
DF031 DF031 is offline
 
Join Date: Nov 2012
http://www.vbulletin.com/forum/forum/vbulletin-4
Reply With Quote
  #7  
Old 06 Sep 2013, 16:37
cellarius's Avatar
cellarius cellarius is offline
 
Join Date: Aug 2005
Real name: Sven
Thank you for the link, but what is it supposed to show? I'm a vB customer for almost 10 years, having ~ 4.5k posts on vbulletin.com under my belt. I actually know where to look for the official vB4 support forums, should I ever need them.

You said an ETA for php 5.4 support had been "indicated", and I asked for a link. It would be really nice if you could provide such a link - to the actual post with the actual "indication", not to the vbulletin support forums in general.
__________________
Please note that there will be no further updates to my addons, especially they will not be upgraded for vB5. I'm leaving vB, since IB choose to go the banana-way yet again.

http://www.roma-antiqua.de
Reply With Quote
  #8  
Old 06 Sep 2013, 17:05
nhawk nhawk is offline
 
Join Date: Jan 2011
http://www.vbulletin.com/forum/forum...-vbulletin-4-x
Reply With Quote
  #9  
Old 06 Sep 2013, 18:40
DF031 DF031 is offline
 
Join Date: Nov 2012
I do not remember the exact url or name of the topic. My memory is not that good. Sorry. Try using the search enigine on the indicated forum.
Reply With Quote
  #10  
Old 06 Sep 2013, 22:11
ozzy47's Avatar
ozzy47 ozzy47 is offline
 
Join Date: Jul 2009
Real name: Chris
I still don't see a ETA in that link either.
Reply With Quote
  #11  
Old 06 Sep 2013, 22:52
Zachery's Avatar
Zachery Zachery is offline
 
Join Date: Jul 2002
Real name: Zachery Woods
http://www.vbulletin.com/forum/blogs...d-shell-script

Also:

http://www.vbulletin.com/forum/forum...-been-released
__________________
Looking for ImpEx?

Last edited by Zachery; 06 Sep 2013 at 23:18.
Reply With Quote
  #12  
Old 07 Sep 2013, 07:39
cellarius's Avatar
cellarius cellarius is offline
 
Join Date: Aug 2005
Real name: Sven
Originally Posted by DF031 View Post
I do not remember the exact url or name of the topic. My memory is not that good. Sorry. Try using the search enigine on the indicated forum.
You're the one claiming vBS giving an ETA for PHP 5.4 compliance, so it really is up to you to back that up. If you can't, I'll just assume it never happened: You don't remember because there never was an ETA given - not for vB 4.2.2 and not for any other release in the past. Not even the announcements Zachery linked to, dating today, conain an ETA. Anyway, an ETA hidden away in some obscure thread no one ever saw or can find, given by some poor support wretch that might be fired the next day would mean nothing anyway.
__________________
Please note that there will be no further updates to my addons, especially they will not be upgraded for vB5. I'm leaving vB, since IB choose to go the banana-way yet again.

http://www.roma-antiqua.de
Reply With Quote
  #13  
Old 07 Sep 2013, 07:41
DF031 DF031 is offline
 
Join Date: Nov 2012
I am so sorry I can not back it up instantly as you demand. My sincere and humble apologies. Rest asure I will not make this mistake again.
Reply With Quote
  #14  
Old 20 Sep 2014, 15:37
FractalizeR's Avatar
FractalizeR FractalizeR is offline
 
Join Date: Oct 2005
Real name: Vladislav
It looks like now VB 4.2.2 is PHP 5.5 compatible?
__________________
* My mods and articles * Forum: vB4.x, 400K posts, 300K users, 3M monthly hits
Reply With Quote
  #15  
Old 20 Sep 2014, 16:21
Zachery's Avatar
Zachery Zachery is offline
 
Join Date: Jul 2002
Real name: Zachery Woods
No, but 4.2.3 is.
__________________
Looking for ImpEx?
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 13:09.

Layout Options | Width: Wide Color: