Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Forum Category Icons (Advanced) Details »
Forum Category Icons (Advanced)
Mod Version: 2.0.0, by Dark_Wizard (Coder) Dark_Wizard is offline
Developer Last Online: Jun 2014 I like it Show Printable Version Email this Page

vB Version: 4.x.x Rating: (128 votes - 4.72 average) Installs: 1054
Released: 10 Jun 2010 Last Update: 05 Aug 2011 Downloads: 8472
Not Supported DB Changes Uses Plugins Template Edits Auto-Template  

This is a hack that will add icons to your forum categories on the forum home page.

History: I was the originator of this hack back in the vBulletin 1.x days and continued this in vb 3.7.x. I have had numerous requests to port this to vb 4.x.x so here you are.

Please click install if you want support for this mod and to encourage me to continue adding features!

Enjoy!

You can find nice icons here, here and here.

Thanks to LatinoCheats for this link.

Changelogs:

1.2.0:
  • * Option to change icon location i.e. After Status Icon, Under Forum Title or Replace Status Icon.
    * Now contains a dropdown listing your icons in the folder so you just select and save.
    * Displays icon in forum manager when editing a forum that contains an icon.
    * Change icon width and height so you need to only upload one size icon.
    * Set icon position so you can center the icon when using smaller icons.
    * Dropdown of transparency settings for icons used to replace status icons when indicating "Old Posts".
    * Allows you to mark forum/subforum as read.
    * Now shows locked icons (lock icon added to download and this overlays the status icons when indicating a locked forum).

1.2.1:
  • * Now works for Mark Forum/SubForum as read!

1.2.2:
  • * Fixed: template bug.
    * Added: Now shows locked icons (lock icon added to download and this overlays the status icons when indicating a locked forum.)

1.2.3:
  • * Added: Automatic Template Edits!
    * Added: Only jpg, gif and png icons allowed. (extensions checked in forum edit).
    * Fixed: Mark Forum Read for specific forum/subforum.
    * Fixed: Now shows non-transparent status icon when "Show Locks" is enabled.

1.2.4:
  • * Fixed: Users Viewing. (This is working on a default vb style, others styles may have issues)
    * Fixed: Mark Read should now be fixed, working fine on my end.
    * Fixed: Icon not appearing when "Forum Description" disabled.

2.0.0
  • * Icon size can be set either globally or set per forum, setting is in vb options.
    * When selecting an icon in forum manager the selected icon now shows to the right of the dropdown so you can see what you are selecting.
    * If your upgrading from 1.2.4 and had to do manual template edits then you will need to revert the templates and redo the edits.

Upgrades: For those upgrading just make sure when you import the product you select "Allow Overwrite". You will also need to revert your templates (only for users of version 1.2.2 or earlier) and then follow the instructions as outlined in the install.html file.

Note: Before you ask, yes this works with all browsers. (Tested on FF, IE8, IE7, Chrome, Safari and Opera)

IMPORTANT! If you use the "Auto Template" feature of this mod and it doesn't work then you MUST do the manual template edits outlined in the install.html. This plugin was created using a default vbulletin style.

If you like this mod than please nominate for "MOTM".

Donations are gladly accepted!

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	select_icon.jpg
Views:	2259
Size:	15.9 KB
ID:	118464   Click image for larger version

Name:	forum_edit.jpg
Views:	3255
Size:	15.1 KB
ID:	118465   Click image for larger version

Name:	after_status.png
Views:	5942
Size:	25.0 KB
ID:	118466   Click image for larger version

Name:	title.png
Views:	6305
Size:	11.6 KB
ID:	118476  

Click image for larger version

Name:	status.png
Views:	6073
Size:	12.4 KB
ID:	118477   Click image for larger version

Name:	status1.png
Views:	6985
Size:	13.2 KB
ID:	118478   Click image for larger version

Name:	options.jpg
Views:	7133
Size:	104.5 KB
ID:	118966   Click image for larger version

Name:	lock.png
Views:	5440
Size:	13.3 KB
ID:	118967  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Mini Mods Forum Category Icons on Forum Home Dark_Wizard vBulletin 3.7 Add-ons 106 02 Oct 2011 12:14

  #256  
Old 12 Aug 2010, 16:59
mach_y mach_y is offline
 
Join Date: Jul 2010
Hi, I am running 4.0.5, and am having a small issue.
I installed it fine, created the folder, added icons, set the options, turned it on.
I then go to Forums & Moderators -> Forum Manager -> next to a forum click "GO" next to edit forum -> and on the forum edit page, there is no option to select what icon I want... any help?

Thanks!
Reply With Quote
  #257  
Old 12 Aug 2010, 17:01
LuisManson LuisManson is offline
 
Join Date: Jun 2010
any chance to mod this or ad a category icon option? like xda-developers does
Reply With Quote
  #258  
Old 12 Aug 2010, 20:41
onehost onehost is offline
 
Join Date: Jul 2006
Exactly what does this mod do? I know it has something to do
with categories and icons..does it allow you to place indidual icons on categories?
Reply With Quote
  #259  
Old 13 Aug 2010, 01:22
LuisManson LuisManson is offline
 
Join Date: Jun 2010
Originally Posted by onehost View Post
Exactly what does this mod do? I know it has something to do
with categories and icons..does it allow you to place indidual icons on categories?
it does what you see in the screenshots
Reply With Quote
  #260  
Old 13 Aug 2010, 17:08
bandare bandare is offline
 
Join Date: Nov 2004
It says it installed flawlessly.... but I can't get any icons to show. I have added a folder, put in icons and then selected them for the various forums..... nothing shows on 4.0.6

UPDATE: I have a structure where I have a forum as a category and then a list of sub forum categories within there. It's letting me assign an image for that sub forum category that doesn't act as a forum but then has forums within that sub category. Those images are not showing but the actual forums underneath are. Any way to allow for images to show for sub forum categories? If I click to show the top level category only then I see the images but not if I want to see on the forum homepage

However, since installing I have found this error in my admincp since the install.

I only get the following showing at the top of the page in the admincp when I click on a specific forum to edit. Any thoughts? I am running 4.06

Warning: asort() expects parameter 1 to be array, null given in [path]/admincp/forum.php(240) : eval()'d code on line 21

Warning: Invalid argument supplied for foreach() in [path]/admincp/forum.php(240) : eval()'d code on line 22

Last edited by bandare; 14 Aug 2010 at 15:30.
Reply With Quote
  #261  
Old 13 Aug 2010, 21:23
compact123 compact123 is offline
 
Join Date: Jun 2006
i installed Forum Category Icons (Advanced) on my forum and works very well but when i upload my forum on server its doesnt work, i cant see any icons to show =/ i dont know why!!
Reply With Quote
  #262  
Old 14 Aug 2010, 14:25
Dark_Wizard Dark_Wizard is offline
 
Join Date: Nov 2001
Real name: Bob
Originally Posted by bandare View Post
However, since installing I have found this error in my admincp since the install.

I only get the following showing at the top of the page in the admincp when I click on a specific forum to edit. Any thoughts? I am running 4.06
You need to either upload icons in the folder or set the options correctly to point to the folder, please re-read the instructions as it is clearly written. Thx.
Reply With Quote
  #263  
Old 14 Aug 2010, 14:25
Dark_Wizard Dark_Wizard is offline
 
Join Date: Nov 2001
Real name: Bob
Originally Posted by compact123 View Post
i installed Forum Category Icons (Advanced) on my forum and works very well but when i upload my forum on server its doesnt work, i cant see any icons to show =/ i dont know why!!
Verify your icon folder is correct.
Reply With Quote
  #264  
Old 14 Aug 2010, 15:28
bandare bandare is offline
 
Join Date: Nov 2004
Originally Posted by Dark_Wizard View Post
You need to either upload icons in the folder or set the options correctly to point to the folder, please re-read the instructions as it is clearly written. Thx.
Hi Dark Wizard...... you are right, the error in the admincp causing those error commands was due to not adding the lock.png to the folder.

I still wonder how I can get an image for a forum area on the homepage though as per:

I have a structure where I have a forum as a category and then a list of sub forum categories within there. It's letting me assign an image for that sub forum category that doesn't act as a forum but then has forums within that sub category. Those images are not showing but the actual forums underneath are. Any way to allow for images to show for sub forum categories? If I click to show the top level category only then I see the images but not if I want to see on the forum homepage

Last edited by bandare; 14 Aug 2010 at 20:40.
Reply With Quote
  #265  
Old 18 Aug 2010, 02:18
sevsev sevsev is offline
 
Join Date: Jan 2010
Having same issue as above, everything seems to work great except no picture shows. Forum is setup as a forum as a category with sub forums within that, but I don't think that's the issue as the screenshots here show the same setup. I'm running 4.0.6
Reply With Quote
  #266  
Old 18 Aug 2010, 12:05
Dark_Wizard Dark_Wizard is offline
 
Join Date: Nov 2001
Real name: Bob
Originally Posted by sevsev View Post
Having same issue as above, everything seems to work great except no picture shows. Forum is setup as a forum as a category with sub forums within that, but I don't think that's the issue as the screenshots here show the same setup. I'm running 4.0.6
PM me a link to your site please. Thx.

Bob
Reply With Quote
  #267  
Old 18 Aug 2010, 23:45
RobbieZ RobbieZ is offline
 
Join Date: Jul 2008
Im getting this error when I go into forum manager


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Any ideas Bob?

Create a folder under images and call it what you want. (Make sure this is under the images folder otherwise you will get errors!)
You cant call it what you want as creating a folder thats not in alphabetical order will not appear under images folder..
Reply With Quote
  #268  
Old 19 Aug 2010, 01:18
bandare bandare is offline
 
Join Date: Nov 2004
Originally Posted by RobbieZ View Post
Im getting this error when I go into forum manager


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Any ideas Bob?



You cant call it what you want as creating a folder thats not in alphabetical order will not appear under images folder..
the problem is that you haven't uploaded the locked image that comes with the download. I had the same issue a few posts above and typed how to fix

When he says UNDER< he means inside the images folder
Reply With Quote
  #269  
Old 19 Aug 2010, 13:58
TITAN-UZ TITAN-UZ is offline
 
Join Date: Jun 2010
How to change this background image

Reply With Quote
  #270  
Old 19 Aug 2010, 18:28
sevsev sevsev is offline
 
Join Date: Jan 2010
PM'd

Thanks Bob
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 08:25.

Layout Options | Width: Wide Color: