Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Watermark Attachments Details »
Watermark Attachments
Mod Version: 1.00, by bjhuang (Member) bjhuang is offline
Developer Last Online: Jun 2013 I like it Show Printable Version Email this Page

vB Version: 3.8.0 Rating: (6 votes - 4.50 average) Installs: 140
Released: 16 Jan 2009 Last Update: 16 Jan 2009 Downloads: 1216
Not Supported Uses Plugins Re-usable Code  

Product: 1
Plugin: 2
Query: 0

tested only on the pure installation of vbulletin. install at your own risk to work with other attachment mods.

Feature

* put a logo (watermark) on your attachments.
* option to watermark only attachments after X days of creation. this helps your hotlinked images become free ads.
* option to watermark thumbnails but stop hotlinking to full size image (return a blank image instead)
* option NOT to watermark images for traffic from certain sites

Install

Step 1: import product-watermark.xml
Step 2: create and upload your own watermark logos. one for top and one for bottom.
Step 3: put the absolute path of watermark images into options. (/var/www/html/.../watermark.png)
Step 4 (optional) : if you don't want the attachments watermarked viewing on your own site or some other friend sites (like google image), just put the domains into "Skip Referer" option.

Not working
1. set the "Days Delay" option to 0
2. refresh your cache by press Ctrl-F5.
3. the watermark images should be in PNG format with transparent background.
4. check the "Safe Mode Temporary Directory" option. the directory should be writable.
5. only works for PNG, GIF, JPG attachments.
6. only works if the attachments are stored in the filesystem.
7. GD library should be installed.

Todo
* currently, we have to create a temp file while sending a watermarked attachment. It will be appreciate if anybody can help me to get rid of this.




The most famous travel forum in chinese world - www.bbkz.com

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	example_watermark_bottom.png
Views:	354
Size:	4.5 KB
ID:	92799  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
  #106  
Old 28 Mar 2011, 00:42
Mopar1973Man's Avatar
Mopar1973Man Mopar1973Man is offline
 
Join Date: Mar 2007
Real name: Michael Nelson
Still working fine in vB 4.1.0



Still working fine in vB 3.8.5



Still working in vB 3.8.6

__________________


Powered By vBulletin 4.2.0 & Joomla 2.5.9 -~- Michael Nelson -~- AKA: Mopar1973Man
Reply With Quote
  #107  
Old 29 Mar 2011, 18:21
Goodfather's Avatar
Goodfather Goodfather is offline
 
Join Date: Jan 2010
Still working fine in vB 4.1.2

Reply With Quote
  #108  
Old 21 Apr 2011, 12:03
indreksi indreksi is offline
 
Join Date: Mar 2009
Looks like its dont work in vB 4.1.3
Reply With Quote
  #109  
Old 14 May 2011, 19:49
8thos's Avatar
8thos 8thos is offline
 
Join Date: Aug 2010
Real name: DRE
Interesting. Can't wait to test this out. Does it work with Pictures and Album Gallery?
__________________
www.8thos.com
www.qapla.com
Reply With Quote
  #110  
Old 17 Aug 2011, 04:20
Mopar1973Man's Avatar
Mopar1973Man Mopar1973Man is offline
 
Join Date: Mar 2007
Real name: Michael Nelson
Well gang... vB 4.1.4 or vB 4.1.5 kills the plugin it no longer functions...

Interesting. Can't wait to test this out. Does it work with Pictures and Album Gallery?
No it doesn't work in those areas only attachments...
__________________


Powered By vBulletin 4.2.0 & Joomla 2.5.9 -~- Michael Nelson -~- AKA: Mopar1973Man
Reply With Quote
  #111  
Old 28 Aug 2011, 18:57
JohorBahru JohorBahru is offline
 
Join Date: Jan 2009
Hi, may i know who does "Stop hotlinking to full size image" mean for?
isn't the watermark is on the full size image as well?
Reply With Quote
  #112  
Old 08 Feb 2012, 09:27
Internetcafe Internetcafe is offline
 
Join Date: May 2008
Still working on 4.1.10
__________________
Reply With Quote
  #113  
Old 04 Mar 2012, 08:05
Bulent Tekcan Bulent Tekcan is offline
 
Join Date: Oct 2003
Not work 4.1.11
__________________

Reply With Quote
  #114  
Old 23 Nov 2012, 14:16
stained stained is offline
 
Join Date: Jun 2009
If you get the path to your watermark files right it definitely works on 4.1.11.

Does anyone know how to move the bottom watermark over to the left? Post #25 gives a tip but changing those numbers changes the colour of the watermark background as far as I can see.
Reply With Quote
  #115  
Old 25 Nov 2012, 04:51
RyanFabbro's Avatar
RyanFabbro RyanFabbro is offline
 
Join Date: Aug 2012
Real name: Ryan
can someone who has this working screenshot their settings for me i have...





in those first options when i turn on "Safe Mode Upload Enabled"

i get the following error when i upload a file and yes i have a tmp directory that is writable
Attached Images
File Type: jpg Capture1.jpg (33.7 KB, 225 views)
File Type: jpg Capture.jpg (74.4 KB, 227 views)
File Type: png Capture2.PNG (32.4 KB, 222 views)
Reply With Quote
  #116  
Old 25 Nov 2012, 06:50
RyanFabbro's Avatar
RyanFabbro RyanFabbro is offline
 
Join Date: Aug 2012
Real name: Ryan
idk why or how but is magically started working =)
Reply With Quote
  #117  
Old 22 Jan 2013, 15:27
fxdigi-cash fxdigi-cash is offline
 
Join Date: Jul 2012
this is what I was looking for..... finally got it.
Thanks a lot. works great without any issues on vb.4.2 pl3

Reply With Quote
  #118  
Old 08 Jan 2014, 15:38
keyla31's Avatar
keyla31 keyla31 is offline
 
Join Date: Feb 2009
I had to re install this on 4.2.2 and it seems to not work now, maybe it has to cron and will evenetually work again?
Reply With Quote
  #119  
Old 08 Jan 2014, 20:25
Moh4m4d Moh4m4d is offline
 
Join Date: Feb 2010
Real name: Mohamad
any idea for vb 4.2 ?!
Reply With Quote
  #120  
Old 17 Mar 2014, 17:14
Vibhor Vibhor is offline
 
Join Date: Jul 2009
* currently, we have to create a temp file while sending a watermarked attachment. It will be appreciate if anybody can help me to get rid of this.
Is it safe to remove those temporary files? They're consuming more than 50% of our server space.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 02:50.

Layout Options | Width: Wide Color: