Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Watermark Generator Details »
Watermark Generator
Mod Version: 1.1, by Disasterpiece (Coder) Disasterpiece is offline
Developer Last Online: Oct 2019 I like it Show Printable Version Email this Page

vB Version: 4.0.x Rating: (22 votes - 4.77 average) Installs: 151
Released: 18 May 2011 Last Update: 09 Jun 2011 Downloads: 1058
Not Supported DB Changes Uses Plugins Additional Files Is in Beta Stage  

Quick Info

This mod adds a watermark to album and attachment images.
The watermark is customizable via image files or specified text.
Processed images are cached and the original files remain untouched, so you can modify or remove the watermark anytime you want.


Features

- Intelligent Caching
- Uses standard vBulletin methods, therefore no file modifications necessary
- Settings-Preview with a sample image in Adminpanel
- Generative plugin behaviour, works with most other mods which use the same hooks or use attachment images elsewhere

Installation


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Changelog

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Additional Info

The Mod is currently in BETA. This means, that we tested it on a test environment (vb 4.0.x to 4.1.3) but has not yet undergo excessive stress test.
Keep an eye out for updated versions until the final release!
If you encounter any bugs, missing or misplaced features, let us know!

F.A.Q

- I don't see changes in my live images!
> To see changes on the image files you have to clear your browser's cache!
In firefox it's enough to force a fresh reload via STRG+F5 and on other browsers STRG+F5 or SHIFT+F5 should work.
If you don't perform this step, your browser will show the old cached version and maybe the watermark won't show or changes won't apply.

- My png/gif watermark isn't transparent, instead I get a black background!
> PNG-8 is known for having transparency problems, GIF in some cases as well.
Fall back to PNG-24 with Alpha channel (all modern image tools should be able to save as PNG-24)
If you have trouble creating a working png-24 with alpha channel, you can send me a PM with a link to your watermark and I'll convert it to png-24 for you.

- I have trouble with special characters or non-latin charactersets!
> The addon is using standard php functionalities for the text. If for any reason you have trouble with special chars, I suggest using a transparent png-24 with the text from an external image tool instead.

Support / Branding

We provide quality vbulletin software modifications for zero costs. To help our mod to be well-known, a backlink is added to your forum footer by the plugin, where the plugin is used in any way.
You must not remove the copyright/backlink code!
However, if you like to support us, you are allowed to remove the footer note with a small donation (10$ minimum).
If you choose to do so, we'll contact you via the email provided by paypal with instructions on how to remove the footer note.
A link to paypal donation service can be found on the top right area of this post.

Feel free to contact an author of the mod if you have any questions or suggestions.

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	plwatermark_2.jpg
Views:	2786
Size:	105.4 KB
ID:	129186   Click image for larger version

Name:	plwatermark_3.jpg
Views:	3195
Size:	120.2 KB
ID:	129187   Click image for larger version

Name:	plwatermark_admin12.jpg
Views:	1677
Size:	108.0 KB
ID:	129188   Click image for larger version

Name:	plwatermark_admin11.jpg
Views:	3098
Size:	68.3 KB
ID:	129189  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
  #121  
Old 14 Jan 2012, 20:12
vinkenier vinkenier is offline
 
Join Date: Jan 2012
Originally Posted by BadgerDog View Post
Update ...

Did so more research and there's definitely a pattern of only grey bars appearing for pics over a certain HxW ...

For example, it seemed to be working fine on recent uploads, then a member just added 3 pics that are 1279px × 959px, they display fine, however, all three have a grey bar across the bottom.

I noticed that another member immediately afterwards uploaded some pic attachments that were less than 1024x768 and the watermarks show just fine on them ...

Hope that helps debug things ...

Regards,
Doug

Edit: I've added another example that shows how large pics seem to a factor in triggering the grey bar. The pic attached is one a member just uploaded as an attachment and it's 2448px × 2958px (scaled by vBulletin for internal storage to 532px × 643px).
I'm having the same problem. Is there any solution yet?
Happens when you you upload bigger pics and when the watermark is not set to the bottom. When I set it to the bottom corner, it's working fine. But I want to get this working with the watermark in the center.
Using vb 4.1.9
Reply With Quote
  #122  
Old 15 Jan 2012, 11:55
angeljs's Avatar
angeljs angeljs is offline
 
Join Date: Aug 2005
Real name: Angela
Working great on 4.1.10 so far
Reply With Quote
  #123  
Old 15 Jan 2012, 12:18
Kraxell Kraxell is offline
 
Join Date: Jun 2010
Real name: Andi
work with 4.1.9 too.
Reply With Quote
  #124  
Old 17 Jan 2012, 13:34
4nawadir.com's Avatar
4nawadir.com 4nawadir.com is offline
 
Join Date: May 2009
Real name: Abdallah
Good Job ! 5 Starts
Can i translate it to ARABIC?
__________________
لا اله الا الله محمد رسول الله
Facebook Me!
Université Abdelhamid Ibn Badis Mostaganem
Reply With Quote
  #125  
Old 18 Jan 2012, 12:27
Disasterpiece's Avatar
Disasterpiece Disasterpiece is offline
 
Join Date: Apr 2007
Sure, why not
Reply With Quote
  #126  
Old 18 Jan 2012, 13:31
fromtheflames fromtheflames is offline
 
Join Date: Dec 2009
Originally Posted by vinkenier View Post
I'm having the same problem. Is there any solution yet?
Happens when you you upload bigger pics and when the watermark is not set to the bottom. When I set it to the bottom corner, it's working fine. But I want to get this working with the watermark in the center.
Using vb 4.1.9
Same here

Do something please!
Reply With Quote
  #127  
Old 18 Jan 2012, 17:37
4nawadir.com's Avatar
4nawadir.com 4nawadir.com is offline
 
Join Date: May 2009
Real name: Abdallah
Translated !

http://www.traidnt.net/vb/traidnt2022257/

in attachments !
Attached Images
File Type: jpg 00.jpg (49.8 KB, 25 views)
File Type: png 001.PNG (16.9 KB, 31 views)
File Type: png 003.PNG (9.2 KB, 21 views)
File Type: png 004.PNG (410.1 KB, 43 views)
Attached Files
File Type: zip waterMark_Dz4aLL.Com.zip (58.4 KB, 1 views)
__________________
لا اله الا الله محمد رسول الله
Facebook Me!
Université Abdelhamid Ibn Badis Mostaganem
Reply With Quote
  #128  
Old 29 Mar 2012, 09:04
Reed_HCT Reed_HCT is offline
 
Join Date: Jan 2009
The scheduled task for cache pruning does not work for me.

Cache liftime is set to 86400 (1 day) and lru table size is set to 100.
The task is scheduled at 9 am.
I'm running vbulletin 4.1.11

When I look into the cache dir I find all the files created since the last manual cache prune, while I suppose only to see files created from 9 am of yesterday, and no more than 100 files.
Reply With Quote
  #129  
Old 31 Mar 2012, 00:11
Mopar1973Man's Avatar
Mopar1973Man Mopar1973Man is offline
 
Join Date: Mar 2007
Real name: Michael Nelson
Really good mod!

I got it installed on 4.1.11 and no problems so far... I really do like the different options, preview panel, etc.
__________________


Powered By vBulletin 4.2.0 & Joomla 2.5.9 -~- Michael Nelson -~- AKA: Mopar1973Man
Reply With Quote
  #130  
Old 02 Apr 2012, 01:15
BryanLong BryanLong is offline
 
Join Date: Feb 2012
Dear Disasterpiece,

installed your Add-On on my forums (4.1.11) and everything seemed to work as we have tested the Board; but now in Live-Stages just two questions

1) MySQL-Errors

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Note: Edited out the Board-URL as our Forums are "Not Safe for Work"


Is there anything I can do preventing this Error? The Pictures seems to be uploaded correctly.

2) My Users are moaning about the Add-On as it will "destroy small pictures".
Means if you have big HQ-Pictures of about 2000 px (or up) you will need a much bigger watermark to make it "visibe" even on big pictures, but then smaller pictures (reaching their threshold) don`look goog anymore.

So will there be any possibility to somehow add scaling to the Add-On; so that the watermark-sizes is set depending on this size of the uploaded picture.

Can imagine to pay for such feature; maybe you can drop me a line.

Greetings,
Bryan
Reply With Quote
  #131  
Old 02 Apr 2012, 16:50
Disasterpiece's Avatar
Disasterpiece Disasterpiece is offline
 
Join Date: Apr 2007
Originally Posted by BryanLong View Post
1) MySQL-Errors

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.
"MySQL server has gone away" usually refers to: MySQL Server crashed/exeeded its limits. This is a hoster-specific problem and not related to vb/the mod.

2) My Users are moaning about the Add-On as it will "destroy small pictures".
Means if you have big HQ-Pictures of about 2000 px (or up) you will need a much bigger watermark to make it "visibe" even on big pictures, but then smaller pictures (reaching their threshold) don`look goog anymore.

So will there be any possibility to somehow add scaling to the Add-On; so that the watermark-sizes is set depending on this size of the uploaded picture.
Watermark scaling doesn't make much sense imho, because on huge pictures, you have a huge annoying watermark which looks pixelated and low-quality. On small pictures you might run in trouble that it's too small to read it properly.

Because of the small images issue, I added the option to exclude images below a size of x pixels which should be enough to prevent the case that pictures get broken.
Reply With Quote
  #132  
Old 11 Apr 2012, 15:05
Sommersprosse Sommersprosse is offline
 
Join Date: Feb 2012
Originally Posted by Disasterpiece View Post
Watermark scaling doesn't make much sense imho, because on huge pictures, you have a huge annoying watermark which looks pixelated and low-quality. On small pictures you might run in trouble that it's too small to read it properly.

Because of the small images issue, I added the option to exclude images below a size of x pixels which should be enough to prevent the case that pictures get broken.
I have two ideas for this problem:
  • watermark 1 for graphics that are smaller than X pixels (or deactivated)
  • watermark 2 for graphics that are between x and x pixels pixels (maybe 1000px to 2000px)
  • watermark 3 for graphics from size x pixels (over 2000px)

Moreover it would be awesome to be able disable the watermark for select individuals forums.

Please let me know, what you think about it.

Greetings

Sommersprosse
Reply With Quote
  #133  
Old 11 Apr 2012, 21:54
BryanLong BryanLong is offline
 
Join Date: Feb 2012
Originally Posted by Sommersprosse View Post
I have two ideas for this problem:
  • watermark 1 for graphics that are smaller than X pixels (or deactivated)
  • watermark 2 for graphics that are between x and x pixels pixels (maybe 1000px to 2000px)
  • watermark 3 for graphics from size x pixels (over 2000px)

Moreover it would be awesome to be able disable the watermark for select individuals forums.

Please let me know, what you think about it.

Greetings
Sommersprosse
To add up to my colleague:

We will be willing to donate/pay something for getting any of the two possibilities mentioned:
  • Set specific Forums where the Watermark-Add-On will be disabled
  • Different Watermark-images depending on Picture-Sizes

Greetings,
Bryan

Last edited by BryanLong; 11 Apr 2012 at 22:08.
Reply With Quote
  #134  
Old 13 Apr 2012, 23:04
thanasis1 thanasis1 is offline
 
Join Date: Aug 2008
on 4.1.13 does not load the attachments at all
Reply With Quote
  #135  
Old 01 May 2012, 16:19
oddmud's Avatar
oddmud oddmud is offline
 
Join Date: Oct 2009
Any updates on this for working with the latest version?
__________________
Like Fly Fishing?
www.flyfishbc.com
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 20:57.

Layout Options | Width: Wide Color: