Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Doublepost Prevention Details »
Doublepost Prevention
Mod Version: 4.1.7.0, by Paul M (Member) Paul M is offline
Developer Last Online: Jan 2018 I like it Show Printable Version Email this Page

This thread is in the Modification Graveyard.
vB Version: 4.1.4 Rating: (91 votes - 4.79 average) Installs: 1009
Released: 15 Jan 2010 Last Update: 24 May 2012 Downloads: 4911
Not Supported Uses Plugins Translations  


--------------------------------------------------------------------------------
This modification has been withdrawn.
vBulletin 4.0.x and 4.1.x are no longer supported.

The feature is already built into the core vBulletin 4.2.x code.
--------------------------------------------------------------------------------


This is a current version of the popular modification, originally developed for the early 3.x series by Xenon.

Basically, if member posts in a thread where they were the previous last poster, then if the conditions are met, their new post will be auto-merged into the previous post instead of creating a new "double" post.

A number of options are provided ;

Time Limit - if more than xxx minutes have passed since the last post, no merge is done.

Timestamp Spacer - if enabled, a timestamped spacer is added between the old post text and the new post text.
Other spacer choices provided are no spacer, a default, or a custom spacer.

Spacer Colour - allows you to set the colour of the spacer between merged posts (if one is enabled).

Post Timestamp Update - if enabled the newly merged post will have its post time updated to the new time, otherwise it retains the time of the original post.

Usergroup exceptions - Allows you to exempt certain usergroups from the doublepost merges.

Forum exceptions - Allows you to exempt certain forums form the doublepost merges.

IP Address Check - Specifies if the poster IP should be checked, if enabled, the post will only be merged if the user and ip address are the same.

All settings are located in vBulletin Options > Doublepost Prevention.

To install just unzip the XML and import into vB using the ACP Product Manager.


History:

v4.0.1 : 15-Jan-2010 : Initial release for vb 4.0.0 Gold.

v4.1.0 : 04-Dec-2010 : Updated for vBulletin 4.1.
v4.1.1 : 17-Jun-2011 : Fixed for vBulletin 4.1.4.
v4.1.2 : 30-Jun-2011 : Javascript updated for CKE and Autosave.
v4.1.3 : 08-Jul-2011 : Dependancies updated as its no longer compatible with vB 4.1.3 or less.

v4.1.7.0 : 16-Oct-2011 : Updated for vBulletin 4.1.7.

Download Now

Only licensed members can download files, Click Here for more information.

Show Your Support

  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
New Posting Features Doublepost Prevention Paul M Modification Graveyard 345 03 Dec 2017 18:51
New Posting Features Doublepost Prevention Plus Vitaly Modification Graveyard 159 04 Jul 2010 12:36

  #346  
Old 20 Jun 2012, 11:40
yjeanrenaud yjeanrenaud is offline
 
Join Date: Aug 2010
works like a charm, but not with tapatalk posts :-(
Reply With Quote
  #347  
Old 19 Aug 2012, 04:37
Naijasite's Avatar
Naijasite Naijasite is offline
 
Join Date: Mar 2012
All my Rss feed are posting duplicate Thread, can this stop rss duplicate Thread?

Please reply
Reply With Quote
  #348  
Old 19 Aug 2012, 09:59
yjeanrenaud yjeanrenaud is offline
 
Join Date: Aug 2010
most likely depends on your feeds. make sure they always supply unique QUIDs
Reply With Quote
  #349  
Old 17 Oct 2012, 09:27
ostap ostap is offline
 
Join Date: Apr 2012
4.1.12 works !!!
Reply With Quote
  #350  
Old 19 Oct 2012, 16:13
Reed_HCT Reed_HCT is offline
 
Join Date: Jan 2009
Uninstalled due to upgrade to 4.2.0
Reply With Quote
  #351  
Old 14 Nov 2012, 08:43
Skyrider Skyrider is offline
 
Join Date: Feb 2006
Originally Posted by Reed_HCT View Post
Uninstalled due to upgrade to 4.2.0
Re-installed. This plugin prevents duplicate posts through Tapatalk & ForumRunner as they can bypass it with the default doublepost merger within vB.

Last edited by Skyrider; 14 Nov 2012 at 08:59.
Reply With Quote
  #352  
Old 14 Nov 2012, 09:55
yjeanrenaud yjeanrenaud is offline
 
Join Date: Aug 2010
cool! tapatalk could also bypass this mod, great if that works now
Reply With Quote
  #353  
Old 14 Nov 2012, 10:17
Skyrider Skyrider is offline
 
Join Date: Feb 2006
Originally Posted by yjeanrenaud View Post
cool! tapatalk could also bypass this mod, great if that works now
Nope, with this plugin installed you can no longer post double (or more) posts with tapatalk/forumrunner
Reply With Quote
  #354  
Old 17 Nov 2012, 23:13
Alan_SP's Avatar
Alan_SP Alan_SP is offline
 
Join Date: Nov 2009
There's one bug with DBTech's Advanced User Tagging (v3.0.5, maybe all in v3 series) and this mod.

Anyway, it is noticeable if you use Paul's mod double post prevention. I described bug here: http://www.dragonbyte-tech.com/f51/s...tion-mod-9721/

Solution is to as follows:

Find Prevent DoublePost plug-in for newpost_complete hook (all plug ins have same name, but hook location is different).

In plugin you need to find this code:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

And it needs to be changed into this:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

It adds line break at the beginning and at the end. Actually, for this bug it is only necessary to have only in the end line break, but I added it to both places, so people could easier remove color tags from the rest of the post.

Now it works fine.

If you use both of this mods, you certainly would like to apply this change. And, it makes easier for users to quote double posts from other's if they want to delete unnecessary content of their posts (it puts information about double posts in new lines, not the same as users text).
Reply With Quote
  #355  
Old 18 Nov 2012, 20:09
Paul M's Avatar
Paul M Paul M is offline
 
Join Date: Sep 2004
Real name: Paul M
Its not really a bug, but it is something I noticed a long while ago (when quoting), which is why I actually changed it when I added this to the 4.2.0 core.

If you want to match what vB4.2.0 does, change it to this ;


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

__________________
Former vBulletin.org Staff Member


Cable Forum
Please do not PM me about custom work - I no longer undertake any.
Note: I will not answer support questions via e-mail or PM - please use the relevant thread or forum.
Reply With Quote
  #356  
Old 19 Nov 2012, 07:33
Alan_SP's Avatar
Alan_SP Alan_SP is offline
 
Join Date: Nov 2009
Thanks Paul. One new line is enough for me, but I'm sure that some would use as it is in vB4.2.

When I said bug, I meant that this didn't worked for DBTech AUT. Strange thing is, it worked with older version of AUT and your mod without any need to change it.

EDIT: By playing a bit with spacer, this is what I find the most satisfying for me:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

It makes spacer all in a one line and separated from posts' content. I think this is the most easiest for users to delete from their quotes. Mentioning works too.

Last edited by Alan_SP; 19 Nov 2012 at 08:05.
Reply With Quote
  #357  
Old 19 Nov 2012, 13:53
Skyrider Skyrider is offline
 
Join Date: Feb 2006
Hey Paul. Is there any specific reason why Tapatalk and Forumrunner ignores and bypasses the double post prevention feature build in the core of vB while your plugin (this one) works fine in preventing double posts made through tapatalk/forumrunner?
Reply With Quote
  #358  
Old 20 Nov 2012, 21:02
Paul M's Avatar
Paul M Paul M is offline
 
Join Date: Sep 2004
Real name: Paul M
Since I have no clue how Tapatalk and Forumrunner work, I dont know.
__________________
Former vBulletin.org Staff Member


Cable Forum
Please do not PM me about custom work - I no longer undertake any.
Note: I will not answer support questions via e-mail or PM - please use the relevant thread or forum.
Reply With Quote
  #359  
Old 08 May 2013, 16:01
muimui muimui is offline
 
Join Date: Apr 2013
This product is not compatible with version 4.2.1 of vBulletin. (Compatible starting with 4.1.4 / Incompatible with 4.1.99 and greater)
Reply With Quote
  #360  
Old 08 May 2013, 16:24
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
Originally Posted by muimui View Post
This product is not compatible with version 4.2.1 of vBulletin. (Compatible starting with 4.1.4 / Incompatible with 4.1.99 and greater)
That's correct. It's because the feature is already built in to versions 4.2.0 and 4.2.1 so there's no need for an add-on.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 21:16.

Layout Options | Width: Wide Color: