Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 17 Aug 2019, 18:43
Daryn Daryn is offline
 
Join Date: Nov 2008
MyBB to vb 4.2.5 Attachment Issue

I'm having an issue with importing a MyBB forum to vb using Impex.

Not all of my attachments are coming over. If I look in my MyBB uploads folder, I can see several subfolders with attachments in them. they typically have filenames of post_##_##.attach and _thump.jpg.

I also have a whole bunch of these files in the root of the uploads folder, but these are all named post_0_xxxx_thump.jpg and .attach.

In the MyBB forum these all work, but none of these come over.

Only the ones that have post numbers did.

Prior to MyBB, I was using SMF, so perhaps that's where those came from.

Is there a way for me to fix these so that an import will get them associated to the correct posts?

Thanks.
Reply With Quote
Comments
  #2  
Old 20 Aug 2019, 15:53
yellow_spider yellow_spider is offline
 
Join Date: Dec 2005
How many are actually awol ?

The only reason for asking this is if its a small number say under 50 or so it would probably be easier/quicker to manually add them back via editing the posts and re-uploading them.

I suspect you are mostly correct though in that they are likely not quite in MyBB format so Impex is having a couple of issues (expected) as they are technically not MyBB attachments despite being in use on that system. I'd not recommend trying to manually re-run the importer or part of on a copy of the database (another copy) to try to trick it to read the SMF ones out.

Problem is seems that Impex has not been updated to fix or add anything since Sept '15 , mind you the slightly ironic thing there is the last update was to fix MyBB imports.
__________________
Reply With Quote
  #3  
Old 20 Aug 2019, 16:25
Daryn Daryn is offline
 
Join Date: Nov 2008
There's about 1000+ of them missing. So there is no way I am manually going through all of those.

I've tried a few imports, resets and re-imports on my VM and only those attachments with post numbers ever come through. So to me, the key would be getting those attachments properly associated to MyBB. Help from the MyBB community has been nonexistant, basicaly telling me I need to come here. When I know that for Impex to work, I've got to get MyBB's attachment situation sorted first.

noticed the update that was made to Impex, but that was still 3 years ago. Just getting Impex running was a chore in and of itself.

That said, unless anyone knows a way to get MyBB to import all those attachments correctly, or get Impex to take them into account, I'll just end up making the MyBB forum read only and letting users grab them from there.

Thanks to anyone that helps out.
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 02:17.

Layout Options | Width: Wide Color: