Register Members List Search Today's Posts Mark Forums Read

Reply
 
Article Options
  #76  
Old 13 May 2008, 13:40
Fireproof Fireproof is offline
 
Join Date: May 2007
I'm sorry, I'm still a bit lost.

I'm using the FORM HACK modification. Can someone tell me what I should be adding, and where? I don't know if I'm supposed to add the "define" tag or the "Input securitytoken" tag" or both.
Reply With Quote
  #77  
Old 14 May 2008, 15:54
Bounce's Avatar
Bounce Bounce is offline
 
Join Date: Mar 2004
Real name: J
Originally Posted by Fireproof View Post
I'm sorry, I'm still a bit lost.

I'm using the FORM HACK modification. Can someone tell me what I should be adding, and where? I don't know if I'm supposed to add the "define" tag or the "Input securitytoken" tag" or both.
If its the same FORM hack as i'm thinking of in the form template find


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Add after

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

I had same problem
__________________
Thanks for your help

J
Reply With Quote
  #78  
Old 14 May 2008, 19:39
JBMoney JBMoney is offline
 
Join Date: Feb 2002
What if all the templates look fine, and include the code above, but it still happens?

On my site, it happens to users who haven't logged in for a while. They log in, see the forum briefly and then get the error while being redirected to profile.php?do=dst.
Reply With Quote
  #79  
Old 14 May 2008, 20:03
dancue dancue is offline
 
Join Date: Feb 2008
Am I correct in assuming that this is where the change would take place?

What must be done?


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

I am using itsid's HIDE Hack.
Reply With Quote
  #80  
Old 14 May 2008, 20:29
Fireproof Fireproof is offline
 
Join Date: May 2007
Originally Posted by hIBEES View Post
If its the same FORM hack as i'm thinking of in the form template find


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Add after

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

I had same problem

Genius! Thank you - worked perfectly!!
Reply With Quote
  #81  
Old 17 May 2008, 01:39
Aclikyano Aclikyano is offline
 
Join Date: Apr 2006
Originally Posted by Wayne Luke View Post
Search for: value="$session[sessionhash]"


In every template this occurs in add this line directly after the line containing the above, if it doesn't exist already:
<input type="hidden" name="securitytoken" value="$bbuserinfo[securitytoken]" />

Save the template.
I did this to avoid editing some newer templates and noticed SOME templates i did before already have it... and Im afraid they have the sec token value=bla bla TWICE instead of just ONCE...

<input type="hidden" name="s" value="$session[sessionhash]"
<input type="hidden" name="securitytoken" value="$bbuserinfo[securitytoken]"
/>
<input type="hidden" name="securitytoken" value="$bbuserinfo[securitytoken]" />
How would I only make every template have this ONCE like its supposed to be?
Reply With Quote
  #82  
Old 17 May 2008, 11:36
lms lms is offline
 
Join Date: Jan 2008
sids HIDE

Originally Posted by dancue View Post
I'm trying to add the security token to a mod that is giving me an error message. The mod is very important and I'm not getting any answers from the author.

The mod uses AJAX, which is what is not working. When someone uses quickreply and posts their reply it's supposed to automatically reveal the hidden content. Instead it gives the security token issue.

Here are the templates. Must there be a change to the xml file also?


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

I understand it's the author's duty to solve the issue, but the author seems to have abandoned the mod.

I am not asking for the solution, but guidance.
Cámbialo por este otro código: (you must change by this other code

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

A mí me funciona bien (Me, it works right).

Salud2
Reply With Quote
  #83  
Old 21 May 2008, 07:55
HearthrobZ HearthrobZ is offline
 
Join Date: May 2008
This is really a mess! I'm not a professional coder.Plz Some One make a step by step instruction to do this to avoid security token missing error,as it'd help lot of people.

Thanks
Reply With Quote
  #84  
Old 21 May 2008, 08:40
mikesz mikesz is offline
 
Join Date: Jan 2006
I have seen this one before but don't know exactly what triggers it BUT for what its worth,

Find in your footer template the following,



Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

It should be:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

HTH, mikesz
Reply With Quote
  #85  
Old 21 May 2008, 16:34
blindmedia ltd blindmedia ltd is offline
 
Join Date: May 2008
Real name: shaun
its ok for you all to say do this if people know the code and i dont know

surely as jelsoft screwed up with this they should issue a fix,i installed my 3.7 as a clean 1st time full install and i still get this error
Reply With Quote
  #86  
Old 21 May 2008, 18:06
scan-pa scan-pa is offline
 
Join Date: May 2006
Real name: Peter Kirk
Originally Posted by blindmedia ltd View Post
its ok for you all to say do this if people know the code and i dont know

surely as jelsoft screwed up with this they should issue a fix,i installed my 3.7 as a clean 1st time full install and i still get this error
it's not Jelsofts problem. they fixed all of the templates that come with the basic software. But the current errors are from all of the various Non Jelsoft add-ons and Modification programs. Since jelsoft does not Officialy support these add-ons, you use them at your own risk.

But posted in the early posts is the exact steps you should take to search your templates and find the ones that need the line of code added to it.
Reply With Quote
  #87  
Old 21 May 2008, 22:16
dssart dssart is offline
 
Join Date: May 2002
Originally Posted by blindmedia ltd View Post
its ok for you all to say do this if people know the code and i dont know

surely as jelsoft screwed up with this they should issue a fix,i installed my 3.7 as a clean 1st time full install and i still get this error
Do yourself a favor..if your having problems and the hacks you have installed are something you can live without then uninstall them., revert your templates, upgrade, and you will be stress-free. Have you tried contacting the author of the hack? he probably has moved onto other things which is why you are here. If that's the case, the hack is obviously unsupported now and it's just a matter of time anyways before it breaks under another update and you will have to go through this all over again.
Reply With Quote
  #88  
Old 22 May 2008, 22:57
blindmedia ltd blindmedia ltd is offline
 
Join Date: May 2008
Real name: shaun
Originally Posted by dssart View Post
Do yourself a favor..if your having problems and the hacks you have installed are something you can live without then uninstall them., revert your templates, upgrade, and you will be stress-free. Have you tried contacting the author of the hack? he probably has moved onto other things which is why you are here. If that's the case, the hack is obviously unsupported now and it's just a matter of time anyways before it breaks under another update and you will have to go through this all over again.
thats what i said it was a 100% clean install brand new with no hacks installed and it was giving this error

therefore it would be impossible for it to be anything other than vbulletin itself causing the problem

it is 100% vbulletin 3.7.0 at fault there was at the time it started NO other software hack or mods installed
Reply With Quote
  #89  
Old 23 May 2008, 01:55
dssart dssart is offline
 
Join Date: May 2002
I can't comment accurately on your situation, but I had serious reservations myself in upgrading from 3.6.9 to 3.7.0. I have a custom hack coded for my forum that I was almost positive was going to fail with this CSRF thing. I did the following and it was the smoothest upgrade I've ever had. Not even my custom hack cracked:

Backup database, backup my /images folder, shut down forum, do upgrade. Upload my custom /images and overwrite the new, then perform upgrade. After, go back and revert everything the upgrade reported as needing to be reverted. Sounds to me like some of the upgrade files were munged during the transfer. I'd re-upload the upgrade files and make sure all appropriate ascii files are transferred as ascii and all binary as binary. Something that simple can easily be overlooked. Also, make sure your config.php is correctly configured. Something is missing..you just have to.

Seeing as it was a brand new install, I'd say the problem is either with a corrupt file upload or misconfigured config.php. Something isn't seeing something the way it's supposed to. Many people have installed the 3.7.0 software as an upgrade (which is a helluva lot trickier than a virgin install) and are running with no problem.
Reply With Quote
  #90  
Old 23 May 2008, 20:19
tafreeh's Avatar
tafreeh tafreeh is offline
 
Join Date: May 2008
Location: Canada
Real name: DON
ok here is the thing .... i almost check all my templates for security tokken code.... and fix all of them ....
but still only super mod getting security tokken error when ever they try to reply to the post... whether in new reply or quick reply ....

can some1 tell me which templates i have fix....
Reply With Quote
Reply

Similar Article
Article Author Type Replies Last Post
Show Thread Enhancements Stamps (CSRF protection added) misr.cc vBulletin 3.7 Add-ons 98 14 Oct 2012 13:54
Add-On Releases vBTube 1.2.9 (CSRF protection added) Playa82 vBulletin 3.7 Add-ons 434 22 Jan 2012 22:08
Mini Mods [ITECH] Inferno CSRF Auto Protection Inferno Tech vBulletin 3.6 Add-ons 15 02 Nov 2010 03:01



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Article Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 14:36.

Layout Options | Width: Wide Color: